Kategorie funkcji arkusza kalkulacyjnego

Część zawartości tego tematu może nie mieć zastosowania w przypadku niektórych języków.

Funkcje bazy danych

Chcąc sprawdzić, czy wartości znajdujące się na liście spełniają określony warunek, można użyć funkcji arkusza kalkulacyjnego bazy danych. Na przykład na liście zawierającej informacje o sprzedaży można zliczyć wszystkie wiersze lub rekordy, w których wartość sprzedaży jest większa niż 1 000 zł, lecz mniejsza niż 2 500 zł.

Niektóre funkcje arkusza kalkulacyjnego używane do obsługi baz danych i zarządzania listami mają nazwy rozpoczynające się do litery „D”. Funkcje te, nazywane również funkcjami D, mają trzy argumenty: baza_danych, pole i kryteria.

  • Argument baza_danych to zakres zawierający listę. Do zakresu należy włączyć wiersz zawierający etykiety kolumn.
  • Argument pole to etykieta kolumny, dla której ma zostać utworzone podsumowanie.
  • Argument kryterium to zakres zawierający określony warunek.

Funkcje daty i czasu

Użycie w formułach funkcji daty i czasu umożliwia analizę wartości daty i godziny oraz pracę z nimi. Na przykład aby zastosować w formule bieżącą datę, należy użyć funkcji arkusza kalkulacyjnego DZIŚ, która zwraca bieżącą datę na podstawie zegara systemowego komputera.

Funkcje finansowe

Funkcje finansowe służą do wykonywania popularnych obliczeń finansowych, takich jak ustalanie wysokości spłat pożyczki, wartości przyszłej lub wartości bieżącej netto inwestycji oraz wartości obligacji lub odsetek.

Do najczęściej stosowanych argumentów funkcji finansowych należą:

  • Wartość przyszła (fv) — wartość inwestycji lub pożyczki po uregulowaniu wszystkich płatności.
  • Liczba rat (liczba_rat) — łączna liczba płatności lub okresów dla inwestycji.
  • Rata (rata) — regulowana okresowo kwota związana z inwestycją lub pożyczką.
  • Wartość bieżąca (wa) — wartość inwestycji lub pożyczki na początku okresu inwestowania. Na przykład wartość bieżąca pożyczki jest to kwota podstawowa, która została pożyczona.
  • Oprocentowanie (stopa) — wysokość stopy procentowej lub dyskontowej dla pożyczki lub inwestycji.
  • Typ (typ) — odstęp czasu w okresie spłat, w którym dokonywane są płatności, np. początek miesiąca lub koniec miesiąca.

Funkcje informacyjne

Funkcje informacyjne arkusza kalkulacyjnego służą do ustalania typu danych przechowywanych w komórce. Do funkcji informacyjnych należy grupa funkcji arkusza kalkulacyjnego znanych jako funkcje CZY. Jeśli dana komórka spełnia warunek, funkcje te zwracają wartość PRAWDA. Na przykład jeśli komórka zawiera liczbę, to funkcja arkusza CZY.LICZBA zwraca wartość PRAWDA. Jeśli trzeba ustalić, czy w zakresie komórek istnieją komórki puste, można użyć funkcji arkusza kalkulacyjnego LICZ.PUSTE, która zliczy puste komórki w zakresie lub funkcji CZY.PUSTA, która ustali, czy w zakresie znajduje się przynajmniej jedna pusta komórka.

Funkcje logiczne

Można wykorzystać funkcje logiczne, aby zobaczyć, czy dany warunek jest prawdziwy lub fałszywy albo sprawdzić jeden lub wiele warunków. Na przykład można użyć funkcji JEŻELI do ustalenia, czy warunek jest prawdą lub fałszem: jedna wartość jest zwracana, jeśli warunek jest prawdziwy, a inna, gdy jest on fałszywy.

Funkcje wyszukiwania

Chcąc znaleźć wartości na listach lub w tabelach albo odwołanie do komórki, można użyć funkcji wyszukiwania i odwołania arkusza kalkulacyjnego. Na przykład, aby znaleźć w tabeli wartość odpowiadającą wartości z pierwszej kolumny tabeli, należy użyć funkcji arkusza kalkulacyjnego WYSZUKAJ.PIONOWO. Aby ustalić pozycję wartości na liście, należy użyć funkcji arkusza kalkulacyjnego PODAJ.POZYCJĘ.

Funkcje matematyczne

Funkcje matematyczne i trygonometryczne umożliwiają wykonywanie prostych obliczeń, takich jak zaokrąglanie liczby lub obliczanie całkowitej wartości zakresu komórek lub obliczeń złożonych, takich jak obliczanie całkowitej wartości zakresu komórek spełniających warunek określony w innym zakresie komórek.

Funkcje obiektowe

Funkcje obiektowe zezwalają na zwracanie w komórkach arkusza kalkulacyjnego informacji dotyczących obiektu. Na przykład można użyć funkcji HOST(), aby zwracane były informacje o obiektach znajdujących się na tej samej stronie sieci Web, na której znajduje się arkusz kalkulacyjny. Poniższa formuła zwraca wartość pola tekstowego TextBox1 znajdującego się na tej samej stronie sieci Web, na której znajduje się arkusz kalkulacyjny:

=HOST().Pole_Tekstowe1.Wartość

Aby zwracane były informacje znajdujące się w obiektach znajdujących się na tym samym serwerze lub na innych serwerach, można użyć innych funkcji, takich jak kombinacja funkcji UTWÓRZ.OBIEKT() i OBIEKT().

Funkcje statystyczne

Funkcje statystyczne arkusza kalkulacyjnego są przeznaczone do wykonywania analizy statystycznej zakresów danych. Na przykład funkcja statystyczna arkusza kalkulacyjnego może dostarczyć informacji statystycznych na temat linii prostej wykreślonej dla grupy wartości, takich jak nachylenie linii lub punkt przecięcia z osią y lub informacji o rzeczywistych punktach tworzących linię prostą.

Funkcje tekstu i daty

Funkcje tekstowe umożliwiają wykonywanie działań na ciągach tekstowych w formułach. Na przykład można zmienić wielkość liter albo ustalić długość ciągu tekstowego. Można także łączyć datę z ciągiem tekstowym. Poniższa formuła jest przykładem sposobu użycia funkcji DZIŚ z funkcją TEKST w celu utworzenia komunikatu zawierającego bieżącą datę w formacie liczbowym „dd-mmm-rrrr”.

="Raport budżetu z dnia "&TEKST(DZIŚ();"dd-mmm-rrrr")


Przykłady funkcji baz danych

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


BD.ILE.REKORDÓW

Zobacz też

W kolumnie listy lub bazy danych zlicza komórki, zawierające liczby odpowiadające określonym kryteriom.

Argument pole jest opcjonalny. Jeśli zostanie on pominięty, funkcja BD.ILE.REKORDÓW zlicza wszystkie rekordy w bazie danych, które spełniają kryteria.

Składnia

BD.ILE.REKORDÓW(baza;pole;kryteria)

Baza danych to zakres komórek, które tworzą listę lub bazę danych. Baza danych to lista powiązanych danych, gdzie wiersze powiązanych informacji to rekordy, a kolumny danych to pola. Pierwszy wiersz listy zawiera etykiety poszczególnych kolumn.

Pole wskazuje, której kolumny użyto w funkcji. Pole może zawierać tekst z etykietą kolumny ujętą w podwójny cudzysłów, na przykład „Wiek” lub „Plon”, albo liczbę reprezentującą pozycję kolumny na liście: 1 dla pierwszej kolumny, 2 dla drugiej kolumny itd. Jeśli argument pole zostanie pominięty, funkcja BD.ILE.REKORDÓW zlicza wszystkie rekordy w bazie danych, które spełniają kryteria.

Kryteria to zakres komórek, które zawierają warunki określone przez użytkownika. Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


BD.ILE.REKORDÓW.A

W kolumnie listy lub bazy danych zlicza wszystkie niepuste komórki, zawierające liczby odpowiadające określonym kryteriom.

Argument pole jest opcjonalny. Jeśli zostanie on pominięty, funkcja BD.ILE.REKORDÓW.A zlicza wszystkie rekordy w bazie danych, które spełniają kryteria.

Składnia

BD.ILE.REKORDÓW.A(baza;pole;kryteria)

Baza danych to zakres komórek, które tworzą listę lub bazę danych. Baza danych to lista powiązanych danych, gdzie wiersze powiązanych informacji to rekordy, a kolumny danych to pola. Pierwszy wiersz listy zawiera etykiety poszczególnych kolumn.

Pole wskazuje, której kolumny użyto w funkcji. Pole może zawierać tekst z etykietą kolumny ujętą w podwójny cudzysłów, na przykład „Wiek” lub „Plon”, albo liczbę reprezentującą pozycję kolumny na liście: 1 dla pierwszej kolumny, 2 dla drugiej kolumny itd. Jeśli argument pole zostanie pominięty, funkcja BD.ILE.REKORDÓW.A zwraca liczbę wszystkich rekordów spełniających kryteria. Jeśli argument pole zostanie uwzględniony, funkcja BD.ILE.REKORDÓW.A zwraca liczbę wszystkich rekordów, które zawierają niepusty argument pole oraz spełniają kryteria.

Kryteria to zakres komórek, które zawierają warunki określone przez użytkownika. Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


BD.ILOCZYN

Mnoży wartości w kolumnie listy lub bazy danych, spełniające podane warunki.

Składnia

BD.ILOCZYN(baza_danych;pole;kryteria)

Baza danych to zakres komórek, które tworzą listę lub bazę danych. Baza danych to lista powiązanych danych, gdzie wiersze powiązanych informacji to rekordy, a kolumny danych to pola. Pierwszy wiersz listy zawiera etykiety poszczególnych kolumn.

Pole wskazuje, której kolumny użyto w funkcji. Pole może być dane jako tekst z etykietą kolumny ujętą w znaki cudzysłowu, na przykład „Wiek” albo „Plon”, albo jako liczba reprezentująca pozycję kolumny na liście: 1 w przypadku pierwszej kolumny, 2 w przypadku drugiej kolumny i tak dalej.

Kryteria to zakres komórek, które zawierają warunki określone przez użytkownika. Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


BD.MAX

Zwraca największą liczbę w kolumnie listy lub bazy danych spełniającą określone warunki.

Składnia

BD.MAX(baza_danych;pole;kryteria)

Baza danych to zakres komórek, które tworzą listę lub bazę danych. Baza danych to lista powiązanych danych, gdzie wiersze powiązanych informacji to rekordy, a kolumny danych to pola. Pierwszy wiersz listy zawiera etykiety poszczególnych kolumn.

Pole wskazuje, której kolumny użyto w funkcji. Pole może być dane jako tekst z etykietą kolumny ujętą w znaki cudzysłowu, na przykład „Wiek” albo „Plon”, albo jako liczba reprezentująca pozycję kolumny na liście: 1 w przypadku pierwszej kolumny, 2 w przypadku drugiej kolumny i tak dalej.

Kryteria to zakres komórek, które zawierają warunki określone przez użytkownika. Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


BD.MIN

Zwraca najmniejszą liczbę w kolumnie listy lub bazy danych spełniającą określone warunki.

Składnia

BD.MIN(baza_danych;pole;kryteria)

Baza danych to zakres komórek, które tworzą listę lub bazę danych. Baza danych to lista powiązanych danych, gdzie wiersze powiązanych informacji to rekordy, a kolumny danych to pola. Pierwszy wiersz listy zawiera etykiety poszczególnych kolumn.

Pole wskazuje, której kolumny użyto w funkcji. Pole może być dane jako tekst z etykietą kolumny ujętą w znaki cudzysłowu, na przykład „Wiek” albo „Plon”, albo jako liczba reprezentująca pozycję kolumny na liście: 1 w przypadku pierwszej kolumny, 2 w przypadku drugiej kolumny i tak dalej.

Kryteria to zakres komórek, które zawierają warunki określone przez użytkownika. Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


BD.ODCH.STANDARD

Oszacowuje odchylenie standardowe populacji z próby, na podstawie liczb w kolumnie listy lub bazy danych spełniających określone warunki.

Składnia

BD.ODCH.STANDARD(baza_danych;pole;kryteria)

Baza danych to zakres komórek, które tworzą listę lub bazę danych. Baza danych to lista powiązanych danych, gdzie wiersze powiązanych informacji to rekordy, a kolumny danych to pola. Pierwszy wiersz listy zawiera etykiety poszczególnych kolumn.

Pole wskazuje, której kolumny użyto w funkcji. Pole może być dane jako tekst z etykietą kolumny ujętą w znaki cudzysłowu, na przykład „Wiek” albo „Plon”, albo jako liczba reprezentująca pozycję kolumny na liście: 1 w przypadku pierwszej kolumny, 2 w przypadku drugiej kolumny i tak dalej.

Kryteria to zakres komórek, które zawierają warunki określone przez użytkownika. Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


BD.ODCH.STANDARD.POPUL

Oblicza odchylenie standardowe populacji na podstawie całej populacji, używając liczb w kolumnie listy lub bazy danych, spełniających określane warunki.

Składnia

BD.ODCH.STANDARD.POPUL(baza_danych;pole;kryteria)

Baza danych to zakres komórek, które tworzą listę lub bazę danych. Baza danych to lista powiązanych danych, gdzie wiersze powiązanych informacji to rekordy, a kolumny danych to pola. Pierwszy wiersz listy zawiera etykiety poszczególnych kolumn.

Pole wskazuje, której kolumny użyto w funkcji. Pole może być dane jako tekst z etykietą kolumny ujętą w znaki cudzysłowu, na przykład „Wiek” albo „Plon”, albo jako liczba reprezentująca pozycję kolumny na liście: 1 w przypadku pierwszej kolumny, 2 w przypadku drugiej kolumny i tak dalej.

Kryteria to zakres komórek, które zawierają warunki określone przez użytkownika. Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


BD.POLE

Pobiera pojedynczą wartość z kolumny listy lub bazy danych, spełniającą określone warunki.

Składnia

BD.POLE(baza_danych;pole;kryteria)

Baza danych to zakres komórek, które tworzą listę lub bazę danych. Baza danych to lista powiązanych danych, gdzie wiersze powiązanych informacji to rekordy, a kolumny danych to pola. Pierwszy wiersz listy zawiera etykiety poszczególnych kolumn.

Pole wskazuje, której kolumny użyto w funkcji. Pole może być dane jako tekst z etykietą kolumny ujętą w znaki cudzysłowu, na przykład „Wiek” albo „Plon”, albo jako liczba reprezentująca pozycję kolumny na liście: 1 w przypadku pierwszej kolumny, 2 w przypadku drugiej kolumny i tak dalej.

Kryteria to zakres komórek, które zawierają warunki określone przez użytkownika. Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku.

Spostrzeżenia

  • Jeśli żaden z rekordów nie spełnia kryteriów, to funkcja BD.POLE zwraca wartość błędu #ARG!.
  • Jeśli więcej niż jeden rekord spełnia kryteria, to funkcja BD.POLE zwraca wartość błędu #LICZBA!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


BD.SUMA

Sumuje liczby w kolumnie listy lub bazy danych, spełniające podane warunki.

Składnia

BD.SUMA(baza_danych;pole;kryteria)

Baza danych to zakres komórek, które tworzą listę lub bazę danych. Baza danych to lista powiązanych danych, gdzie wiersze powiązanych informacji to rekordy, a kolumny danych to pola. Pierwszy wiersz listy zawiera etykiety poszczególnych kolumn.

Pole wskazuje, której kolumny użyto w funkcji. Pole może być dane jako tekst z etykietą kolumny ujętą w znaki cudzysłowu, na przykład „Wiek” albo „Plon”, albo jako liczba reprezentująca pozycję kolumny na liście: 1 w przypadku pierwszej kolumny, 2 w przypadku drugiej kolumny i tak dalej.

Kryteria to zakres komórek, które zawierają warunki określone przez użytkownika. Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


BD.ŚREDNIA

Uśrednia wartości w kolumnie listy lub bazy danych, spełniające podane kryteria.

Składnia

BD.ŚREDNIA(baza_danych;pole;kryteria)

Baza danych to zakres komórek, które tworzą listę lub bazę danych. Baza danych to lista powiązanych danych, gdzie wiersze powiązanych informacji to rekordy, a kolumny danych to pola. Pierwszy wiersz listy zawiera etykiety poszczególnych kolumn.

Pole wskazuje, której kolumny użyto w funkcji. Pole może być dane jako tekst z etykietą kolumny ujętą w znaki cudzysłowu, na przykład „Wiek” albo „Plon”, albo jako liczba reprezentująca pozycję kolumny na liście: 1 w przypadku pierwszej kolumny, 2 w przypadku drugiej kolumny i tak dalej.

Kryteria to zakres komórek, które zawierają warunki określone przez użytkownika. Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


BD.WARIANCJA

Oszacowuje wariancję populacji z próby, używając liczb w kolumnie listy lub bazy danych, spełniających określone warunki.

Składnia

BD.WARIANCJA(baza_danych;pole;kryteria)

Baza danych to zakres komórek, które tworzą listę lub bazę danych. Baza danych to lista powiązanych danych, gdzie wiersze powiązanych informacji to rekordy, a kolumny danych to pola. Pierwszy wiersz listy zawiera etykiety poszczególnych kolumn.

Pole wskazuje, której kolumny użyto w funkcji. Pole może być dane jako tekst z etykietą kolumny ujętą w znaki cudzysłowu, na przykład „Wiek” albo „Plon”, albo jako liczba reprezentująca pozycję kolumny na liście: 1 w przypadku pierwszej kolumny, 2 w przypadku drugiej kolumny i tak dalej.

Kryteria to zakres komórek, które zawierają warunki określone przez użytkownika. Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


BD.WARIANCJA.POPUL

Oblicza wariancję populacji na podstawie całej populacji, używając liczb w kolumnie listy lub bazy danych, spełniających podane warunki.

Składnia

BD.WARIANCJA.POPUL(baza;pole;kryteria)

Baza danych to zakres komórek, które tworzą listę lub bazę danych. Baza danych to lista powiązanych danych, gdzie wiersze powiązanych informacji to rekordy, a kolumny danych to pola. Pierwszy wiersz listy zawiera etykiety poszczególnych kolumn.

Pole wskazuje, której kolumny użyto w funkcji. Pole może być dane jako tekst z etykietą kolumny ujętą w znaki cudzysłowu, na przykład „Wiek” albo „Plon”, albo jako liczba reprezentująca pozycję kolumny na liście: 1 w przypadku pierwszej kolumny, 2 w przypadku drugiej kolumny i tak dalej.

Kryteria to zakres komórek, które zawierają warunki określone przez użytkownika. Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Drzewo | Wysokość | Wiek | Plon | Zysk | Wysokość
Jabłko | >10 |  |  |  | <16
Gruszka |  |  |  |  |
Drzewo | Wysokość | Wiek | Plon | Zysk
Jabłko | 18 | 20 | 14 | 105,00
Gruszka | 12 | 12 | 10 | 96,00
Wiśnia | 13 | 14 | 9 | 105,00
Jabłko | 14 | 15 | 10 | 75,00
Gruszka | 9 | 8 | 8 | 76,80
Jabłko | 8 | 9 | 6 | 45,00
Formuła | Opis (Wynik)
=BD.ILE.REKORDÓW(A4:E10;"Wiek";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Wiek w tych rekordach zawiera liczby. (1)
=BD.ILE.REKORDÓW.A(A4:E10;"Zysk";A1:F2) | Funkcja ta przegląda rekordy dotyczące jabłoni o wysokości od 10 do 16 i zlicza, ile pól Zysk w tych rekordach nie jest pustych. (1)
=BD.MAX(A4:E10;"Zysk";A1:A3) | Zysk maksymalny z drzew gruszy i jabłoni. (105)
=BD.MIN(A4:E10;"Zysk";A1:B2) | Zysk minimalny z drzew jabłoni o wysokości większej niż 3. (75)
=BD.SUMA(A4:E10;"Zysk";A1:A2) | Zysk całkowity z drzew jabłoni. (225)
=BD.SUMA(A4:E10;"Zysk";A1:F2) | Zysk całkowity z drzew jabłoni o wysokości między 3 a 4,8. (75)
=BD.ILOCZYN(A4:E10;"Plon";A1:B2) | Iloczyn plonów z drzew jabłoni o wysokości większej niż 3. (140)
=BD.ŚREDNIA(A4:E10;"Plon";A1:B2) | Średni plon z drzew jabłoni o wysokości większej niż 3 metry. (12)
=BD.ŚREDNIA(A4:E10;3;A4:E10) | Średnia wieku wszystkich drzew w bazie danych. (13)
=BD.ODCH.STANDARD(A4:E10;"Plon";A1:A3) | Szacowane standardowe odchylenie plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (2.97)
=BD.ODCH.STANDARD.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywiste odchylenie standardowe plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (2.65)
=BD.WARIANCJA(A4:E10;"Plon";A1:A3) | Szacowana wariancja plonu z drzew jabłoni i gruszy, jeżeli dane w bazie danych stanowią tylko próbę całkowitej populacji sadu. (8.8)
=BD.WARIANCJA.POPUL(A4:E10;"Plon";A1:A3) | Rzeczywista wariancja plonu z drzew jabłoni i gruszy, jeżeli w bazie danych są dane całej populacji. (7.04)
=BD.POLE(A4:E10;"Plon";A1:A3) | Zwraca błąd #NUM!, ponieważ więcej niż jeden rekord spełnia kryteria.

Porady

  • Możliwe jest użycie dowolnego zakresu jako argumentu kryteriów, o ile tylko zawiera on co najmniej jedną etykietę kolumny i co najmniej jedną komórkę poniżej etykiety, służącą do określania warunku. Na przykład, jeśli zakres G1:G2 zawiera etykietę kolumny Przychód w komórce G1 i kwotę 10 000 w komórce G2, to można nadać zakresowi nazwę "DobierzPrzychód" i użyć jej jako argumentu kryteriów w funkcjach bazy danych.
  • W większości przypadków zakres kryteriów nie powinien zachodzić na listę.
  • Aby przeprowadzić operację na całej kolumnie w bazie danych, należy wprowadzić pusty wiersz poniżej etykiet kolumn w zakresie zawierającym kryteria.

Przykłady kryteriów

Wiele warunków w jednej kolumnie

Jeśli trzeba zastosować dwa lub więcej warunków w jednej kolumnie, wpisz kryteria bezpośrednio jedno pod drugim w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wierszy zawierających w kolumnie Sprzedawca nazwiska "Stępień", "Borowik" lub "Kocoń".

Sprzedawca
Stępień
Borowik
Kocoń

Jeden warunek w dwóch lub w większej liczbie kolumn

Aby znaleźć dane spełniające warunek w dwóch lub większej liczbie kolumn, wprowadź wszystkie kryteria w tym samym wierszu zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca a wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał | Stępień | >1 000

Jeden warunek w jednej lub drugiej kolumnie

Aby znaleźć dane spełniające albo warunek w jednej kolumnie albo warunek w drugiej kolumnie, wprowadź wszystkie kryteria w różnych wierszach zakresu kryteriów. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających słowo "Nabiał" w kolumnie Rodzaj, nazwisko "Stępień" w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 000 złotych.

Rodzaj | Sprzedawca | Sprzedaż
Nabiał |  |
 | Stępień |
 |  | >1 000

Jeden z dwóch zestawów warunków dla dwóch kolumn

Aby znaleźć wiersze spełniające jeden z dwóch zestawów warunków, przy czym każdy zestaw zawiera warunki dla więcej niż jednej kolumny, wprowadź kryteria w oddzielnych wierszach. Na przykład poniższy zakres kryteriów powoduje wyświetlenie wszystkich wierszy zawierających zarówno nazwisko Stępień w kolumnie Sprzedawca i wartości sprzedaży większe niż 3 000 złotych, jak i wierszy zawierających nazwisko Borowik w kolumnie Sprzedawca i wartości sprzedaży większe niż 1 500 złotych.

Sprzedawca | Sprzedaż
Stępień | >3 000
Borowik | >1 500

Więcej niż dwa zbiory warunków dla jednej kolumny

Aby wyszukać wiersze spełniające więcej niż dwa zestawy warunków, uwzględnij kilka kolumn o tym samym nagłówku kolumny. Na przykład, następujący zakres kryteriów powoduje wyświetlenie transakcji sprzedaży na kwoty od 5 000 do 8 000 oraz transakcji na kwoty mniejsze niż 500.

Sprzedaż | Sprzedaż
>5 000 | <8 000
<500 |


CZAS

Zwraca wartość dziesiętną dla podanego czasu. Liczba dziesiętna zwracana przez funkcję CZAS jest wartością z zakresu od 0 do 0,99999999, reprezentującą czas od 0:00:00 (północ) do 23:59:59 (11:59:59 wieczorem).

Składnia

CZAS(godzina;minuta;sekunda)

Godzina to liczba z zakresu od 0 (zero) do 32 767 reprezentująca godzinę. Każda wartość większa niż 23 zostanie podzielona przez 24, a reszta będzie traktowana jako wartość godziny. Na przykład funkcja CZAS(27;0;0) = CZAS(3;0;0) = ,125 czyli 3:00.

Minuta to liczba z zakresu od 0 do 32 767 reprezentująca minuty. Każda wartość większa niż 59 zostanie konwertowana na godziny i minuty. Na przykład funkcja CZAS(0;750;0) = CZAS(12;30;0) = ,520833 czyli 12:30.

Sekunda to liczba z zakresu od 0 do 32 767 reprezentująca sekundy. Każda wartość większa niż 59 zostanie konwertowana na godziny, minuty i sekundy. Na przykład funkcja CZAS(0;0;2000) = CZAS(0;33;22) = ,023148 czyli 0:33:20.

Spostrzeżenia

Wartości czasu są częścią wartości daty i są reprezentowane przez liczby dziesiętne (na przykład 12:00 jest reprezentowane jako 0,5, ponieważ wypada w połowie dnia).

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Godzina | Minuta | Sekunda
12 | 0 | 0
16 | 48 | 10
Formuła | Opis (Wynik)
=CZAS(A2;B2;C2) | Pierwszy podany czas w reprezentacji dziesiętnej (0,5)
=CZAS(A3;B3;C3) | Drugi podany czas w reprezentacji dziesiętnej (0,700115741)

Uwaga Aby wyświetlić czas w postaci liczby dziesiętnej, należy zaznaczyć komórkę i kliknąć przycisk Polecenia i opcje [image] na pasku narzędzi. Następnie należy kliknąć kartę Format i wybrać format liczby Ogólny.


CZAS.WARTOŚĆ

Zwraca wartość dziesiętną dla czasu podanego w postaci łańcucha tekstowego. Wartość dziesiętna jest wartością z zakresu od 0 do 0,99999999, reprezentującą czas od 0:00:00 (północ) do 23:59:59 (11:59:59 wieczorem).

Składnia

CZAS.WARTOŚĆ(czas_tekst)

Czas_tekst to łańcuch tekstowy reprezentujący wartość czasu w dowolnym formacie czasu stosowanym w arkuszu kalkulacyjnym — na przykład łańcuch "6:45 PM" lub "18:45" w cudzysłowie.

Spostrzeżenia

  • Pominięta zostaje informacja o dacie zawarta w argumencie czas_tekst.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=CZAS.WARTOŚĆ("2:24") | Liczba dziesiętna odpowiadająca podanej wartości (0,1)
=CZAS.WARTOŚĆ("22-sie-2008 6:35") | Liczba dziesiętna odpowiadająca podanej wartości (0,274305556)

Uwaga Aby zmienić sposób wyświetlania wyniku z liczby kolejnej na format czasu lub odwrotnie, należy zaznaczyć komórkę i kliknąć przycisk Polecenia i opcje [image] na pasku narzędzi. Następnie należy kliknąć kartę Format i wskazać odpowiedni format w polu Format liczby. Aby wyświetlić datę jako liczbę kolejną, należy zastosować format liczby Ogólny.


DATA

Zwraca liczbę kolejną reprezentującą określoną datę.

Składnia

DATA(rok;miesiąc;dzień)

Rok Argument rok może zawierać od jednej do czterech cyfr.

  • Jeśli wartość argumentu rok zawiera się w przedziale od 0 (zero) do 1899 (włącznie), w celu obliczenia roku wartość ta zostaje dodana do liczby 1900. Na przykład funkcja DATA(108;1;2) zwraca datę 2 stycznia 2008 roku (1900+108).

  • Jeśli wartość argumentu rok zawiera się w przedziale od 1900 do 9999 (włącznie), wartość ta jest stosowana jako rok. Na przykład funkcja DATA(2008;1;2) zwraca datę 2 stycznia 2008 roku.

Miesiąc to liczba reprezentująca miesiąc roku. Jeśli wartość argumentu miesiąc jest większa niż 12, jest ona dodawana do pierwszego miesiąca podanego roku. Na przykład funkcja DATA(2008;14;2) zwraca liczbę kolejną reprezentującą datę 2 lutego 2009 roku.

Dzień to liczba reprezentująca dzień miesiąca. Jeśli wartość argumentu dzień jest większa niż liczba dni w miesiącu, jest ona dodawana do pierwszego dnia miesiąca. Na przykład funkcja DATA(2008;1;35) zwraca liczbę kolejną reprezentującą datę 4 lutego 2008 roku.

Spostrzeżenia

  • Daty są przechowywane jako liczby kolejne, dzięki czemu można ich używać w obliczeniach. Domyślnie wartość 31 grudnia 1899 jest równa liczbie kolejnej 1, a wartość 1 stycznia 2008 jest równa liczbie kolejnej 39 448, ponieważ jest to 39 448 dzień od 1 stycznia 1900.
  • Funkcja DATA jest najbardziej przydatna w formułach, w których rok, miesiąc i dzień są formułami, a nie stałymi.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Rok | Miesiąc | Dzień
2008 | 1 | 1
Formuła | Opis (Wynik)
=DATA(A2;B2;C2) | Data jako liczba kolejna dla daty pokazanej powyżej (2008-01-01 lub 39448)

Uwaga Aby zmienić sposób wyświetlania wyniku z liczby kolejnej na format daty lub odwrotnie, zaznacz komórkę i kliknij przycisk Polecenia i opcje [image] na pasku narzędzi. Kliknij kartę Format, a następnie zaznacz żądany format w polu Format liczby. Aby wyświetlić datę jako liczbę kolejną, zastosuj format liczbowy Ogólny.


DATA.WARTOŚĆ

Zwraca liczbę kolejną daty reprezentowanej przez argument tekst_daty. Funkcja DATA.WARTOŚĆ jest przydatna do zamiany dat, wyrażonych w postaci tekstu, na liczbę kolejną.

Składnia

DATA.WARTOŚĆ(tekst_daty)

Data_tekst to tekst reprezentujący datę, zapisany w formacie daty. Na przykład ciągi „30-01-1998” lub „30 stycznia 1998” są tekstami ujętymi w cudzysłów, reprezentującymi daty.

Jeśli część roczna argumentu tekst_daty jest pominięta, funkcja DATA.WARTOŚĆ pobiera aktualny rok z zegara wbudowanego w komputerze. Informacja o godzinie w argumencie tekst_daty jest ignorowana.

Spostrzeżenia

  • Daty są przechowywane jako liczby kolejne, dzięki czemu można ich używać w obliczeniach. Domyślnie wartość 31 grudnia 1899 jest równa liczbie kolejnej 1, a wartość 1 stycznia 2008 jest równa liczbie kolejnej 39 448, ponieważ jest to 39 448 dzień od 1 stycznia 1900.
  • Większość funkcji automatycznie zamienia wartości daty na liczby kolejne.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=DATA.WARTOŚĆ("22-08-2008") | Liczba kolejna daty wyrażonej tekstem (39682)
=DATA.WARTOŚĆ("22-sie-2008") | Liczba kolejna daty wyrażonej tekstem (39682)
=DATA.WARTOŚĆ("2008-02-23") | Liczba kolejna daty wyrażonej tekstem (39501)
=DATA.WARTOŚĆ("14-mar") | Liczba kolejna daty wyrażonej tekstem przy założeniu, że zegar wbudowany w komputerze jest ustawiony na rok 2000 (36712)

Uwaga Aby zmienić sposób wyświetlania wyniku z liczby kolejnej na format daty lub odwrotnie, zaznacz komórkę i kliknij przycisk Polecenia i opcje [image] na pasku narzędzi. Kliknij kartę Format, a następnie zaznacz żądany format w polu Format liczby. Aby wyświetlić datę jako liczbę kolejną, zastosuj format liczbowy Ogólny.


DNI.360

Zwraca liczbę dni pomiędzy dwiema datami, stosując rok 360-dniowy (dwanaście 30-dniowych miesięcy), który jest używany w pewnych obliczeniach księgowych. Funkcja ta jest przydatna w obliczaniu płatności w przypadku, gdy system księgowy jest oparty na dwunastu 30-dniowych miesiącach.

Składnia

DNI.360(data_początkowa;data_końcowa;metoda)

Data_początkowa i data_końcowa to dwie daty, między którymi ma zostać określona liczba dni. Jeśli wartość argumentu data_początkowa przypada po wartości argumentu data_końcowa, funkcja DNI.360 zwraca wartość ujemną. Daty powinny być wprowadzane przy użyciu funkcji DATA lub jako wynik innych formuł lub funkcji. Na przykład należy użyć funkcji DATA(2008;5;23), aby wprowadzić datę 23 maja 2008 roku. Jeśli daty będą wprowadzane jako tekst, mogą wystąpić problemy.

Metoda to wartość logiczna określająca, czy w obliczeniach ma być użyta metoda europejska czy amerykańska.

Metoda | Określenie
FAŁSZ lub pominięte | Metoda amerykańska (NASD). Jeśli data początkowa przypada na 31. dzień miesiąca, staje się ona równa 30. dniowi tego samego miesiąca. Jeśli data końcowa przypada na 31. dzień miesiąca, a data początkowa przypada wcześniej niż na 30. dzień miesiąca, data końcowa staje się równa 1. dniowi następnego miesiąca. W przeciwnym razie data końcowa staje się równa 30. dniowi tego samego miesiąca.
PRAWDA | Metoda europejska. Daty początkowe lub końcowe przypadające na 31. dzień miesiąca stają się równe 30. dniowi tego samego miesiąca.

Spostrzeżenie

Daty są przechowywane jako liczby kolejne, dzięki czemu można ich używać w obliczeniach. Domyślnie wartość 31 grudnia 1899 jest równa liczbie kolejnej 1, a wartość 1 stycznia 2008 jest równa liczbie kolejnej 39 448, ponieważ jest to 39 448 dzień od 1 stycznia 1900.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Daty
2008-01-30
2008-02-01
Formuła | Opis (Wynik)
=DNI.360(A2;A3) | Liczba dni między datami określonymi powyżej, obliczona w oparciu o rok 360-dniowy (1)


DZIEŃ

Zwraca dzień z daty, reprezentowany przez liczbę kolejną. Dzień jest wyrażony liczbą całkowitą w przedziale od 1 do 31.

Składnia

DZIEŃ(liczba_kolejna)

Liczba_kolejna to data dnia, który jest wyszukiwany.

Spostrzeżenia

  • Daty powinny być wprowadzane przy użyciu funkcji DATA lub jako wynik innych formuł lub funkcji. Na przykład użyj funkcji DATA(2008;5;23), aby wprowadzić datę 23 maja 2008 roku. Jeśli daty są wprowadzane jako tekst, może zostać zwrócona wartość błędu #ARG!.

  • Daty są przechowywane jako liczby kolejne, dzięki czemu można ich używać w obliczeniach. Domyślnie wartość 31 grudnia 1899 jest równa liczbie kolejnej 1, a wartość 1 stycznia 2008 jest równa liczbie kolejnej 39 448, ponieważ jest to 39 448 dzień od 1 stycznia 1900.
  • Wartości zwracane przez funkcje ROK, MIESIĄC i DZIEŃ mają format gregoriański, niezależnie od formatu wyświetlania podanej daty. Na przykład, jeśli format wyświetlania podanej daty to Hidżra, zwracane wartości funkcji ROK, MIESIĄC i DZIEŃ będą wartościami skojarzonymi z odpowiednią datą kalendarza gregoriańskiego.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Data
15 kwietnia 2008
Formuła | Opis (Wynik)
=DZIEŃ(A2) | Dzień w powyższej dacie (15)


DZIEŃ.TYG

Zwraca dzień tygodnia odpowiadający dacie. Dzień jest wyrażony domyślnie jako liczba całkowita w zakresie od 1 (niedziela) do 7 (sobota).

Składnia

DZIEŃ.TYG(numer_kolejny;zwracany_typ)

Numer_kolejny to liczba odpowiadająca dacie zawierającej szukany dzień. Daty powinny być wprowadzane przy użyciu funkcji DATA lub jako wynik innych formuł lub funkcji. Na przykład, aby wprowadzić datę 23 maja 2008 roku, należy użyć funkcji DATA(2008;5;23). Jeśli daty będą wprowadzane jako tekst, mogą wystąpić problemy.

Zwracany_typ to liczba, która określa typ obliczanej wartości.

Zwracany_typ | Zwrócona liczba
1 lub jest pominięty | Liczby od 1 (niedziela) do 7 (sobota).
2 | Liczby od 1 (poniedziałek) do 7 (niedziela)
3 | Liczby od 0 (poniedziałek) do 6 (niedziela)

Spostrzeżenie

Daty są przechowywane jako liczby kolejne, dzięki czemu można ich używać w obliczeniach. Domyślnie wartość 31 grudnia 1899 jest równa liczbie kolejnej 1, a wartość 1 stycznia 2008 jest równa liczbie kolejnej 39 448, ponieważ jest to 39 448 dzień od 1 stycznia 1900.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
14-2-2008
Formuła | Opis (Wynik)
=DZIEŃ.TYG(A2) | Dzień tygodnia — liczby od 1 (niedziela) do 7 (sobota) (5)
=DZIEŃ.TYG(A2;2) | Dzień tygodnia — liczby od 1 (poniedziałek) do 7 (niedziela) (4)
=DZIEŃ.TYG(A2;3) | Dzień tygodnia — liczby od 0 (poniedziałek) do 6 (niedziela) (3)

Uwaga Dzień 14-2-2008 to wtorek.


DZIŚ

Zwraca liczbę kolejną bieżącej daty. Liczba kolejna to kod daty-czasu używany przez arkusz kalkulacyjny do obliczeń daty i czasu.

Składnia

DZIŚ( )

Spostrzeżenia

Daty są przechowywane jako liczby kolejne, dzięki czemu można ich używać w obliczeniach. Domyślnie wartość 31 grudnia 1899 jest równa liczbie kolejnej 1, a wartość 1 stycznia 2008 jest równa liczbie kolejnej 39 448, ponieważ jest to 39 448 dzień od 1 stycznia 1900.

Uwaga Aby zmienić sposób wyświetlania wyniku z liczby kolejnej na format daty lub odwrotnie, zaznacz komórkę i kliknij przycisk Polecenia i opcje [image] na pasku narzędzi. Kliknij kartę Format, a następnie zaznacz żądany format w polu Format liczby. Aby wyświetlić datę jako liczbę kolejną, zastosuj format liczbowy Ogólny.


GODZINA

Zwraca godzinę odpowiadającą wartości czasu. Godzina jest przedstawiona jako liczba całkowita z zakresu od 0 (północ) do 23 (11:00 wieczór).

Składnia

GODZINA(liczba_kolejna)

Liczba_kolejna to czas zawierający godzinę, która ma zostać odnaleziona. Czas może być wprowadzany jako tekst ujęty w cudzysłów (na przykład "18:45"), jako liczba dziesiętna (na przykład 0,78125, odpowiadająca godzinie 18:45), albo jako wynik innych formuł lub funkcji (na przykład CZAS.WARTOŚĆ("18:45")).

Spostrzeżenia

Wartości czasu są częścią wartości daty i są reprezentowane przez liczby dziesiętne (na przykład 12:00 jest reprezentowane jako 0,5, ponieważ wypada w połowie dnia).

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Czas
3:30:30 AM
3:30:30 PM
15:30
Formuła | Opis (Wynik)
=GODZINA(A2) | Godzina dla pierwszej wartości czasu (3)
=GODZINA(A3) | Godzina dla drugiej wartości czasu (15)
=GODZINA(A4) | Godzina dla trzeciej wartości czasu (15)


MIESIĄC

Zwraca miesiąc przedstawiany przez liczbę kolejną. Miesiąc jest podawany jako liczba całkowita z zakresu od 1 (styczeń) do 12 (grudzień).

Składnia

MIESIĄC(liczba_kolejna)

Liczba_kolejna to data miesiąca, który należy znaleźć. Daty powinny być wprowadzane przy użyciu funkcji DATA lub jako wynik innych formuł lub funkcji. Na przykład, aby wprowadzić datę 23 maja 2008 roku, należy użyć funkcji DATA(2008;5;23). Jeśli daty będą wprowadzane jako tekst, mogą wystąpić problemy.

Spostrzeżenia

Daty są przechowywane jako liczby kolejne, dzięki czemu można ich używać w obliczeniach. Domyślnie wartość 31 grudnia 1899 jest równa liczbie kolejnej 1, a wartość 1 stycznia 2008 jest równa liczbie kolejnej 39 448, ponieważ jest to 39 448 dzień od 1 stycznia 1900.

Wartości zwracane przez funkcje ROK, MIESIĄC i DZIEŃ mają format gregoriański, niezależnie od formatu wyświetlania podanej daty. Na przykład, jeśli format wyświetlania podanej daty to Hidżra, zwracane wartości funkcji ROK, MIESIĄC i DZIEŃ będą wartościami skojarzonymi z odpowiednią datą kalendarza gregoriańskiego.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Data
15 kwietnia 2008
Formuła | Opis (Wynik)
=MIESIĄC(A2) | Miesiąc w powyższej dacie (4)


MINUTA

Zwraca minuty wartości czasowej. Minuty podaje się jako liczbę całkowitą, z zakresu od 0 do 59.

Składnia

MINUTA(liczba_kolejna)

Liczba_kolejna to czas zawierający minutę, którą należy znaleźć. Czas może być wprowadzany jako ciąg tekstowy w cudzysłowie (na przykład "18:45"), jako liczba w systemie dziesiętnym (na przykład 0,78125, reprezentujące 18:45) lub jako wynik innych formuł lub funkcji (na przykład CZAS.WARTOŚĆ("18:45")).

Spostrzeżenia

Wartości czasu są częścią wartości daty i reprezentowane są przez liczby dziesiętne (na przykład godzina 12:00 jest reprezentowana jako 0,5 ponieważ wypada w połowie dnia).

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Czas
16:48:00
Formuła | Opis (Wynik)
=MINUTA(A2) | Minuty podanego powyżej czasu (48)


ROK

Zwraca rok odpowiadający podanej dacie.

Składnia

ROK(numer_kolejny)

Numer_kolejny to data, dla której ma być określony rok. Daty powinny być wprowadzane przy użyciu funkcji DATA lub jako wynik innych formuł lub funkcji. Na przykład, aby wprowadzić datę 23 maja 2008 roku, należy użyć funkcji DATA(2008;5;23). Jeśli daty będą wprowadzane jako tekst, mogą wystąpić problemy.

Spostrzeżenia

Daty są przechowywane jako liczby kolejne, dzięki czemu można ich używać w obliczeniach. Domyślnie wartość 31 grudnia 1899 jest równa liczbie kolejnej 1, a wartość 1 stycznia 2008 jest równa liczbie kolejnej 39 448, ponieważ jest to 39 448 dzień od 1 stycznia 1900.

Wartości zwracane przez funkcje ROK, MIESIĄC i DZIEŃ mają format gregoriański, niezależnie od formatu wyświetlania podanej daty. Na przykład, jeśli format wyświetlania podanej daty to Hidżra, zwracane wartości funkcji ROK, MIESIĄC i DZIEŃ będą wartościami skojarzonymi z odpowiednią datą kalendarza gregoriańskiego.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Data
5-7-2008
5-7-10
Formuła | Opis (Wynik)
=ROK(A2) | Rok pierwszej daty (2008)
=ROK(A3) | Rok drugiej daty (2010)


SEKUNDA

Zwraca w wyniku liczbę sekund wartości czasu. Sekunda jest wyrażona w postaci liczby całkowitej w zakresie od 0 do 59.

Składnia

SEKUNDA(kolejna_liczba)

Kolejna_liczba to czas zawierający sekundy, których liczbę chcesz określić. Czas może być wprowadzany jako łańcuch tekstowy w cudzysłowie (na przykład "18:45"), jako liczba w systemie dziesiętnym (na przykład 0,78125, reprezentujące 18:45) lub jako wynik innych formuł lub funkcji (na przykład CZAS.WARTOŚĆ("18:45")).

Spostrzeżenia

Wartości czasu są częścią wartości daty i są reprezentowane przez liczby dziesiętne (na przykład 12:00 jest reprezentowane jako 0,5, ponieważ wypada w połowie dnia).

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Czas
16:48:18
16:48 PM
Formuła | Opis
=SEKUNDA(A2) | Liczba sekund w pierwszej wartości czasu (18)
=SEKUNDA(A3) | Liczba sekund w drugiej wartości czasu (0)


TERAZ

Zwraca liczbę kolejną bieżącej daty i godziny.

Składnia

TERAZ( )

Spostrzeżenia

  • Daty są przechowywane jako liczby kolejne, dzięki czemu można ich używać w obliczeniach. Domyślnie wartość 31 grudnia 1899 jest równa liczbie kolejnej 1, a wartość 1 stycznia 2008 jest równa liczbie kolejnej 39 448, ponieważ jest to 39 448 dzień od 1 stycznia 1900.
  • Liczby po prawej stronie przecinka dziesiętnego przedstawiają godzinę, liczby po lewej stronie przedstawiają datę. Na przykład liczba kolejna 0,5 reprezentuje godzinę 12:00 w południe.
  • Funkcja TERAZ zmienia się tylko przy obliczaniu arkusza kalkulacyjnego. Nie ma ciągłej aktualizacji.

Uwaga Aby zmienić sposób wyświetlania wyniku z liczby kolejnej na format daty lub odwrotnie, zaznacz komórkę i kliknij przycisk Polecenia i opcje [image] na pasku narzędzi. Kliknij kartę Format, a następnie zaznacz żądany format w polu Format liczby. Aby wyświetlić datę jako liczbę kolejną, zastosuj format liczbowy Ogólny.


DB

Zwraca wartość amortyzacji środka trwałego w podanym okresie na podstawie metody równomiernie malejącego salda.

Składnia

DB(koszt;odzysk;czas_życia;okres;miesiąc)

Koszt to początkowy koszt środka trwałego.

Odzysk to wartość na koniec okresu amortyzacji (czasami nazywana wartością końcową środka trwałego).

Czas_życia to liczba okresów, w czasie których środek trwały jest amortyzowany (czasami jest zwany czasem życia środka trwałego).

Okres to okres, dla którego jest liczona amortyzacja. Argument okres musi być wyrażony w tych samych jednostkach, co argument czas_życia.

Miesiąc to liczba miesięcy w pierwszym roku. Jeśli argument miesiąc jest pominięty, jego wartość przyjmuje się jako 12.

Spostrzeżenia

  • Metoda równomiernie malejącego salda służy do obliczania amortyzacji przy stałej stawce. Amortyzację za dany okres wyznacza się według następującego wzoru:

    (koszt — całkowita amortyzacja za poprzednie okresy) * stopa

    gdzie:

    stawka = 1 — ((odzysk / koszt ) ^ (1 / czas_życia )), zaokrąglona do trzech miejsc dziesiętnych.

  • Amortyzację w pierwszym i ostatnim okresie oblicza się w inny sposób. Dla pierwszego okresu funkcja DB korzysta z formuły:

    koszt * stopa * miesiąc / 12

  • Dla ostatniego okresu funkcja DB korzysta z formuły:

    ((koszt — całkowita amortyzacja za poprzednie okresy) * stawka * (12 — miesiąc )) / 12

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
1 000 000 | Koszt początkowy
100 000 | Wartość odzyskana
6 | Okres użytkowania wyrażony w latach
Formuła | Opis (Wynik)
=DB(A2;A3;A4;1;7) | Amortyzacja w pierwszym roku, uwzględniająca okres jedynie 7 miesięcy (186 083,33)
=DB(A2;A3;A4;2;7) | Amortyzacja w drugim roku (259 639,42)
=DB(A2;A3;A4;3;7) | Amortyzacja w trzecim roku (176 814,44)
=DB(A2;A3;A4;4;7) | Amortyzacja w czwartym roku (120 410,64)
=DB(A2;A3;A4;5;7) | Amortyzacja w piątym roku (81 999,64)
=DB(A2;A3;A4;6;7) | Amortyzacja w szóstym roku (55 841,76)
=DB(A2,A3,A4,7;7) | Amortyzacja w siódmym roku, uwzględniająca jedynie okres 5 miesięcy (15 845,10)


DDB

Zwraca wartość amortyzacji środka trwałego dla zadanego okresu przy użyciu metody podwójnie malejącego salda lub innej wybranej.

Składnia

DDB(koszt;odzysk;czas_życia;okres;współczynnik)

Koszt to początkowy koszt środka trwałego.

Odzysk to wartość na koniec okresu amortyzacji (czasami nazywana wartością końcową środka trwałego).

Czas_życia to liczba okresów, w czasie których środek trwały jest amortyzowany (czasami jest zwany czasem życia środka trwałego).

Okres to okres, dla którego jest liczona amortyzacja. Argument okres musi być wyrażony w tych samych jednostkach, co argument czas_życia.

Współczynnik to szybkość, z jaką zmniejsza się saldo. Jeśli współczynnik ten jest pominięty, jego wartość przyjmuje się jako 2 (metoda podwójnie malejącego salda).

Wszystkie argumenty muszą mieć wartość dodatnią.

Spostrzeżenia

  • Metoda podwójnie malejącego salda służy do obliczania amortyzacji w sposób przyspieszony. Wartość amortyzacji jest największa w pierwszym okresie i maleje w kolejnych okresach. Do obliczania amortyzacji w wybranym okresie funkcja DDB korzysta z poniższego wzoru:

    ((koszt — odzysk) — całkowita amortyzacja za poprzednie okresy) * (współczynnik / czas_życia)

  • Jeśli użycie metody podwójnie malejącego salda jest niepożądane, należy zmienić wartość argumentu współczynnik.
  • Aby się przełączyć na metodę liniowo malejącego salda, kiedy amortyzacja jest większa niż obliczone malejące saldo, należy użyć funkcji VDB.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
2400 | Koszt początkowy
300 | Wartość odzyskana
10 | Okres użytkowania wyrażony w latach
Formuła | Opis (Wynik)
=DDB(A2;A3;A4*365;1) | Amortyzacja w pierwszym dniu. Wartość współczynnika jest automatycznie przyjmowana jako 2 (1,32)
=DDB(A2;A3;A4*12;1;2) | Amortyzacja w pierwszym miesiącu (40,00)
=DDB(A2;A3;A4;1;2) | Amortyzacja w pierwszym roku (480,00)
=DDB(A2;A3;A4;2;1,5) | Amortyzacja w drugim roku przy zastosowaniu współczynnika 1,5 zamiast metody podwójnie malejącego salda (306,00)
=DDB(A2;A3;A4;10) | Amortyzacja w dziesiątym roku. Wartość współczynnika jest automatycznie przyjmowana jako 2 (22,12)

Uwaga Wyniki są zaokrąglane do dwóch miejsc dziesiętnych.


EUROCONVERT

Część zawartości tego tematu może nie mieć zastosowania w przypadku niektórych języków.

Konwertuje liczbę na euro, daną wartość w euro na wartość w walucie kraju członkowskiego euro lub wartość w walucie jednego kraju członkowskiego na wartość w walucie innego kraju członkowskiego za pomocą euro jako waluty pośredniej (triangulacja). Waluty dostępne dla konwersji to waluty krajów należących do Unii Europejskiej, które przyjęły euro. Funkcja stosuje podczas konwersji kursy walut ustanowione przez Unię Europejską.

Składnia

EUROCONVERT(liczba;źródło;cel;pełna_dokładność;dokładność_triangulacji)

Liczba to wartość walutowa, która ma być konwertowana albo odwołanie do komórki zawierającej taką wartość.

Źródło to trzyliterowy ciąg lub odwołanie do komórki zawierającej ciąg odpowiadający kodowi ISO waluty źródłowej. Dla funkcji EUROCONVERT dostępne są następujące kody walut:

Kraj | Waluta podstawowa | Kod ISO
Belgia | frank | BEF
Luksemburg | frank | LUF
Niemcy | marka niemiecka | DEM
Hiszpania | peseta | ESP
Francja | frank | FRF
Irlandia | funt | IEP
Włochy | lir | ITL
Holandia | gulden | NLG
Austria | szyling | ATS
Portugalia | escudo | PTE
Finlandia | marka | FIM
Kraje członkowskie euro | euro | EUR

Cel to trzyliterowy ciąg lub odwołanie do komórki zawierającej ciąg odpowiadający kodowi ISO waluty, na którą ma być konwertowana podana liczba. Kody ISO przedstawiono w poprzednich tabelach źródła.

Pełna_dokładność to wartość logiczna (PRAWDA lub FAŁSZ) albo wyrażenie oszacowujące wartość PRAWDA lub FAŁSZ określającą sposób zaokrąglenia wyniku.

Użyj | Aby uzyskać
FAŁSZ | Wynik wyświetlany z regułami zaokrąglania określonymi dla danej waluty (patrz tabela poniżej). Wartość FAŁSZ jest wartością domyślną, jeśli argument pełna_dokładność zostanie pominięty.
PRAWDA | Wynik wyświetlany ze wszystkimi cyframi znaczącymi, wynikającymi z obliczeń.

W poniższej tabeli przedstawiono zasady zaokrąglania dla poszczególnych walut. Zasady te określają, ile miejsc dziesiętnych zostaje użytych podczas konwersji waluty i wyświetlania wyniku.

Kod ISO | Dokładność obliczeń | Dokładność wyświetlania
BEF | 0 | 0
LUF | 0 | 0
DEM | 2 | 2
ESP | 0 | 0
FRF | 2 | 2
IEP | 2 | 2
ITL | 0 | 0
NLG | 2 | 2
ATS | 2 | 2
PTE | 1 | 2
FIM | 2 | 2
EUR | 2 | 2

Dokładność_triangulacji to liczba całkowita nie mniejsza niż 3, która podczas konwersji między dwiema walutami krajów członkowskich euro określa liczbę cyfr znaczących, stosowanych do pośredniej wartości wyrażonej w euro. Jeśli argument ten zostanie pominięty, pośrednia wartość wyrażona w euro nie będzie zaokrąglana. Jeśli podczas konwersji z waluty kraju będącego członkiem EMU na euro argument ten zostanie uwzględniony, w arkuszu zostaje obliczona pośrednia wartość wyrażona w euro, która może być następnie skonwertowana na walutę innego kraju będącego członkiem EMU.

Spostrzeżenia

  • Końcowe zera w zwróconej wartości są obcinane.
  • Jeśli kod ISO waluty źródłowej jest taki sam, jak kod waluty docelowej, zwracana jest oryginalna wartość wyrażona w danej walucie.
  • W przypadku nieprawidłowych parametrów zwracana jest wartość #ARG.
  • Dla funkcji tej nie jest stosowany format liczbowy.

Przykłady

W przykładach tych przyjęto, że 1 euro = 6,55957 franka francuskiego i 1,95583 marki niemieckiej. Funkcja EUROCONVERT korzysta z bieżących kursów ustalonych przez UE. Firma Microsoft zaktualizuje tę funkcję, jeśli kursy ulegną zmianie. Aby uzyskać pełne informacje dotyczące aktualnie obowiązujących zasad i kursów, należy zapoznać się z publikacjami Unii Europejskiej na temat euro.

W przykładach pokazywany jest wynik przechowywany w komórce, a nie wartość sformatowana.

EUROCONVERT(1,20;"DEM";"EUR") równa się 0,61 euro. Ponieważ argumenty pełna_dokładność i dokładność_triangulacji nie są określone, stosowana jest dokładność obliczeń dla euro, czyli 2 miejsca dziesiętne.

EUROCONVERT(1;"FRF";"EUR";PRAWDA;3) równa się 0,152 euro. Jeśli podczas konwersji na euro argument pełna_dokładność ma wartość PRAWDA, stosowana jest dokładność określona przez argument dokładność_triangulacji.

EUROCONVERT(1;"FRF";"EUR";FAŁSZ;3) równa się 0,15 euro. Jeśli podczas konwersji na euro argument pełna_dokładność ma wartość FAŁSZ, stosowana jest dokładność obliczeń dla euro, czyli 2 miejsca dziesiętne.

EUROCONVERT(1;"FRF";"DEM";PRAWDA;3) równa się 0,29728616 DM. Ponieważ argument dokładność_triangulacji ma wartość 3, wartość wyrażona w euro jako walucie pośredniej jest zaokrąglana do trzech miejsc dziesiętnych. Ponieważ argument pełna_dokładność ma wartość TRUE, otrzymana wartość w markach niemieckich przechowywana jest ze wszystkimi cyframi znaczącymi.

EUROCONVERT(1;"FRF";"DEM";FAŁSZ;3) równa się 0,30 DM. Ponieważ argument dokładność_triangulacji ma wartość 3, wartość wyrażona w euro jako walucie pośredniej jest zaokrąglana do trzech miejsc dziesiętnych. Ponieważ argument pełna_dokładność ma wartość FAŁSZ, otrzymana wartość w markach niemieckich jest zaokrąglana zgodnie z dokładnością obliczeń dla marki niemieckiej, czyli do dwóch miejsc dziesiętnych.


FV

Zwraca wartość przyszłą inwestycji przy założeniu okresowych, stałych płatności i stałej stopy procentowej.

Składnia

FV(stopa;liczba_rat;rata;wa;typ)

Aby uzyskać pełniejszy opis argumentów funkcji FV oraz więcej informacji na temat funkcji renty, należy zapoznać się z opisem funkcji PV.

Stopa to stopa procentowa dla okresu.

Liczba_rat to całkowita liczba okresów płatności w okresie spłaty.

Rata to wpłata dokonywana okresowo; nie może ona ulec zmianie w całym okresie płatności. Rata obejmuje zazwyczaj kapitał i odsetki z wyłączeniem innych opłat i podatków. Jeśli argument spłata zostanie pominięty, musi zostać umieszczony argument wa.

Wa to wartość obecna lub skumulowana wartość przyszłego strumienia płatności według wyceny na dzień obecny. Jeśli argument wa jest pominięty, przyjmuje się jego wartość jako 0 (zero) i należy określić argument rata.

Typ to liczba 0 albo 1, który wskazuje, kiedy płatność jest należna. Jeśli pomija się ten argument, domyślnie przyjmuje on wartość 0.

Wartość argumentu typ wynosi | Płatność przypada na
0 | koniec okresu
1 | początek okresu

Uwagi
  • Należy się upewnić, czy dobrze została zrozumiana treść dotycząca argumentów stopa i liczba_rat. Jeśli dokonuje się miesięcznych spłat czteroletniej pożyczki oprocentowanej na 12% rocznie, to stopa wynosi 12%/12, a liczba_rat 4*12. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to stopa wynosi 12%, zaś liczba_rat 4.
  • Przy wszystkich argumentach, środki wypłacane, takie jak wpłaty na rachunki oszczędnościowe wyrażone są liczbami ujemnymi, podczas gdy przychody, takie jak czeki z tytułu dywidend, wyrażone są liczbami dodatnimi.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
6% | Roczna stopa procentowa
10 | Liczba płatności
-200 | Kwota płatności
-500 | Wartość obecna
1 | Płatność powinna być dokonana na początku okresu (zobacz powyżej)
Formuła | Opis (Wynik)
=FV(A2/12;A3;A4;A5;A6) | Przyszła wartość inwestycji przy powyższych warunkach (2 581,40)

Uwaga Roczna stopa procentowa jest podzielona przez 12, ponieważ dotyczy płatności naliczanych miesięcznie.

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
12% | Roczna stopa procentowa
12 | Liczba płatności
-1 000 | Kwota płatności
Formuła | Opis (Wynik)
=FV(A2/12;A3;A4) | Przyszła wartość inwestycji przy powyższych warunkach (12 682,50)

Uwaga Roczna stopa procentowa jest podzielona przez 12, ponieważ dotyczy płatności naliczanych miesięcznie.


IPMT

Zwraca wysokość spłaty odsetek dla danego okresu dla kredytu opartego na regularnych, stałych spłatach i stałej stopie procentowej. Dodatkowe informacje na temat argumentów używanych w funkcji IPMT i na temat funkcji kredytu przedstawiono w opisie funkcji PV.

Składnia

IPMT(stopa;okres;liczba_rat;wa; wp;typ)

Stopa to stopa procentowa dla okresu.

Okres to okres, za który należy wyznaczyć oprocentowanie; musi pochodzić z przedziału wartości od 1 do liczba_rat.

Liczba_rat to całkowita liczba okresów płatności w okresie spłaty.

Wa to obecna wartość, czyli całkowita suma bieżącej wartości serii przyszłych płatności.

Wp to przyszła wartość, czyli poziom finansowy, do którego zmierza się po dokonaniu ostatniej płatności. Jeśli argument wp jest pominięty, to jako jego wartość przyjmuje się 0 (przyszła wartość pożyczki na przykład wynosi 0).

Typ to liczba 0 albo 1, który wskazuje, kiedy płatność jest należna. Jeśli pomija się ten argument, domyślnie przyjmuje on wartość 0.

Wartość argumentu typ wynosi | Płatność przypada na
0 | koniec okresu
1 | początek okresu

Uwagi
  • Należy się upewnić, czy dobrze została zrozumiana treść dotycząca argumentów stopa i liczba_rat. Jeśli dokonuje się miesięcznych spłat czteroletniej pożyczki oprocentowanej na 12% rocznie, to stopa wynosi 12%/12, a liczba_rat 4*12. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to stopa wynosi 12%, zaś liczba_rat 4.
  • Przy wszystkich argumentach, środki wypłacane, takie jak wpłaty na rachunki oszczędnościowe wyrażone są liczbami ujemnymi, podczas gdy przychody, takie jak czeki z tytułu dywidend, wyrażone są liczbami dodatnimi.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
10% | Oprocentowanie roczne
1 | Okres, dla którego chcesz obliczyć oprocentowanie
3 | Lata pożyczki
8 000 | Obecna wartość pożyczki
Formuła | Opis (Wynik)
=IPMT(A2/12; A3*3; A4; A5) | Oprocentowanie należne w pierwszym miesiącu pożyczki przy powyższych warunkach (-22,41)
=IPMT(A2; 3; A4; A5) | Oprocentowanie należne w ostatnim roku pożyczki przy powyższych warunkach, przy czym wpłaty są dokonywane rocznie (-292,45)

Uwaga Aby uzyskać stopę miesięczną, stopa oprocentowania jest dzielona przez 12. Liczba lat okresu spłaty należności jest mnożona przez 12 w celu obliczenia liczby spłat.


IRR

Zwraca wewnętrzną stopę zysku dla serii przepływów gotówkowych reprezentowanych przez liczby w wartościach. Przepływy gotówkowe nie muszą być równe, tak jaki byłyby dla renty. Muszą jednak występować w regularnych odstępach czasu, np. rocznie lub miesięcznie. Wewnętrzna stopa zysku jest stopą procentową otrzymywaną z inwestycji składającej się z wydatków (wartości ujemne) i dochodów (wartości dodatnie) występujących regularnie.

Składnia

IRR(wartości; wynik)

Wartości to tablica lub odwołanie do komórek, które zawierają liczby, dla których chcesz obliczyć wewnętrzną stopę zysku.

  • Wyliczenie wewnętrznej stopy zysku wymaga obecności przynajmniej jednej liczby dodatniej i jednej liczby ujemnej w wartościach.
  • W interpretacji kolejności przepływów gotówkowych, funkcja IRR wykorzystuje kolejność wartości. Należy się upewnić, że wartości płatności i przychodów wprowadzane są we właściwej kolejności.
  • Jeśli argument tablicowy lub odwołaniowy zawiera tekst, wartości logiczne lub puste komórki, wartości te są pomijane.

Przypuszczenie to liczba przypuszczalnie zbliżona do wyniku funkcji IRR.

  • Do obliczenia wartości funkcji IRR stosowana jest technika iteracyjna. Zaczynając od argumentu przypuszczenie, funkcja IRR powtarza obliczenia do chwili osiągnięcia wyniku z dokładnością do 0,00001%. Jeśli funkcja IRR nie może znaleźć wyniku po 20 próbach, zwracana jest wartość błędu #LICZBA!.
  • W większości wypadków do wyliczenia wartości funkcji IRR nie jest wymagane wprowadzenie argumentu przypuszczenie. W przypadku pominięcia argumentu przypuszczenie zakłada się, że jego wartość wynosi 0,1 (10%).
  • Jeśli funkcja IRR zwraca wartość błędu #LICZBA! lub jeśli wynik nie jest zbliżony do wartości oczekiwanej, należy powtórzyć próbę, podając inną wartość argumentu przypuszczenie.

Spostrzeżenia

Funkcja IRR pozostaje w ścisłym związku z funkcją NPV, tj. funkcją obliczającą wartość bieżącą netto. Stopa zysku obliczona przez funkcję IRR to stopa procentowa odpowiadająca zerowej wartości bieżącej netto. Przedstawiona poniżej formuła ilustruje powiązanie funkcji NPV i IRR:

NPV(IRR(B1:B6);B1:B6) jest równe 3,60E-08 (Przy danej dokładności wyliczenia IRR wartość 3,60E-08 wynosi praktycznie 0.)

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
-70 000 | Początkowy koszt inwestycji
12 000 | Przychód netto dla pierwszych pięciu lat
15 000 | Przychód netto dla pierwszych pięciu lat
18 000 | Przychód netto dla pierwszych pięciu lat
21 000 | Przychód netto dla pierwszych pięciu lat
26 000 | Przychód netto dla pierwszych pięciu lat
Formuła | Opis (Wynik)
=IRR(A2:A6) | Wewnętrzna stopa zysku inwestycji po czterech latach (-2%)
=IRR(A2:A7) | Wewnętrzna stopa zysku inwestycji po pięciu latach (9%)
=IRR(A2:A4;10%) | Do wyliczenia wewnętrznej stopy zysku na inwestycji po dwóch latach konieczne jest podanie przypuszczenia (-44%)


ISPMT

Oblicza wysokość odsetek płatnych w określonym okresie inwestycji. Funkcja zapewnia zgodność z programem Lotus 1-2-3.

Składnia

ISPMT(stopa;okres;liczba_rat;wa)

Stopa to stopa oprocentowania inwestycji.

Okres to okres, za który należy wyznaczyć oprocentowanie; musi pochodzić z przedziału wartości 1 do liczba_rat.

Liczba_rat to łączna liczba okresów płatności inwestycji.

Wa to obecna wartość inwestycji. W przypadku kredytu wa jest sumą kredytu.

Spostrzeżenia

  • Należy się upewnić, czy dobrze została zrozumiana treść dotycząca argumentów stopa i liczba_rat. Jeśli dokonuje się spłat miesięcznych pożyczki czteroletniej, oprocentowanej na 12% rocznie, należy użyć wartości 12%/12 dla argumentu stopa i 4*12 dla argumentu liczba_rat. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to stopa wynosi 12%, zaś liczba_rat 4.
  • We wszystkich argumentach środki wypłacane, takie jak wpłaty na rachunki oszczędnościowe lub inne sposoby wycofania gotówki, wyrażone są liczbami ujemnymi, podczas gdy przychody takie jak czeki z tytułu dywidend i inne depozyty wyrażone są liczbami dodatnimi.
  • Dodatkowe informacje na temat funkcji finansowych można znaleźć w opisie funkcji PV.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
10% | Roczna stopa procentowa
1 | Okres
3 | Liczba lat inwestycji
8 000 000 | Kwota pożyczki
Formuła | Opis (Wynik)
=ISPMT(A2/12;A3;A4*12;A5) | Odsetki płacone w pierwszym miesiącu pożyczki przy powyższych warunkach (-64814,8)
=ISPMT(A2;1;A4;A5) | Odsetki płacone w pierwszym roku pożyczki przy powyższych warunkach (-533333)

Uwaga Aby uzyskać stopę miesięczną, stopa oprocentowania jest dzielona przez 12. Liczba lat okresu spłaty należności jest mnożona przez 12 w celu obliczenia liczby spłat.


MIRR

Zwraca wartość zmodyfikowanej wewnętrznej stopy zysku dla szeregu okresowych przepływów gotówkowych. W funkcji MIRR jest brany pod uwagę jednocześnie koszt inwestycji oraz procent uzyskany z ponownego zainwestowania środków pieniężnych.

Składnia

MIRR(wartości;stopa_finansowa;stopa_reinwestycji)

Wartości to tablica lub odwołanie do komórek zawierających liczby. Liczby te reprezentują szereg płatności (wartości ujemne) i przychodów (wartości dodatnie) występujących w regularnych okresach.

  • Aby możliwe było obliczenie zmodyfikowanej wewnętrznej stopy zysku, wartości muszą zawierać co najmniej jedną wartość dodatnią i jedną ujemną. W przeciwnym wypadku funkcja MIRR zwraca wartość błędu #DZIEL/0!.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.

Stopa_finansowa to stopa oprocentowania pobierana od środków uczestniczących w przepływach środków pieniężnych.

Stopa_reinwestycji to stopa oprocentowania otrzymywana od reinwestowanych środków pieniężnych.

Spostrzeżenia

  • W funkcji MIRR wykorzystuje się ciąg wartości, by przedstawić przepływ środków pieniężnych. Należy się upewnić, czy sekwencja płatności i przychodów jest właściwa oraz czy przyjęto odpowiednie znaki wartości (dodatnie dla otrzymywanych kwot, ujemne dla kwot wypłacanych).
  • Jeśli n jest liczbą wartości przepływów środków pieniężnych, stopa_finansowa jest stopą finansową, a stopa_reinwestycji jest stopą reinwestycji, to formuła dla funkcji MIRR jest następująca:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
-120 000 zł | Koszt początkowy
39 000 | Zysk w pierwszym roku
30 000 | Zysk w drugim roku
21 000 | Zysk w trzecim roku
37 000 | Zysk w czwartym roku
46 000 | Zysk w piątym roku
10,00% | Roczna stopa oprocentowania pożyczki w wysokości 120 000
12,00% | Roczna stopa oprocentowania reinwestowanych zysków
Formuła | Opis (Wynik)
=MIRR(A2:A7; A8; A9) | Zmodyfikowana stopa zysku z inwestycji po pięciu latach (13%)
=MIRR(A2:A5; A8; A9) | Zmodyfikowana stopa zysku po trzech latach (-5%)
=MIRR(A2:A7; A8; 14%) | Pięcioletnia, zmodyfikowana stopa zysku na podstawie stopy_reinwestycji 14 procent (13%)


NPER

Zwraca liczbę okresów dla inwestycji polegającej na okresowych, stałych wpłatach przy stałym oprocentowaniu.

Składnia

NPER(stopa;rata;wa;wp;typ)

Szerszy opis argumentów funkcji NPER oraz więcej informacji o funkcjach rentowych znajduje się w opisie funkcji PV.

Stopa to stopa procentowa dla okresu.

Rata to płatność dokonywana okresowo, która nie ulega zmianie w czasie trwania kredytu. Rata obejmuje zazwyczaj kapitał i odsetki z wyłączeniem innych opłat i podatków.

Wa to obecna wartość, czyli całkowita suma bieżącej wartości serii przyszłych płatności.

Wp to przyszła wartość, czyli poziom finansowy, do którego zmierza się po dokonaniu ostatniej płatności. Jeśli argument wp jest pominięty, to jako jego wartość przyjmuje się 0 (przyszła wartość pożyczki na przykład wynosi 0).

Typ to liczba 0 albo 1, która wskazuje, kiedy płatność jest należna.

Wartość argumentu typ wynosi | Płatność przypada na
0 lub jest pominięty | koniec okresu
1 | początek okresu

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
12% | Roczna stopa procentowa
-100 | Płatność dokonywana w każdym okresie
-1 000 | Wartość obecna
10 000 | Wartość przyszła
1 | Płatność powinna być dokonana na początku okresu (zobacz powyżej)
Formuła | Opis (Wynik)
=NPER(A2/12; A3; A4; A5; 1) | Okresy w inwestycji przy powyższych warunkach (60)
=NPER(A2/12; A3; A4; A5) | Okresy w inwestycji przy powyższych warunkach, z takim wyjątkiem, że płatności są dokonywane na początku okresu (60)
=NPER(A2/12; A3; A4) | Okresy w inwestycji przy powyższych warunkach, z taką wyjątkiem, że wartość przyszła jest równa 0 (-9,578)


NPV

Oblicza zdyskontowaną wartość netto serii przyszłych płatności (wartości ujemne) i dochodów (wartości dodatnie) dla danej stopy dyskontowej.

Składnia

NPV(stopa;wartość1;wartość2;...)

Stopa to stopa dyskontowa stała we wszystkich okresach.

Wartość1; wartość2,... to od 1 do 29 argumentów przedstawiających płatności i przychody.

  • Przyjmuje się, że wartość1, wartość2,... są równomiernie rozmieszczone w czasie i przypadają na koniec każdego okresu.
  • Funkcja NPV wykorzystuje sekwencję wartość1, wartość2,... by przedstawić przepływy pieniężne. Płatności i przychody należy koniecznie wprowadzać w poprawnej kolejności.
  • Argumenty będące liczbami, pustymi komórkami, wartościami logicznymi czy tekstami przedstawiającymi liczby są uwzględniane; argumenty będące wartościami błędów lub tekstami, niemożliwymi do przetworzenia na liczby są pomijane.
  • Jeśli argument jest tablicą lub odwołaniem, to obliczane są tylko liczby zawarte w tej tablicy lub odwołaniu. Pominięte zostaną puste komórki, wartości logiczne, tekst lub wartości błędów w tablicy lub odwołaniu.

Spostrzeżenia

  • Inwestycja w funkcji NPV rozpoczyna się jeden okres przed datą przepływu gotówki wartość1, a kończy się wraz z ostatnim przepływem gotówki znajdującym się na liście. Obliczenie wartości funkcji NPV jest wykonywane na podstawie przyszłych przepływów gotówki. Jeżeli pierwszy przepływ ma miejsce na początku pierwszego okresu, to wartość ta musi być dodana do wyniku NPV, a nie zawarta w wartościach argumentów. Więcej informacji zawierają poniższe przykłady.
  • Jeśli n jest liczbą przepływów wartości na liście wartości, formuła funkcji NPV jest następująca:

  • Funkcja NPV jest podobna do funkcji PV (obecna wartość). Podstawowa różnica pomiędzy funkcją PV a funkcją NPV polega na tym, że funkcja PV pozwala, by przepływy zaczynały się na końcu lub na początku okresu. W odróżnieniu od zmiennych przepływów pieniężnych NPV, przepływy pieniężne PV muszą być stałe w okresie kredytu. Więcej informacji o kredytach i funkcjach finansowych zamieszczono w opisie PV.
  • Funkcja NPV jest także związana z funkcją IRR (wewnętrzna stopa zysku). Funkcja IRR jest stopą, dla której NPV ma wartość zero: NPV(IRR(...); ...) = 0.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
10% | Roczna stopa dyskontowa
-10 000 | Początkowy koszt inwestycji rok temu
3 000 | Zysk z pierwszego roku
4200 | Zysk z drugiego roku
6800 | Zysk z trzeciego roku
Formuła | Opis (Wynik)
=NPV(A2; A3; A4; A5; A6) | Bieżąca wartość netto tej inwestycji (1188,44)

W powyższym przykładzie wprowadzono początkowy koszt 10 000 zł jako jedną z wartości, ponieważ płatność przypadała na koniec pierwszego okresu.

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
8% | Roczna stopa dyskontowa. Wartość ta może reprezentować stopę inflacji lub stopę oprocentowania konkurencyjnej inwestycji.
-40 000 | Początkowy koszt inwestycji
8 000 | Zysk z pierwszego roku
9200 | Zysk z drugiego roku
10 000 | Zysk z trzeciego roku
12 000 | Zysk z czwartego roku
14500 | Zysk z piątego roku
Formuła | Opis (Wynik)
=NPV(A2; A4:A8)+A3 | Bieżąca wartość netto tej inwestycji (1 922,06)
=NPV(A2; A4:A8; -9000)+A3 | Bieżąca wartość netto tej inwestycji, ze stratą 9 000 w szóstym roku (-3 749,47)

W powyższym przykładzie nie można uwzględnić kosztu początkowego 40 000 zł jako jednej z wartości, ponieważ płatność miała miejsce na początku pierwszego okresu.


PMT

Oblicza spłatę pożyczki przy założeniu stałych, okresowych płatności i stałej stopy oprocentowania.

Składnia

PMT(stopa;liczba_rat;wa;wp;typ)

Dokładniejszy opis argumentów funkcji PMT znajduje się w opisie funkcji PV.

Stopa to stopa procentowa pożyczki.

Liczba_rat to całkowita liczba płatności w czasie pożyczki.

Wa to obecna wartość, czyli całkowita suma bieżącej wartości serii przyszłych płatności (nazywana także kapitałem).

Wp to przyszła wartość, czyli poziom finansowy, do którego zmierza się po dokonaniu ostatniej płatności. Jeśli argument zostanie pominięty, to jako jego wartość przyjmuje się 0 (przyszła wartość pożyczki na przykład wynosi 0).

Typ to liczba 0 lub 1 wskazująca, kiedy płatność ma miejsce.

Wartość argumentu typ wynosi | Płatność przypada na
0 lub jest pominięty | koniec okresu
1 | początek okresu

Uwagi
  • Płatności zwracane przez funkcję PMT obejmują kapitał i oprocentowanie, lecz nie obejmują podatków ani innych opłat związanych z pożyczką.
  • Należy się upewnić, czy dobrze została zrozumiana treść dotycząca argumentów stopa i liczba_rat. Jeśli dokonuje się spłat miesięcznych pożyczki czteroletniej, oprocentowanej na 12% rocznie, należy użyć wartości 12%/12 dla argumentu stopa i 4*12 dla argumentu liczba_rat. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to stopa wynosi 12%, a liczba_rat 4.

Porada

Aby uzyskać całkowitą sumę płatną po okresie trwania pożyczki, należy pomnożyć wynik funkcji PMT przez liczba_rat.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
8% | Roczna stopa procentowa
10 | Liczba miesięcy wpłat
10 000 | Kwota pożyczki
Formuła | Opis (Wynik)
=PMT(A2/12; A3; A4) | Miesięczna spłata pożyczki przy podanych powyżej warunkach (-1 037,03)
=PMT(A2/12; A3; A4; 0; 1) | Miesięczna spłata pożyczki przy podanych powyżej warunkach z takim wyjątkiem, że wpłaty muszą być dokonywane na początku każdego okresu (-1 030,16)

Przykład 2

Funkcję PMT można zastosować do obliczenia płatności obciążeń innych niż pożyczki.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
6% | Roczna stopa procentowa
18 | Przewidywane lata oszczędności
50 000 | Kwota, którą należy oszczędzić w ciągu 18 lat
Formuła | Opis (Wynik)
=PMT(A2/12; A3*12; 0; A4) | Kwota przewidywanych oszczędności w każdym miesiącu, aby w końcu 18 lat oszczędzania zgromadzić 50 000 (-129,08)

Uwaga Aby uzyskać stopę miesięczną, stopa oprocentowania jest dzielona przez 12. Liczba lat okresu spłaty należności jest mnożona przez 12 w celu obliczenia liczby spłat.


PPMT

Zwraca spłaty kapitału w podanym okresie dla inwestycji w oparciu o stałe, okresowe płatności i stałą stopę procentową.

Składnia

PPMT(stopa;okres;liczba_rat;wa;wp;typ)

Dokładniejszy opis argumentów funkcji PPMT znajduje się w opisie funkcji PV.

Stopa to stopa procentowa dla okresu.

Okres to okres w zakresie od 1 do liczba_rat.

Liczba_rat to całkowita liczba okresów płatności w okresie spłaty.

Wa to obecna wartość, czyli całkowita suma bieżącej wartości szeregu przyszłych płatności.

Wp to przyszła wartość, czyli poziom finansowy, do którego zmierza się po dokonaniu ostatniej płatności. Jeśli argument zostanie pominięty, to jako jego wartość przyjmuje się 0 (przyszła wartość pożyczki na przykład wynosi 0).

Typ to liczba 0 albo 1, która wskazuje, kiedy płatność jest należna.

Wartość argumentu typ wynosi | Płatność przypada na
0 lub jest pominięty | koniec okresu
1 | początek okresu

Spostrzeżenie

Należy się upewnić, czy dobrze została zrozumiana treść dotycząca argumentów stopa i liczba_rat. Jeśli dokonuje się miesięcznych spłat czteroletniej pożyczki oprocentowanej na 12% rocznie, to stopa wynosi 12%/12, a liczba_rat 4*12. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to stopa wynosi 12%, zaś liczba_rat 4.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis (Wynik)
10% | Roczna stopa procentowa
2 | Liczba lat pożyczki
2 000 | Kwota pożyczki
Formuła | Opis (Wynik)
=PPMT(A2/12; 1; A3*12; A4) | Spłata kapitału w pierwszym miesiącu pożyczki (-75,62)

Uwaga Aby uzyskać stopę miesięczną, stopa oprocentowania jest dzielona przez 12. Liczba lat okresu spłaty należności jest mnożona przez 12 w celu obliczenia liczby spłat.

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis (Wynik)
8% | Roczna stopa procentowa
10 | Liczba lat pożyczki
200 000 | Kwota pożyczki
Formuła | Opis (Wynik)
=PPMT(A2; A3; 10; A4) | Spłata kapitału w ostatnim roku pożyczki przy podanych powyżej warunkach (-27598,05)


PV

Zwraca wartość bieżącą inwestycji. Wartość bieżąca jest całkowitą sumą bieżącej wartości szeregu przyszłych płatności. Na przykład w przypadku pożyczania pieniędzy kwota pożyczki jest wartością bieżącą dla pożyczkobiorcy.

Składnia

PV(stopa;liczba_rat;rata;wp;typ)

Stopa to stopa procentowa dla okresu. Na przykład osoba otrzymująca pożyczkę na samochód, oprocentowaną na 10 procent rocznie, spłacająca tę pożyczkę w miesięcznych ratach, będzie płacić miesięczne oprocentowanie w wysokości 10%/12, czyli 0,83%. Dlatego jako oprocentowanie należy wprowadzić do formuły wartość 10%/12 albo 0,83% albo 0,0083.

Liczba_rat to całkowita liczba okresów płatności w okresie spłaty. Na przykład osoba otrzymująca czteroletnią pożyczkę na samochód, spłacająca tę pożyczkę w miesięcznych ratach, będzie ją spłacać w ciągu 4*12 (lub 48) okresów. Dlatego jako argument liczba_rat należy wprowadzić do formuły liczbę 48.

Rata to płatność dokonywana w każdym okresie, nie zmieniana przez cały okres pożyczki. Rata obejmuje zazwyczaj kapitał i odsetki z wyłączeniem innych opłat i podatków. Na przykład miesięczna spłata czteroletniej pożyczki na samochód w wysokości 10 000 zł, oprocentowanej na 12 %, wynosi 263,33 zł. Jako argument rata należy wprowadzić do formuły wartość -263,33. Jeśli argument rata zostanie pominięty, musi zostać umieszczony argument wp.

Pw to przyszła wartość czyli poziom finansowy, do którego zmierza się po dokonaniu ostatniej płatności. Jeśli argument jest pominięty, to jako jego wartość przyjmuje się 0 (przyszła wartość pożyczki na przykład wynosi 0). Na przykład, jeśli chce się zaoszczędzić 50 000 zł w ciągu 18 lat na określony cel, to 50 000 zł jest wartością przyszłą. Zakładając pewną stopę procentową, można obliczyć, ile pieniędzy trzeba odkładać co miesiąc. Jeśli argument wp jest pominięty, musi zostać włączony argument rata.

Typ to liczba 0 albo 1, która wskazuje, kiedy płatność jest należna.

Wartość argumentu typ wynosi | Płatność przypada na
0 lub jest pominięty | koniec okresu
1 | początek okresu

Uwagi
  • Należy się upewnić, czy dobrze została zrozumiana treść dotycząca argumentów stopa i liczba_rat. Jeśli dokonuje się miesięcznych spłat czteroletniej pożyczki oprocentowanej na 12% rocznie, to stopa wynosi 12%/12, a liczba_rat 4*12. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to stopa wynosi 12%, zaś liczba_rat 4.
  • Poniższe funkcje odnoszą się do rachunku rentowego:
    PPMT
    PV
    FV
    IPMT
    PMT
    RATE

    Renta jest to szereg stałych płatności gotówkowych wykonywanych w ciągłym okresie czasu. Na przykład rentą jest kredyt konsumpcyjny na zakup samochodu lub kredyt hipoteczny. Więcej informacji znajduje się w opisie każdej funkcji dotyczącej pożyczki.
  • W funkcjach rentowych wydatki (koszty) mają wartości ujemne, a przychody — dodatnie. Na przykład 1 000 zł jako depozyt w banku będzie reprezentowane przez argument -1 000 dla depozytariusza (1 000 dla banku).
  • Jeden argument finansowy jest obliczany w funkcji innych. Jeśli stopa jest różna od zera to:

    Jeśli stopa jest równa 0:

    (rata * liczba_rat) + wa + wp = 0

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
500 | Pieniądze wpłacane jako renta ubezpieczeniowa w końcu każdego miesiąca
8% | Oprocentowanie zarabiane na wpłacanych pieniądzach
20 | Liczba lat, w których pieniądze będą wpłacane
Formuła | Opis (Wynik)
=PV(A3/12; 12*A4; A2; ; 0) | Obecna wartość renty przy przedstawionych powyżej warunkach (-59777,15).

Wynik jest ujemny ponieważ reprezentuje pieniądze wpłacane przez indywidualną osobę, czyli wydatki. Gdyby od tej osoby zażądano wpłacenia jako ubezpieczenia kwoty (60 000), mogła by stwierdzić, że nie jest to dobra inwestycja, ponieważ bieżąca wartość renty (59777,15) jest niższa od żądanej wpłaty.

Uwaga Aby uzyskać stopę miesięczną, stopa oprocentowania jest dzielona przez 12. Liczba lat okresu spłaty należności jest mnożona przez 12 w celu obliczenia liczby spłat.


RATE

Zwraca stopę procentową za okres renty. Funkcja RATE jest wyliczana przez iterację i może mieć 0 lub więcej rozwiązań. Jeśli kolejne wyniki funkcji RATE nie są zbieżne z przybliżeniem 0,0000001, to po 20 iteracjach funkcja RATE zwraca wartość błędu #LICZBA!.

Składnia

RATE(liczba_rat;rata;wa;wp;typ;wynik)

Pełny opis argumentów liczba_rat, rata, wa, wp i typ znajduje się w opisie funkcji PV.

Liczba_rat to całkowita liczba okresów płatności w okresie spłaty.

Rata to płatność dokonywana w każdym okresie, nie zmieniana przez cały okres pożyczki. Rata obejmuje zazwyczaj kapitał i odsetki z wyłączeniem innych opłat i podatków. Jeśli argument rata zostanie pominięty, musi zostać umieszczony argument wa.

Wa to obecna wartość, czyli całkowita suma bieżącej wartości szeregu przyszłych płatności.

Wp to przyszła wartość, czyli poziom finansowy, do którego zmierza się po dokonaniu ostatniej płatności. Jeśli argument wp jest pominięty, to jako jego wartość przyjmuje się 0 (przyszła wartość pożyczki na przykład wynosi 0).

Typ to liczba 0 albo 1, która wskazuje, kiedy płatność jest należna.

Wartość argumentu typ wynosi | Płatność przypada na
0 lub jest pominięty | koniec okresu
1 | początek okresu

Przypuszczenie to przypuszczenie co do wysokości oprocentowania.
  • Jeśli pominie się argument przypuszczenie, to za jego wartość przyjmuje się 10%.
  • Jeśli funkcja RATE nie jest zbieżna, należy spróbować innej wartości argumentu przypuszczenie. Funkcja RATE jest zwykle zbieżna dla wartości argumentu przypuszczalnie zawartego pomiędzy 0 a 1.

Spostrzeżenia

Należy się upewnić, że argumenty przypuszczenie i liczba_rat są zrozumiałe. Jeśli dokonuje się miesięcznych spłat czteroletniej pożyczki oprocentowanej na 12% rocznie, to argument przypuszczenie wynosi 12%/2, argument liczba_rat 4*12. Jeśli dokonuje się rocznych spłat tej samej pożyczki, to argument przypuszczenie wynosi 12%, a liczba_rat 4.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
4 | Lata pożyczki
-200 | Miesięczna rata
8 000 | Wartość pożyczki
Formuła | Opis (Wynik)
=RATE(A2*12; A3; A4) | Miesięczne oprocentowanie pożyczki przy podanych powyżej warunkach (1%)
=RATE(A2*12; A3; A4)*12 | Roczne oprocentowanie pożyczki przy podanych powyżej warunkach (0,09241767 lub 9,24%)

Uwaga Aby uzyskać liczbę miesięcy, liczba lat pożyczki jest mnożona przez 12.


SLN

Zwraca wartość amortyzacji środka trwałego w jednym okresie metodą liniową.

Składnia

SLN(koszt;odzysk;czas_życia)

Koszt to początkowy koszt środka trwałego.

Odzysk to wartość na koniec okresu amortyzacji (czasami nazywana wartością końcową środka trwałego).

Czas_życia to liczba okresów, w trakcie których środek trwały jest amortyzowany (czasami jest zwany okresem użytkowania środka trwałego).

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
30 000 | Koszt
7 500 | Wartość odzyskana
10 | Lata okresu użytkowania
Formuła | Opis (Wynik)
=SLN(A2;A3;A4) | Odpis na amortyzację w stosunku rocznym (2 250)


SYD

Zwraca amortyzację środka trwałego w podanym okresie metodą sumy cyfr wszystkich lat amortyzacji.

Składnia

SYD(koszt;odzysk;czas_życia;okres)

Koszt to początkowy koszt środka trwałego.

Odzysk to wartość na koniec okresu amortyzacji (czasami nazywana wartością końcową środka trwałego).

Czas_życia to liczba okresów, w trakcie których środek trwały jest amortyzowany (czasami jest zwany okresem użytkowania środka trwałego).

Okres to okres czasu i musi być wyrażony w takich samych jednostkach jak czas_życia.

Spostrzeżenia

  • Funkcja SYD jest obliczana w następujący sposób:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
30 000 | Koszt początkowy
7 500 | Wartość odzyskana
10 | Okres eksploatacji w latach
Formuła | Opis (Wynik)
=SYD(A2;A3;A4;1) | Roczny odpis amortyzacyjny w pierwszym roku (4 090,91)
=SYD(A2;A3;A4;10) | Roczny odpis amortyzacyjny w dziesiątym roku (409,09)


VDB

Zwraca amortyzację środka trwałego za podany okres, łącznie z podokresami, korzystając z metody podwójnie malejącego salda lub innej metody określonej przez użytkownika. Funkcja VDB oznacza zmienne saldo malejące.

Składnia

VDB(koszt;odzysk;czas_życia;początek;koniec;współczynnik;bez_przełączenia)

Koszt to początkowy koszt środka trwałego.

Odzysk to wartość na koniec okresu amortyzacji (czasami nazywana wartością końcową środka trwałego).

Czas_życia to liczba okresów, w trakcie których środek trwały jest amortyzowany (czasami jest zwany okresem użytkowania środka trwałego).

Początek to początkowy okres, dla którego chce się obliczyć amortyzację. Argument początek musi być wyrażony w tych samych jednostkach, co argument czas_życia.

Koniec to końcowy okres, dla którego chce się obliczyć amortyzację. Argument koniec musi być wyrażony w tych samych jednostkach, co argument czas_życia.

Współczynnik to szybkość zmniejszania się podstawy. Jeśli współczynnik ten zostanie pominięty, to zakłada się, że wynosi 2 (metoda podwójnie malejącego salda). Jeśli użycie metody podwójnie malejącego salda jest niepożądane, należy zmienić wartość argumentu współczynnik. Aby uzyskać informacje dotyczące tej metody, zobacz opis funkcji DDB.

Bez_przełączenia to wartość logiczna określająca, czy przełączyć się na metodę liniową, kiedy amortyzacja jest większa niż obliczenie malejącej podstawy.

  • Jeśli argument bez_przełączenia przyjmuje wartość PRAWDA, przełączenie na metodę liniową nie następuje, nawet jeśli amortyzacja jest większa niż obliczenie malejącego salda.
  • Jeśli argument bez_przełączenia ma wartość FAŁSZ lub jest pominięty, funkcja VDB przełącza się na metodę amortyzacji liniowej, gdy amortyzacja przewyższa obliczenie malejącej podstawy.

Wszystkie argumenty oprócz argumentu bez_przełączenia muszą być liczbami dodatnimi.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
2400 | Koszt początkowy
300 | Wartość odzyskana
10 | Okres użytkowania wyrażony w latach
Formuła | Opis (Wynik)
=VDB(A2;A3;A4*365;0;1) | Amortyzacja w pierwszym dniu użytkowania. Funkcja zakłada, że współczynnik wynosi 2 (1,32)
=VDB(A2;A3;A4*12;0;1) | Amortyzacja w pierwszym miesiącu (40,00)
=VDB(A2;A3;A4;0;1) | Amortyzacja w pierwszym roku (480,00)
=VDB(A2;A3;A4*12;6;18) | Amortyzacja między miesiącem szóstym a osiemnastym (396,31)
=VDB(A2;A3;A4*12;6;18;1,5) | Amortyzacja między miesiącem szóstym a osiemnastym przy użyciu współczynnika 1,5 zamiast metody podwójnie malejącego salda (311,81)
=VDB(A2;A3;A4;0;0,875;1,5) | Amortyzacja w pierwszym roku podatkowym użytkowania środka trwałego przy założeniu, że przepisy podatkowe ograniczają amortyzację malejącego salda do 150 procent. Środek został zakupiony w połowie pierwszego kwartału danego roku podatkowego. (315,00)

Uwaga Wyniki są zaokrąglane do dwóch miejsc dziesiętnych.


BRAK

Zwraca wartość błędu #N/D. #N/D jest wartością błędu, która oznacza, że "wartość jest niedostępna". Funkcji BRAK należy używać do oznaczenia pustych komórek. Wprowadzając wartość #N/D do komórek, w których brak informacji, można uniknąć problemu niezamierzonego uwzględnienia pustych komórek w obliczeniach. (Kiedy formuła odwołuje się do komórki zawierającej wartość #N/D, formuła zwraca wartość błędu #N/D.)

Składnia

BRAK( )

Spostrzeżenia

  • Do nazwy funkcji należy dołączyć puste zwykłe nawiasy. W przeciwnym wypadku arkusz kalkulacyjny nie rozpozna jej jako funkcji.
  • Wartość #N/D! można wpisać bezpośrednio do komórki. Funkcja BRAK zapewnia zgodność z innymi programami arkuszy kalkulacyjnych.


Funkcje CZY

W części tej przedstawiono opis dziewięciu funkcji arkusza kalkulacyjnego wykorzystywanych do testowania rodzaju wartości lub odwołania.

Każda z tych funkcji, określanych zbiorczo mianem funkcji CZY, sprawdza rodzaj wartości i zwraca wartość PRAWDA lub FAŁSZ w zależności od wyniku. Na przykład funkcja CZY.PUSTA zwraca wartość logiczną PRAWDA, jeśli wartość jest odwołaniem do pustej komórki; w przeciwnym wypadku funkcja zwraca wartość logiczną FAŁSZ.

Składnia

CZY.ADR(wartość)

CZY.BŁ(wartość)

CZY.BŁĄD(wartość)

CZY.BRAK(wartość)

CZY.PUSTA(wartość)

CZY.LICZBA(wartość)

CZY.LOGICZNA(wartość)

CZY.NIE.TEKST(wartość)

CZY.TEKST(wartość)

Wartość to wartość, która ma być testowana. Wartość może nie istnieć (pusta komórka), może zawierać poddawany testowi błąd, wartość logiczną, tekst, liczbę, odwołanie lub nazwę odnoszącą się do którejkolwiek z powyższych wartości.

Funkcja | Zwraca wartość PRAWDA jeśli
CZY.ADR | Wartość odnosi się do odwołania.
CZY.BŁ | Wartość odnosi się do każdej wartości błędnej z wyjątkiem #N/D!.
CZY.BŁĄD | Wartość odnosi się do każdej wartości błędu (#N/D!, #ARG!, #ADR!, #DZIEL/0!, #LICZBA!, #NAZWA? lub #ZERO!).
CZY.BRAK | Wartość odnosi się do wartości błędu #N/D (braku wartości).
CZY.LICZBA | Wartość odnosi się do liczby.
CZY.LOGICZNA | Wartość odnosi się do wartości logicznej.
CZY.NIE.TEKST | Wartość odnosi się do każdej zawartości komórki innej niż tekst. (Należy zauważyć, że funkcja ta zwraca wartość logiczną PRAWDA, jeśli wartość odnosi się do pustej komórki.)
CZY.PUSTA | Wartość odnosi się do pustej komórki.
CZY.TEKST | Wartość odnosi się do tekstu.

Spostrzeżenia

  • Argumenty wartości funkcji CZY nie są przekształcane. Na przykład w większości innych funkcji, w których wymagana jest liczba, wartość tekstowa "19" jest poddawana konwersji na liczbę 19. Jednak w formule CZY.LICZBA("19"), "19" nie jest poddawana konwersji z wartości tekstowej, a funkcja CZY.LICZBA zwraca FAŁSZ.
  • Funkcje CZY są przydatne w formułach do testowania wyniku obliczeń. W połączeniu z funkcją JEŻELI, pozwalają na wyszukiwanie błędów w formułach (patrz przykłady poniżej).

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=CZY.LOGICZNA(PRAWDA) | Sprawdza, czy PRAWDA jest wartością logiczną (PRAWDA)
=CZY.LOGICZNA("PRAWDA") | Sprawdza, czy "PRAWDA" jest wartością logiczną (FAŁSZ)
=CZY.LICZBA(4) | Sprawdza, czy 4 jest liczbą (PRAWDA)

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Złoto
Region1
#ADR!
330,92
#N/D
Formuła | Opis (Wynik)
=CZY.PUSTA(A2) | Sprawdza, czy komórka A2 jest pusta (FAŁSZ)
=CZY.BŁĄD(A4) | Sprawdza, czy #ADR! jest błędem (PRAWDA)
=CZY.BRAK(A4) | Sprawdza, czy #ADR! jest błędem #N/D (FAŁSZ)
=CZY.BRAK(A6) | Sprawdza, czy #N/D jest błędem #N/D (PRAWDA)
=CZY.BŁ(A6) | Sprawdza, czy #N/D jest błędem (FAŁSZ)
=CZY.LICZBA(A5) | Sprawdza, czy 330,92 jest liczbą (PRAWDA)
=CZY.TEKST(A3) | Sprawdza, czy Region1 jest tekstem (PRAWDA)


KOMÓRKA

Zwraca informacje o formacie, położeniu lub zawartości górnej lewej komórki w odwołaniu.

Składnia

KOMÓRKA(typ_info;odwołanie)

Typ_info jest to wartość tekstowa określająca żądany typ informacji o komórce. Na poniższej liście przedstawiono możliwe wartości argumentu typ_info i odpowiadające im wyniki.

Typ_info | Zwraca
"adres" | Odwołanie do pierwszej komórki w odwołaniu w formie tekstu.
"kolumna" | Numer kolumny komórki w odwołaniu.
"zawartość" | Wartość lewej górnej komórki w odwołaniu; nie formułę.
"wiersz" | Numer wiersza komórki w odwołaniu.
"typ" | Wartość tekstową odpowiadającą typowi danych w komórce. Zwraca literę "b" jeśli komórka jest pusta, "l" jako etykietę, jeśli komórka zawiera stałą tekstową i "v" jako wartość, jeśli komórka zawiera coś innego.

Odwołanie jest komórką, o której potrzebne są informacje. Jeśli zostanie pominięte, to informacja określona w argumencie typ_info jest zwracana dla ostatniej zmienianej komórki.

Spostrzeżenia

Funkcja KOMÓRKA ma zapewnić zgodność z innymi programami arkuszy kalkulacyjnych.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
5 mar
razem
Formuła | Opis (Wynik)
=KOMÓRKA("wiersz";A20) | Numer wiersza komórki A20 (20)
=KOMÓRKA("typ";A2) | Typ danych w komórce A2 (v)
=KOMÓRKA("zawartość";A3) | Zawartość komórki A3 (razem)


L

Zwraca wartość przekonwertowaną na liczbę.

Składnia

L(wartość)

Wartość oznacza wartość, którą należy konwertować. Funkcja L konwertuje wartości zgodnie z poniższą tabelą.

Jeśli wartość jest lub odwołuje się do | Funkcja L zwraca:
Liczbą | Tę samą liczbę
Datą w jednym z wbudowanych formatów daty arkusza kalkulacyjnego | Numer kolejny tej daty
PRAWDA | 1
FAŁSZ | 0
Wartością błędu, taką jak #DZIEL/0! | Wartość błędu
Wszystkie inne | 0

Uwagi
  • Używanie funkcji L w formułach nie jest konieczne, ponieważ w razie potrzeby wartości są konwertowane automatycznie. Funkcja umożliwia zachowanie zgodności z innymi programami arkuszy kalkulacyjnych.
  • Daty są przechowywane jako liczby kolejne, dzięki czemu można ich używać w obliczeniach. Domyślnie wartość 31 grudnia 1899 jest równa liczbie kolejnej 1, a wartość 1 stycznia 2008 jest równa liczbie kolejnej 39 448, ponieważ jest to 39 448 dzień od 1 stycznia 1900.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
7
Parzyste
PRAWDA
17 marca 2008
Formuła | Opis (Wynik)
=L(A2) | Ponieważ komórka A2 zawiera liczbę, zwracana jest ta sama liczba (7)
=L(A3) | Ponieważ komórka A3 zawiera tekst, zwracane jest 0 (0, zobacz wyżej)
=L(A4) | Ponieważ komórka A4 zawiera wartość logiczną PRAWDA, zwracana jest wartość 1 (1, zobacz wyżej)
=L(A5) | Ponieważ komórka A5 zawiera datę, zwracana jest liczba kolejna daty (w zależności od używanego systemu daty)
=L("7") | Ponieważ "7" jest tekstem, zwracane jest 0 (0, zobacz wyżej)


LICZ.PUSTE

Zlicza puste komórki w wybranym zakresie.

Składnia

LICZ.PUSTE(zakres)

Zakres to zakres, z którego mają być zliczane puste komórki.

Spostrzeżenia

Zliczane są także komórki z formułami zwracającymi w wyniku "" (pusty tekst). Nie są zliczane komórki z wartością równą zero.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Dane
6 | =JEŻELI(B4<30;"";B4)
 | 27
4 | 34
Formuła | Opis (Wynik)
=LICZ.PUSTE(A2:B5) | Zlicza puste komórki w podanym powyżej zakresie. Formuła zwraca liczbę pustych komórek tekstowych. (3)


NR.BŁĘDU

Zwraca numer odpowiadający jednej z wartości błędu w arkuszu kalkulacyjnym lub zwraca błąd #N/D (wartość niedostępna), jeśli błąd nie wystąpił. Funkcję NR.BŁĘDU można zastosować w funkcji JEŻELI, aby testować wartość błędu i zamiast wartości błędu zwracać ciąg tekstowy, taki jak komunikat.

Składnia

NR.BŁĘDU(błąd_wartość)

Błąd_wartość to wartość błędu, którego numer identyfikacyjny należy wyznaczyć. Chociaż błąd_wartość może być rzeczywistą wartością błędu, zwykle jest jednak odwołaniem do komórki zawierającej formułę, która ma być przetestowana.

Jeśli błąd_wartość jest | NR.BŁĘDU zwraca
#NULL! | 1
#DZIEL/0! | 2
#WARTOŚĆ! | 3
#ADR! | 4
#NAZWA? | 5
#LICZBA! | 6
#N/D | 7
#CYKL! | 8
Wszystkie inne | #N/D

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
#NULL!
=1/0
Formuła | Opis (Wynik)
=NR.BŁĘDU(A2) | Numer błędu #NULL!. (1)
=JEŻELI(NR.BŁĘDU(A3)<3,WYBIERZ(NR.BŁĘDU(A3),"Zakresy nie przecinają się","Dzielnik jest zerem")) | Sprawdza, czy komórka A3 zawiera wartość błędu #NULL! albo #DZIEL/0!. Jeśli tak, to numer błędu jest używany w funkcji arkusza WYBIERZ, aby wyświetlić jeden z dwóch komunikatów; w przeciwnym wypadku zwracana jest wartość błędu #N/D!. (Dzielnik jest zerem.)


TYP

Funkcja zwraca typ wartości. Z funkcji TYP należy korzystać, gdy zachowanie innej funkcji zależy od rodzaju wartości w danej komórce.

Składnia

TYP(wartość)

Wartość może być dowolną wartością, taką jak liczba, tekst, wartość logiczna itd.

Jeśli wartość jest typu | Funkcja TYP zwraca wartość
Liczba | 1
Tekst | 2
Wartość logiczna | 4
Wartość błędu | 16
Tablica | 64

Uwagi
  • Funkcji TYP nie można używać do stwierdzenia, czy komórki zawierają formułę. Funkcja TYP pozwala jedynie stwierdzić jaki jest typ wyświetlanej lub wynikowej wartości. Jeśli wartość jest odwołaniem do komórki zawierającej formułę, funkcja TYP zwraca typ wartości, która jest wynikiem tej formuły.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Borowik
Formuła | Opis (Wynik)
=TYP(A2) | Sprawdza typ powyższej wartości (2)
=TYP("Pan "&A2) | Sprawdza typ wartości "Pan Borowik" (2)
=TYP(2+A2) | Sprawdza typ formuły, która zwraca błąd #WARTOŚĆ! (16)
=TYP({1,2;3,4}) | Sprawdza typ tablicy stałych (64)


FAŁSZ

Zwraca wartość logiczną FAŁSZ.

Składnia

FAŁSZ( )

Spostrzeżenia

Słowo FAŁSZ można także wpisać bezpośrednio do arkusza lub do formuły, gdzie będzie interpretowane jako wartość logiczna FAŁSZ.


JEŻELI

Zwraca jedną wartość, jeśli argument test_logiczny zostanie obliczony jako PRAWDA lub inną, jeśli wartością tą będzie FAŁSZ.

Funkcję JEŻELI należy wykorzystywać w celu przeprowadzania testów warunkowych na wartościach i formułach.

Składnia

JEŻELI(test_logiczny;wartość_jeżeli_prawda;wartość_jeżeli_fałsz)

Test_logiczny to dowolna wartość lub wyrażenie, które może być obliczone jako PRAWDA lub FAŁSZ. Na przykład A10=100 jest wyrażeniem logicznym; jeśli wartość w komórce A10 jest równa 100, wyrażenie ma wartość PRAWDA. W przeciwnym wypadku wyrażenie przyjmuje wartość FAŁSZ. Argumentem tym może być dowolny operator obliczeń porównawczych.

Wartość_jeżeli_prawda to wartość zwracana w przypadku, gdy argument test_logiczny ma wartość PRAWDA. Na przykład, jeśli ten argument jest ciągiem tekstowym "W budżecie", a argument test_logiczny ma wartość PRAWDA, to funkcja JEŻELI wyświetla tekst "W budżecie". Jeśli test_logiczny równa się PRAWDA, a wartość_jeżeli_prawda jest pusta, to zwracana jest wartość 0 (zero). Aby wyświetlić słowo PRAWDA, należy użyć wartości logicznej PRAWDA jako tego argumentu. Wartość_jeżeli_prawda może być inną formułą.

Wartość_jeżeli_fałsz to wartość wyniku w przypadku, gdy argument test_logiczny ma wartość FAŁSZ. Na przykład, jeśli ten argument jest ciągiem tekstowym "Przekroczony budżet", a argument test_logiczny ma wartość FAŁSZ, to funkcja JEŻELI wyświetla tekst "Przekroczony budżet". Jeśli test_logiczny równa się FAŁSZ, a wartość_jeżeli_fałsz jest pominięta, (to znaczy, po wartość_jeżeli_prawda nie ma średnika), to zwracana jest logiczna wartość FAŁSZ. Jeśli test_logiczny ma wartość FAŁSZ, wartość_jeżeli_fałsz jest pusta (to znaczy, po wartość_jeżeli_prawda jest średnik poprzedzający zamykający nawias), to zwracana jest wartość 0 (zero). Wartość_jeżeli_fałsz może być inną formułą.

Spostrzeżenia

  • W celu skonstruowania bardziej złożonych warunków można zagnieździć do siedmiu funkcji JEŻELI stosując je jako argumenty wartość_jeżeli_prawda i wartość_jeżeli_fałsz. Zobacz ostatni z poniższych przykładów.
  • Kiedy zostaną obliczone argumenty wartość_jeżeli_prawda i wartość_jeżeli_fałsz, to funkcja JEŻELI zwróci wartość zwróconą przez te argumenty.
  • Jeśli pewne argumenty w funkcji JEŻELI są tablicami, to w trakcie wykonywania instrukcji JEŻELI obliczane są wszystkie elementy tablicy.

  • Do analizowania danych na podstawie warunków mogą być także używane inne funkcje. Na przykład, aby zliczyć liczbę wystąpień ciągu tekstowego lub liczbę w zakresie komórek, można zastosować funkcję arkusza kalkulacyjnego LICZ.JEŻELI. Aby obliczyć sumę na podstawie ciągu tekstowego lub liczbę w zakresie komórek, można zastosować funkcję arkusza kalkulacyjnego SUMA.JEŻELI.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
50
Formuła | Opis (Wynik)
=JEŻELI(A2<=100;"W budżecie";"Przekroczony budżet") | Jeśli powyższa liczba jest mniejsza niż lub równa 100, wówczas formuła wyświetla komunikat "W budżecie". W przeciwnym wypadku funkcja wyświetla komunikat "Przekroczony budżet". (W budżecie)
=JEŻELI(A2=100;SUMA(B5:B15);"") | Jeśli powyższa liczba jest równa 100, wówczas obliczany jest zakres B5:B15. W przeciwnym wypadku zwracany jest tekst pusty (""). ()

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Wydatki rzeczywiste | Wydatki przewidywane
1 500 | 900
500 | 900
500 | 925
Formuła | Opis (Wynik)
=JEŻELI(A2>B2;"Przekroczony budżet";"OK") | Sprawdza, czy w pierwszym wierszu jest przekroczony budżet (Przekroczony budżet)
=JEŻELI(A3>B3;"Przekroczony budżet";"OK") | Sprawdza, czy w drugim wierszu jest przekroczony budżet (OK)

Przykład 3

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Punkty
45
90
78
Formuła | Opis (Wynik)
=JEŻELI(A2>89;"A";JEŻELI(A2>79;"B"; JEŻELI(A2>69;"C";JEŻELI(A2>59;"D";"F")))) | Przypisuje literę oceny do pierwszej liczby punktów (F)
=JEŻELI(A3>89;"A";JEŻELI(A3>79;"B"; JEŻELI(A3>69;"C";JEŻELI(A3>59;"D";"F")))) | Przypisuje literę oceny do drugiej liczby punktów (A)
=JEŻELI(A4>89;"A";JEŻELI(A4>79;"B"; JEŻELI(A4>69;"C";JEŻELI(A4>59;"D";"F")))) | Przypisuje literę oceny do trzeciej liczby punktów (C)

W powyższym przykładzie, druga instrukcja JEŻELI jest jednocześnie argumentem wartość_jeżeli_fałsz dla pierwszej instrukcji JEŻELI. Analogicznie trzecia instrukcja JEŻELI jest argumentem wartość_jeżeli_fałsz dla drugiej instrukcji JEŻELI. Na przykład, jeśli pierwszy argument test_logiczny (Średnia>89) ma wartość PRAWDA, to wynikiem jest "A". Jeśli zaś wartością pierwszego argumentu test_logiczny jest FAŁSZ, to obliczany jest wynik argumentu drugiego JEŻELI itd..

Litery ocen są przypisywane do liczb według następującego klucza (zakładając tylko liczby całkowite).

Jeśli liczba punktów jest równa | To ocena jest następująca
więcej niż 89 | A
od 80 do 89 | B
od 70 do 79 | C
od 60 do 69 | D
mniej niż 60 | F


LUB

Funkcja zwraca wartość logiczną PRAWDA, jeśli choć jeden argument ma wartość logiczną PRAWDA; jeśli wszystkie argumenty mają wartość logiczną FAŁSZ, funkcja zwraca wartość logiczną FAŁSZ.

Składnia

LUB(logiczny1; logiczny2; ...)

Logiczna1; logiczna2; ... to od 1 do 30 warunków, które można testować i które mogą mieć wartość albo PRAWDA, albo FAŁSZ.

Spostrzeżenia

  • Argumenty powinny być wartościami logicznymi PRAWDA lub FAŁSZ albo tablicami lub odwołaniami zawierającymi wartości logiczne.
  • Jeśli którykolwiek z argumentów tablicowych lub odwołaniowych zawiera tekst lub puste komórki, wartości te są pomijane.
  • Jeśli określony zakres nie zawiera wartości logicznych, funkcja LUB zwraca wartość błędu #ARG!.
  • Formuły tabeli funkcji LUB można użyć do sprawdzenia, czy dana wartość występuje w tabeli. Aby wprowadzić formułę tablicową, naciśnij klawisze CTRL+SHIFT+ENTER.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=LUB(PRAWDA) | Jedyny argument ma wartość PRAWDA (PRAWDA)
=LUB(1+1=1;2+2=5) | Wszystkie argumenty mają wartość FAŁSZ (FAŁSZ)
=LUB(PRAWDA;FAŁSZ;PRAWDA) | Przynajmniej jeden argument ma wartość PRAWDA (PRAWDA)


NIE

Odwraca wartość swego argumentu. Funkcję NIE należy stosować wtedy, kiedy trzeba zagwarantować, że dana wartość nie jest równa jakiejś szczególnej wartości.

Składnia

NIE(logiczna)

Logiczna to wartość lub wyrażenie, które może przyjmować wartości PRAWDA lub FAŁSZ.

Spostrzeżenia

Jeśli argument logiczna ma wartość FAŁSZ, funkcja NIE zwraca wartość PRAWDA; jeśli argument logiczna ma wartość PRAWDA, funkcja NIE zwraca wartość FAŁSZ.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=NIE(FAŁSZ) | Odwraca FAŁSZ (PRAWDA)
=NIE(1+1=2) | Odwraca równanie, którego wynikiem jest PRAWDA (FAŁSZ)


ORAZ

Zwraca wartość PRAWDA, jeśli wszystkie argumenty funkcji mają wartość PRAWDA; zwraca wartość FAŁSZ, jeśli co najmniej jeden z argumentów ma wartość FAŁSZ.

Składnia

ORAZ(logiczna1;logiczna2;...)

Logiczna1; logiczna2; ... to od 1 do 30 warunków, które można testować i które mogą mieć wartość albo PRAWDA, albo FAŁSZ.

Spostrzeżenia

  • Argumenty powinny być wartościami logicznymi PRAWDA lub FAŁSZ albo tablicami lub odwołaniami zawierającymi wartości logiczne.
  • Jeśli którykolwiek z argumentów tablicowych lub odwołaniowych zawiera tekst lub puste komórki, wartości te są pomijane.
  • Zwraca wartość błędu #ARG!, jeśli określony zakres nie zawiera wartości logicznych.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ORAZ(PRAWDA; PRAWDA) | Wszystkie argumenty mają wartość PRAWDA (PRAWDA)
=ORAZ(PRAWDA; FAŁSZ) | Jeden argument ma wartość FAŁSZ (FAŁSZ)
=ORAZ(2+2=4; 2+3=5) | Wszystkie argumenty dają wynik PRAWDA (PRAWDA)

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
50
104
Formuła | Opis (Wynik)
=ORAZ(1<A2; A2<100) | Ponieważ 50 jest zawarte między 1 a 100 (PRAWDA)
=JEŻELI(ORAZ(1<A3; A3<100); A3; "Wartość jest spoza zakresu".) | Wyświetla drugą liczbę znajdującą się powyżej, jeśli zawiera się ona między 1 a 100, w przeciwnym przypadku wyświetla komunikat (Wartość jest spoza zakresu.)
=JEŻELI(ORAZ(1<A2; A2<100); A2; "Wartość jest spoza zakresu".) | Wyświetla pierwszą liczbę znajdującą się powyżej, jeśli zawiera się ona między 1 a 100, w przeciwnym przypadku wyświetla komunikat (50)


PRAWDA

Zwraca wartość logiczną PRAWDA.

Składnia

PRAWDA( )

Spostrzeżenia

Można także wprowadzić wartość PRAWDA bezpośrednio do komórek i formuł bez korzystania z tej funkcji. Funkcja PRAWDA zapewnia przede wszystkim zgodność z innymi programami arkuszy kalkulacyjnych.


ADR.POŚR

Zwraca odwołanie określone przez ciąg tekstowy. Odwołania są obliczane natychmiast, tak aby była wyświetlana ich zawartość. Należy użyć funkcji ADR.POŚR, chcąc zmienić w formule odwołanie do komórki, a pozostawić niezmienioną samą formułę.

Składnia

ADR.POŚR(adres_tekst;a1)

Adres_tekst to odwołanie do komórki zawierającej odwołanie w formacie A1 lub W1K1, nazwę zdefiniowaną jako odwołanie lub odwołanie do komórki jako ciągu tekstowego. Jeśli argument adres_tekst jest nieprawidłowym odwołaniem do komórki, to funkcja ADR.POŚR zwraca wartość błędu #ADR!.

  • Jeśli argument adres_tekst odwołuje się do innego skoroszytu (odwołanie zewnętrzne), to musi być on otwarty. Jeśli skoroszyt źródłowy nie jest otwarty, to funkcja ADR.POŚR zwraca wartość błędu #ADR!.

A1 to wartość logiczna określająca typ odwołania znajdującego się w komórce adres_tekst.

  • Jeśli argument a1 ma wartość PRAWDA lub jest pominięty, to argument adres_tekst jest interpretowany jako odwołanie w formacie A1.

  • Jeśli argument a1 ma wartość FAŁSZ, to argument adres_tekst jest interpretowany jako odwołanie w formacie W1K1.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Dane
B2 | 1,333
B3 | 45
Jerzy | 10
5 | 62
Formuła | Opis (Wynik)
=ADR.POŚR($A$2) | Wartość odwołania w komórce A2 (1,333)
=ADR.POŚR($A$3) | Wartość odwołania w komórce A3 (45)
=ADR.POŚR($A$4) | Jeśli w komórce B4 znajduje się zdefiniowana nazwa „Jerzy”, to zwracana jest wartość nazwy (10)
=ADR.POŚR("B"&$A$5) | Wartość odwołania w komórce A5 (62)

Po utworzenia formuły odwołującej się do komórki odwołanie będzie aktualizowane, jeśli (1) komórka będzie przeniesiona za pomocą polecenia Wytnij, które powoduje jej usunięcie lub (2) komórka będzie przeniesiona z powodu wstawienia lub usunięcia wierszy albo kolumn. Jeśli formuła zawsze ma się odwoływać do tej samej komórki bez względu na to, czy wiersz powyżej jest usuwany lub komórka jest przenoszona, to należy użyć funkcji arkusza kalkulacyjnego ADR.POŚR. Na przykład aby odwołanie zawsze dotyczyło komórki A10, należy użyć następującej składni:

ADR.POŚR("A10")


ADRES

Na podstawie określonych numerów wiersza i kolumny tworzy odwołanie do komórki w postaci tekstu.

Składnia

ADRES(nr_wiersza;nr_kolumny;typ_adresu;a1;tekst_arkusz)

Nr_wiersza to numer wiersza, który zostanie użyty w odwołaniu do komórki.

Nr_kolumny to numer kolumny, który zostanie użyty w odwołaniu do komórki.

Typ_adresu określa typ odwołania, jakie będzie zwracane.

Typ_adresu | Zwracany typ odwołania
1 lub jest pominięty | Bezwzględne
2 | Bezwzględne dla wiersza, względne dla kolumny
3 | Względne dla wiersza, bezwzględne dla kolumny
4 | Względne

A1 to wartość logiczna określająca styl adresowania — A1 lub W1K1. Jeśli argument a1 ma wartość PRAWDA lub zostanie pominięte, funkcja ADRES zwróci odwołanie o stylu A1, jeśli zaś ma wartość FAŁSZ, funkcja ADRES zwróci odwołanie o stylu W1K1.

Tekst_arkusz to tekst określający nazwę arkusza, który zostanie użyty jako odwołanie zewnętrzne. Jeśli argument tekst_arkusz zostanie pominięty, nie zostanie użyta żadna nazwa arkusza.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ADRES(2;3) | Odwołanie bezwzględne ($C$2)
=ADRES(2;3;2) | Bezwzględne dla wiersza; względne dla kolumny (C$2)
=ADRES(2;3;2;FAŁSZ) | Bezwzględne dla wiersza; względne dla kolumny, styl odwołania W1K1 (W2K[3])
=ADRES(2;3;1;FAŁSZ;"Arkusz1") | Odwołanie bezwzględne do innego arkusza (Arkusz1!W2K3)


HIPERŁĄCZE

Tworzy hiperłącze otwierające dokument przechowywany na serwerze sieciowym, w sieci intranet lub w sieci Internet. Po kliknięciu komórki zawierającej funkcję HIPERŁĄCZE otwierany jest plik przechowywany w lokalizacji określonej argumentem łącze_lokalizacja.

Składnia

HIPERŁĄCZE(łącze_lokalizacja;przyjazna_nazwa)

Łącze_lokalizacja to ścieżka i nazwa pliku dokumentu, który ma być otwarty jako tekst. Może to być albo ścieżka do pliku przechowywanego na dysku twardym, albo ścieżka UNC (Universal Naming Convention) na serwerze, albo ścieżka URL (Uniform Resource Locator) w sieci Internet lub sieci intranet.

  • Argument łącze_lokalizacja może być ciągiem tekstowym ujętym w znaki cudzysłowu lub komórką zawierającą łącze w postaci ciągu tekstowego.

  • Jeśli skok określony argumentem łącze_lokalizacja nie istnieje lub nie można go znaleźć, po kliknięciu komórki wyświetlany jest błąd.

Przyjazna_nazwa to tekst skoku lub wartość liczbowa wyświetlana w komórce. Argument przyjazna_nazwa jest wyświetlany tekstem podkreślonym w kolorze niebieskim. Jeśli pominięto argument przyjazna_nazwa, to w komórce jako tekst skoku wyświetlany jest argument łącze_lokalizacja.

  • Argument przyjazna_nazwa może być wartością, ciągiem tekstowym, nazwą lub komórką zawierającą tekst skoku lub wartość.

  • Jeśli argument przyjazna_nazwa zwraca wartość błędu (np. #ARG!), to w komórce zamiast tekstu skoku jest wyświetlana wartość błędu.

Spostrzeżenia

Aby zaznaczyć komórkę zawierającą hiperłącze bez wykonania skoku do miejsca docelowego hiperłącza, kliknij komórkę obok komórki z hiperłączem, a następnie użyj klawiszy strzałek, aby ją zaznaczyć.

Przykład

Przykładowe łącze otwiera arkusz kalkulacyjny o nazwie Raport budżetu.xls przechowywany w sieci Internet w lokalizacji o nazwie example.microsoft.com/raport i wyświetla tekst "Kliknij, aby otworzyć raport":

=HIPERŁĄCZE("http://example.microsoft.com/raport/raport budżetu.xls"; "Kliknij, aby otworzyć raport")


ILE.WIERSZY

Zwraca liczbę wierszy w odwołaniu lub tablicy.

Składnia

ILE.WIERSZY(tablica)

Tablica to tablica lub formuła tablicowa albo odwołanie do zakresu komórek, dla którego ma być zwrócona liczba kolumn.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ILE.WIERSZY(C1:E4) | Liczba wierszy w odwołaniu (4)
=ILE.WIERSZY({1;2;3;4;5;6}) | Liczba wierszy w tablicy stałych (2)


INDEKS

Zwraca wartość lub odwołanie do wartości znajdującej się w tabeli lub w zakresie. Występują dwie formy funkcji INDEKS(): tablicowa i odwołaniowa. Forma tablicowa zwraca zawsze wartość lub tablicę wartości; forma odwołaniowa zwraca zawsze odwołanie. Natomiast forma odwołaniowa zawsze zwraca odwołanie.

INDEKS(tablica;nr_wiersza;nr_kolumny) zwraca wartość określonej komórki lub tablicy komórek w tablicy.

INDEKS(odwołanie;nr_wiersza;nr_kolumny;nr_obszaru) zwraca odwołanie do określonych komórek.

Składnia 1 (tablicowa)

Funkcja zwraca wartość elementu w tablicy, wybranego przez indeksy numerów kolumny i wiersza.

Funkcja INDEKS ma dwie formy składni: tablicową i odwołaniową. Forma tablicowa zawsze zwraca wartość lub tablicę wartości. Natomiast forma odwołaniowa zawsze zwraca odwołanie. Formę tablicową należy stosować wtedy, kiedy pierwszy argument funkcji INDEKS jest stałą tablicową.

Składnia 1

Forma tablicowa

INDEKS(tablica;nr_wiersza;nr_kolumny)

Tablica to zakres komórek albo stała tablicowa.

  • Jeśli argument tablica zawiera tylko jeden wiersz lub kolumnę, to argumenty nr_wiersza lub nr_kolumny są odpowiednio opcjonalne.

  • Jeśli tablica zawiera kilka wierszy i kilka kolumn, a wykorzystany jest tylko argument nr_wiersza lub nr_kolumny, to funkcja INDEKS zwraca tablicę z całym wierszem lub kolumną.

Nr_wiersza wybiera wiersz tablicy, z którego ma być zwrócona wartość. Jeśli argument nr_wiersza zostanie pominięty, to argument nr_kolumny jest wymagany.

Nr_kolumny wybiera kolumnę tablicy, z której ma być zwrócona wartość. Jeśli argument nr_kolumny zostanie pominięty, to argument nr_wiersza jest wymagany.

Spostrzeżenia

  • Jeśli zostaną użyte zarówno argumenty nr_wiersza jak i nr_kolumny, to funkcja INDEKS zwraca wartość w komórce leżącej na przecięciu nr_wiersza i nr_kolumny.
  • Jeśli argument nr_wiersza lub nr_kolumny będzie mieć wartość zero (0), funkcja INDEKS zwróci tablicę wartości odpowiednio dla całego wiersza lub dla całej kolumny. Aby wykorzystać wartości zwracane w postaci tablicy, funkcję INDEKS należy wprowadzać jako formułę tablicową, dla wiersza do poziomego zakresu komórek, a dla kolumny do pionowego zakresu komórek. Aby wprowadzić formułę tablicową, należy nacisnąć klawisze CTRL+SHIFT+ENTER.

  • Argumenty nr_wiersza i nr_kolumny muszą odnosić się do komórki wewnątrz tablicy, w przeciwnym wypadku funkcja INDEKS zwróci wartość błędu #ADR!.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Dane
jabłka | Cytryny
Banany | Gruszki
Formuła | Opis (Wynik)
=INDEKS(A2:C6;2;3) | Wartość znajdująca się na przecięciu drugiego wiersza i drugiej kolumny zakresu (Gruszki)
=INDEKS(A2:C6;2;3) | Wartość znajdująca się na przecięciu drugiego wiersza i pierwszej kolumny zakresu (Banany)

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=INDEKS({1;2/3;4};0;2) | Wartość w pierwszym wierszu, drugiej kolumnie w stałej tablicowej (2)
 | Wartość w drugim wierszu, drugiej kolumnie w stałej tablicowej (4)

Uwaga Formuła w przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego, wybierz zakres A2:A3, poczynając od komórki formuły. Naciśnij klawisz F2, a następnie naciśnij klawisze CTRL+SHIFT+ENTER. Jeżeli formuła nie jest wprowadzona jako formuła tablicowa, jedynym wynikiem będzie liczba 2.

Składnia 2 (odwołaniowa)

Funkcja zwraca odwołanie do komórki leżącej na przecięciu konkretnego wiersza i kolumny. Jeśli odwołanie składa się z wyborów nieciągłych można wybrać zaznaczony obszar, aby mu się przyjrzeć.

Funkcja INDEX ma dwie formy składni: tablicową i odwołaniową. Forma tablicowa zawsze zwraca wartość lub tablicę wartości. Natomiast forma odwołaniowa zawsze zwraca odwołanie.

Składnia 2

Forma odwołaniowa

INDEKS(odwołanie;nr_wiersza;nr_kolumny;nr_obszaru)

Odwołanie to odwołanie jednego lub kilku zakresów komórek.

  • Jeśli wprowadza się wybór nieciągły do argumentu odwołanie, należy zamknąć odwołanie w nawiasie.

  • Jeśli każdy obszar w odwołaniu zawiera tylko jeden wiersz lub kolumnę, to argument nr_wiersza lub nr_kolumny odpowiednio jest opcjonalny. Na przykład dla argumentu odwołanie określającego pojedynczy wiersz należy zastosować funkcję INDEKS(odwołanie;nr_kolumny).

Nr_wiersza to numer wiersza w odwołaniu, z którego ma pochodzić wynik w postaci odwołania.

Nr_kolumny to numer kolumny w odwołaniu, z którego ma pochodzić wynik w postaci odwołania.

Nr_obszaru wybiera zakres w odwołaniu, z którego ma pochodzić wynik w postaci przecięcia wiersza i kolumny określonego argumentami nr_wiersza i nr_kolumny. Zakres wybrany lub wprowadzony jako pierwszy ma numer 1, drugi ma numer 2 itd. Jeśli argument nr_obszaru jest pominięty, funkcja INDEKS przyjmuje obszar 1.

  • Na przykład, jeśli odwołanie opisuje komórki (A1:B4;D1:E4;G1:H4), wtedy obszar numer 1 jest zakresem A1:B4, obszar numer 2 jest zakresem D1:E4, a obszar numer 3 jest zakresem G1:H4.

Spostrzeżenia

  • Po wybraniu konkretnego zakresu przez argument odwołanie i argument nr_obszaru, argumenty nr_wiersza i nr_kolumny wybierają konkretną komórkę: nr_wiersza 1 jest pierwszym wierszem w zakresie, nr_kolumny 1 jest pierwszą kolumną itd. Odwołanie zwracane przez funkcję INDEKS jest przecięciem nr_wiersza i nr_kolumny.

  • W przypadku, gdy nr_wiersza lub nr_kolumny ma wartość zero (0), funkcja INDEKS zwraca odwołanie odpowiednio całego wiersza lub kolumny.

  • Argumenty nr_wiersza, nr_kolumny i nr_obszaru muszą odnosić się do komórki wewnątrz odwołania. W przeciwnym wypadku funkcja INDEKS zwraca wartość błędu #ADR!. Jeśli argumenty nr_wiersza i nr_kolumny zostaną pominięte, funkcja INDEKS zwróci obszar w odwołaniu wyznaczony przez argument nr_obszaru.
  • Wynik działania funkcji INDEKS jest odwołaniem i w ten sposób jest interpretowany przez inne formuły. W zależności od formuły wynik funkcji INDEKS może być wykorzystywany jako odwołanie lub wartość. Na przykład formuła KOMÓRKA("szerokość";INDEKS(A1:B2;1;2)) jest równoważna formule KOMÓRKA("szerokość";B1). Funkcja KOMÓRKA wykorzystuje wartość otrzymaną z funkcji INDEKS jako odwołanie do komórki. Z drugiej strony formuła typu 2*INDEKS(A1:B2;1;2) tłumaczy wynik funkcji INDEKS na liczbę zawartą w komórce B1.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Owoc | Cena | Liczba
jabłka | 0,69 | 40
Banany | 0,34 | 38
Cytryny | 0,55 | 15
pomarańcze | 0,25 | 25
Gruszki | 0,59 | 40
Migdały | 2,80 | 10
Nerkowce | 3,55 | 16
Orzeszki ziemne | 1,25 | 20
Orzechy włoskie | 1,75 | 12
Formuła | Opis (Wynik)
=INDEKS(A2:C6;2;3) | Przecięcie drugiego wiersza i trzeciej kolumny w zakresie A2:C6, które jest zawartością komórki C3. (38)
=INDEKS((A1:C6;A8:C11);2;2;2) | Przecięcie drugiego wiersza i drugiej kolumny w obszarze drugim zakresu A8:C11, które jest zawartością komórki B9. (3.55)
=SUMA(INDEKS(A1:C11;0;3;1)) | Suma trzeciej kolumny w obszarze pierwszym zakresu A1:C11, która jest sumą zawartości komórek C1:C6. (216)


LICZBA.KOLUMN

Zwraca liczbę kolumn w tablicy lub odwołaniu.

Składnia

LICZBA.KOLUMN(tablica)

Tablica to tablica lub formuła tablicowa albo odwołanie do zakresu komórek, dla którego ma być zwrócona liczba kolumn.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=LICZBA.KOLUMN(C1:E4) | Liczba kolumn w odwołaniu (3)
=LICZBA.KOLUMN({1;2;3/4;5;6}) | Liczba kolumn w stałej tablicowej (3)


NR.KOLUMNY

Zwraca numer kolumny danego odwołania.

Składnia

NR.KOLUMNY(odwołanie)

Odwołanie to komórka lub zakres komórek, którego numer kolumny ma być zwrócony.

Spostrzeżenia

  • Jeśli argument odwołanie zostanie pominięty, to zakłada się, że jest odwołaniem do komórki, w której pojawia się funkcja NR.KOLUMNY.
  • Jeśli odwołanie to zakres komórek i jeśli funkcja NR.KOLUMNY jest wprowadzona jako tablica pozioma, to funkcja NR.KOLUMNY zwraca numery kolumn odwołania jako tablicę poziomą.
  • Odwołanie nie może obejmować kilku obszarów.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=NR.KOLUMNY() | Numer kolumny, w której występuje formuła (1)
=NR.KOLUMNY(B10) | Numer kolumny odwołania (2)


OBSZARY

Zwraca liczbę obszarów w odwołaniu. Obszar to zakres przylegających do siebie komórek lub pojedyncza komórka.

Składnia

OBSZARY(odwołanie)

Odwołanie to odwołanie do komórki lub do zakresu komórek i może odwoływać się do wielu obszarów. Aby określić kilka odwołań jako jeden argument, należy dołączyć dodatkowe zestawy nawiasów, dzięki którym średnik nie zostanie zinterpretowany jako separator pól. Zapoznaj się z następującym przykładem.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=OBSZARY(B2:D4) | Liczba obszarów w zakresie (1)
=OBSZARY((B2:D4;E5;F6:I9)) | Liczba obszarów w zakresie (3)
=OBSZARY((B2:D4;B2)) | Liczba obszarów w zakresie (2)


PODAJ.POZYCJĘ

Zwraca względną pozycję w tablicy elementu, który spełnia określone wymagania w określony sposób. Funkcji PODAJ.POZYCJĘ należy używać zamiast jednej z funkcji WYSZUKAJ, kiedy konieczna jest znajomość pozycji odpowiedniego elementu, a nie tylko samego elementu.

Składnia

PODAJ.POZYCJĘ(szukana_wartość;przeszukiwana_tab;typ_porównania)

Szukana_wartość to wartość wykorzystywana do znalezienia w tablicy żądanej wartości.

  • Szukana_wartość to wartość, która ma spełniać oczekiwania w przeszukiwana_tab. Na przykład, kiedy poszukuje się czyjegoś telefonu w książce telefonicznej, używa się nazwiska tej osoby jako wartości przeglądowej, lecz wartością poszukiwaną jest numer telefonu.

  • Argument szukana_wartość może być wartością (liczbą, tekstem lub wartością logiczną) lub odwołaniem do komórki zawierającej liczbę, tekst lub wartość logiczną.

Przeszukiwana_tab to ciągły zakres komórek, zawierający możliwe wartości poszukiwane. Argument przeszukiwana_tab musi być tablicą lub odwołaniem do tablicy.

Typ_porównania to liczba -1, 0 albo 1. Argument typ_porównania określa sposób porównywania argumentu szukana_wartość z wartościami w przeszukiwana_tab.

  • Jeśli argument typ_porównania jest równy 1, funkcja PODAJ.POZYCJĘ znajdzie największą wartość, która jest mniejsza niż lub równa wartości szukana_wartość. Wartości w tablicy przeszukiwana_tab muszą być umieszczone w kolejności rosnącej: ...-2, -1, 0, 1, 2, ..., A-Z, FAŁSZ, PRAWDA.

  • Jeśli argument typ_porównania jest równy 0, funkcja PODAJ.POZYCJĘ znajdzie pierwszą wartość dokładnie równą wartości szukana_wartość. W tym wypadku kolejność wartości w tablicy przeszukiwana_tab może być dowolna.

  • Jeśli argument typ_porównania jest równy -1, funkcja PODAJ.POZYCJĘ znajdzie najmniejszą wartość, która jest większa niż lub równa szukana_wartość. Wartości w tablicy przeszukiwana_tab muszą być umieszczone w kolejności malejącej: PRAWDA, FAŁSZ, Z-A, ...2, 1, 0, -1, -2, ..., itd.

  • Jeśli argument typ_porównania zostanie pominięty, zakłada się, że jest równy 1.

Spostrzeżenia

  • Funkcja PODAJ.POZYCJĘ podaje pozycję spełniającej wymagania wartości wewnątrz przeszukiwana_tab, lecz nie samą wartość. Na przykład PODAJ.POZYCJĘ("b";{"a";"b";"c"};0) zwraca wartość 2, czyli pozycję względną litery "b" wewnątrz tablicy{"a";"b";"c"}.
  • Funkcja PODAJ.POZYCJĘ nie rozróżnia wielkich i małych liter podczas porównywania wartości tekstowych.
  • Jeśli funkcja PODAJ.POZYCJĘ zakończy niepowodzeniem wyszukiwanie dopasowania, zwraca wartość błędu #N/D.
  • Jeśli argument typ_porównania wynosi 0 i argument szukana_wartość jest tekstem, szukana_wartość może zawierać znaki zastępcze gwiazdkę (*) i znak zapytania (?). Gwiazdka zastępuje dowolny ciąg znaków, a znak zapytania dowolny pojedynczy znak.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Nabiał | Liczba
Banany | 25
pomarańcze | 38
jabłka | 40
Gruszki | 41
Formuła | Opis (Wynik)
=PODAJ.POZYCJĘ(39;B2:B5;1) | Ponieważ brak dokładnego odpowiednika, zwracana jest pozycja następnej najmniejszej wartości (38) w zakresie B2:B5. (2)
=PODAJ.POZYCJĘ(41;B2:B5;0) | Pozycja liczby 41 w zakresie B2:B5. (4)
=PODAJ.POZYCJĘ(40;B2:B5;-1) | Zwraca błąd, ponieważ zakres B2:B5 nie jest uporządkowany malejąco. (#N/D)


PRZESUNIĘCIE

Zwraca odwołanie do zakresu, który jest podaną liczbą wierszy lub kolumn począwszy od komórki lub zakresu komórek. Zwracane odwołanie może być pojedynczą komórką lub zakresem komórek. Można określić liczbę zwracanych wierszy i kolumn.

Składnia

PRZESUNIĘCIE(adres;wiersze;kolumny;wysokość;szerokość)

Adres to odwołanie, od którego wyznacza się przesunięcie. Odwołanie musi określać komórkę lub zakres sąsiednich komórek. W przeciwnym wypadku funkcja PRZESUNIĘCIE zwróci wartość błędu #ARG!.

Wiersze to liczba wierszy w górę lub w dół, o które należy przesunąć górną lewą komórkę. Podanie liczby 5 jako argumentu wiersze oznacza, że lewa górna komórka odwołania jest pięć wierszy poniżej od odwołania określonego przez argument adres. Argument wiersze może być dodatni (co oznacza przesunięcie w dół) lub ujemny (co oznacza przesunięcie w górę).

Kolumny to liczba kolumn w lewo lub w prawo, o które należy przesunąć górną lewą komórkę. Podanie liczby 5 jako argumentu kolumny oznacza, że lewa górna komórka odwołania jest pięć kolumn na prawo od odwołania określonego przez argument adres. Argument kolumny może być dodatni (co oznacza przesunięcie w prawo) lub ujemny (przesunięcie w lewo).

Wysokość to wysokość, w sensie liczby wierszy, na której ma znajdować się odwołanie. Argument wysokość musi być liczbą dodatnią.

Szerokość to szerokość, w sensie liczby kolumn, której ma dotyczyć zwracane odwołanie. Argument szerokość musi być liczbą dodatnią.

Spostrzeżenia

  • Jeśli wiersze i kolumny przesuwają odwołania poza brzeg arkusza, to funkcja PRZESUNIĘCIE zwraca wartość błędu #ADR!.

  • Jeśli argumenty wysokość lub szerokość zostaną pominięte, to zakłada się, że ich wartości będą mieć taką samą wysokość lub szerokość jak adres.

  • Funkcja PRZESUNIĘCIE w rzeczywistości nie przesuwa żadnych komórek, ani nie zmienia wyboru, tylko daje w wyniku odwołanie. Funkcja PRZESUNIĘCIE może być wykorzystywana z innymi funkcjami wymagającymi odwołania jako argumentu. Na przykład funkcja SUMA(PRZESUNIĘCIE(C2;1;2;3;1)) oblicza wartość całkowitą zakresu 3 wiersze na jedną kolumnę, który znajduje się 1 wiersz poniżej i 2 kolumny po prawej stronie od komórki C2.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=PRZESUNIĘCIE(C3;2;3;1;1) | Wyświetla wartość w komórce F5 (0)
=SUMA(PRZESUNIĘCIE(C3:E5;-1;0;3;3)) | Sumuje zakres C2:E4 (0)
=PRZESUNIĘCIE(C3:E5;0;-3;3;3) | Zwraca błąd, ponieważ adres jest poza arkuszem kalkulacyjnym (#ADR!)


TRANSPONUJ

Zwraca pionowy zakres komórek jako zakres poziomy i odwrotnie. Funkcja TRANSPONUJ musi być wprowadzana jako formuła tablicowa w zakresie o takiej liczbie wierszy i kolumn, jaka występuje w tablicy. Funkcja TRANSPONUJ służy do zmieniania pionowej i poziomej orientacji tablicy w arkuszu kalkulacyjnym.

Składnia

TRANSPONUJ(tablica)

Tablica to tablica lub zakres komórek w arkuszu kalkulacyjnym, który ma być transponowany. Tablica transponowana jest tworzona w następujący sposób: pierwszy wiersz tablicy staje się pierwszą kolumną nowej tablicy, drugi wiersz staje się drugą kolumną itd.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Dane | Dane
1 | 2 | 3
Formuła | Opis (Wynik)
=TRANSPONUJ($A$2:$C$2) | Wartość z pierwszej kolumny (1)
 | Wartość z drugiej kolumny (2)
 | Wartość z trzeciej kolumny (3)

Uwaga W tym przykładzie formuła musi być wprowadzona w postaci formuły tablicowej. Po skopiowaniu przykładu do pustego arkusza należy zaznaczyć zakres A4:A6, rozpoczynając od komórki zawierającej formułę. Trzeba nacisnąć klawisz F2, a następnie kombinację klawiszy CTRL+SHIFT+ENTER. Jeśli formuła nie będzie wprowadzona w postaci formuły tablicowej, to jedynym wynikiem będzie liczba 1.

Przykład 2

Niektóre funkcje, takie jak REGLINP, zwracają tablice w układzie poziomym. Funkcja REGLINP zwraca poziomą tablicę zawierającą wartości nachylenia prostej i jej punktów przecięcia z osią y. Poniższa formuła na podstawie funkcji REGLINP zwraca tablicę w układzie pionowym, zawierającą wartości nachylenia prostej i jej punktów przecięcia z osią y.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Znane y | Znane x
1 | 0
9 | 4
5 | 2
7 | 3
Formuła | Opis (Wynik)
=TRANSPONUJ(REGLINP(A2:A5;B2:B5;;FAŁSZ)) | Nachylenie (2)
 | Punkt przecięcia z osią Y (1)

Uwaga W tym przykładzie formuła musi być wprowadzona w postaci formuły tablicowej. Po skopiowaniu przykładu do pustego arkusza należy zaznaczyć zakres A7:A8, rozpoczynając od komórki zawierającej formułę. Trzeba nacisnąć klawisz F2, a następnie kombinację klawiszy CTRL+SHIFT+ENTER. Jeśli formuła nie będzie wprowadzona w postaci formuły tablicowej, to jedynym wynikiem będzie liczba 2.


WIERSZ

Zwraca numer wiersza odwołania.

Składnia

WIERSZ(odwołanie)

Odwołanie jest komórką lub zakresem komórek, którego numer wiersza ma być zwrócony.

  • Jeśli argument odwołanie zostanie pominięty, to zakłada się, że jest odwołaniem do komórki, w której znajduje się funkcja WIERSZ.

  • Jeśli argument odwołanie jest zakresem komórek i jeśli funkcja WIERSZ zostanie wprowadzona jako tablica pionowa, funkcja WIERSZ zwraca numery wierszy odwołania jako tablicę pionową.

  • Odwołanie nie może obejmować kilku obszarów.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=WIERSZ() | Wiersz, w którym występuje formuła (2)
=WIERSZ(C10) | Wiersz odwołania (10)

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=WIERSZ(C4:D6) | Pierwszy wiersz w odwołaniu (4)
 | Drugi wiersz w odwołaniu (5)
 | Trzeci wiersz w odwołaniu (6)

Uwaga Formuła w tym przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego należy zaznaczyć zakres A14:B18, rozpoczynając od komórki zawierającej formułę. Trzeba nacisnąć klawisz F2, a następnie kombinację klawiszy CTRL+SHIFT+ENTER. Jeśli formuła nie będzie wprowadzona w postaci formuły tablicowej, jedynym wynikiem będzie liczba 4.


WYBIERZ

Korzystając z argumentu nr_arg, funkcja zwraca wartość z listy wartości będących argumentami. Funkcja WYBIERZ umożliwia wybranie jednej z nie więcej niż 29 wartości na podstawie numeru indeksu. Na przykład jeśli argumenty od wartość1 do wartość7 to dni tygodnia, to użycie jako argumentu nr_arg liczby od 1 do 7 spowoduje, że funkcja WYBIERZ zwróci jeden z tych dni.

Składnia

WYBIERZ(nr_arg;wartość1;wartość2;...)

Nr_arg określa, która wartość argumentów została wybrana. Argument nr_arg musi być liczbą z zakresu od 1 do 29, formułą albo odwołaniem do komórki zawierającej liczbę z podanego przedziału.

  • Jeśli wartość argumentu nr_arg jest równa 1, to funkcja WYBIERZ zwraca argument wartość1; jeśli wartość argumentu jest równa 2, funkcja WYBIERZ zwraca argument wartość2 itd.

  • Jeśli wartość argumentu nr_arg jest mniejsza od 1 lub większa od ostatniej wartości na liście, to funkcja WYBIERZ zwraca wartość błędu #ARG!.

  • Jeśli wartość argumentu nr_arg jest ułamkiem, to przed użyciem zostaje on przycięty do najmniejszej liczby całkowitej.

Wartość1,wartość2,... to zakres od 1 do 29 wartości argumentów, z których funkcja WYBIERZ wybiera wartość lub czynność, która ma zostać wykonana na podstawie wartości argumentu nr_arg. Argumentami mogą być liczby, odwołania do komórek, zdefiniowane nazwy, formuły, funkcje lub tekst.

Spostrzeżenia

  • Jeśli argument nr_arg ma postać tablicy, to podczas działania funkcji WYBIERZ obliczana jest wartość każdego argumentu.
  • Wartości używane jako argumenty funkcji WYBIERZ mogą być zarówno odwołaniami do zakresów, jak i pojedynczymi wartościami.

    Na przykład formuła:

    =SUMA(WYBIERZ(2;A1:A10;B1:B10;C1:C10))

    wykonuje działanie:

    =SUMA(B1:B10),

    z którego następnie zwracana jest wartość na podstawie zakresu B1:B10.

    Najpierw obliczana jest funkcja WYBIERZ, która zwraca odwołanie do zakresu B1:B10. Następnie obliczana jest funkcja SUMA, której argumentem jest zakres B1:B10 będący wynikiem działania funkcji WYBIERZ.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Dane
1 | Gwoździe
2 | Wkręty
3 | Nakrętki
Koniec | Śruby
Formuła | Opis (Wynik)
=WYBIERZ(2;A2;A3;A4;A5) | Wartości z drugiego argumentu A3 (2)
=WYBIERZ(4;B2;B3;B4;B5) | Wartości z czwartego argumentu B5 (Śruby)

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
23
45
12
10
Formuła | Opis (Wynik)
=SUMA(A2:WYBIERZ(2;A3;A4;A5)) | Oblicza sumę zakresu A2:A4 (80)


WYSZUKAJ

Zwraca wartość albo z jednowierszowego, albo jednokolumnowego zakresu lub z tablicy. Funkcja WYSZUKAJ ma dwie formy składniowe: wektorową i tablicową. Forma wektorowa funkcji WYSZUKAJ w zakresie jednowierszowym lub jednokolumnowym (znanym jako wektor) wyszukuje wartość i zwraca wartość z tej samej pozycji w drugim jednowierszowym lub jednokolumnowym zakresie. Tablicowa forma funkcji WYSZUKAJ wyszukuje określoną wartość w pierwszym wierszu lub kolumnie tablicy i zwraca wartość z tej samej pozycji w ostatnim wierszu lub kolumnie tablicy.

Składnia 1 (wektorowa)

WYSZUKAJ(szukana_wartość;przeszukiwany_wektor;wektor_wynikowy)

Szukana_wartość to wartość, której funkcja WYSZUKAJ poszukuje w pierwszym wektorze. Szukana_wartość może być liczbą, tekstem, wartością logiczną, nazwą lub odwołaniem odnoszącym się do wartości.

Przeszukiwany_wektor to zakres zawierający tylko jeden wiersz lub jedną kolumnę. Wartości znajdujące się w argumencie przeszukiwany_wektor mogą być tekstem, liczbami lub wartościami logicznymi.

Ważne Wartości znajdujące się w argumencie przeszukiwany_wektor muszą być umieszczone w kolejności rosnącej: ..., -2, -1, 0, 1, 2, ..., A-Z, FAŁSZ, PRAWDA. W przeciwnym wypadku funkcja WYSZUKAJ może nie znaleźć poprawnej wartości. Teksty pisane wielkimi i małymi literami są równoważne.

Wektor_wynikowy to zakres zawierający tylko jeden wiersz lub jedną kolumnę. Argument ten powinien mieć taką samą wielkość, co argument przeszukiwany_wektor.

Spostrzeżenia

  • Jeśli funkcja WYSZUKAJ nie może znaleźć wartości określonej przez argument szukana_wartość, to wybiera wartość największą w wektorze przeszukiwany_wektor mniejszą lub równą poszukiwanej szukana_wartość.
  • Jeśli argument szukana_wartość jest mniejszy od najmniejszej wartości w wektorze przeszukiwany_wektor, to funkcja WYSZUKAJ zwraca wartość błędu #N/D.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Częstotliwość | Kolor
4,14 | czerwony
4,19 | pomarańczowy
5,17 | żółty
5,77 | zielony
6,39 | niebieski
Formuła | Opis (Wynik)
=WYSZUKAJ(4,91;A2:A6;B2:B6) | Wyszukuje liczbę 4,19 w kolumnie A, a następnie zwraca wartość z kolumny B, która znajduje się w tym samym wierszu (pomarańczowy)
=WYSZUKAJ(5,00;A2:A6;B2:B6) | Wyszukuje liczbę 5,00 w kolumnie A, a następnie zwraca wartość z kolumny B, która znajduje się w tym samym wierszu (pomarańczowy)
=WYSZUKAJ(7,66;A2:A6;B2:B6) | Wyszukuje liczbę 7,66 w kolumnie A, dopasowuje najbliższą najmniejszą wartość (6,39), a następnie zwraca wartość z kolumny B, która znajduje się w tym samym wierszu (niebieski)
=WYSZUKAJ(0;A2:A6;B2:B6) | Wyszukuje liczbę 0 w kolumnie A, a następnie zwraca błąd, ponieważ liczba 0 jest mniejsza niż najmniejsza wartość w argumencie przeszukiwany_wektor A2:A7 (#N/D)

Składnia 2 (tablicowa)

WYSZUKAJ(szukana_wartość;tablica)

Szukana_wartość to wartość poszukiwana przez funkcję WYSZUKAJ w tablicy. Szukana_wartość może być liczbą, tekstem, wartością logiczną, nazwą lub odwołaniem odnoszącym się do wartości.

  • Jeśli funkcja WYSZUKAJ nie może znaleźć wartości określonej przez argument szukana_wartość, to wybiera wartość największą w tablicy, która jest mniejsza niż lub równa szukana_wartość.

  • Jeśli szukana_wartość jest mniejsza od najmniejszej wartości w pierwszym wierszu lub kolumnie (w zależności od wielkości tablicy), to funkcja WYSZUKAJ zwraca wartość błędu #N/D.

Tablica to zakres komórek, zawierających tekst, liczby lub wartości logiczne, które należy porównać z argumentem szukana_wartość.

Forma tablicowa funkcji WYSZUKAJ jest bardzo podobna do funkcji WYSZUKAJ.POZIOMO i WYSZUKAJ.PIONOWO. Różnica polega na tym, że funkcja WYSZUKAJ.POZIOMO poszukuje szukana_wartość w pierwszym wierszu, funkcja WYSZUKAJ.PIONOWO poszukuje w pierwszej kolumnie, a funkcja WYSZUKAJ poszukuje zgodnie z wymiarami tablicy.

  • Jeśli tablica jest obszarem o szerokości większej niż wysokość (ma więcej kolumn niż wierszy), to funkcja WYSZUKAJ poszukuje wartości szukana_wartość w pierwszym wierszu.

  • Jeśli tablica jest kwadratem lub obszarem o wysokości większej niż szerokość (ma więcej wierszy niż kolumn), to funkcja WYSZUKAJ poszukuje wartości w pierwszej kolumnie.

  • Funkcje WYSZUKAJ.POZIOMO i WYSZUKAJ.PIONOWO pozwalają na indeksowanie w pionie i w poziomie, natomiast funkcja WYSZUKAJ zawsze wybiera ostatnią wartość w wierszu lub kolumnie.

Ważne Wartości znajdujące się w tablicy muszą być umieszczone w kolejności rosnącej: ..., -2, -1, 0, 1, 2, ..., A-Z, FAŁSZ, PRAWDA. W przeciwnym wypadku funkcja WYSZUKAJ może nie znaleźć poprawnej wartości. Teksty pisane wielkimi i małymi literami są równoważne.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=WYSZUKAJ("C",{"a","b","c","d";1,2,3,4}) | Wyszukuje literę "C" w pierwszym wierszu tablicy i zwraca wartość znajdującą się w ostatnim wierszu i w tej samej kolumnie (3)
=WYSZUKAJ("bump";{"a";1/"b";2/"c";3}) | Wyszukuje słowo "bump" w pierwszym wierszu tablicy i zwraca wartość znajdującą się w ostatniej kolumnie i tym samym wierszu (2)


WYSZUKAJ.PIONOWO

Przeszukuje skrajną lewą kolumnę tablicy, by znaleźć wartość szczególną i zwraca wartość z tego samego wiersza we wskazanej kolumnie. Funkcję WYSZUKAJ.PIONOWO należy stosować zamiast WYSZUKAJ.POZIOMO wtedy, kiedy wartości porównawcze są umieszczone w kolumnie z lewej strony danych, których się szuka.

PIONOWO w nazwie funkcji WYSZUKAJ.PIONOWO wskazuje, że wyszukiwanie zachodzi w pionie..

Składnia

WYSZUKAJ.PIONOWO(odniesienie;tablica;nr_kolumny;kolumna)

Odniesienie jest wartością, którą należy znaleźć w pierwszej kolumnie tablicy. Odniesienie może być wartością, adresem lub ciągiem tekstowym.

Tablica jest tablicą zawierającą informacje, którą należy przeszukać. Należy użyć odwołania do zakresu lub nazwy zakresu, takiej jak Baza_danych lub Lista.

  • Jeśli argument kolumna ma wartość PRAWDA, wartości w pierwszej kolumnie tablicy muszą być umieszczone w kolejności rosnącej: ...; -2; -1; 0; 1; 2; ...; A-Z; FAŁSZ, PRAWDA. W przeciwnym wypadku funkcja WYSZUKAJ.PIONOWO może nie znaleźć poprawnej wartości. Jeśli wartością argumentu kolumna jest FAŁSZ, nie ma potrzeby sortowania tablicy.

  • Wartości można uporządkować w kolejności rosnącej klikając przycisk Sortuj rosnąco [image] na pasku narzędzi arkusza kalkulacyjnego.

  • Wartości w pierwszej kolumnie tablicy mogą być tekstami, liczbami lub wartościami logicznymi.

  • Teksty pisane wielkimi i małymi literami są równoważne.

Nr_kolumny jest to numer kolumny w tablicy, z której powinna pochodzić poszukiwana wartość. Argument nr_kolumny o wartości 1 powoduje, że zwracana jest wartość z pierwszej kolumny tablicy. Argument nr_kolumny o wartości 2 powoduje, że zwracana jest wartość z drugiej kolumny tablicy i tak dalej. Jeśli argument nr_kolumny jest mniejszy niż 1, funkcja WYSZUKAJ.PIONOWO zwraca wartość błędu #WARTOŚĆ!; jeśli argument nr_kolumny jest większy niż liczba kolumn w tablicy, funkcja WYSZUKAJ.PIONOWO zwraca wartość błędu #ADR!.

Kolumna jest wartością logiczną, określającą czy funkcja WYSZUKAJ.POZIOMO ma znaleźć dokładne czy niedokładne dopasowanie. Jeśli wartością tą jest PRAWDA bądź została pominięta, zwracane jest dopasowanie przybliżone. Innymi słowy, jeśli nie zostanie znalezione dopasowanie dokładne, to zwrócona będzie następna największa wartość, mniejsza od argumentu odniesienie. Jeśli zaś wartością argumentu kolumna będzie FAŁSZ, funkcja WYSZUKAJ.PIONOWO wyszuka dopasowanie dokładne. Jeśli nie zostanie ono znalezione, zostanie zwrócona wartość błędu #N/D!.

Spostrzeżenia

  • Jeśli funkcja WYSZUKAJ.PIONOWO nie może znaleźć odniesienia, a wartością argumentu kolumna jest PRAWDA, funkcja użyje największej wartości nie większej od argumentu odniesienie.
  • Jeśli wartość odniesienia jest mniejsza niż najmniejsza wartość w pierwszej kolumnie tablicy, funkcja WYSZUKAJ.PIONOWO zwróci wartość błędu #N/D.
  • Jeśli funkcja WYSZUKAJ.PIONOWO nie może znaleźć wartości odniesienie, a wartością argumentu kolumna jest FAŁSZ, funkcja WYSZUKAJ.PIONOWO zwróci wartość błędu #N/D.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

W przykładzie użyto wartości dla powietrza pod ciśnieniem 1 atmosfery.

Gęstość | Lepkość | Temperatura
0,457 | 3,55 | 500
0,525 | 3,25 | 400
0,616 | 2,93 | 300
0,675 | 2,75 | 250
0,746 | 2,57 | 200
0,835 | 2,38 | 150
0,946 | 2,17 | 100
1,09 | 1,95 | 50
1,29 | 1,71 | 0
Formuła | Opis (Wynik)
=WYSZUKAJ.PIONOWO(1;A2:C10;2) | Wyszukuje wartość 1 w kolumnie A, a następnie zwraca wartość z kolumny B w tym samym wierszu. (2,17)
=WYSZUKAJ.PIONOWO(1;A2:C10;3;PRAWDA) | Wyszukuje wartość 1 w kolumnie A, a następnie zwraca wartość z kolumny C w tym samym wierszu. (100)
=WYSZUKAJ.PIONOWO(0,7;A2:C10;3;FAŁSZ) | Poszukuje wartości 0,746 w kolumnie A. Ponieważ w tej kolumnie brak dokładnego odpowiednika, zwracany jest błąd. #N/D
=WYSZUKAJ.PIONOWO(0,1;A2:C10;2;PRAWDA) | Poszukuje wartości 0,1 w kolumnie A. Ponieważ wartość 0,1 jest mniejsza niż najmniejsza wartość w kolumnie A, zwracany jest błąd. #N/D
=WYSZUKAJ.PIONOWO(2;A2:C10;2;PRAWDA) | Wyszukuje wartość 2 w kolumnie A, a następnie zwraca wartość z kolumny B w tym samym wierszu. (1,71)


WYSZUKAJ.POZIOMO

Wyszukuje wartość w górnym wierszu tabeli lub w tablicy wartości i zwraca wartość w tej samej kolumnie z wiersza określonego w tablicy lub w tabeli. Należy skorzystać z funkcji WYSZUKAJ.POZIOMO, kiedy porównywane wartości są w górnym wierszu tablicy danych, a chcesz przeszukać określoną liczbę wierszy w dół. Z funkcji WYSZUKAJ.PIONOWO należy skorzystać, kiedy porównywane dane znajdują się w kolumnie z lewej lub prawej strony danych, które chcesz znaleźć.

POZIOMO w nazwie funkcji WYSZUKAJ.POZIOMO wskazuje, że wyszukiwanie zachodzi w poziomie.

Składnia

WYSZUKAJ.POZIOMO(odniesienie;tablica;nr_wiersza;wiersz)

Odniesienie to wartość wyszukiwana w pierwszym wierszu tabeli. Odniesienie może być wartością, odwołaniem lub ciągiem tekstowym.

Tablica to tabela informacji, w której wyszukiwane są dane. Należy użyć odwołania do zakresu lub nazwy zakresu.

  • Wartości w pierwszym wierszu tabeli określonej przez argument tablica mogą być tekstem, liczbami lub wartościami logicznymi.

  • Jeśli wartością argumentu wiersz jest PRAWDA, to wartości w pierwszym wierszu tabeli określonej argumentem tablica muszą być uporządkowane w kolejności rosnącej: ...-2, -1, 0, 1, 2,... , A-Z, FAŁSZ, PRAWDA; w innym przypadku funkcja WYSZUKAJ.POZIOMO może nie dawać poprawnej wartości. Jeśli wartością argumentu wiersz jest FAŁSZ, nie ma potrzeby sortowania tablicy.

  • Teksty pisane wielkimi i małymi literami są równoważne.

  • Można umieścić wartości w kolejności rosnącej, klikając przycisk [image] na pasku narzędzi arkusza kalkulacyjnego.

Nr_wiersza to numer wiersza w tabeli określonej argumentem tablica, z której będzie zwrócona pasująca wartość. Argument nr_wiersza o wartości 1 zwraca pierwszy wiersz w tabeli tablica, argument nr_wiersza o wartości 2 drugi wiersz w tabeli tablica, itd. Jeśli argument nr_wiersza jest mniejszy niż 1, funkcja WYSZUKAJ.POZIOMO zwraca wartość błędu #ARG!; jeśli argument nr_wiersza jest większy niż liczba wierszy tabeli tablica, funkcja WYSZUKAJ.POZIOMO zwraca wartość błędu #ADR!.

Wiersz to wartość logiczna określająca, czy funkcja WYSZUKAJ.POZIOMO ma znaleźć dokładne, czy przybliżone dopasowanie. Jeśli wartością tą jest PRAWDA bądź została pominięta, zwracane jest przybliżone dopasowanie. Innymi słowy, jeśli nie zostanie znalezione dokładne dopasowanie, to zwracana jest następna największa wartość mniejsza od wartości argumentu wiersz. Jeśli wartością argumentu wiersz jest FAŁSZ, funkcja WYSZUKAJ.POZIOMO wyszuka dopasowanie dokładne. Jeśli nie zostanie ono znalezione, zostanie zwrócona wartość błędu #N/D!.

Spostrzeżenia

  • Jeśli funkcja WYSZUKAJ.POZIOMO nie może znaleźć wartości argumentu odniesienie, a wartością argumentu wiersz jest PRAWDA, to funkcja ta używa największej wartości mniejszej niż wartość argumentu odniesienie.
  • Jeśli argument odniesienie jest mniejszy od najmniejszej wartości w pierwszym wierszu tabeli tablica, to funkcja WYSZUKAJ.POZIOMO zwraca wartość błędu #N/D.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Osie | Łożyska | Śruby
4 | 4 | 9
5 | 7 | 10
6 | 8 | 11
Formuła | Opis (Wynik)
=WYSZUKAJ.POZIOMO("Osie";A1:C4;2;PRAWDA) | Wyszukuje wartość Osie w wierszu 1 i zwraca wartość z wiersza 2 tej samej kolumny. (4)
=WYSZUKAJ.POZIOMO("Łożyska";A1:C4;3;FAŁSZ) | Wyszukuje wartość Łożyska w wierszu 1 i zwraca wartość z wiersza 3 tej samej kolumny. (7)
=WYSZUKAJ.POZIOMO("B";A1:C4;3;PRAWDA) | Wyszukuje wartość B w wierszu 1 i zwraca wartość z wiersza 3 tej samej kolumny. Jako że B nie jest dokładnym odpowiednikiem, zostanie użyta następna największa wartość mniejsza niż B: Osie. (5)
=WYSZUKAJ.POZIOMO("Śruby";A1:C4;4) | Wyszukuje wartość Śruby w wierszu 1 i zwraca wartość z wiersza 4 tej samej kolumny. (11)
=WYSZUKAJ.POZIOMO(3;{1;2;3\"a";"b";"c"\"d";"e";"f"};2;PRAWDA) | Wyszukuje wartość 3 w pierwszym wierszu stałej tablicowej i zwraca wartość z wiersza 2 w tej samej kolumnie. (c)


ACOS

Zwraca arcus cosinus, czyli cosinus odwrotny liczby. Arcus cosinus jest to kąt, którego cosinus równy jest liczbie. Kąt jest zwracany w radianach z zakresu od 0 (zero) do pi.

Składnia

ACOS(liczba)

Liczba to cosinus obliczanego kąta i musi zawierać się w zakresie od -1 do 1.

Spostrzeżenia

Aby konwertować wynik z radianów na stopnie, pomnóż go przez wartość 180/PI() albo użyj funkcji STOPNIE.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ACOS(-0,5) | Arcus cosinus liczby -0,5 w radianach, 2*pi/3 (2,094395)
=ACOS(-0,5)*180/PI() | Arcus cosinus liczby -0,5 w stopniach (120)
=STOPNIE(ACOS(-0,5)) | Arcus cosinus liczby -0,5 w stopniach (120)


ACOSH

Zwraca odwrotny cosinus hiperboliczny liczby. Liczba musi być większa lub równa 1. Odwrotny cosinus hiperboliczny to wartość, której cosinus hiperboliczny jest liczbą, zatem wynik funkcji ACOSH(COSH(liczba)) jest równy liczbie.

Składnia

ACOSH(liczba)

Liczba to dowolna liczba rzeczywista większa lub równa 1.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ACOSH(1) | Odwrotny cosinus hiperboliczny liczby 1 (0)
=ACOSH(10) | Odwrotny cosinus hiperboliczny liczby 10 (2,993223)


ASIN

Zwraca arcus sinus, czyli odwrotny sinus liczby. Arcus sinus to kąt, którego sinus równy jest liczbie. Kąt jest zwracany w radianach i jest z zakresu -pi/2 do pi/2.

Składnia

ASIN(liczba)

Liczba to sinus obliczanego kąta i musi zawierać się w zakresie od -1 do 1.

Spostrzeżenia

Aby wyrazić arcus sinus w stopniach, pomnóż wynik przez 180/PI( ) albo użyj funkcji STOPNIE.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ASIN(-0,5) | Arcus sinus liczby -0,5 w radianach, -pi/6 (-0,5236)
=ASIN(-0,5)*180/PI() | Arcus sinus liczby -0,5 wyrażony w stopniach (-30)
=STOPNIE(ASIN(-0,5)) | Arcus sinus liczby -0,5 wyrażony w stopniach (-30)


ASINH

Zwraca odwrotny sinus hiperboliczny liczby. Odwrotny sinus hiperboliczny to wartość, której sinus hiperboliczny jest liczbą, zatem wynik funkcji ASINH(SINH(liczba)) jest równy liczbie.

Składnia

ASINH(liczba)

Liczba to dowolna liczba rzeczywista.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ASINH(-2,5) | Odwrotny sinus hiperboliczny liczby -2,5 (-1,64723)
=ASINH(10) | Odwrotny sinus hiperboliczny liczby 10 (2,998223)


ATAN

Zwraca arcus tangens, czyli odwrotny tangens liczby. Arcus tangens to kąt, którego tangens równy jest liczbie. Kąt jest zwracany w radianach i jest z zakresu -pi/2 do pi/2.

Składnia

ATAN(liczba)

Liczba to tangens obliczanego kąta.

Spostrzeżenia

Aby wyrazić arcus tangens w stopniach, pomnóż wynik przez 180/PI( ) albo użyj funkcji STOPNIE.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ATAN(1) | Arcus tangens liczby 1 w radianach, pi/4 (0,785398)
=ATAN(1)*180/PI() | Arcus tangens liczby 1 wyrażony w stopniach (45)
=STOPNIE(ATAN(1)) | Arcus tangens liczby 1 wyrażony w stopniach (45)


ATAN2

Zwraca arcus tangens, czyli odwrotny tangens określonych współrzędnych x- i y. Arcus tangens jest wartością kąta pomiędzy osią x a linią prostą poprowadzoną przez środek układu współrzędnych i punkt o współrzędnych (x_liczba;y_liczba). Wartość funkcji w radianach zawiera się w przedziale -pi, pi, z wyłączeniem wartości -pi.

Składnia

ATAN2(x_liczba ;y_liczba)

X_liczba to współrzędna x punktu.

Y_liczba to współrzędna y punktu.

Spostrzeżenia

  • Wynik dodatni odpowiada kątowi od osi x w kierunku przeciwnym do ruchu wskazówek zegara, a wynik ujemny odpowiada kierunkowi zgodnemu z ruchem wskazówek zegara.
  • ATAN2(a;b) jest równe ATAN(b/a), z wyjątkiem przypadku, gdy a jest równe 0 dla funkcji ATAN2.
  • Jeśli obydwie wartości x_liczba i y_liczba są równe 0, funkcja ATAN2 zwraca wartość błędu #DZIEL/0!.
  • Aby wyrazić arcus tangens w stopniach, pomnóż wynik przez 180/PI( ) albo użyj funkcji STOPNIE.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ATAN2(1; 1) | Arcus tangens punktu 1; 1 w radianach, pi/4 (0,785398)
=ATAN2(-1; -1) | Arcus tangens punktu -1; -1 w radianach, -3*pi/4 (-2,35619)
=ATAN2(-1; -1)*180/PI() | Arcus tangens punktu 1; 1 wyrażony w stopniach (-135)
=STOPNIE(ATAN2(-1; -1)) | Arcus tangens punktu 1; 1 wyrażony w stopniach (-135)


ATANH

Zwraca odwrotny tangens hiperboliczny liczby. Liczba musi mieć wartość z zakresu -1 do 1 (z wyjątkiem -1 i 1). Odwrotny tangens hiperboliczny to wartość, której tangens hiperboliczny jest równy liczbie; wynik funkcji ATANH(TANH(liczba)) jest równy liczbie.

Składnia

ATANH(liczba)

Liczba to dowolna liczba rzeczywista z zakresu 1 do -1.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ATANH(0,76159416) | Odwrotny tangens hiperboliczny liczby 0,76159416 (około 1)
=ATANH(-0,1) | Odwrotny tangens hiperboliczny liczby -0,1 (-0,10034)


COS

Zwraca wartość cosinusa danego kąta.

Składnia

COS(liczba)

Liczba to kąt w radianach, dla którego należy obliczyć cosinus.

Spostrzeżenia

Jeśli argument podany jest w stopniach, to należy go pomnożyć przez PI()/180 lub wykorzystać funkcję COS do konwertowania stopni na radiany.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=COS(1,047) | Cosinus 1,047 radiana (0,500171)
=COS(60*PI()/180) | Cosinus 60 stopni (0,5)
=COS(RADIANY(60)) | Cosinus 60 stopni (0,5)


COSH

Zwraca wartość cosinusa hiperbolicznego liczby.

Składnia

COSH(liczba)

Liczba to dowolna liczba rzeczywista, dla której ma być znaleziona wartość cosinusa hiperbolicznego.

Spostrzeżenia

Wzór cosinusa hiperbolicznego jest następujący:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=COSH(4) | Cosinus hiperboliczny liczby 4 (27,30823)
=COSH(EXP(1)) | Cosinus hiperboliczny podstawy logarytmu naturalnego (7,610125)


EXP

Zwraca wartość e podniesioną do potęgi liczba. Stała e jest równa 2,71828182845904, podstawie logarytmów naturalnych.

Składnia

EXP(liczba)

Liczba jest wykładnikiem potęgi o podstawie e.

Spostrzeżenia

  • W celu obliczenia potęg przy innych podstawach należy użyć operatora potęgowego (^).
  • Funkcja EXP jest funkcją odwrotną do funkcji LN, logarytmu naturalnego liczby.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=EXP(1) | Przybliżona wartość e (2,718282)
=EXP(2) | Podstawa logarytmu naturalnego e podniesiona do potęgi 2 (7,389056)


ILOCZYN

Funkcja mnoży wszystkie liczby podane jako argumenty i zwraca ich iloczyn.

Składnia

ILOCZYN(liczba1;liczba2;...)

Liczba1; liczba2; ... to od 1 do 30 liczb, które mają być pomnożone.

Spostrzeżenia

  • Obliczane są argumenty będące liczbami, wartościami logicznymi lub tekstowymi reprezentacjami liczb. Natomiast argumenty typu wartości błędów czy teksty, których nie można przekształcić na liczby, powodują błędy.
  • Jeśli argument jest tablicą lub odwołaniem, to obliczane będą wyłącznie liczby zawarte w danej tablicy czy odwołaniu. Pominięte zostaną puste komórki, wartości logiczne, tekst lub wartości błędów w tablicy lub odwołaniu.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
5
15
30
Formuła | Opis (Wynik)
=ILOCZYN(A2:A4) | Mnoży powyższe liczby (2250)
=ILOCZYN(A2:A4;2) | Mnoży powyższe liczby i liczbę 2 (4500)


KOMBINACJE

Zwraca liczbę kombinacji dla danej liczby obiektów. Funkcji KOMBINACJE należy używać, aby wyznaczyć możliwą liczbę grup dla danej liczby obiektów.

Składnia

KOMBINACJE(liczba;liczba_wybrana)

Liczba to liczba obiektów.

Liczba_wybrana to liczba obiektów w każdej kombinacji.

Spostrzeżenia

  • Argumenty liczbowe obcina się do liczb całkowitych.
  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja KOMBINACJE zwraca wartość błędu #WARTOŚĆ!.
  • Jeśli liczba < 0, liczba_wybrana < 0 lub liczba < liczba_wybrana, funkcja KOMBINACJE zwraca wartość błędu #LICZBA!.
  • Kombinacja jest dowolnym zbiorem lub podzbiorem obiektów niezależnie od ich wewnętrznego uporządkowania. Kombinacje różnią się tym od permutacji, dla których wewnętrzny porządek jest istotny.
  • Liczba kombinacji wyraża się następująco, gdzie liczba = n i liczba_wybrana = k:

    gdzie:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=KOMBINACJE(8;2) | Możliwa liczba zespołów dwuosobowych, które można sformować z 8 kandydatów (28)


LICZ.JEŻELI

Zlicza liczbę komórek wewnątrz zakresu, które spełniają podane kryteria.

Składnia

LICZ.JEŻELI(zakres;kryteria)

Zakres to zakres komórek, z którego mają być zliczane komórki.

Kryteria to kryteria w postaci liczby, wyrażenia lub tekstu, określające, które komórki będą zliczane. Na przykład argument kryteria można wyrazić jako 32, „32”, „>32”, „jabłka”.

Spostrzeżenia

Są także inne funkcje, które mogą być używane do analizowania danych na podstawie warunku. Na przykład, aby obliczyć sumę na podstawie ciągu tekstowego lub liczby w zakresie, należy zastosować funkcję arkusza kalkulacyjnego SUMA.JEŻELI. Aby formuła zwracała jedną z dwóch wartości na podstawie warunku, takiego jak premia od sprzedaży na podstawie określonej wartości sprzedaży, należy użyć funkcji arkusza kalkulacyjnego JEŻELI.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Dane
jabłka | 32
pomarańcze | 54
brzoskwinie | 75
jabłka | 86
Formuła | Opis (Wynik)
=LICZ.JEŻELI(A2:A5;"jabłka") | Liczba komórek zawierających jabłka w pierwszej kolumnie powyżej (2)
=LICZ.JEŻELI(B2:B5;">55") | Liczba komórek zawierających wartość większą niż 55 w drugiej kolumnie powyżej (2)


LICZBA.CAŁK

Funkcja obcina liczbę do liczby całkowitej usuwając jej część ułamkową.

Składnia

LICZBA.CAŁK(liczba;liczba_cyfr)

Liczba jest liczbą, która ma być obcięta.

Liczba_cyfr jest liczbą określającą dokładność obcinania. Wartością domyślną argumentu liczba_cyfr jest zero.

Spostrzeżenia

Funkcje LICZBA.CAŁK i ZAOKR.DO.CAŁK są podobne, ponieważ obie zwracają liczby całkowite. Funkcja LICZBA.CAŁK usuwa ułamkową część liczby. Funkcja ZAOKR.DO.CAŁK zaokrągla liczbę w dół do najbliższej liczby całkowitej, na podstawie wartości ułamkowej części liczby. Funkcje LICZBA.CAŁK i ZAOKR.DO.CAŁK różnią się tylko pod względem operacji wykonywanych na liczbach ujemnych: funkcja LICZBA.CAŁK(-4.3) zwraca -4, lecz funkcja ZAOKR.DO.CAŁK(-4.3) zwraca -5, ponieważ liczba -5 jest mniejszą liczbą.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=LICZBA.CAŁK(8,9) | Część całkowita liczby 8,9 (8)
=LICZBA.CAŁK(-8,9) | Część całkowita liczby -8,9 (-8)
=LICZBA.CAŁK(PI()) | Część całkowita liczby pi (3)


LN

Zwraca wartość logarytmu naturalnego liczby. Podstawą logarytmów naturalnych jest stała e (2,71828182845904).

Składnia

LN(liczba)

Liczba to liczba rzeczywista dodatnia, której logarytm naturalny należy obliczyć.

Spostrzeżenia

LN jest funkcją odwrotną do funkcji EXP.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=LN(86) | Logarytm naturalny liczby 86 (4,454347)
=LN(2,7182818) | Logarytm naturalny wartości stałej e (1)
=LN(EXP(3)) | Logarytm naturalny wartości e podniesionej do potęgi 3 (3)


LOG

Zwraca wartość logarytmu liczby przy określonej podstawie.

Składnia

LOG(liczba;podstawa)

Liczba to dodatnia liczba rzeczywista, której logarytm należy obliczyć.

Podstawa to podstawa logarytmu. Jeśli argument podstawa zostanie pominięty, domyślnie przyjmuje się 10.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=LOG(10) | Logarytm liczby 10 (1)
=LOG(8; 2) | Logarytm liczby 8 przy podstawie 2 (3)
=LOG(86; 2,7182818) | Logarytm liczby 86 przy podstawie e (4,454347)


LOG10

Zwraca wartość logarytmu liczby przy podstawie 10.

Składnia

LOG10(liczba)

Liczba to dodatnia liczba rzeczywista, której logarytm przy podstawie 10 należy wyznaczyć.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=LOG10(86) | Logarytm dziesiętny liczby 86 (1,934498451)
=LOG10(10) | Logarytm dziesiętny liczby 10 (1)
=LOG10(1E5) | Logarytm dziesiętny liczby 1E5 (5)
=LOG10(10^5) | Logarytm dziesiętny liczby 10^5 (5)


LOS

Zwraca liczbę losową o równomiernym rozkładzie, która jest większa niż lub równa 0 i mniejsza od 1. Po każdym obliczeniu arkusza otrzymuje się nową liczbę losową.

Składnia

LOS( )

Spostrzeżenia

  • Aby wygenerować losową liczbę rzeczywistą z przedziału od a do b, należy użyć następującego wzoru:

    LOS()*(b-a)+a

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=LOS() | Liczba losowa z zakresu od 0 do 1 (zmienia się)
=LOS()*100 | Liczba losowa większa niż lub równa 0, lecz mniejsza niż 100 (zmienia się)


MACIERZ.ILOCZYN

Zwraca iloczyn macierzowy dwu tablic. Wynik jest tablicą o takiej samej liczbie wierszy jak tablica1 i takiej samej liczbie kolumn jak tablica2.

Składnia

MACIERZ.ILOCZYN(tablica1;tablica2)

Tablica1; tablica2 to tablice, które należy przemnożyć.

Spostrzeżenia

  • Liczba kolumn w argumencie tablica1 musi być taka sama jak liczba wierszy w argumencie tablica2, obydwie tablice mogą zawierać jedynie liczby.

  • Tablica1 i tablica2 mogą podane jako zakresy komórek, stałe tablicowe lub odwołania.
  • Jeśli którakolwiek z komórek jest pusta lub zawiera tekst albo liczba kolumn w tablica1 różni się od liczby wierszy w tablica2, funkcja MACIERZ.ILOCZYN zwraca wartość błędu #ARG!.
  • Tablica zawierająca iloczyn macierzowy a dwóch tablic b i c jest równa:

    gdzie i jest liczbą wierszy a j jest liczbą kolumn.

  • Formuły, które zwracają tablice, muszą być wprowadzone jako formuły tablicowe.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Tablica 1 | Tablica 1
1 | 3
7 | 2
Tablica 2 | Tablica 2
2 | 0
0 | 2
Formuła | Formuła
=MACIERZ.ILOCZYN(A2:B3;A5:B6) |

Uwaga Formuła w przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego wybierz zakres A8:B9 poczynając od komórki formuły. Naciśnij klawisz F2, a następnie naciśnij klawisze CTRL+SHIFT+ENTER. Jeżeli formuła nie jest wprowadzona jako formuła tablicowa, jedynym wynikiem będzie liczba 2.

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Tablica 1 | Tablica 1
3 | 0
2 | 0
Tablica 2 | Tablica 2
2 | 0
0 | 2
Formuła | Formuła
=MACIERZ.ILOCZYN(A2:B3;A5:B6) |

Uwaga Formuła w przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego wybierz zakres A8:B9 poczynając od komórki formuły. Naciśnij klawisz F2, a następnie naciśnij klawisze CTRL+SHIFT+ENTER. Jeżeli formuła nie jest wprowadzona jako formuła tablicowa, jedynym wynikiem będzie liczba 2.


MACIERZ.ODW

Zwraca macierz odwrotną do macierzy przechowywanej w tablicy.

Składnia

MACIERZ.ODW(tablica)

Tablica to tablica numeryczna z jednakową liczbą wierszy i kolumn.

Spostrzeżenia

  • Tablica może być podana jako zakres komórek, na przykład A1:C3; jako stała tablicowa {1;2;3\4;5;6\7;8;9} lub jako nazwa dowolnej z tych dwóch.

  • Jeśli którakolwiek z komórek tablicy jest pusta lub zawiera tekst, funkcja MACIERZ.ODW zwraca wartość błędu #ARG!.

  • Funkcja MACIERZ.ODW także zwraca wartość błędu #ARG!, jeśli tablica nie ma równej liczby wierszy i kolumn.

  • Formuły, które zwracają tablice, muszą być wprowadzone jako formuły tablicowe.
  • Macierzy odwrotnych, podobnie jak wyznaczników używa się zwykle do rozwiązywania układów równań matematycznych wielu zmiennych. Iloczyn macierzy i jej odwrotności jest macierzą jednostkową —macierzą kwadratową, której elementy diagonalne są równe 1, a wszystkie pozostałe są równe 0.
  • Na przykład, aby obliczyć dwuwierszową, dwukolumnową macierz załóżmy, że zakres A1:B2 zawiera litery a, b, c i d reprezentujące dowolne liczby. Poniższa tablica pokazuje odwrotność macierzy A1:B2:
    Kolumna A | Kolumna B
    Wiersz 1 | d/(a*d-b*c) | b/(b*c-a*d)
    Wiersz 2 | c/(b*c-a*d) | a/(a*d-b*c)
  • Funkcja MACIERZ.ODW jest obliczana z dokładnością do około 16 cyfr, co może prowadzić do niewielkich błędów numerycznych, jeśli nie wystąpi ich pełna kompensacja.
  • Niektórych macierzy kwadratowych nie da się odwrócić, a wtedy funkcja MACIERZ.ODW zwraca wartość błędu #LICZBA!. Wyznacznik macierzy nieodwracalnej jest równy 0.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Dane
4 | -1
2 | 0
Formuła | Formuła
=MACIERZ.ODW(A2:B3) |

Uwaga Formuła w przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego wybierz zakres A5:B6 poczynając od komórki formuły. Naciśnij klawisz F2, a następnie naciśnij klawisze CTRL+SHIFT+ENTER. Jeżeli formuła nie jest wprowadzona jako formuła tablicowa, jedynym wynikiem będzie liczba 0.

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Dane | Dane
1 | 2 | 1
3 | 4 | -1
0 | 2 | 0
Formuła | Formuła | Formuła
=MACIERZ.ODW(A2:C4) |  |

Uwaga Formuła w przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego wybierz zakres A6:C8 poczynając od komórki formuły. Naciśnij klawisz F2, a następnie naciśnij klawisze CTRL+SHIFT+ENTER. Jeżeli formuła nie jest wprowadzona jako formuła tablicowa, jedynym wynikiem będzie liczba 0,25.

Porada

W celu uzyskania dostępu do pojedynczych elementów macierzy odwrotnej należy używać funkcji INDEKS.


MOD

Zwraca wartość reszty po podzieleniu liczby przez dzielnik. Wynik ma taki sam znak jak dzielnik.

Składnia

MOD(liczba;dzielnik)

Liczba to liczba, dla której należy wyznaczyć resztę.

Dzielnik to liczba, przez którą ma być podzielona liczba.

Spostrzeżenia

  • Jeśli dzielnik jest równy 0, funkcja MOD zwraca wartość błędu #DZIEL/0!.

  • Funkcja MOD może być wyrażona za pomocą funkcji ZAOKR.DO.CAŁK:

    MOD(n, d) = n — d*INT(n/d)

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=MOD(3; 2) | Reszta z dzielenia 3/2. (1)
=MOD(-3; 2) | Reszta z dzielenia -3/2. Znak jest taki sam jak znak dzielnika. (1)
=MOD(3; -2) | Reszta z dzielenia 3/-2. Znak jest taki sam jak znak dzielnika. (-1)
=MOD(-3; -2) | Reszta z dzielenia -3/-2. Znak jest taki sam jak znak dzielnika. (-1)


MODUŁ.LICZBY

Zwraca wartość bezwzględną liczby. Wartością bezwzględną liczby jest liczba bez znaku.

Składnia

MODUŁ.LICZBY(liczba)

Liczba to liczba rzeczywista, której wartość bezwzględną należy obliczyć.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
-4
Formuła | Opis (Wynik)
=MODUŁ.LICZBY(2) | Wartość bezwzględna liczby 2 (2)
=MODUŁ.LICZBY(-2) | Wartość bezwzględna liczby -2 (2)
=MODUŁ.LICZBY(A2) | Wartość bezwzględna liczby -4 (4)


PI

Funkcja zwraca liczbę 3,14159265358979, czyli stałą matematyczną pi, z dokładnością do 15 cyfr.

Składnia

PI( )

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Promień
3
Formuła | Opis (Wynik)
=PI() | Pi (3,14159265358979)
=PI()/2 | Pi/2 (1,570796327)
=PI()*(A2^2) | Powierzchnia koła o powyższym promieniu (28,27433388)


PIERWIASTEK

Zwraca dodatni pierwiastek kwadratowy liczby.

Składnia

PIERWIASTEK(liczba)

Liczba to liczba, dla której obliczany będzie pierwiastek.

Spostrzeżenia

Jeśli argument ma wartość ujemną, funkcja PIERWIASTEK podaje w wyniku wartość błędu #LICZBA!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
-16
Formuła | Opis (Wynik)
=PIERWIASTEK(16) | Pierwiastek kwadratowy liczby 16 (4)
=PIERWIASTEK(A2) | Pierwiastek kwadratowy powyższej liczby. Ponieważ liczba jest ujemna, zwracany jest błąd (#LICZBA!)
=PIERWIASTEK(MODUŁ.LICZBY(A2)) | Pierwiastek kwadratowy modułu powyższej liczby (4)


POTĘGA

Zwraca wartość liczby podniesionej do potęgi.

Składnia

POTĘGA(liczba;potęga)

Liczba to podstawa potęgi. Może to być dowolna liczba rzeczywista.

Potęga to wykładnik potęgi, do której jest podnoszona podstawa.

Spostrzeżenia

Aby wskazać, do której potęgi ma być podniesiona podstawa, zamiast funkcji POTĘGA można używać operatora "^", na przykład w 5^2.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=POTĘGA(5;2) | Kwadrat liczby 5 (25)
=POTĘGA(98,6;3,2) | Liczba 98,6 podniesiona do potęgi 3,2 (2401077)
=POTĘGA(4;5/4) | Liczba 4 podniesiona do potęgi 5/4 (5,656854)


RADIANY

Zamienia stopnie na radiany.

Składnia

RADIANY(kąt)

Kąt to kąt podany w stopniach, które należy zamienić.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=RADIANY(270) | Kąt 270 stopni, wyrażony w radianach (4,712389 lub 3π/2 radianów)


RZYMSKIE

Zamienia cyfry arabskie na rzymskie, jako tekst.

Składnia

RZYMSKIE(liczba;forma)

Liczba zapisana w systemie cyfr arabskich, którą należy zamienić.

Forma jest liczbą określającą wybrany rodzaj cyfr rzymskich. Numeracja rzymska zmienia się od klasycznej do bardziej uproszczonej, forma ta staje się coraz bardziej zwarta, gdy jej wartość rośnie. Patrz poniższy przykład, wg RZYMSKIE(499;0).

Forma | Rodzaj
0 lub jest pominięty | Klasyczny.
1 | Bardziej zwarta. Patrz przykład poniżej.
2 | Bardziej zwarta. Patrz przykład poniżej.
3 | Bardziej zwarta. Patrz przykład poniżej.
4 | Uproszczony.
PRAWDA | Klasyczny.
FAŁSZ | Uproszczony.

Spostrzeżenia

  • Jeśli liczba jest ujemna, to funkcja zwróci wartość błędu #WARTOŚĆ!.
  • Jeśli liczba jest większa od 3999, to funkcja zwróci wartość błędu #WARTOŚĆ!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=RZYMSKIE(499;0) | Liczba 499 zapisana w klasycznym stylu rzymskim (CDXCIX)
=RZYMSKIE(499;1) | Liczba 499 zapisana w bardziej zwartym stylu rzymskim (LDVLIV)
=RZYMSKIE(499;2) | Liczba 499 zapisana w bardziej zwartym stylu rzymskim (XDIX)
=RZYMSKIE(499;3) | Liczba 499 zapisana w bardziej zwartym stylu rzymskim (VDIV)
=RZYMSKIE(499;4) | Liczba 499 zapisana w bardziej zwartym stylu rzymskim (ID)
=RZYMSKIE(2013;0) | Liczba 2013 zapisana w klasycznym stylu rzymskim (MMXIII)


SILNIA

Zwraca wartość silni liczby. Silnia liczby jest równa 1*2*3*...* liczba.

Składnia

SILNIA(liczba)

Liczba to nieujemna liczba, której silnię należy obliczyć. Jeśli liczba nie jest liczbą całkowitą, jej wartość zostanie obcięta.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=SILNIA(5) | Silnia liczby 5 lub 1*2*3*4*5 (120)
=SILNIA(1,9) | Silnia części całkowitej liczby 1,9 (1)
=SILNIA(0) | Silnia liczby 0 (1)
=SILNIA(-1) | Liczby ujemne powodują wyświetlenie wartości błędu (#LICZBA!)
=SILNIA(1) | Silnia liczby 1 (1)


SIN

Zwraca sinus danego kąta.

Składnia

SIN(liczba)

Liczba jest kątem wyrażonym w radianach, dla którego obliczany będzie sinus.

Spostrzeżenia

Jeśli argument podany jest w stopniach, to należy go pomnożyć przez PI()/180 lub wykorzystać funkcję RADIANY do konwertowania stopni na radiany.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=SIN(PI()) | Funkcja sinus kąta pi radianów (w przybliżeniu 0)
=SIN(PI()/2) | Funkcja sinus kąta pi/2 radianów (1)
=SIN(30*PI()/180) | Funkcja sinus kąta 30 stopni (0,5)
=SIN(RADIANY(30)) | Funkcja sinus kąta 30 stopni (0,5)


SINH

Zwraca sinus hiperboliczny danej liczby.

Składnia

SINH(liczba)

Liczba to dowolna liczba rzeczywista.

Spostrzeżenia

Sinus hiperboliczny jest określony wzorem:

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=SINH(1) | Sinus hiperboliczny liczby 1 (1,175201194)
=SINH(-1) | Sinus hiperboliczny liczby -1 (-1,175201194)

Przykład 2

Z funkcji tej korzysta się, aby aproksymować funkcję łącznego rozkładu prawdopodobieństwa. Niech wartości w teście laboratoryjnym należą do przedziału od 0 do 10 sekund. Analiza empiryczna eksperymentu pokazuje, że prawdopodobieństwo uzyskania rezultatu x, mniejszego niż t sekund jest aproksymowane następującym równaniem:

P(x<t) = 2,868 * SINH(0,0342 * t), gdzie 0<t<10

Aby obliczyć prawdopodobieństwo uzyskania wyniku mniejszego niż 1,03 sekundy, należy za t podstawić wartość 1,03.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=2,868*SINH(0,0342*1,03) | Prawdopodobieństwo uzyskania wyniku mniejszego niż 1,03 sekundy (0,101049063)

Można oczekiwać, że wynik ten wystąpi około 101 razy dla każdego tysiąca doświadczeń.


STOPNIE

Przekształca radiany na stopnie.

Składnia

STOPNIE(kąt)

Kąt to wyrażony w radianach kąt, który ma być przekształcony.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=STOPNIE(PI()) | Pi radianów wyrażone w stopniach (180)


SUMA

Dodaje wszystkie liczby w zakresie komórek.

Składnia

SUMA(liczba1;liczba2;...)

Liczba1,liczba2,... to od 1 do 30 argumentów, które mają być zsumowane.

Spostrzeżenia

  • Obliczane są liczby, wartości logiczne i tekstowe reprezentacje liczb, które zostaną bezpośrednio wpisane do listy argumentów. Zobacz pierwszy i drugi przykład poniżej.
  • Jeśli argument jest tablicą lub odwołaniem, to sumy obliczane są tylko w tej tablicy lub adresie. Znajdujące się w tablicy lub odwołaniu puste komórki, wartości logiczne, tekst lub wartości błędów zostaną pominięte. Ilustruje to trzeci z poniższych przykładów.
  • Argumenty, które są wartościami błędów lub tekstem, których nie można przekształcić, powodują występowanie błędów.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
-5
15
30
'5
PRAWDA
Formuła | Opis (Wynik)
=SUMA(3; 2) | Dodaje liczby 3 i 2 (5)
=SUMA("5"; 15; PRAWDA) | Dodaje liczby 5, 15 i 1, ponieważ wartości tekstowe są przekształcane na liczby, a wartość logiczna PRAWDA jest przekształcana na liczbę 1 (21)
=SUMA(A2:A4) | Dodaje trzy pierwsze liczby w powyższej kolumnie (40)
=SUMA(A2:A4; 15) | Dodaje trzy pierwsze liczby w powyższej kolumnie i liczbę 15 (55)
=SUMA(A5;A6; 2) | Dodaje wartości umieszczone w dwóch ostatnich wierszach powyżej oraz liczbę 2. Ponieważ wartości nieliczbowe w odwołaniach nie są przekształcane, wartości w kolumnie powyżej są ignorowane (2)


SUMA.ILOCZYNÓW

Funkcja mnoży odpowiadające sobie elementy w danych tablicach i zwraca sumę tych iloczynów.

Składnia

SUMA.ILOCZYNÓW(tablica1;tablica2;tablica3;...)

Tablica1; tablica2; tablica3; ... to od 2 do 30 tablic, których elementy mają być pomnożone i dodane.

Spostrzeżenia

  • Argumenty tablic muszą mieć takie same wymiary. W przeciwnym wypadku funkcja SUMA.ILOCZYNÓW zwraca wartość błędu #WARTOŚĆ!.
  • Elementy tablic, które nie są liczbami, funkcja SUMA.ILOCZYNÓW traktuje jako równe zero.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Tablica 1 | Tablica 1 | Tablica 2 | Tablica 2
3 | 4 | 2 | 7
8 | 6 | 6 | 7
1 | 9 | 5 | 3
Formuła | Opis (Wynik)
=SUMA.ILOCZYNÓW(A2:B4; C2:D4) | Mnoży wszystkie elementy dwóch tablic, a następnie dodaje iloczyny — to znaczy wykonuje następujące obliczenia: 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3. (156)

Uwaga W poprzednim przykładzie zwracany jest ten sam wynik, który jest zwracany przez formułę SUMA(A2:B4*C2:D4) wprowadzoną jako tablica. Użycie tablic zapewnia bardziej ogólne rozwiązanie przy wykonywaniu operacji podobnych do funkcji SUMA.ILOCZYNÓW. Na przykład można obliczyć sumę kwadratów elementów w zakresie A2:B4 stosując formułę =SUMA(A2:B4^2) i naciskając klawisze CTRL+SHIFT+ENTER.


SUMA.JEŻELI

Sumuje komórki spełniające podane kryteria.

Składnia

SUMA.JEŻELI(zakres;kryteria;suma_zakres)

Zakres jest zakresem komórek, które mają być obliczone.

Kryteria są to kryteria w postaci liczby, wyrażenia lub tekstu określające, które komórki będą sumowane. Na przykład, kryteria można wyrazić jako 32, „32”, „>32” i „jabłka”.

Suma_zakres to komórki przewidziane do zsumowania.

Spostrzeżenia

  • Komórki w suma_zakres są sumowane tylko wtedy, jeśli odpowiadające im komórki w zakresie spełniają kryterium.

  • Jeśli argument suma_zakres zostanie pominięty, to sumowane są komórki w zakresie.

  • Dostępne są także inne funkcje, które można stosować do analizowania danych na podstawie warunków. Na przykład, aby zliczyć liczbę wystąpień ciągu tekstowego lub liczby w zakresie komórek, należy zastosować funkcję LICZ.JEŻELI. Aby formuła zwracała jedną z dwóch wartości na podstawie warunku, taką jak premię od sprzedaży na podstawie określonej wartości sprzedaży, należy zastosować funkcję JEŻELI.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Wartość własności | Prowizja
100 000 | 7 000
200 000 | 14 000
300 000 | 21 000
400 000 | 28 000
Formuła | Opis (Wynik)
=SUMA.JEŻELI(A2:A5;">160000";B2:B5) | Sumuje prowizje od wartości własności powyżej 160 000 (63 000)


SUMA.KWADRATÓW

Zwraca sumę kwadratów argumentów.

Składnia

SUMA.KWADRATÓW(liczba1;liczba2;...)

Liczba1; liczba2; ... to od 1 do 30 argumentów, których sumę kwadratów należy obliczyć. Zamiast argumentów rozdzielonych średnikami można także stosować pojedynczą tablicę lub odwołanie do tablicy.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=SUMA.KWADRATÓW(3; 4) | Suma kwadratów liczb 3 i 4 (25)


SUMA.X2.M.Y2

Zwraca sumę różnic kwadratów odpowiadających sobie wartości w dwóch tablicach.

Składnia

SUMA.X2.M.Y2(tablica_x;tablica_y)

Tablica_x to pierwsza tablica lub zakres wartości.

Tablica_y to druga tablica lub zakres wartości.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami lub odwołaniami zawierającymi liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeśli argumenty tablica_x i tablica_y mają różne liczby wartości, to funkcja SUMA.X2.M.Y2 zwraca wartość błędu #N/D.
  • Równanie sumy różnicy kwadratów ma postać:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Pierwsza tablica | Druga tablica
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
7 | 4
5 | 4
Formuła | Opis (Wynik)
=SUMA.X2.M.Y2(A2:A8;B2:B8) | Suma różnic kwadratów dwóch powyższych tablic (-55)
=SUMA.X2.M.Y2({2; 3; 9; 1; 8; 7; 5};{6; 5; 11; 7; 5; 4; 4}) | Suma różnic kwadratów dwóch tablic stałych (-55)


SUMA.X2.P.Y2

Zwraca sumę sum kwadratów odpowiadających sobie wartości w dwóch tablicach. Suma sum kwadratów występuje często jako składnik w wielu obliczeniach statystycznych.

Składnia

SUMA.X2.P.Y2(tablica_x;tablica_y)

Tablica_x to pierwsza tablica lub zakres wartości.

Tablica_y to druga tablica lub zakres wartości.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami lub odwołaniami zawierającymi liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeśli argumenty tablica_x i tablica_y mają różne liczby wartości, to funkcja SUMA.X2.P.Y2 zwraca wartość błędu #N/D.
  • Równanie sumy sum kwadratów ma postać:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Pierwsza tablica | Druga tablica
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
7 | 4
5 | 4
Formuła | Opis (Wynik)
=SUMA.X2.P.Y2(A2:A8;B2:B8) | Suma sum kwadratów dwóch powyższych tablic (521)
=SUMA.X2.P.Y2({2; 3; 9; 1; 8; 7; 5};{6; 5; 11; 7; 5; 4; 4}) | Suma sum kwadratów dwóch tablic stałych (521)


SUMA.XMY.2

Zwraca sumę kwadratów różnic odpowiadających sobie wartości w dwóch tablicach.

Składnia

SUMA.XMY.2(tablica_x;tablica_y)

Tablica_x to pierwsza tablica lub zakres wartości.

Tablica_y to druga tablica lub zakres wartości.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami lub odwołaniami zawierającymi liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeśli argumenty tablica_x i tablica_y mają różne ilości wartości, to funkcja SUMA.XMY.2 zwraca wartość błędu #N/D!.
  • Równanie sumy kwadratów różnic ma postać:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Pierwsza tablica | Druga tablica
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
7 | 4
5 | 4
Formuła | Opis (Wynik)
=SUMA.XMY.2(A2:A8;B2:B8) | Suma kwadratów różnic dwóch powyższych tablic (79)
=SUMA.XMY.2({2; 3; 9; 1; 8; 7; 5};{6; 5; 11; 7; 5; 4; 4}) | Suma kwadratów różnic dwóch tablic stałych (79)


SUMY.POŚREDNIE

Zwraca sumę pośrednią w liście lub bazie danych. Po utworzeniu listy sumy pośredniej można ją modyfikować edytując funkcję SUMY.POŚREDNIE.

Składnia

SUMY.POŚREDNIE(funkcja_nr;odwołanie1;odwołanie2;...)

Funkcja_nr to liczba od 1 do 11 określająca, która funkcja ma być użyta do obliczania sum pośrednich na liście.

Funkcja_nr | Funkcja
1 | ŚREDNIA
2 | Liczba
3 | ILE.NIEPUSTYCH
4 | MAKS
5 | MIN
6 | Nabiał
7 | ODCH.STANDARDOWE
8 | ODCH.STANDARD.POPUL
9 | SUMA
10 | WARIANCJA
11 | WARIANCJA.POPUL

Odwołanie1; odwołanie2, ... to od 1 do 29 zakresów lub odwołań dla których ma być obliczona suma pośrednia.

Spostrzeżenia

  • Jeśli wewnątrz odwołań odwołanie1, odwołanie2, ... znajdują się inne sumy pośrednie (lub zagnieżdżone sumy pośrednie), to te zagnieżdżone sumy są ignorowane, aby uniknąć podwójnego obliczania.
  • Funkcja SUMY.POŚREDNIE zignoruje wszystkie ukryte wiersze, które powstają na filtrowanej liście. Jest to ważne, gdy chcemy zsumować tylko widoczne dane, powstające na filtrowanej liście.
  • Jeśli jakiś odwołanie z listy jest odwołaniem 3-W, funkcja SUMY.POŚREDNIE zwraca wartość błędu #WARTOŚĆ!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
120
10
150
23
Formuła | Opis (Wynik)
=SUMY.POŚREDNIE(9;A2:A5) | Suma pośrednia powyższej kolumny obliczona za pomocą funkcji SUMA (303)
=SUMY.POŚREDNIE(1;A2:A5) | Suma pośrednia powyższej kolumny obliczona za pomocą funkcji ŚREDNIA (75,75)


TAN

Funkcja zwraca tangens danego kąta.

Składnia

TAN(liczba)

Liczba jest to kąt wyrażony w radianach, dla którego ma być obliczany tangens.

Spostrzeżenia

Jeśli argument podany jest w stopniach, to należy go pomnożyć przez PI()/180 lub wykorzystać funkcję RADIANY do konwertowania stopni na radiany.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=TAN(0,785) | Tangens kąta 0,785 radiana (0,99920)
=TAN(45*PI()/180) | Tangens kąta 45 stopni (1)
=TAN(RADIANY(45)) | Tangens kąta 45 stopni (1)


TANH

Zwraca tangens hiperboliczny liczby.

Składnia

TANH(liczba)

Liczba to dowolna liczba rzeczywista.

Spostrzeżenia

Tangens hiperboliczny wyrażony jest wzorem:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=TANH(-2) | Tangens hiperboliczny liczby -2 (-0,96403)
=TANH(0) | Tangens hiperboliczny liczby 0 (0)
=TANH(0,5) | Tangens hiperboliczny liczby 0,5 (0,462117)


WYZNACZNIK.MACIERZY

Zwraca wartość wyznacznika macierzy tablicy.

Składnia

WYZNACZNIK.MACIERZY(tablica)

Tablica to tablica numeryczna z jednakową liczbą wierszy i kolumn.

Spostrzeżenia

  • Tablica może być podana jako zakres komórek; na przykład A1:C3; jako stała tablicowa stałych taka jak {1;2;3\4;5;6\7;8;9}; lub jako nazwa dowolnej z tych dwóch.

  • Jeśli którakolwiek z komórek tablicy jest pusta lub zawiera tekst, funkcja WYZNACZNIK.MACIERZY zwraca wartość błędu #ARG!.

  • Funkcja WYZNACZNIK.MACIERZY także zwraca wartość błędu #ARG!, jeśli liczba wierszy i kolumn tablicy nie jest równa.

  • Wyznacznik macierzy jest liczbą wyznaczoną na podstawie wartości tablicy. Wyznacznik trzywierszowej i trzykolumnowej tablicy A1:C3, definiuje się następująco:

    WYZNACZNIK.MACIERZY(A1:C3) jest równy
    A1*(B2*C3-B3*C2) + A2*(B3*C1-B1*C3) + A3*(B1*C2-B2*C1)

  • Wyznaczników macierzy używa się zwykle do rozwiązywania układów równań wielu zmiennych.
  • Funkcja WYZNACZNIK.MACIERZY jest obliczana z dokładnością do około 16 cyfr, co może powodować niewielkie błędy numeryczne, gdy obliczenie jest niezupełne. Na przykład wyznacznik macierzy osobliwej może się różnić od zera o 1E-16.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Dane | Dane | Dane
1 | 3 | 8 | 5
1 | 3 | 6 | 1
1 | 1 | 1 | 0
7 | 3 | 10 | 2
Formuła | Opis (Wynik)
=WYZNACZNIK.MACIERZY(A2:D5) | Wyznacznik powyższej macierzy (88)
=WYZNACZNIK.MACIERZY({3;6;1\1;1;0\3;10;2}) | Wyznacznik macierzy jako stałej tablicowej (1)
=WYZNACZNIK.MACIERZY({3;6\1;1}) | Wyznacznik macierzy jako stałej tablicowej (-3)
=WYZNACZNIK.MACIERZY({1;3;8;5\1;3;6;1}) | Zwraca błąd, ponieważ tablica ma niejednakową liczbę wierszy i kolumn (#ARG!)


ZAOKR

Część zawartości tego tematu może nie mieć zastosowania w przypadku niektórych języków.

Zaokrągla liczbę do określonej liczby cyfr.

Składnia

ZAOKR(liczba;liczba_cyfr)

Liczba jest liczbą, która ma być zaokrąglona.

Liczba_cyfr określa liczbę cyfr, do których ma być zaokrąglona liczba.

Spostrzeżenia

  • Jeśli argument liczba_cyfr jest większy od zera, to liczba jest zaokrąglona do wybranej liczby cyfr po przecinku.
  • Jeśli argument liczba_cyfr wynosi zero, to liczba jest zaokrąglana do najbliższej liczby całkowitej.
  • Jeśli argument liczba_cyfr jest mniejszy od 0, wtedy liczba jest zaokrąglana do lewej strony przecinka dziesiętnego.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ZAOKR(2,15; 1) | Zaokrągla liczbę 2,15 do jednego miejsca dziesiętnego (2,2)
=ZAOKR(2,149; 1) | Zaokrągla liczbę 2,149 do jednego miejsca dziesiętnego (2,1)
=ZAOKR(-1,475; 2) | Zaokrągla liczbę -1,475 do dwóch miejsc dziesiętnych (-1,48)
=ZAOKR(21,5; -1) | Zaokrągla liczbę 21,5 do jednego miejsca dziesiętnego po lewej stronie przecinka (20)


ZAOKR.DO.CAŁK

Zaokrągla liczbę w dół do najbliższej liczby całkowitej.

Składnia

ZAOKR.DO.CAŁK(liczba)

Liczba to liczba rzeczywista, którą należy zaokrąglić w dół do liczby całkowitej.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
19,5
Formuła | Opis (Wynik)
=ZAOKR.DO.CAŁK(8,9) | Zaokrągla 8,9 w dół (8)
=ZAOKR.DO.CAŁK(-8,9) | Zaokrągla -8,9 w dół (-9)
=A2-ZAOKR.DO.CAŁK(A2) | Zwraca część dziesiętną dodatniej liczby rzeczywistej w komórce A2 (0,5)


ZAOKR.DO.NPARZ

Zwraca wartość liczby zaokrągloną w górę do najbliższej nieparzystej liczby całkowitej.

Składnia

ZAOKR.DO.NPARZ(liczba)

Liczba to wartość do zaokrąglenia.

Spostrzeżenia

  • Jeśli liczba nie jest liczbą, funkcja ZAOKR.DO.NPARZ zwraca wartość błędu #ARG!.
  • Niezależnie od znaku liczby, wartość podlega zaokrągleniu w kierunku dalszym od zera. Jeśli liczba jest nieparzystą liczbą całkowitą, nie zachodzi żadne zaokrąglenie.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ZAOKR.DO.NPARZ(1,5) | Zaokrągla liczbę 1,5 w górę do najbliższej liczby całkowitej nieparzystej (3)
=ZAOKR.DO.NPARZ(3) | Zaokrągla liczbę 3 w górę do najbliższej liczby całkowitej nieparzystej (3)
=ZAOKR.DO.NPARZ(2) | Zaokrągla liczbę 2 w górę do najbliższej liczby całkowitej nieparzystej (3)
=ZAOKR.DO.NPARZ(-1) | Zaokrągla liczbę -1 w górę do najbliższej liczby całkowitej nieparzystej (-1)
=ZAOKR.DO.NPARZ(-2) | Zaokrągla liczbę -2 w górę do najbliższej liczby całkowitej nieparzystej (-3)


ZAOKR.DO.PARZ

Zwraca wartość liczby zaokrąglonej do najbliższej parzystej liczby całkowitej. Funkcję tę należy stosować do przetwarzania obiektów występujących parami. Na przykład opakowanie pozwala na ułożenie jednego lub dwu przedmiotów. Opakowanie jest wypełnione, gdy liczba przedmiotów, zaokrąglona do najbliższej parzystej, zgadza się z jego pojemnością.

Składnia

ZAOKR.DO.PARZ(liczba)

Liczba to wartość do zaokrąglenia.

Spostrzeżenia

  • Jeśli argument liczba nie jest liczbą, funkcja ZAOKR.DO.PARZ zwraca wartość błędu #WARTOŚĆ!.
  • Niezależnie od znaku liczby, wartość podlega zaokrągleniu w kierunku dalszym od zera. Jeśli liczba jest parzystą liczbą całkowitą zaokrąglanie nie zachodzi.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ZAOKR.DO.PARZ(1,5) | Zaokrągla 1,5 w górę do najbliższej liczby całkowitej parzystej (2)
=ZAOKR.DO.PARZ(3) | Zaokrągla 3 w górę do najbliższej liczby całkowitej parzystej (4)
=ZAOKR.DO.PARZ(2) | Zaokrągla 2 w górę do najbliższej liczby całkowitej parzystej (2)
=ZAOKR.DO.PARZ(-1) | Zaokrągla -1 w górę do najbliższej liczby całkowitej parzystej (-2)


ZAOKR.DÓŁ

Zaokrągla liczbę w dół w kierunku zera.

Składnia

ZAOKR.DÓŁ(liczba;liczba_cyfr)

Liczba jest dowolną liczbą rzeczywistą, która ma być zaokrąglona w dół.

Liczba_cyfr jest to liczba cyfr, do ilu liczba ma być zaokrąglona.

Spostrzeżenia

  • Funkcja ZAOKR.DÓŁ zachowuje się jak funkcja ZAOKR, z taką różnicą, że zawsze zaokrągla liczbę w dół.
  • Jeśli argument liczba_cyfr jest większy od 0, to liczba jest zaokrąglana w dół do wybranej liczby miejsc dziesiętnych.
  • Jeśli argument liczba_cyfr wynosi zero, to liczba jest zaokrąglana w dół do najbliższej liczby całkowitej.
  • Jeśli argument liczba_cyfr jest mniejszy od zera, to liczba jest zaokrąglana w dół do wartości z lewej strony przecinka dziesiętnego.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ZAOKR.DÓŁ(3,2; 0) | Zaokrągla liczbę 3,2 w dół do zerowej liczby miejsc dziesiętnych (3)
=ZAOKR.DÓŁ(76,9;0) | Zaokrągla liczbę 76,9 w dół do zerowej liczby miejsc dziesiętnych (76)
=ZAOKR.DÓŁ(3,14159; 3) | Zaokrągla liczbę 3,14159 w dół do trzech miejsc dziesiętnych (3,141)
=ZAOKR.DÓŁ(-3,14159; 1) | Zaokrągla liczbę -3.14159 w dół do jednego miejsca dziesiętnego (-3,1)
=ZAOKR.DÓŁ(31415,92654; -2) | Zaokrągla liczbę 31415,92654 w dół do dwóch miejsc dziesiętnych po lewej stronie przecinka (31400)


ZAOKR.GÓRA

Zaokrągla liczbę w górę, dalej od zera.

Składnia

ZAOKR(liczba;liczba_cyfr)

Liczba jest dowolną liczbą rzeczywistą, która ma być zaokrąglona w górę.

Liczba_cyfr jest to liczba cyfr, do ilu liczba ma być zaokrąglona.

Spostrzeżenia

  • Funkcja ZAOKR.GÓRA zachowuje się jak ZAOKR, z taką różnicą, że zawsze zaokrągla liczbę w górę.

  • Jeśli argument liczba_cyfr jest większy od 0, to liczba jest zaokrąglana w górę do wybranej liczby miejsc dziesiętnych.

  • Jeśli argument liczba_cyfr wynosi zero, to liczba jest zaokrąglana do najbliższej liczby całkowitej.

  • Jeśli argument liczba_cyfr jest mniejszy od zera, to liczba zostaje zaokrąglona do wartości z lewej strony przecinka dziesiętnego.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ZAOKR.GÓRA(3,2;0) | Zaokrągla liczbę 3,2 w górę do zerowej liczby miejsc dziesiętnych (4)
=ZAOKR.GÓRA(76,9;0) | Zaokrągla liczbę 76,9 w górę do zerowej liczby miejsc dziesiętnych (77)
=ZAOKR.GÓRA(3,14159;3) | Zaokrągla liczbę 3,14159 w górę do trzech miejsc dziesiętnych (3,142)
=ZAOKR.GÓRA(-3,14159;1) | Zaokrągla liczbę -3,14159 w górę do jednego miejsca dziesiętnego (-3,2)
=ZAOKR.GÓRA(31415,92654;-2) | Zaokrągla liczbę 31 415,92654 w górę do dwóch miejsc dziesiętnych po lewej stronie przecinka (31 500)


ZAOKR.W.DÓŁ

Zaokrągla liczbę w dół, w kierunku zera, do najbliższej wielokrotności istotności.

Składnia

ZAOKR.W.DÓŁ(liczba; istotność)

Liczba to wartość liczbowa, którą należy zaokrąglić.

Istotność to wielokrotność, do której należy wykonać zaokrąglenie.

Spostrzeżenia

  • Jeśli jakikolwiek argument nie jest liczbą, funkcja ZAOKR.W.DÓŁ zwraca wartość błędu #ARG!.
  • Jeśli argumenty liczba i istotność są różnych znaków, funkcja ZAOKR.W.DÓŁ zwraca wartość błędu #LICZBA!.
  • Niezależnie od znaku liczby, wartość jest zaokrąglana w dół przy odsuwaniu się od zera. Jeśli liczba jest dokładną wielokrotnością argumentu istotność, nie zostanie zaokrąglona.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ZAOKR.W.DÓŁ(2,5; 1) | Zaokrągla liczbę 2,5 w dół do najbliższej wielokrotności 1 (2)
=ZAOKR.W.DÓŁ(-2,5; -2) | Zaokrągla liczbę -2,5 w dół do najbliższej wielokrotności -2 (-2)
=ZAOKR.W.DÓŁ(-2,5; 2) | Zwraca błąd, ponieważ -2,5 i 2 mają odmienne znaki (#LICZBA!)
=ZAOKR.W.DÓŁ(1,5; 0,1) | Zaokrągla liczbę 1,5 w dół do najbliższej wielokrotności 0,1 (1,5)
=ZAOKR.W.DÓŁ(0,234; 0,01) | Zaokrągla liczbę 0,234 w dół do najbliższej wielokrotności 0,01 (0,23)


ZAOKR.W.GÓRĘ

Zwraca wartość liczby zaokrąglając ją w górę, dalej od zera, do najbliższej wielokrotności cyfry znaczącej. Na przykład chcąc uniknąć używania ułamków monet w cenach, a produkt wyceniony jest na 4,42 zł, należy użyć formuły =ZAOKR.W.GÓRĘ(4,42;0,05) by zaokrąglić cenę do najbliższej drobnej monety.

Składnia

ZAOKR.W.GÓRĘ(liczba;znaczenie)

Liczba to wartość, która ma być zaokrąglona.

Znaczenie to podstawa wielokrotności, do której ma nastąpić zaokrąglenie.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ZAOKR.W.GÓRĘ zwraca wartość błędu #WARTOŚĆ!.
  • Niezależnie od znaku argumentu liczba, wartość podlega zaokrągleniu w kierunku dalszym od zera. Jeśli argument liczba jest dokładną wielokrotnością argumentu znaczenie, nie zostanie on zaokrąglony.
  • Jeśli argument liczba i argument znaczenie mają różne znaki, funkcja ZAOKR.W.GÓRĘ zwraca wartość błędu #LICZBA!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ZAOKR.W.GÓRĘ(2,5; 1) | Zaokrągla liczbę 2,5 w górę do najbliższej wielokrotności 1 (3)
=ZAOKR.W.GÓRĘ(-2,5; -2) | Zaokrągla liczbę -2,5 w górę do najbliższej wielokrotności -2 (-4)
=ZAOKR.W.GÓRĘ(-2,5; 2) | Zwraca błąd, ponieważ -2,5 i 2 mają odmienne znaki (#LICZBA!)
=ZAOKR.W.GÓRĘ(1,5; 0,1) | Zaokrągla liczbę 1,5 w górę do najbliższej wielokrotności 0,1 (1,5)
=ZAOKR.W.GÓRĘ(0,234; 0,01) | Zaokrągla liczbę 0,234 w górę do najbliższej wielokrotności 0,01 (0,24)


ZNAK.LICZBY

Funkcja stosowana do ustalania znaku liczby. Zwraca wartość 1 dla liczb dodatnich, 0 gdy liczbą jest 0, i -1 dla liczb ujemnych.

Składnia

ZNAK.LICZBY(liczba)

Liczba to dowolna liczba rzeczywista.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ZNAK.LICZBY(10) | Znak liczby dodatniej (1)
=ZNAK.LICZBY(4-4) | Znak liczby zero (0)
=ZNAK.LICZBY(-0,00001) | Znak liczby ujemnej (-1)


CREATEOBJECT

Zwraca wystąpienie obiektu IDispatch z danym identyfikatorem ProgID. Ta funkcja pozwala utworzyć dowolny obiekt COM działający na komputerze lokalnym lub uruchamiany zdalnie na wyznaczonym serwerze.

Składnia

CREATEOBJECT(ProgID, NazwaSerwera)

ProgID jest identyfikatorem obiektu IDispatch.

NazwaSerwera jest nazwą serwera, z którego ma być otrzymany obiekt IDispatch. Jeśli ten argument zostanie pominięty, to zostanie użyta nazwa lokalnego komputera.

Przykład

Uwaga W poniższym przykładzie użyto fikcyjnego identyfikatora ProgID i fikcyjnej NazwySerwera.

 | A | Opis (wynik)
1 | =CREATEOBJECT("msn.marketdata", "\\investor") | Zwraca obiekt IDispatch danych giełdowych z serwera inwestora.
2 | =OBJECT($A$1).LastPrice("MSFT") | Zwraca ostatnią cenę giełdową z informacji zawartych w obiekcie zwróconym w komórce A1.


HOST

Zwraca obiekt kontenera zawierający składnik Arkusz kalkulacyjny. Na stronie sieci Web jest to obiekt dokumentu Internet Explorer. W aplikacji Visual Basic jest to odwołanie do obiektu Formularz.

Składnia

HOST().[obiekt].[właściwość lub metoda]

Przykład

=HOST().Pole_Tekstowe1.Wartość

W tym przykładzie funkcja HOST() zwraca obiekt IHTMLDocument programu Internet Explorer, zapewniając dostęp do wszystkich informacji zawartych na stronie sieci Web. Operator “.” jest tu użyty do wywołania właściwości “PoleTekstowe1”, która zwraca obiekt pola tekstowego. Następnie operator “.” jest używany ponownie, aby wywołać właściwość “Wartość”, która zwraca ciąg tekstowy zawierający wartość pola tekstowego.


OBJECT

Zwraca informacje z obiektu zwróconego do arkusza kalkulacyjnego.

Składnia

OBJECT(zakres)

Zakres odwołanie do obiektu zakresu zwróconego przez funkcję, taką jak CREATEOBJECT. Może to być funkcja zagnieżdżona lub odwołanie do komórki.

Przykład

Uwaga W poniższym przykładzie użyto fikcyjnego identyfikatora ProgID i fikcyjnej NazwySerwera.

 | A | Opis (wynik)
1 | =CREATEOBJECT("msn.marketdata", "\\investor") | Zwraca obiekt IDispatch danych giełdowych z serwera inwestora.
2 | =OBJECT($A$1).LastPrice("MSFT") | Zwraca ostatnią cenę giełdową z informacji zawartych w obiekcie zwróconym w komórce A1.


XMLDOM

Zwraca wystąpienie obiektu dokumentu XML w określonym dokumencie.

Uwaga Funkcja XMLDOM wymaga zainstalowania składnika MSXML3.0 na każdym komputerze, na którym działa składnik arkusz kalkulacyjny. Jeżeli składnik MSXML3.0 jest niezainstalowany, ta funkcja zwróci wartość błędu #NAZWA?. Składnik MSXML3.0 jest instalowany w ramach typowej instalacji pakietu Office XP albo można go pobrać z sieci MSDN Online. Składnik MSXML3.0 nie jest instalowany w przypadku instalowania składników Microsoft Office Web Components z sieci Web. Hiperłącze w tym temacie prowadzi do sieci Web. W każdej chwili można powrócić do Pomocy.

Składnia

XMLDOM(url)

URL to adres określonego dokumentu.

Przykład

=XMLDOM("klienci.xml").SelectSingleNode("//Klient/Telefon").Text

W tym przykładzie funkcja XMLDOM zwraca numer telefonu klienta z pliku xml, klienci.xml, wyglądający jak następuje:

<Klient>
Davolio
<Telefon>
555-1212
</Telefon>
</Klient>


CZĘSTOŚĆ

Oblicza, jak często wartości występują w określonym zakresie wartości, a następnie zwraca tablicę liczb w układzie pionowym. Funkcja CZĘSTOŚĆ umożliwia na przykład sprawdzenie liczby wyników testów mieszczących się w pewnym zakresie. Ponieważ funkcja CZĘSTOŚĆ zwraca tablicę, musi być wprowadzona jako formuła tablicowa.

Składnia

CZĘSTOŚĆ(tablica_dane;tablica_przedziały)

Tablica_dane to tablica wartości lub odwołanie do zbioru wartości, dla których mają być liczone częstości. Jeśli argument tablica_dane nie ma żadnych wartości, funkcja CZĘSTOŚĆ zwraca tablicę zer.

Tablica_przedziały to tablica przedziałów lub odwołanie do przedziałów, w których mają być grupowane wartości argumentu tablica_dane. Jeśli argument tablica_przedziały nie zawiera żadnych wartości, funkcja CZĘSTOŚĆ zwraca liczbę elementów w argumencie tablica_dane.

Spostrzeżenia

  • Funkcja CZĘSTOŚĆ wprowadzana jest jako formuła tablicowa po wybraniu zakresu sąsiadujących komórek, do których mają być zwrócone wartości funkcji rozkładu.
  • Liczba elementów w zwróconej tablicy jest o jeden większa niż liczba elementów w argumencie tablica_przedziały. Ten dodatkowy element zwraca liczbę wszystkich wartości istniejących poza najwyższym przedziałem. Na przykład przy zliczaniu trzech zakresów wartości danych (przedziałów) wprowadzonych w komórki należy umieścić funkcję CZĘSTOŚĆ w czterech komórkach tablicy wyników. W dodatkowej komórce zostanie zwrócona liczba wartości argumentu tablica_dane większych niż górna wartość trzeciego przedziału.
  • Funkcja CZĘSTOŚĆ ignoruje puste komórki i tekst.
  • Formuły, które zwracają tablice, muszą być wprowadzone jako formuły tablicowe.

Przykład

W przykładzie tym założono, że wszystkie wyniki testów są liczbami całkowitymi.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Wyniki | Przedziały
79 | 70
85 | 79
78 | 89
85 |
50 |
81 |
95 |
88 |
97 |
Formuła | Opis (Wynik)
=CZĘSTOŚĆ(A2:A10;B2:B5) | Liczba wyników mniejszych lub równych 70 (1)
 | Liczba wyników w przedziale 71-79 (2)
 | Liczba wyników w przedziale 80-89 (4)
 | Liczba wyników większych lub równych 90 (2)

Uwaga Formuła w powyższym przykładzie musi zostać wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego należy zaznaczyć zakres komórek A12:A15, rozpoczynając od komórki zawierającej formułę. Należy nacisnąć klawisz F2, a następnie klawisze CTRL+SHIFT+ENTER. Jeśli formuła nie jest wprowadzana jako formuła tablicowa, jedynym wynikiem będzie liczba 1.


ILE.LICZB

Zlicza komórki zawierające liczby i liczby na liście argumentów. Funkcja ILE.LICZB jest przydatna do zliczania wpisów w polu liczbowym w zakresie lub tablicy liczb.

Składnia

ILE.LICZB(wartość1;wartość2;...)

Wartość1; wartość2; ... to ciąg od 1 do 30 argumentów zawierających lub odwołujących się do szeregu różnych typów danych, spośród których zliczane są tylko liczby.

Spostrzeżenia

  • Zliczane są tylko argumenty będące liczbami, datami lub tekstowymi prezentacjami liczb; argumenty będące wartościami błędu lub tekstami, które nie mogą być zinterpretowane jako liczby, są ignorowane.
  • Jeśli argument jest tablicą lub odwołaniem, zliczane są jedynie liczby znajdujące się w tej tablicy lub odwołaniu. Puste komórki, wartości logiczne, tekstowe lub wartości błędów w tablicy lub odwołaniu są pomijane. Aby zliczyć wartości logiczne, tekstowe lub wartości błędów, użyj funkcji ILE.NIEPUSTYCH.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Sprzedaż
2008-12-08
19
22,24
PRAWDA
#DZIEL/0!
Formuła | Opis (Wynik)
=ILE.LICZB(A2:A8) | Zlicza na liście powyżej komórki zawierające liczby (3)
=ILE.LICZB(A5:A8) | Zlicza w ostatnich 4 wierszach listy komórki zawierające liczby (2)
=ILE.LICZB(A2:A8;2) | Zlicza na liście komórki zawierające liczby oraz wartość 2 (4)


ILE.NIEPUSTYCH

Zlicza komórki, które nie są puste, i wartości na liście argumentów. Funkcja ILE.NIEPUSTYCH jest przydatna do zliczania komórek zawierających dane w zakresie lub tablicy liczb.

Składnia

ILE.NIEPUSTYCH(wartość1;wartość2;...)

Wartość1; wartość2; ... to od 1 do 30 argumentów reprezentujących wartości, które mają zostać zliczone. W tym przypadku wartość oznacza dowolny typ informacji, łącznie z pustym tekstem (""), ale nie puste komórki. Jeśli argument jest tablicą lub odwołaniem, puste komórki w tablicy lub odwołaniu są ignorowane. Jeśli nie ma potrzeby zliczania wartości logicznych, tekstowych lub wartości błędów, należy użyć funkcji ILE.LICZB.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Sprzedaż
2008-12-08
19
22,24
PRAWDA
#DZIEL/0!
Formuła | Opis (Wynik)
=ILE.NIEPUSTYCH(A2:A8) | Zlicza na liście komórki niepuste (6)
=ILE.NIEPUSTYCH(A5:A8) | Zlicza w ostatnich 4 wierszach listy komórki niepuste (4)
=ILE.NIEPUSTYCH(A1:A7;2) | Zlicza na liście komórki niepuste oraz wartość 2 (7)
=ILE.NIEPUSTYCH(A1:A7;"Dwa") | Zlicza na liście komórki niepuste oraz wartość „Dwa” (7)


KOWARIANCJA

Zwraca wartość kowariancji, tzn. średniej z iloczynów odchyleń dla każdej pary punktów danych. Kowariancja jest przydatna w określaniu relacji między dwoma zbiorami danych. Można na przykład sprawdzić, czy większe przychody są związane z wyższym poziomem wykształcenia.

Składnia

KOWARIANCJA(tablica1;tablica2)

Tablica1 to pierwszy zakres komórek zawierających liczby naturalne.

Tablica2 to pierwszy zakres komórek zawierających liczby naturalne.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami bądź odwołaniami, które zawierają liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeśli argumenty tablica1 i tablica2 mają różną liczbę punktów danych, funkcja KOWARIANCJA zwraca wartość błędu #N/D!.
  • Jeśli którykolwiek z argumentów tablica1 lub tablica2 jest pusty, funkcja KOWARIANCJA zwraca wartość błędu #DZIEL/0!.
  • Równanie kowariancji ma postać:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane1 | Dane2
3 | 9
2 | 7
4 | 12
5 | 15
6 | 17
Formuła | Opis (Wynik)
=KOWARIANCJA(A2:A6;B2:B6) | Kowariancja, czyli średnia z iloczynów odchyleń dla każdej z powyższych par punktów danych (5,2)


KURTOZA

Zwraca kurtozę zestawu danych. Kurtoza charakteryzuje względną szczytowość lub płaskość rozkładu w porównaniu z rozkładem normalnym. Dodatnia kurtoza oznacza rozkład o stosunkowo dużej szczytowości. Ujemna kurtoza oznacza rozkład stosunkowo płaski.

Składnia

KURTOZA(liczba1;liczba2;...)

Liczba1; liczba2; ... to od 1 do 30 argumentów, dla których chcemy obliczyć kurtozę. Zamiast argumentów rozdzielonych średnikami można stosować pojedynczą tablicę lub odwołanie do tablicy.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami bądź odwołaniami, które zawierają liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeżeli jest mniej niż cztery punkty danych lub jeśli standardowe odchylenie próbki jest równe zero, funkcja KURTOZA zwraca wartość błędu #DZIEL/0!.
  • Kurtoza jest definiowana w następujący sposób:

    gdzie:

    s jest standardowym odchyleniem próbki.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
3
4
5
2
3
4
5
6
4
7
Formuła | Opis (Wynik)
=KURTOZA(A2:A11) | Kurtoza podanego powyżej zestawu danych (-0,1518)


KWARTYL

Zwraca kwartyl zbioru danych. Kwartyle są często używane w danych o sprzedaży i w danych pomiarowych do dzielenia populacji na grupy. Na przykład funkcję KWARTYL można zastosować do znalezienia górnych 25% dochodów w populacji.

Składnia

KWARTYL(tablica;kwartyl)

Tablica to tablica lub zakres komórek wartości liczbowych, dla których chcemy obliczyć wartość kwartylu.

Kwartyl wskazuje wartość, która ma być zwrócona.

Jeżeli kwartyl równa się | funkcja KWARTYL zwraca
0 | Wartość minimalna
1 | Pierwszy kwartyl (25. percentyl)
2 | Wartość mediany (50. percentyl)
3 | Trzeci kwartyl ( 75. percentyl)
4 | Wartość maksymalna

Uwagi
  • Jeżeli argument tablica jest pusty, funkcja KWARTYL zwraca wartość błędu #LICZBA!.
  • Jeśli argument kwartyl nie jest liczbą całkowitą, zostanie obcięty do liczby całkowitej.
  • Jeśli argument kwartyl < 0 lub jeśli kwartyl > 4, funkcja KWARTYL zwraca wartość błędu #LICZBA!.
  • Funkcje MIN, MEDIANA i MAX zwracają tę samą liczbę co funkcja KWARTYL, jeśli argument kwartyl jest równy odpowiednio 0, 2 i 4.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
1
2
4
7
8
9
10
12
Formuła | Opis (Wynik)
=KWARTYL(A2:A9;1) | Pierwszy kwartyl (25. percentyl) powyższych danych (3,5)


MAKS

Zwraca maksymalną wartość z listy wartości.

Składnia

MAKS(liczba1;liczba2;...)

Liczba1; liczba2; ... to liczby od 1 do 30, spośród których wyszukiwana jest wartość maksymalna.

Spostrzeżenia

  • Argumentami mogą być liczby, puste komórki, wartości logiczne lub tekstowa reprezentacja liczb. Argumenty, które są wartościami błędów lub tekstem, którego nie można przekształcić na liczby, powodują występowanie błędów.
  • Jeśli argument jest tablicą lub odwołaniem, brane są pod uwagę jedynie liczby w nim zawarte. Puste komórki, wartości logiczne, tekst lub wartości błędów zawarte w tablicy lub adresie zostaną pominięte. Jeśli wartości logiczne i tekst nie powinny być ignorowane, zamiast tej należy użyć funkcji MAKS.A.
  • Jeśli argumenty nie zawierają liczb, funkcja MAKS zwraca wartość 0.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
10
7
9
27
2
Formuła | Opis (Wynik)
=MAKS(A2:A6) | Największa spośród powyższych liczb (27)
=MAKS(A2:A6; 30) | Największa spośród powyższych liczb i liczby 30 (30)


MAKS.A

Zwraca największą wartość z listy argumentów. Oprócz liczb, w obliczeniach mogą być brane pod uwagę teksty oraz wartości logiczne PRAWDA i FAŁSZ.

Funkcja MAKS.A jest podobna do funkcji MIN.A. Więcej informacji można znaleźć w przykładach dotyczących funkcji MIN.A.

Składnia

MAKS.A(wartość1;wartość2;...)

Wartość1; wartość2; ... to od 1 do 30 wartości, spośród których należy znaleźć największą wartość.

Spostrzeżenia

  • Argumentami mogą być liczby, puste komórki, wartości logiczne lub tekstowa reprezentacja liczb. Argumenty będące wartościami błędów powodują wystąpienie błędów. Jeśli obliczenia nie powinny obejmować tekstu lub wartości logicznych, zamiast tej należy użyć funkcji MAKS.
  • Jeśli argumentem jest tablica lub odwołanie, to uwzględniane są tylko wartości liczbowe w tablicy lub w podanym odwołaniu. Puste komórki oraz wartości tekstowe są pomijane.
  • Wartość liczbowa argumentów zawierających wartość logiczną PRAWDA wynosi 1; wartość liczbowa argumentów zawierających wartość tekstową lub wartość logiczną FAŁSZ wynosi 0 (zero).
  • Jeśli argumenty nie zawierają żadnych wartości, to funkcja MAKS.A zwraca wartość 0 (zero).

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
0
0,2
0,5
0,4
PRAWDA
Formuła | Opis (Wynik)
=MAKS.A(A2:A6) | Największa spośród powyższych liczb. Wartości PRAWDA odpowiada liczba 1 (1)


MAX.K

Zwraca k-tą największą wartość w zestawie danych. Funkcję tę można wykorzystać do wybrania wartości na podstawie jej względnej pozycji. Na przykład funkcję MAX.K można zastosować w celu określenia pierwszego, drugiego lub trzeciego miejsca.

Składnia

MAX.K(tablica;k)

Tablica to tablica lub zakres danych, dla których chcemy określić k-tą największą wartość.

K to pozycja danej, która ma być określona, (od największej) w tablicy lub zakresie komórek.

Spostrzeżenia

  • Jeżeli argument tablica jest pusty, funkcja MAX.K zwraca wartość błędu #LICZBA!.
  • Jeżeli argument k ≤ 0 lub jeśli k jest większe niż liczba punktów danych, wówczas funkcja MAX.K zwraca wartość błędu #LICZBA!.

Jeżeli n jest liczbą punktów danych w zakresie, wówczas funkcja MAX.K(tablica;1) zwraca największą wartość, a funkcja MAX.K(tablica;n) zwraca najmniejszą wartość.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Dane
3 | 4
5 | 2
3 | 4
5 | 6
4 | 7
Formuła | Opis (Wynik)
=MAX.K(A2:B6;3) | Trzecia największa liczba wśród podanych powyżej liczb (5)
=MAX.K(A2:B6;7) | Siódma największa liczba wśród podanych powyżej liczb (4)


MEDIANA

Zwraca wartość mediany danych liczb. Mediana jest liczbą w środku zbioru liczb tzn., że połowa liczb ma wartości większe niż mediana i połowa ma wartości mniejsze.

Składnia

MEDIANA(liczba1;liczba2;...)

Liczba1; liczba2; ... to od 1 do 30 liczb, których medianę należy wyznaczyć.

Spostrzeżenia

  • Argumentami mogą być liczby, nazwy lub tablice albo odwołania zawierające liczby. W arkuszu kalkulacyjnym sprawdzane są wszystkie liczby w każdym odwołaniu lub tablicy.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.

  • Jeśli liczba danych liczbowych w zestawie jest parzysta, to funkcja MEDIANA oblicza średnią dwóch liczb środkowych. Zobacz drugą z poniższych formuł.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
1
2
3
4
5
6
Formuła | Opis (Wynik)
=MEDIANA(A2:A6) | Mediana pierwszych 5 liczb na powyższej liście (3)
=MEDIANA(A2:A7) | Mediana wszystkich powyższych liczb, czyli średnia liczb 3 i 4 (3,5)


MIN

Zwraca wartość najmniejszej liczby na liście wartości.

Składnia

MIN(liczba1;liczba2;...)

Liczba1; liczba2; ... to od 1 do 30 liczb, spośród których należy znaleźć wartość minimalną.

Spostrzeżenia

  • Argumentami mogą być liczby, puste komórki, wartości logiczne lub tekstowa reprezentacja liczb. Argumenty, które są wartościami błędów lub tekstem, którego nie można przekształcić na liczby, powodują występowanie błędów.
  • Jeśli argument jest tablicą lub odwołaniem, brane są pod uwagę jedynie liczby w nim zawarte. Puste komórki, wartości logiczne, tekst lub wartości błędów zawarte w tablicy lub odwołaniu zostaną pominięte. Jeśli wartości logiczne i tekst nie powinny być ignorowane, należy użyć funkcji MIN.A.
  • Jeśli argumenty nie zawierają liczb, funkcja MIN zwraca wartość 0.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
10
7
9
27
2
Formuła | Opis (Wynik)
=MIN(A2:A6) | Najmniejsza spośród powyższych liczb (2)
=MIN(A2:A6;0) | Najmniejsza spośród powyższych liczb i liczby 0 (0)


MIN.A

Zwraca wartość najmniejszej liczby na liście wartości. Oprócz liczb, w obliczeniach mogą być brane pod uwagę teksty oraz wartości logiczne PRAWDA i FAŁSZ.

Składnia

MIN.A(wartość1;wartość2;...)

Wartość1; wartość2; ... to od 1 do 30 wartości, spośród których należy znaleźć wartość minimalną.

Spostrzeżenia

  • Argumentami mogą być liczby, puste komórki, wartości logiczne lub tekstowa reprezentacja liczb. Argumenty będące wartościami błędów powodują wystąpienie błędów. Jeśli w obliczeniach wartości tekstowe i logiczne powinny być pomijane, zamiast tej należy stosować funkcję arkusza MIN.
  • Jeśli argumentem jest tablica lub odwołanie, to uwzględniane są tylko wartości liczbowe w tablicy lub w podanym odwołaniu. Puste komórki oraz wartości tekstowe są pomijane.
  • Wartość liczbowa argumentów zawierających wartość logiczną PRAWDA wynosi 1; wartość liczbowa argumentów zawierających wartość tekstową lub wartość logiczną FAŁSZ wynosi 0 (zero).
  • Jeśli argumenty nie zawierają żadnych wartości, to funkcja MIN.A zwraca wartość 0 (zero).

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
FAŁSZ
0,2
0,5
0,4
0,8
Formuła | Opis (Wynik)
=MIN.A(A2:A6) | Najmniejsza spośród powyższych liczb. Wartość logiczna FAŁSZ ma wartość liczbową 0 (0)


MIN.K

Zwraca w wyniku k-tą najmniejszą wartość w zbiorze danych. Należy stosować tę funkcję w celu obliczenia wartości mających określoną względną pozycję w zbiorze danych.

Składnia

MIN.K(tablica;k)

Tablica to tablica lub zakres danych liczbowych, w którym użytkownik chce określić k-tą najmniejszą wartość.

K to pozycja (od najniższej) w tablicy lub zakresie danych, która ma być zwrócona.

Spostrzeżenia

  • Jeżeli argument tablica jest pusty, funkcja MIN.K zwraca w wyniku wartość błędu #LICZBA!.
  • Jeżeli k ≤ 0 lub jeśli k przekracza liczbę punktów danych, funkcja MIN.K daje w wyniku wartość błędu #LICZBA!.
  • Jeżeli n jest liczbą punktów danych w tablicy, funkcja MIN.K(tablica;1) jest równa najmniejszej wartości, a funkcja MIN.K(tablica;n) jest równa największej wartości.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Dane
3 | 1
4 | 4
5 | 8
2 | 3
3 | 7
4 | 12
6 | 54
4 | 8
7 | 23
Formuła | Opis (Wynik)
=MIN.K(A2:A10;4) | Czwarta z kolei najmniejsza liczba w pierwszej kolumnie (4)
=MIN.K(B2:B10;2) | Druga z kolei najmniejsza liczba w drugiej kolumnie (3)


NACHYLENIE

Zwraca w wyniku nachylenie całego wykresu regresji liniowej dla wszystkich punktów danych argumentów znane_y i znane_x. Nachylenie jest to odległość na osi pionowej podzielona przez odległość na osi poziomej między dowolnymi dwoma punktami wykresu liniowego. Stosunek ten oznacza prędkość zmiany wzdłuż wykresu regresji.

Składnia

NACHYLENIE(znane_y;znane_x)

Znane_y to tablica lub zakres komórek zawierający zależne punkty danych liczbowych.

Znane_x to zbiór niezależnych punktów danych.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami bądź odwołaniami, które zawierają liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeżeli argumenty znane_y i znane_x są puste lub mają inną liczbę punktów danych, funkcja NACHYLENIE daje w wyniku wartość błędu #N/D!.
  • Równaniem nachylenia wykresu regresji jest:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Znane y | Znane x
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
7 | 4
5 | 4
Formuła | Opis (Wynik)
=NACHYLENIE(A2:A8;B2:B8) | Nachylenie regresji liniowej dla zadanych punktów danych (0,305556)


NORMALIZUJ

Zwraca wartość znormalizowaną dla rozkładu charakteryzowanego przez argumenty średnia i odchylenie_std.

Składnia

NORMALIZUJ(x;średnia;odchylenie_std)

X to wartość, która ma zostać znormalizowana.

Średnia to średnia arytmetyczna rozkładu.

Odchylenie_std to odchylenie standardowe rozkładu.

Spostrzeżenia

  • Jeżeli odchylenie_std ≤ 0, funkcja NORMALIZUJ zwraca wartość błędu #LICZBA!.
  • Równanie wartości normalizowanej jest następujące:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
42 | Wartość, która ma być normalizowana
40 | Średnia arytmetyczna rozkładu
1,5 | Odchylenie standardowe rozkładu
Formuła | Opis (Wynik)
=NORMALIZUJ(A2;A3;A4) | Wartość znormalizowana dla 42 przy założeniach określonych powyżej (1,333333)


ODCH.KWADRATOWE

Zwraca wartość sumy kwadratów odchyleń dla punktów danych od ich średniej z próby.

Składnia

ODCH.KWADRATOWE(liczba1;liczba2;...)

Liczba1,liczba2,... to od 1 do 30 argumentów, dla których ma zostać wyznaczona suma kwadratów odchyleń. Zamiast argumentów rozdzielonych średnikami można używać pojedynczej tablicy lub odwołania do tablicy.

Spostrzeżenia

  • Argumenty powinny być liczbami, nazwami, tablicami lub odwołaniami zawierającymi liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Równanie sumy kwadratów odchyleń ma postać:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
4
5
8
7
11
4
3
Formuła | Opis (Wynik)
=ODCH.KWADRATOWE(A2:A8) | Suma odchyleń kwadratowych dla powyższych danych od ich średniej z próby (48)


ODCH.STANDARD.POPUL

Oblicza odchylenie standardowe całej populacji podanej w postaci argumentów. Odchylenie standardowe jest miarą tego, jak szeroko wartości są rozłożone w stosunku do wartości średniej.

Składnia

ODCH.STANDARD.POPUL(liczba1;liczba2;...)

Liczba1; liczba2; ... to od 1 do 30 wartości odpowiadających populacji. Można stosować pojedynczą tablicę lub odwołanie do tablicy zamiast argumentów rozdzielonych średnikami.

Spostrzeżenia

  • Wartości logiczne takie jak PRAWDA i FAŁSZ oraz wartości tekstowe są ignorowane. Jeśli wartości logiczne mają nie być ignorowane, należy użyć funkcji arkusza ODCH.STANDARDOWE.POPUL.A.
  • Funkcja ODCH.STANDARD.POPUL zakłada, że jej argumenty są całą populacją. Jeżeli dane reprezentują próbkę populacji, należy obliczyć odchylenie standardowe za pomocą funkcji ODCH.STANDARDOWE.
  • Dla dużych próbek funkcje ODCH.STANDARDOWE i ODCH.STANDARD.POPUL dają w przybliżeniu jednakowe wartości.
  • Odchylenie standardowe oblicza się, stosując metodę "obciążoną" lub metodę "n".
  • Funkcja ODCH.STANDARD.POPUL korzysta z następującej formuły:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Siła
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
Formuła | Opis (Wynik)
=ODCH.STANDARD.POPUL(A2:A11) | Odchylenie standardowe wytrzymałości na złamanie przy założeniu, że wyprodukowano tylko 10 narzędzi (26,05455814)


ODCH.STANDARD.POPUL.A

Oblicza odchylenie standardowe całej populacji podanej w postaci argumentów, uwzględniając wartości tekstowe i logiczne. Odchylenie standardowe jest miarą tego, jak szeroko wartości są rozłożone w stosunku do wartości średniej.

Składnia

ODCH.STANDARD.POPUL.A(wartość1;wartość2;...)

Wartość1; wartość2; ... to od 1 do 30 wartości odpowiadających populacji. Można stosować pojedynczą tablicę lub odwołanie do tablicy zamiast argumentów rozdzielonych średnikami.

Spostrzeżenia

  • Funkcja ODCH.STANDARD.POPUL.A zakłada, że jej argumenty są całą populacją. Jeżeli dane reprezentują próbkę populacji, należy obliczyć odchylenie standardowe za pomocą funkcji ODCH.STANDARDOWE.A.
  • Wartość liczbowa argumentów zawierających wartość logiczną PRAWDA wynosi 1; wartość liczbowa argumentów zawierających wartość tekstową lub wartość logiczną FAŁSZ wynosi 0 (zero). Jeśli w obliczeniach wartości tekstowe i logiczne powinny być pomijane, należy stosować funkcję arkusza ODCH.STANDARD.POPUL.
  • Dla dużych próbek funkcje ODCH.STANDARDOWE.A i ODCH.STANDARD.POPUL.A dają w przybliżeniu jednakowe wartości.
  • Odchylenie standardowe oblicza się, stosując metodę "obciążoną" lub metodę "n".
  • Funkcja ODCH.STANDARD.POPUL.A korzysta z następującej formuły:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Siła
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
Formuła | Opis (Wynik)
=ODCH.STANDARD.POPUL.A(A2:A11) | Odchylenie standardowe wytrzymałości na złamanie przy założeniu, że wyprodukowano tylko 10 narzędzi (26,05455814)


ODCH.STANDARDOWE

Szacuje odchylenie standardowe na podstawie próbki. Odchylenie standardowe jest miarą rozrzutu wartości względem wartości średniej.

Składnia

ODCH.STANDARDOWE(liczba1;liczba2;...)

Liczba1; liczba2; ... to liczba argumentów od 1 do 30 odpowiadających próbce populacji. Zamiast argumentów oddzielonych średnikami można stosować pojedynczą tablicę lub odwołanie do tablicy.

Spostrzeżenia

  • Wartości logiczne, takie jak PRAWDA i FAŁSZ oraz tekst są ignorowane. Jeśli wartości logiczne mają być uwzględniane, to należy użyć funkcji arkusza kalkulacyjnego ODCH.STANDARDOWE.A.
  • Funkcja ODCH.STANDARDOWE zakłada, że argumenty są próbą populacji. Jeżeli dane reprezentują całą populację, to odchylenie standardowe należy obliczyć za pomocą funkcji ODCH.STANDARD.POPUL.
  • Odchylenie standardowe oblicza się, stosując metodę "nieobciążoną" lub metodę "n-1".
  • W funkcji ODCH.STANDARDOWE używana jest następująca formuła:

Przykład

Przyjmijmy, ze 10 narzędzi wykonanych na tej samej maszynie w jednym cyklu produkcji zostało zebranych jako przypadkowa próbka, na której przeprowadzono pomiar wytrzymałości na złamanie.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Siła
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
Formuła | Opis (Wynik)
=ODCH.STANDARDOWE(A2:A11) | Odchylenie standardowe wytrzymałości na złamanie (27,46391572)


ODCH.STANDARDOWE.A

Oszacowuje odchylenie standardowe próby. Odchylenie standardowe jest miarą tego, jak szeroko wartości są rozłożone w stosunku do wartości średniej. W obliczeniach mogą być brane pod uwagę wartości tekstowe oraz wartości logiczne PRAWDA i FAŁSZ.

Składnia

ODCH.STANDARDOWE.A(wartość1;wartość2;...)

Wartość1; wartość2; ... to od 1 do 30 wartości odpowiadających próbce populacji. Można stosować pojedynczą tablicę lub odwołanie do tablicy zamiast argumentów rozdzielonych średnikami.

Spostrzeżenia

  • Funkcja ODCH.STANDARDOWE.A zakłada, że jej argumenty są próbą populacji. Jeżeli dane reprezentują całą populację, odchylenie standardowe należy obliczyć za pomocą funkcji ODCH.STANDARD.POPUL.A.
  • Wartość liczbowa argumentów zawierających wartość logiczną PRAWDA wynosi 1; wartość liczbowa argumentów zawierających wartość tekstową lub wartość logiczną FAŁSZ wynosi 0 (zero). Jeśli w obliczeniach wartości tekstowe i logiczne powinny być pomijane, należy stosować funkcję arkusza ODCH.STANDARD.
  • Odchylenie standardowe oblicza się, stosując metodę "nieobciążoną" lub metodę "n-1".
  • Funkcja ODCH.STANDARDOWE.A korzysta z następującej formuły:

Przykład

Przyjmijmy, ze 10 narzędzi wykonanych na tej samej maszynie w jednym cyklu produkcji zostało zebranych jako przypadkowa próbka, na której przeprowadzono pomiar wytrzymałości na złamanie.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Siła
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
Formuła | Opis (Wynik)
=ODCH.STANDARDOWE.A(A2:A11) | Odchylenie standardowe wytrzymałości na złamanie dla wszystkich narzędzi (27,46391572)


ODCH.ŚREDNIE

Zwraca wartość średnią odchyleń bezwzględnych punktów danych od ich wartości średniej. Funkcja ODCH.ŚREDNIE jest miarą zmienności zbioru danych.

Składnia

ODCH.ŚREDNIE(liczba1;liczba2;...)

Liczba1; liczba2; ... to argumenty od 1 do 30, dla których ma zostać wyznaczona średnia odchyleń bezwzględnych. Zamiast argumentów oddzielonych średnikami można użyć pojedynczej tablicy odwołania do tablicy.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami bądź odwołaniami, które zawierają liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Równanie odchylenia średniego ma postać:

Na wartość funkcji ODCH.ŚREDNIE wpływa przyjęty system jednostek danych wejściowych.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
4
5
6
7
5
4
3
Formuła | Opis (Wynik)
=ODCH.ŚREDNIE(A2:A8) | Wartość średnia odchyleń bezwzględnych dla wartości średniej powyższych liczb (1,020408)


ODCIĘTA

Oblicza punkt przecięcia się linii regresji liniowej z osią y, wykorzystując istniejące wartości x i y. Punkt przecięcia jest to punkt, w którym prosta regresji poprowadzona przez wartości znane_x i znane_y przecina oś y. Funkcję tę należy stosować wtedy, gdy chce się wyznaczyć wartość zmiennej zależnej przy zerowej wartości zmiennej niezależnej. Na przykład można zastosować funkcję ODCIĘTA do wyznaczenia rezystancji metalu przy 0°C, podczas gdy punkty pomiarowe wyznaczano w temperaturze pokojowej i wyższych.

Składnia

ODCIĘTA(znane_y;znane_x)

Znane_y to zbiór danych lub obserwacji zależnych.

Znane_x to zbiór danych lub obserwacji niezależnych.

Spostrzeżenia

  • Argumentami mogą być liczby, nazwy lub tablice albo odwołania zawierające liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeśli argumenty znane_y i znane_x zawierają różne liczby punktów danych lub nie zawierają punktów danych, funkcja ODCIĘTA zwraca wartość błędu #N/D.
  • Równanie punktu przecięcia linii regresji przedstawia się następująco:

    gdzie nachylenie oblicza się jako:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Znane y | Znane x
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
Formuła | Opis (Wynik)
=ODCIĘTA(A2:A6; B2:B6) | Punkt, w którym linia regresji przecina oś y przy wykorzystaniu podanych powyżej wartości x i y (0,0483871)


PEARSON

Zwraca współczynnik korelacji liniowej Pearsona r. Jest to bezwymiarowy wskaźnik, którego wartość mieści się w zakresie od -1,0 do 1,0 włącznie i który odzwierciedla stopień liniowej zależności pomiędzy dwoma zestawami danych.

Składnia

PEARSON(tablica1;tablica2)

Tablica1 to zbiór wartości niezależnych.

Tablica2 to zbiór wartości zależnych.

Spostrzeżenia

  • Argumenty powinny być liczbami lub nazwami, stałymi tablicowymi lub odwołaniami, które zawierają liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeżeli argumenty tablica1 i tablica2 są puste lub mają różną liczbę punktów danych, funkcja PEARSON zwraca wartość błędu #N/D!.
  • Wartość r linii regresji wylicza się na podstawie następującego wzoru:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Wartości niezależne | Wartości zależne
9 | 10
7 | 6
5 | 1
3 | 5
1 | 3
Formuła | Opis (Wynik)
=PEARSON(A2:A6;B2:B6) | Współczynnik korelacji liniowej Pearsona podanych powyżej zestawów danych (0,699379)


PERCENTYL

Zwraca k-ty percentyl wartości w zakresie. Funkcję tę można zastosować do określenia progu akceptacji. Na przykład można podjąć decyzję o przebadaniu kandydatów, których wyniki są powyżej 90-ego percentylu.

Składnia

PERCENTYL(tablica;k)

Tablica to tablica lub zakres danych, który określa względną pozycję.

K to wartość percentylu w zakresie od 0 do 1 włącznie.

Spostrzeżenia

  • Jeżeli tablica jest pusta lub zawiera więcej niż 8191 punktów danych, funkcja PERCENTYL zwraca wartość błędu #LICZBA!.
  • Jeżeli k jest argumentem nieliczbowym, funkcja PERCENTYL zwraca wartość błędu #ARG!.
  • Jeżeli argument k < 0 lub jeśli k > 1, funkcja PERCENTYL zwraca wartość błędu #LICZBA!.
  • Jeżeli argument k nie jest wielokrotnością 1/(n — 1), funkcja PERCENTYL stosuje interpolację w celu określenia wartości k-tego percentylu.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
1
3
2
4
Formuła | Opis (Wynik)
=PERCENTYL(A2:A5;0,3) | Trzydziesty percentyl powyższej listy (1,9)


PERMUTACJE

Zwraca liczbę permutacji dla podanej liczby obiektów, które można wybrać z szerszej grupy obiektów liczbowych. Permutacją jest dowolny zbiór lub podzbiór obiektów lub zdarzeń, gdzie ważne jest wewnętrzne uporządkowanie. Permutacje różnią się od kombinacji, dla których wewnętrzne uporządkowanie nie jest istotne. Funkcję tę należy stosować do obliczania prawdopodobieństwa typu loteryjnego.

Składnia

PERMUTACJE(liczba;wybór_liczba)

Liczba to liczba całkowita, która opisuje liczbę obiektów.

Wybór_liczba to liczba całkowita, która opisuje liczbę obiektów w każdej permutacji.

Spostrzeżenia

  • Obydwa argumenty są w razie potrzeby obcinane do liczb całkowitych.
  • Jeżeli argumenty liczba lub wybór_liczba jest argumentami nieliczbowymi, funkcja PERMUTACJE zwraca wartość błędu #ARG!.
  • Jeżeli argument liczba ≤ 0 lub wybór_liczba < 0, funkcja PERMUTACJE zwraca wartość błędu #LICZBA!.
  • Jeżeli argument liczba < wybór_liczba, funkcja PERMUTACJE zwraca wartość błędu #LICZBA!.
  • Liczba permutacji wyraża się równaniem:

Przykład

Załóżmy, że chcemy obliczyć szansę wybrania wygrywającego losu loteryjnego. Każdy los loteryjny zawiera trzy numery, z których każdy może być z przedziału od 0 do 99 włącznie. Podana poniżej funkcja pozwala obliczyć liczbę możliwych permutacji.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
100 | Liczba obiektów
3 | Liczba obiektów w każdej permutacji
Formuła | Opis (Wynik)
=PERMUTACJE(A2;A3) | Permutacje możliwe dla podanych powyżej warunków (970200)


POZYCJA

Zwraca pozycję pewnej liczby na liście liczb. Pozycja liczby jest to jej wielkość w stosunku do innych wartości na liście. (Gdyby przeprowadzić sortowanie listy, pozycja liczby oznaczałaby jej miejsce na liście po sortowaniu.)

Składnia

POZYCJA(liczba;lista;lp)

Liczba to liczba, której pozycję chcemy znaleźć.

Lista to tablica albo odwołanie do listy liczb. Nieliczbowe wartości argumentu lista będą ignorowane.

Lp to liczba określająca sposób określania pozycji liczby.

  • Jeżeli argument lp jest 0 lub jest pominięty, pozycja liczby jest określana, jak gdyby argument lista był listą sortowaną w kolejności malejącej.
  • Jeżeli argument lp ma dowolną wartość niezerową, pozycja liczby jest określana, jak gdyby argument lista był listą sortowaną w kolejności rosnącej.

Spostrzeżenia

Funkcja POZYCJA nadaje podwójnym liczbom taką samą pozycję. Obecność podwójnych liczb ma jednak wpływ na pozycje następnych liczb. Na przykład na liście liczb całkowitych, jeżeli liczba 10 pojawia się dwukrotnie i ma pozycję 5, wówczas liczba 11 będzie miała pozycję 7 (żadna liczba nie będzie miała pozycji 6).

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
7
3,5
3,5
1
2
Formuła | Opis (Wynik)
=POZYCJA(A3;A2:A6;1) | Pozycja liczby 3,5 na podanej powyżej liście (3)
=POZYCJA(A2;A2:A6;1) | Pozycja liczby 7 na podanej powyżej liście (5)


PRAWDPD

Zwraca prawdopodobieństwo, że wartości w zakresie znajdują się pomiędzy dwiema granicami. Jeżeli argument górna_granica nie jest podany, funkcja ta zwraca prawdopodobieństwo, że wartości w zakres_x są równe dolna_granica.

Składnia

PRAWDPD(zakres_x;zakres_prawdop;dolna_granica;górna_granica)

Zakres_x to zakres wartości liczbowych x, z którymi związane są prawdopodobieństwa.

Zakres_prawdop to zestaw prawdopodobieństw związanych z wartościami w zakres_x.

Dolna_granica to dolna granica wartości, dla których poszukuje się prawdopodobieństwa.

Górna_granica to opcjonalna górna granica wartości, dla których poszukuje się prawdopodobieństwa.

Spostrzeżenia

  • Jeżeli jakaś wartość w argumencie zakres_prawdop ≤ 0 lub jeśli jakaś wartość w zakres_prawdop > 1, funkcja PRAWDPD zwraca wartość błędu #LICZBA!.
  • Jeżeli suma wartości w argumencie zakres_prawdop ą 1, funkcja PRAWDPD zwraca wartość błędu #LICZBA!.
  • Jeżeli argument górna_granica jest pominięty, funkcja PRAWDPD zwraca prawdopodobieństwo równości argumentowi dolna_granica.
  • Jeżeli argumenty zakres_x i zakres_prawdop zawierają inną liczbę punktów danych, funkcja PRAWDPD zwraca wartość błędu #N/D!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

x | Prawdopodobieństwo
0 | 0,2
1 | 0,3
2 | 0,1
3 | 0,4
Formuła | Opis (Wynik)
=PRAWDPD(A2:A5;B2:B5;2) | Prawdopodobieństwo, że x jest równe 2 (0,1)
=PRAWDPD(A2:A5;B2:B5;1;3) | Prawdopodobieństwo, że x jest zawarte między 1 a 3 (0,8)


PROCENT.POZYCJA

Zwraca procentową pozycję wartości w zestawie danych. Funkcja ta może być użyta do oceny względnej pozycji wartości w zbiorze danych. Na przykład funkcję PROCENT.POZYCJA można zastosować do oceny pozycji jakiegoś wyniku testu zdolności w zbiorze wyników testu.

Składnia

PROCENT.POZYCJA(tablica;x;istotność)

Tablica to tablica lub zakres danych z wartościami liczbowymi, który określa względną pozycję.

X to wartość, której pozycja ma być obliczona.

Znaczenie to wartość opcjonalna, która określa liczbę cyfr znaczących w zwracanej wartości procentowej. Jeżeli argument ten jest pominięty, funkcja PROCENT.POZYCJA stosuje trzy cyfry (0,xxx).

Spostrzeżenia

  • Jeżeli argument tablica jest argumentem pustym, funkcja PROCENT.POZYCJA zwraca wartość błędu #LICZBA!.
  • Jeżeli argument istotność < 1, funkcja PROCENT.POZYCJA zwraca wartość błędu #LICZBA!.
  • Jeżeli wartość argumentu x nie ma odpowiednika wśród wartości argumencie tablica, funkcja PROCENT.POZYCJA realizuje interpolację, aby zwrócić właściwą pozycję procentową.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
13
12
11
8
4
3
2
1
1
1
Formuła | Opis (Wynik)
=PROCENT.POZYCJA(A2:A11;2) | Procentowa pozycja liczby 2 na powyższej liście (0,333, ponieważ 3 wartości w zbiorze są mniejsze niż 2, a 6 jest większe niż 2; 3/(3+6)=0,333)
=PROCENT.POZYCJA(A2:A11;4) | Procentowa pozycja liczby 4 na powyższej liście (0,555)
=PROCENT.POZYCJA(A2:A11;8) | Procentowa pozycja liczby 8 na powyższej liście (0,666)
=PROCENT.POZYCJA(A2:A11;5) | Procentowa pozycja liczby 5 na powyższej liście (0,583, jedna czwarta drogi pomiędzy wartościami funkcji PROCENT.POZYCJA liczby 4 a PROCENT.POZYCJA liczby 8)

Uwaga Aby wyświetlić liczbę jako wartość procentową, należy zaznaczyć komórkę i kliknąć polecenie Polecenia i opcje [image] na pasku narzędzi. Następnie należy kliknąć kartę Format, a następnie zaznaczyć żądany format Procentowe w polu Format liczby.


PRÓG.ROZKŁAD.DWUM

Zwraca najmniejszą wartość, dla której wartość skumulowanego rozkładu dwumianowego jest większa lub równa wartości kryterium. Funkcja ta jest przydatna w badaniach dotyczących zapewnienia jakości. Na przykład można użyć funkcji PRÓG.ROZKŁAD.DWUM do wyznaczenia największej liczby wadliwych części, jakie mogą zejść z linii montażowej bez odrzucenia całej serii produkcyjnej.

Składnia

PRÓG.ROZKŁAD.DWUM(próby;prawdopodobieństwo_s;alfa)

Próby to liczba prób w schemacie Bernoulliego.

Prawdopodobieństwo_s to prawdopodobieństwo sukcesu w każdej próbie.

Alfa to wartość kryterium.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja PRÓG.ROZKŁAD.DWUM zwraca wartość błędu #ARG!.
  • Jeśli argument próby nie jest liczbą całkowitą, zostaje obcięty do liczby całkowitej.
  • Jeśli argument próby < 0, funkcja PRÓG.ROZKŁAD.DWUM zwraca wartość błędu #LICZBA!.
  • Jeśli argument prawdopodobieństwo_s < 0 lub argument prawdopodobieństwo_s > 1, funkcja PRÓG.ROZKŁAD.DWUM zwraca wartość błędu #LICZBA!.
  • Jeśli argument alfa < 0 lub argument alfa > 1, funkcja PRÓG.ROZKŁAD.DWUM zwraca wartość błędu #LICZBA!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
6 | Liczba prób w schemacie Bernoulliego
0,5 | Prawdopodobieństwo sukcesu w każdej próbie
0,75 | Wartość kryterium
Formuła | Opis (Wynik)
=PRÓG.ROZKŁAD.DWUM (A2;A3;A4) | Najmniejsza wartość, dla której wartość skumulowanego rozkładu dwumianowego jest większa lub równa wartości kryterium (4)


R.KWADRAT

Zwraca kwadrat współczynnika korelacji liniowej Pearsona przez punkty danych określone argumentami znane_y i znane_x. Więcej informacji można znaleźć w opisie funkcji PEARSON. Kwadrat wartości r można interpretować jako stosunek wariancji w zbiorze y do wariancji w zbiorze x.

Składnia

R.KWADRAT(znane_y;znane_x)

Znane_y to tablica lub zakres punktów danych.

Znane_x to tablica lub zakres punktów danych.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami bądź odwołaniami, które zawierają liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeżeli znane_y i znane_x są puste lub mają różną liczbę punktów danych, wówczas funkcja R.KWADRAT zwraca wartość błędu #N/D!.
  • Równaniem wartości r wykresu regresji jest:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Znane y | Znane x
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
7 | 4
5 | 4
Formuła | Opis (Wynik)
=RSQ(A2:A8;B2:B8) | Kwadrat współczynnika korelacji liniowej Pearsona przez punkty powyższe danych (0,05795)


REGBŁSTD

Zwraca standardowy błąd prognozowanej wartości y dla każdego x przy regresji. Błąd standardowy jest miarą stopnia błędu prognozowania wartości y dla poszczególnych wartości x.

Składnia

REGBŁSTD(znane_y;znane_x)

Znane_y to tablica lub zakres zależnych punktów danych.

Znane_x to tablica lub zakres niezależnych punktów danych.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami bądź odwołaniami, które zawierają liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeżeli argumenty znane_y i znane_x są puste lub mają inną liczbę punktów danych, funkcja REGBŁSTD daje w wyniku wartość błędu #N/D.
  • Równanie na standardowy błąd prognozowanej wartości y jest następujące:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Znane y | Znane x
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
7 | 4
5 | 4
Formuła | Opis (Wynik)
=REGBŁSTD(A2:A8;B2:B8) | Błąd standardowy prognozowanej wartości y dla każdego x przy regresji (3,305719)


REGEXPP

W analizie regresji oblicza krzywą wykładniczą, która jest przybliżeniem danych i zwraca tablicę wartości opisujących krzywą. Ponieważ ta funkcja zwraca tablicę wartości, musi być wprowadzona jako formuła tablicowa.

Równanie krzywej jest następujące:

y = b*m^x lub y = (b*(m1^x1)*(m2^x2)*_) (jeśli jest wiele wartości x)

gdzie zależne wartości y są funkcją niezależnych wartości x. Wartości m są podstawami odpowiadającymi każdej wartości wykładniczej x, a b jest wartością stałą. Należy zauważyć, że y, x i m mogą być wektorami. Funkcja REGEXPP zwraca tablicę {mn;mn-1;...;m1;b}.

Składnia

REGEXPP(znane_y;znane_x;stała;statystyka)

Znane_y to zestaw wartości y, które mogą już być znane, wyrażonych zależnością y = b*m^x.

  • Jeżeli tablica znane_y jest pojedynczą kolumną, wtedy każda kolumna tablicy znane_x jest interpretowana jako oddzielna zmienna.

  • Jeżeli tablica znane_y jest pojedynczym wierszem, wówczas każdy wiersz tablicy znane_x jest interpretowany jako oddzielna zmienna.

Znane_x to opcjonalny zestaw wartości x, które mogą być już znane w zależności y = b*m^x.

  • Tablica znane_x może zawierać jeden lub kilka zestawów zmiennych. Jeżeli wykorzystywana jest tylko jedna zmienna, argumenty znane_y i znane_x mogą być zakresami dowolnego kształtu, jeżeli tylko mają jednakowe wymiary. Jeśli używanych jest kilka zmiennych, argument znane_y musi być wektorem (tj. zakresem o wysokości jednego wiersza lub o szerokości jednej kolumny).

  • Jeżeli znane_x pominie się, argument ten jest przyjmowany jako tablica {1;2;3;...}, która ma taki sam rozmiar, jak znane_y.

Stała to wartość logiczna określająca, czy ma być wymuszana wartość stałej b równa 1.

  • Jeżeli argument stała ma wartość PRAWDA lub jest pominięty, stała b jest obliczana normalnie.

  • Jeśli stała ma wartość FAŁSZ, to stała b jest ustawiana na wartość 1, a wartości m są dopasowywane do równania y = m^x.

Statystyka to wartość logiczna określająca, czy należy wyznaczyć dodatkowe statystyki regresji.

  • Jeśli argument statystyka ma wartość PRAWDA, funkcja REGEXPP zwraca dodatkowe statystyki regresji tak, że zwracana tablica przedstawia się następująco: {mn;mn-1;...;m1;b;sen;sen-1;...;se1;seb;r 2;sey; F;df;ssreg;ssresid}.

  • Jeśli argument statystyka ma wartość FAŁSZ lub został pominięty, to funkcja REGEXPP zwraca jedynie współczynniki m i stałą b.

Więcej informacji na temat dodatkowych statystyk regresji można znaleźć w opisie funkcji REGLINP.

Spostrzeżenia

  • Im bardziej wykres danych przypomina krzywą wykładniczą, tym lepiej wyznaczona krzywa jest dopasowana do danych. Podobnie jak funkcja REGLINP, funkcja REGEXPP zwraca tablicę wartości opisującą związek między wartościami, ale funkcja REGLINP dopasowuje do danych linię prostą, natomiast funkcja REGEXPP dopasowuje krzywą wykładniczą. Więcej informacji można znaleźć w opisie funkcji REGLINP.
  • Wtedy gdy jest tylko jedna zmienna niezależna x, można bezpośrednio uzyskać wartość nachylenia (m) i przecięcia z osią y (b), stosując poniższe formuły:

    Nachylenie (m):
    INDEKS(REGEXPP(znane_y;znane_x);1)

    Przecięcie z osią Y (b):
    INDEKS(REGEXPP(znane_y;znane_x);2)

    Do przewidywania przyszłych wartości y można używać równania y = b*m^x, lecz zamiast tego można wykorzystać funkcję REGEXPW. Więcej informacji na ten temat można znaleźć w opisie funkcji REGEXPW.

  • Formuły, które zwracają tablice, muszą być wprowadzone jako formuły tablicowe.
  • Podczas wprowadzania jako argumentu stałej tablicowej, takiej jak znane_x, wartości w tym samym wierszu należy rozdzielać średnikami, a wartości w tej samej kolumnie — kreskami ułamkowymi odwróconymi (\). Znaki separatora mogą się różnić w zależności od ustawień w oknie Ustawienia regionalne albo Opcje regionalne w Panelu sterowania.
  • Należy mieć na względzie, że wartości y prognozowane przez równanie regresji mogą nie być poprawne, jeśli znajdują się poza zakresem wartości y użytych do wyznaczenia równania.

Przykład 1: współczynniki m i stała b

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Miesiąc | Jednostki
11 | 33 100
12 | 47 300
13 | 69 000
14 | 102 000
15 | 150 000
16 | 220 000
Formuła | Formuła
=REGEXPP(B2:B7;A2:A7; PRAWDA; FAŁSZ) |

Uwaga Formuła w tym przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego, wybierz zakres A9:B13 poczynając od komórki zawierającej formułę. Naciśnij klawisz F2, a następnie naciśnij klawisze CTRL+SHIFT+ENTER. Jeżeli formuła nie została wprowadzona jako formuła tablicowa, jedynym wynikiem będzie liczba 1,463275628.

Kiedy formuła zostanie wprowadzona jako formuła tablicowa, zwracane są współczynniki m i stała b.

y = b*m1^x1

albo używając wartości z tablicy:

y = 495,3 * 1,4633x

Można przewidzieć sprzedaż na następne miesiące przez podstawienie liczby miesięcy zamiast x do tego równania albo zastosować funkcję REGEXPW.

Przykład 2: Pełna statystyka

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Miesiąc | Jednostki
11 | 33 100
12 | 47 300
13 | 69 000
14 | 102 000
15 | 150 000
16 | 220 000
Formuła
=REGEXPP(B2:B7;A2:A7; PRAWDA; PRAWDA)

Uwaga Formuła w tym przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego, wybierz zakres A9:B13 poczynając od komórki zawierającej formułę. Naciśnij klawisz F2, a następnie naciśnij klawisze CTRL+SHIFT+ENTER. Jeżeli formuła nie została wprowadzona jako formuła tablicowa, jedynym wynikiem będzie liczba 1,463275628.

Kiedy formuła zostanie wprowadzona jako formuła tablicowa, zwracane są następujące statystyki regresji. Użyj tego klucza do identyfikacji żądanej statystyki.

Do wyznaczenia użyteczności równania do prognozowania przyszłych wartości można użyć dodatkowych statystyk regresji (komórki A10:B13 powyższej tablicy wyjściowej).

Ważne Metody używane do weryfikacji równania za pomocą funkcji REGEXPP są podobne do metod stosowanych dla funkcji REGLINP. Jednakże do uzyskania dodatkowych statystyk REGEXPP wykorzystano poniższy model liniowy:

ln y = x1 ln m1 + ... + xn ln mn + ln b

Należy mieć to na uwadze weryfikując statystyki dodatkowe, szczególnie wartości sei i seb, które należałoby porównać z wartościami ln mi i ln b, a nie z wartościami mi i b. Więcej informacji na ten temat można znaleźć w zaawansowanym podręczniku statystyki.


REGEXPW

Oblicza przewidywany wzrost o skali wykładniczej na podstawie istniejących danych. Funkcja REGEXPW zwraca wartości y dla serii nowych wartości x, określonych na podstawie istniejących wartości x i y. Funkcja REGEXPW jest również przydatna w tworzeniu krzywej wykładniczej uwzględniającej istniejące wartości x i y.

Składnia

REGEXPW(znane_y;znane_x;nowe_x,stała)

Znane_y to zestaw wartości y, które mogą już być znane, wyrażonych zależnością y = b*m^x.

  • Jeżeli tablica znane_y jest pojedynczą kolumną, wtedy każda kolumna tablicy znane_x jest interpretowana jako oddzielna zmienna.

  • Jeżeli tablica znane_y jest pojedynczym wierszem, wówczas każdy wiersz tablicy znane_x jest interpretowany jako oddzielna zmienna.

  • Jeśli którakolwiek z liczb w tablicy znane_y jest zerem lub ma wartość ujemną, funkcja REGEXPW zwraca wartość błędu #LICZBA!.

Znane_x to opcjonalny zestaw wartości x, które mogą być już znane w zależności y = b*m^x.

  • Tablica znane_x może zawierać jeden lub więcej zbiorów zmiennych. Jeżeli użyta jest tylko jedna zmienna, znane_y i znane_x mogą być zakresami dowolnego kształtu, jeżeli tylko mają jednakowe wymiary. Jeżeli korzysta się z więcej niż jednej zmiennej, znane_y musi być wektorem (tzn. zakresem o wysokości jednego wiersza lub szerokości jednej kolumny).

  • Jeżeli znane_x pominie się, argument ten jest przyjmowany jako tablica {1;2;3;...}, która ma taki sam rozmiar, jak znane_y.

Nowe_x to zbiór nowych wartości x, dla których funkcja REGEXPW ma zwrócić odpowiednie wartości y.

  • Argument nowe_x musi zawierać kolumnę (lub wiersz) dla każdej zmiennej niezależnej, tak samo jak argument znane_x. A zatem, jeśli znane_y to pojedyncza kolumna, argumenty znane_x i nowe_x muszą zawierać taką samą liczbę kolumn. Jeśli argument znane_y zawiera się w pojedynczym wierszu, argumenty znane_x i nowe_x muszą składać się z takiej samej liczby wierszy.

  • Jeśli argument nowe_ x zostanie pominięty, przyjmuje się, że jest on taki sam, jak argument znane_x.

  • Jeśli zostanie pominięty zarówno argument znane_x, jak i argument nowe_x, przyjmuje się, że mają one postać tablicy {1;2;3;...}, która ma taki sam rozmiar, jak tablica argumentu znane_y.

Stała to wartość logiczna określająca, czy ma być wymuszana wartość stałej b równa 1.

  • Jeżeli argument stała ma wartość PRAWDA lub jest pominięty, stała b jest obliczana normalnie.

  • Jeśli argument stała ma wartość FAŁSZ, stała b przybiera wartość 1, a wartości m są dobierane tak, aby y = m^x.

Spostrzeżenia

  • Formuły, które zwracają wynik w postaci tablic, muszą być wprowadzane jako formuły tablicowe po wybraniu poprawnej liczby komórek.
  • Przy wprowadzaniu stałej tablicy dla argumentu takiego jak znane_x należy rozdzielać średnikami wartości w tym samym wierszu, a kreskami ułamkowymi odwróconymi rozdzielać wiersze.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

W przykładzie tym wykorzystano te same dane, co w przykładzie dla funkcji REGEXPP. Pierwsza formuła pokazuje dane odpowiadające wartościom znanym. Druga formuła przewiduje wartości dla przyszłego miesiąca, jeśli kontynuowany będzie trend wykładniczy.

Miesiąc | Jednostki | Formuła (odpowiadające jednostki)
11 | 33 100 | =REGEXPW(B2:B7;A2:A7)
12 | 47 300 |
13 | 69 000 |
14 | 102 000 |
15 | 150 000 |
16 | 220 000 |
Miesiąc | Formuła (przewidywane jednostki)
17 | =REGEXPW(B2:B7;A2:A7;A9:A10)
18 |

Uwaga Formuła w tym przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego zaznacz zakres C2:C7 lub B9:B10, rozpoczynając od komórki zawierającej formułę. Naciśnij klawisz F2, a następnie naciśnij klawisze CTRL+SHIFT+ENTER. Jeśli formuła nie zostanie wprowadzona jako formuła tablicowa, zostaną zwrócone jedynie wartości 32618,20377 i 20196,7184.


REGLINP

Funkcja ta oblicza statystykę dla prostej, stosując metodę najmniejszych kwadratów w celu wyznaczenia przebiegu linii prostej najlepiej odzwierciedlającej wartości danych i zwracając tablicę opisującą linię. Ponieważ funkcja zwraca tablicę wartości, musi być wprowadzona jako formuła tablicowa.

Równanie prostej ma postać:

y = mx + b

lub

y = m1x1 + m2x2 + ... + b (jeśli istnieje wiele zakresów wartości x)

gdzie wartość zmiennej zależnej y jest funkcją wartości zmiennych niezależnych x. Wartości m są współczynnikami odpowiadającymi każdej wartości zmiennej x, a b jest wartością stałą. Należy zauważyć, że y, x i m mogą być wektorami. Tablica zwracana przez funkcję REGLINP ma postać {mn;mn-1;...;m1;b}. Funkcja REGLINP może również zwracać dodatkową statystykę regresji.

Składnia

REGLINP(znane_y;znane_x;stała;statystyki)

Znane_y to zbiór znanych już wartości y w zależności y = mx + b.

  • Jeżeli tablica znane_y jest pojedynczą kolumną, wtedy każda kolumna tablicy znane_x jest interpretowana jako oddzielna zmienna.

  • Jeżeli tablica znane_y jest pojedynczym wierszem, wówczas każdy wiersz tablicy znane_x jest interpretowany jako oddzielna zmienna.

Znane_x to opcjonalny zbiór wartości x, który może być już znany w zależności y = mx + b.

  • Tablica znane_x może zawierać jeden lub więcej zbiorów zmiennych. Jeżeli użyta jest tylko jedna zmienna, znane_y i znane_x mogą być zakresami dowolnego kształtu, jeżeli tylko mają jednakowe wymiary. Jeżeli korzysta się z więcej niż jednej zmiennej, znane_y musi być wektorem (tzn. zakresem o wysokości jednego wiersza lub szerokości jednej kolumny).

  • Jeżeli znane_x pominie się, argument ten jest przyjmowany jako tablica {1;2;3;...}, która ma taki sam rozmiar, jak znane_y.

Stała to wartość logiczna określająca, czy ma być wymuszana wartość stałej b równa 0.

  • Jeżeli argument stała ma wartość PRAWDA lub jest pominięty, stała b jest obliczana normalnie.

  • Jeśli argument stała ma wartość FAŁSZ, to stałej b jest nadawana wartość 0, a wartości m są tak dobierane, aby spełniały równość y = mx.

Statystyka to wartość logiczna określająca, czy należy wyznaczyć dodatkowe statystyki regresji.

  • Jeśli argument statystyki ma wartość PRAWDA, funkcja REGLINP zwraca dodatkowe statystyki regresji, więc zwracana tablica ma postać {mn;mn-1;...;m1;b\sen;sen-1;...;se1;seb\r2;sey\F;df\ssreg;ssresid}.

  • Jeśli argument statystyki ma wartość FAŁSZ lub jest pominięty, to funkcja REGLINP zwraca tylko współczynniki m i stałą b.

Dodatkowe statystyki regresji są następujące:

Statystyka | Opis
se1;se2;...;sen | Standardowe wartości błędów dla współczynników m1,m2,...,mn.
Seb | Standardowa wartość błędu dla stałej b (jeśli argument stała ma wartość FAŁSZ, seb = #N/D).
r2 | Współczynnik wyznaczania. Porównuje szacunkowe i rzeczywiste wartości y, a jego wartość zawiera się w granicach od 0 do 1. Jeśli współczynnik ma wartość 1, w próbce istnieje doskonała korelacja, tzn. nie ma różnicy między szacowaną a rzeczywistą wartością y. Jeśli współczynnik wyznaczania ma wartość 0, to równanie regresji nie jest pomocne w przewidywaniu wartości y. Aby uzyskać informacje dotyczące sposobu obliczania współczynnika r2, zobacz rozdział „Spostrzeżenia” w dalszej części tego tematu.
sey | Standardowy błąd oceny wartości y.
F | Statystyka F lub wartość obserwowana F. Statystyka F służy do określania, czy obserwowana zależność między zmienną zależną a zmienną niezależną jest przypadkowa.
df | Stopnie swobody. Stopnie swobody pomagają odnajdywać wartości krytyczne F w tablicy statystycznej. Porównanie wartości znalezionych w tabeli ze statystyką F zwróconą przez funkcję REGLINP umożliwia określenie poziomu ufności modelu.
ssreg | Regresyjna suma kwadratów.
ssresid | Resztkowa suma kwadratów.

Na poniższej ilustracji pokazano kolejność zwracania dodatkowych statystyk regresji.

Spostrzeżenia

  • Można opisać dowolną prostą mającą nachylenie i przecinającą oś y:

    Nachylenie (m):
    Aby znaleźć nachylenie prostej, często oznaczane jako m, należy obrać dwa różne punkty (x1,y1) i (x2,y2) leżące na prostej. Nachylenie jest równe (y2 — y1)/(x2 — x1).

    Punkt przecięcia z osią y (b):
    Punkt przecięcia prostej z osią y, często oznaczany jako b, to wartość y w punkcie, w którym prosta przecina oś y.

    Równanie prostej ma postać y = mx + b. Jeśli znane są wartości m i b, to można obliczyć każdy punkt na prostej, podstawiając w równaniu wartości x lub y. Można również użyć funkcji REGLINW.

  • Jeśli dana jest tylko jedna zmienna niezależna x, to bezpośrednio można otrzymać nachylenie i punkt przecięcia z osią y za pomocą następujących formuł:

    Nachylenie:
    =INDEKS(REGLINP(znane_y;znane_x);1)

    Punkt przecięcia z osią y:
    =INDEKS(REGLINP(znane_y;znane_x);2)

  • Dokładność przebiegu prostej, obliczonego za pomocą funkcji REGLINP, zależy od stopnia rozrzutu danych. Im bardziej dane są liniowe, tym dokładniejszy jest model tworzony przez funkcję REGLINP. Funkcja REGLINP korzysta z metody najmniejszych kwadratów w celu najlepszego odzwierciedlenia wartości danych. Jeśli dostępna jest tylko jedna zmienna niezależna x, to obliczenia wartości m i b oparte są na następujących formułach:

  • Funkcje dopasowania do prostej i krzywej REGLINP i REGEXPP umożliwiają wyznaczenie najlepszego przebiegu linii prostej lub krzywej wykładniczej odzwierciedlającej wartości danych. Dla linii prostej używana jest funkcja REGLINW(znane_y;znane_x), a dla krzywej wykładniczej funkcja REGEXPW(znane_y;znane_x). Jeśli funkcje nie zawierają argumentu nowe_x, to zwracają wzdłuż danej prostej lub krzywej tablicę wartości y przewidywanych dla rzeczywistych punktów danych. Można następnie porównać wartości przewidywane z rzeczywistymi. Oba zbiory wartości można również przedstawić na wykresie, co ułatwia ich wizualne porównanie.
  • W analizie metodą regresji dla każdego punktu obliczany jest kwadrat różnicy pomiędzy wartością y szacowaną dla tego punktu a jego rzeczywistą wartością y. Suma kwadratów różnic nazywana jest resztkową sumą kwadratów. Następnie obliczana jest suma kwadratów różnic między rzeczywistymi wartościami y a średnią z wartości y, która jest nazywana łączną sumą kwadratów (regresyjna suma kwadratów + resztkowa suma kwadratów). Im mniejsza jest resztkowa suma kwadratów w porównaniu z łączną sumą kwadratów, tym większa jest wartość współczynnika wyznaczania r2, który wskazuje, w jakim stopniu równanie wynikające z analizy metodą regresji wyjaśnia zależność pomiędzy zmiennymi.
  • Formuły, które zwracają tablice, muszą być wprowadzone jako formuły tablicowe.
  • Podczas wprowadzania jako argumentu stałej tablicowej, takiej jak znane_x, wartości w tym samym wierszu należy rozdzielać średnikami, a wartości w tej samej kolumnie — kreskami ułamkowymi odwróconymi (\). Znaki separatora mogą się różnić w zależności od ustawień w oknie Ustawienia regionalne albo Opcje regionalne w Panelu sterowania.
  • Należy zauważyć, że przewidziane na podstawie równania regresji wartości y nie muszą być prawidłowe, jeśli znajdują się poza zakresem wartości y użytym w równaniu.

Przykład 1 Nachylenie i punkt przecięcia z osią y

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Znane y | Znane x
1 | 0
9 | 4
5 | 2
7 | 3
Wzór | Wzór
=REGLINP(A2:A5;B2:B5;;FAŁSZ) |

Uwaga Formuła w tym przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego należy zaznaczyć zakres A7:B7, rozpoczynając od komórki zawierającej formułę. Trzeba nacisnąć klawisz F2, a następnie kombinację klawiszy CTRL+SHIFT+ENTER. Jeśli formuła nie będzie wprowadzona w postaci formuły tablicowej, jedynym wynikiem będzie liczba 2.

Po wprowadzeniu formuły jako formuły tablicowej zwracane są wartości nachylenia (2) i punktu przecięcia z osią y (1).

Przykład 2 Prosta regresja liniowa

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Miesiąc | Sprzedaż
1 | 3 100
2 | 4 500
3 | 4 400
4 | 5 400
5 | 7 500
6 | 8 100
Formuła | Opis (Wynik)
=SUMA(REGLINP(B2:B7;A2:A7)*{9;1}) | Szacowana wartość sprzedaży w dziewiątym miesiącu (11 000)

Zazwyczaj wartość SUMA({m;b}*{x;1}) jest równa wartości mx + b, czyli szacowanej wartości y dla danej wartości x. Można również użyć funkcji REGLINW.

Uwaga Formuła w tym przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego należy zaznaczyć komórkę zawierającą formułę (A9). Trzeba nacisnąć klawisz F2, a następnie kombinację klawiszy CTRL+SHIFT+ENTER.

Przykład 3 Wielokrotna regresja liniowa

Załóżmy, że deweloper rozważa zakup grupy niewielkich biurowców w uznanej dzielnicy biurowej.

Może on zastosować analizę metodą wielokrotnej regresji liniowej, aby oszacować wartość biurowca na danym terenie na podstawie następujących zmiennych.

Zmienna | Dotyczy
y | Szacowana wartość biurowca
x1 | Powierzchnia w metrach kwadratowych
x2 | Liczba lokali biurowych
x3 | Liczba wejść
x4 | Wiek budynku w latach

W przykładzie założono, że istnieje zależność prostoliniowa między każdą ze zmiennych niezależnych (x1, x2, x3 i x4) a zmienną zależną (y), czyli wartością biurowców na danym terenie.

Deweloper wybiera losowo próbkę złożoną z 11 spośród możliwych 1 500 biurowców i otrzymuje następujące dane. „Połowa wejścia” oznacza wejście tylko dla dostawców.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Powierzchnia biurowa (x1) | Liczba lokali biurowych (x2) | Liczba wejść (x3) | Wiek (x4) | Szacowana wartość (y)
2 310 | 2 | 2 | 20 | 142 000
2 333 | 2 | 2 | 12 | 144 000
2 356 | 3 | 1,5 | 33 | 151 000
2 379 | 3 | 2 | 43 | 150 000
2 402 | 2 | 3 | 53 | 139 000
2 425 | 4 | 2 | 23 | 169 000
2 448 | 2 | 1,5 | 99 | 126 000
2 471 | 2 | 2 | 34 | 142 900
2 494 | 3 | 3 | 23 | 163 000
2 517 | 4 | 4 | 55 | 169 000
2 540 | 2 | 3 | 22 | 149 000
Formuła
=REGLINP(E2:E12;A2:D12;PRAWDA;PRAWDA)

Uwaga Formuła w tym przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego należy zaznaczyć zakres A14:B18, rozpoczynając od komórki zawierającej formułę. Trzeba nacisnąć klawisz F2, a następnie kombinację klawiszy CTRL+SHIFT+ENTER. Jeśli formuła nie będzie wprowadzona w postaci formuły tablicowej, jedynym wynikiem będzie liczba -234,2371645.

Kiedy formuła zostanie wprowadzona jako formuła tablicowa, zwracane są następujące statystyki regresji. Użyj tego klucza do identyfikacji żądanej statystyki.

Stosując wartości z wiersza 14 można otrzymać równanie regresji wielokrotnej, y = m1*x1 + m2*x2 + m3*x3 + m4*x4 + b:

y = 27,64*x1 + 12 530*x2 + 2 553*x3+ 234,24*x4 + 52 318

Stosując poniższe równanie, deweloper może ocenić wartość usytuowanego na tym samym terenie budynku biurowego, którego powierzchnia wynosi 2 500 metrów kwadratowych, wiek — 25 lat. Budynek ma trzy lokale biurowe i dwa wejścia:

y = 27,64*2 500 + 12 530*3 + 2 553*2 — 234,24*25 + 52 318 = 158 261 zł

Do komórki A21 przykładowego arkusza można również skopiować poniższą tabelę.

Powierzchnia biurowa (x1) | Liczba lokali biurowych (x2) | Liczba wejść (x3) | Wiek (x4) | Szacowana wartość (y)
2 500 | 3 | 2 | 25 | =$D$14*$A$22 +$C$14*$B$22 + $B$14*$C$22 +$A$14*$D$22 +$E$14

Aby obliczyć tę wartość, można także zastosować funkcję REGLINW.

Przykład 4 Wykorzystanie statystyk F i r2

W poprzednim przykładzie współczynnik wyznaczania (r2) wynosi 0,99675 (patrz komórka A17 w wyniku funkcji REGLINP), co oznaczałoby silną zależność między zmiennymi niezależnymi a ceną sprzedaży. Można użyć statystyki F do określenia, czy wyniki te, przy tak wysokiej wartości r2, wystąpiły przypadkowo.

Przyjmijmy na chwilę, że w rzeczywistości nie ma żadnej zależności między zmiennymi, ale została przyjęta rzadka próbka z 11 biurowców, która powoduje, że analiza statystyczna wskazuje na silną zależność. Dla określenia prawdopodobieństwa błędnego wnioskowania o istnieniu zależności stosowane jest pojęcie „Alfa”.

Zależność między zmiennymi istnieje, jeżeli statystyka obserwowana F jest większa niż wartość krytyczna F. Wartość krytyczną F można znaleźć w tabeli wartości krytycznych F znajdującej się w wielu podręcznikach statystyki. Podczas odczytywania tabeli należy przyjąć test jednostronny, wartość Alfa równą 0,05, a dla stopni swobody (oznaczanych skrótowo w większości tabel jako v1 i v2) przyjąć równania v1 = k = 4 i v2 = n — (k + 1) = 11 — (4 + 1) = 6, gdzie k jest liczbą zmiennych w analizie metodą regresji, a n jest liczbą punktów danych. Wartość krytyczna F wynosi 4,53.

Wartość obserwowana F wynosi 459,753674 (komórka A18), a więc jest znacznie większa niż wartość krytyczna F wynosząca 4,53. Dlatego też równanie regresji jest użyteczne przy prognozowaniu szacunkowej wartości biurowców na tym terenie.

Przykład 5 Obliczanie statystyk t

Inny hipotetyczny test będzie określał, czy do oceny szacunkowej wartości biurowca w przykładzie 3 przydatny jest każdy współczynnik nachylenia. Na przykład aby sprawdzić znaczenie statystyczne współczynnika wieku, należy podzielić wartość -234,24 (współczynnik nachylenia odpowiadający wiekowi) przez wartość 13,268 (szacunkowy standardowy błąd współczynników wieku, widoczny w komórce A15). Poniżej przedstawiono wartości obserwowaną t:

t = m4 ÷ se4 = -234,24 ÷ 13,268 = -17,7

W tabeli podręcznika do statystyki można odczytać, że wartość dla jednostronnego testu krytycznego t z 6 stopniami swobody przy współczynniku Alfa = 0,05 wynosi 1,94. Ponieważ wartość bezwzględna t, wynosząca 17,7, jest większa niż 1,94, wiek jest ważną zmienną podczas oceny szacunkowej wartości biurowca. W podobny sposób można sprawdzić pod względem ważności statystycznej każdą z pozostałych zmiennych niezależnych. Poniżej przedstawiono wartości obserwowane t dla każdej ze zmiennych niezależnych:

Zmienna | wartość obserwowana t
Powierzchnia | 5,1
Liczba lokali biurowych | 31,3
Liczba wejść | 4,8
Wiek | 17,7

Wartość bezwzględna wszystkich tych wartości jest większa niż 1,94, a zatem wszystkie zmienne użyte w równaniu regresji są potrzebne przy prognozowaniu szacunkowej wartości biurowców na tym terenie.


REGLINW

Zwraca wartości wzdłuż trendu liniowego. Dopasowuje prostą (metodą najmniejszych kwadratów) do tablic znane_y i znane_x. Daje w wyniku wartości y wzdłuż tej prostej dla podanej przez użytkownika tablicy nowe_x.

Składnia

REGLINW(znane_y;znane_x;nowe_x;stała)

Znane_y to zbiór znanych już wartości y w zależności y = mx + b.

  • Jeżeli tablica znane_y jest pojedynczą kolumną, wtedy każda kolumna tablicy znane_x jest interpretowana jako oddzielna zmienna.

  • Jeżeli tablica znane_y jest pojedynczym wierszem, wówczas każdy wiersz tablicy znane_x jest interpretowany jako oddzielna zmienna.

Znane_x to opcjonalny zbiór wartości x, który może być już znany w zależności y = mx + b.

  • Tablica znane_x może zawierać jeden lub więcej zbiorów zmiennych. Jeżeli użyta jest tylko jedna zmienna, znane_y i znane_x mogą być zakresami dowolnego kształtu, jeżeli tylko mają jednakowe wymiary. Jeżeli korzysta się z więcej niż jednej zmiennej, znane_y musi być wektorem (tzn. zakresem o wysokości jednego wiersza lub szerokości jednej kolumny).

  • Jeżeli znane_x pominie się, argument ten jest przyjmowany jako tablica {1;2;3;...}, która ma taki sam rozmiar, jak znane_y.

Nowe_x to nowe wartości x, dla których funkcja REGLINW ma zwrócić odpowiednie wartości y.

  • Argument nowe_x musi zawierać kolumnę (lub wiersz) dla każdej zmiennej niezależnej, tak samo jak argument znane_x. A zatem, jeśli znane_y to pojedyncza kolumna, argumenty znane_x i nowe_x muszą zawierać taką samą liczbę kolumn. Jeśli argument znane_y zawiera się w pojedynczym wierszu, argumenty znane_x i nowe_x muszą składać się z takiej samej liczby wierszy.

  • Jeżeli pominie się nowe_x, wówczas argument ten jest przyjmowany domyślnie jako taki sam, jak argument znane_x.

  • Jeżeli pominie się zarówno argument znane_x, jak i argument nowe_x, są one przyjmowane jako tablica {1;2;3;...}, która ma taki sam rozmiar jak argument znane_y.

Stała to wartość logiczna określająca, czy ma być wymuszana wartość stałej b równa 0.

  • Jeżeli argument stała ma wartość PRAWDA lub jest pominięty, stała b jest obliczana normalnie.

  • Jeżeli argument stała ma wartość FAŁSZ, stała b jest ustawiana jako równa 0, a wartości m są ustawiane tak, że y = mx.

Spostrzeżenia

  • Aby uzyskać informacje dotyczące sposobu dopasowywania prostej do danych, zobacz opis funkcji REGLINP.
  • Można użyć funkcji REGLINW do dopasowywania krzywej wielomianowej przez regresję wobec tej samej zmiennej podniesionej do różnych potęg. Przykładowo można przyjąć, że kolumna A zawiera wartości y, a kolumna B zawiera wartości x. Można wstawić x^2 do kolumny C, x^3 do kolumny D itd., a następnie przeprowadzić regresję kolumn od B do D wobec kolumny A.
  • Formuły, które zwracają tablice, muszą być wprowadzone jako formuły tablicowe.
  • Przy wprowadzaniu stałej tablicy dla argumentu takiego jak znane_x należy rozdzielać średnikami wartości w tym samym wierszu, a kreskami ułamkowymi odwróconymi rozdzielać wiersze.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Pierwsza formuła przedstawia wartości odpowiadające wartościom znanym. Druga formuła umożliwia prognozowanie wartości dla następnych miesięcy przy założeniu, że zostanie zachowany trend liniowy.

Miesiąc | Koszt | Formuła (odpowiadający koszt)
1 | 133 890 zł | =REGLINW(B2:B13;A2:A13)
2 | 135 000 zł |
3 | 135 790 zł |
4 | 137 300 zł |
5 | 138 130 zł |
6 | 139 100 zł |
7 | 139 900 zł |
8 | 141 120 zł |
9 | 141 890 zł |
10 | 143 230 zł |
11 | 144 000 zł |
12 | 145 290 zł |
Miesiąc | Formuła (koszt prognozowany)
13 | =REGLINW(B2:B13;A2:A13;A15:A19)
14 |
15 |
16 |
17 |

Uwaga Formuła w tym przykładzie musi być wprowadzona jako formuła tablicowa. Po skopiowaniu przykładu do pustego arkusza kalkulacyjnego należy zaznaczyć zakres C2:C13 lub B15:B19, zaczynając od komórki z formułą. Należy nacisnąć klawisz F2, a następnie klawisze CTRL+SHIFT+ENTER. Jeśli formuła nie zostanie wprowadzona jako formuła tablicowa, pojedyncze wyniki będą miały postać 133953,3333 i 146171,5152.


REGLINX

Oblicza czyli przewiduje wartość przyszłą na podstawie dostępnych wartości obecnych. Wartość przewidywana jest to wartość y dla danej wartości x. Wartościami znanymi są istniejące wartości x i y, a nowa wartość jest obliczana za pomocą regresji liniowej. Funkcja ta jest przydatna w przewidywaniu przyszłego poziomu sprzedaży, wymagań dotyczących zapasów lub trendów konsumpcyjnych.

Składnia

REGLINX(x;znane_y;znane_x)

X to punkt danych, dla którego ma zostać dokonana prognoza wartości.

Znane_y to tablica lub zakres danych zależnych.

Znane_x to tablica lub zakres danych niezależnych.

Spostrzeżenia

  • Jeśli argument x nie jest liczbą, funkcja REGLINX zwraca wartość błędu #ARG!.
  • Jeśli argumenty znane_y i znane_x są puste lub zawierają różną liczbę punktów danych, funkcja REGLINX zwraca wartość błędu #N/D!.
  • Jeśli wariancja argumentu znane_x jest równa zeru, funkcja REGLINX zwraca wartość błędu #DZIEL/0!.
  • Równanie funkcji REGLINX ma postać a+bx, gdzie:

    i:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Znane y | Znane x
6 | 20
7 | 28
9 | 31
15 | 38
21 | 40
Formuła | Opis (Wynik)
=REGLINX(30;A2:A6;B2:B6) | Przewiduje wartość y przy danej wartości x równej 30 (10,60725)


ROZKŁAD.BETA

Zwraca funkcję skumulowanego rozkładu gęstości prawdopodobieństwa beta. Funkcji tej używa się zazwyczaj do badania rozrzutu procentowego wielkości wśród próbek, na przykład części doby, jaką ludzie spędzają na oglądaniu telewizji.

Składnia

ROZKŁAD.BETA(x;alfa;beta;A;B)

X to wartość między A i B, dla której należy obliczyć funkcję.

Alfa to parametr rozkładu.

Beta to parametr rozkładu.

A to opcjonalna dolna granica przedziału wartości x.

B to opcjonalna górna granica przedziału wartości x.

Spostrzeżenia

  • Jeśli jakikolwiek argument nie jest liczbą, to funkcja ROZKŁAD.BETA zwraca wartość błędu #ARG!.
  • Jeśli wartość argumentu alfa ≤ 0 lub wartość argumentu beta ≤ 0, to funkcja ROZKŁAD.BETA zwraca wartość błędu #LICZBA!.
  • Jeśli wartość argumentu x < A, wartość argumentu x > B lub zachodzi zależność A = B, to funkcja ROZKŁAD.BETA zwraca wartość błędu #LICZBA!.
  • Jeśli wartości argumentów A i B zostaną pominięte, to funkcja ROZKŁAD.BETA używa standardowego skumulowanego rozkładu beta, aby zachodziły zależności A = 0 i B = 1.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
2 | Wartość, dla której funkcja ma być oszacowana
8 | Parametr rozkładu
10 | Parametr rozkładu
1 | Dolna granica
3 | Górna granica
Formuła | Opis (Wynik)
=ROZKŁAD.BETA(A2;A3;A4;A5;A6) | Funkcja skumulowanego rozkładu gęstości prawdopodobieństwa beta dla powyższych parametrów (0,685470581)


ROZKŁAD.BETA.ODW

Oblicza odwrotność funkcji skumulowanego rozkładu gęstości prawdopodobieństwa beta. Oznacza to, że jeśli prawdopodobieństwo wynosi =ROZKŁAD.BETA(x;...), to zachodzi równość ROZKŁAD.BETA.ODW(prawdopodobieństwo;...) = x. Funkcja ta jest przydatna w planowaniu przedsięwzięć, bo umożliwia modelowanie prawdopodobnych czasów zakończenia na podstawie przewidywanych czasów zakończenia oraz zmienności.

Składnia

ROZKŁAD.BETA.ODW(prawdopodobieństwo;alfa;beta;A;B)

Prawdopodobieństwo to prawdopodobieństwo związane z rozkładem beta.

Alfa to parametr rozkładu.

Beta to parametr rozkładu.

A to opcjonalna dolna granica przedziału wartości x.

B to opcjonalna górna granica przedziału wartości x.

Spostrzeżenia

  • Jeśli jakikolwiek argument nie jest liczbą, to funkcja ROZKŁAD.BETA.ODW zwraca wartość błędu #ARG!.
  • Jeśli wartość argumentu alfa ≤ 0 lub wartość argumentu beta ≤ 0, to funkcja ROZKŁAD.BETA.ODW zwraca wartość błędu #LICZBA!.
  • Jeśli wartość argumentu prawdopodobieństwo ≤ 0 lub wartość argumentu prawdopodobieństwo > 1, to funkcja ROZKŁAD.BETA.ODW zwraca wartość błędu #LICZBA!.
  • Jeśli wartości argumentów A i B zostaną pominięte, funkcja ROZKŁAD.BETA.ODW używa standardowego skumulowanego rozkładu beta, aby zachodziły zależności A = 0 i B = 1.
Funkcja ROZKŁAD.BETA.ODW wykorzystuje technikę iteracyjną obliczania funkcji. Na podstawie danej wartości prawdopodobieństwa funkcja ROZKŁAD.BETA.ODW dokonuje iteracji do momentu uzyskania wyniku z dokładnością ±3x10^-7. Jeśli funkcja ROZKŁAD.BETA.ODW nie osiąga zbieżności po 100 iteracjach, zwraca wartość błędu #N/D!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
0,685470581 | Prawdopodobieństwo związane z rozkładem beta
8 | Parametr rozkładu
10 | Parametr rozkładu
1 | Dolna granica
3 | Górna granica
Formuła | Opis (Wynik)
=ROZKŁAD.BETA.ODW(A2;A3;A4;A5;A6) | Odwrotność skumulowanego rozkładu gęstości prawdopodobieństwa beta dla parametrów pokazanych powyżej (2)


ROZKŁAD.CHI

Zwraca wartość jednostronnego prawdopodobieństwa rozkładu chi-kwadrat. Rozkład γ2 jest związany z testem γ2. Test γ2 jest przydatny w porównywaniu wartości rzeczywistych i oczekiwanych. Na przykład eksperyment genetyczny może mieć na celu weryfikację hipotezy, że następna generacja roślin będzie występować w określonym zestawie kolorów. Przez porównanie wyników obserwacji z oczekiwaniami można ocenić słuszność postawionej hipotezy.

Składnia

ROZKŁAD.CHI(x;stopnie_swobody)

X to wartość, dla której ma zostać obliczony rozkład.

Stopnie_swobody to liczba stopni swobody.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.CHI zwraca wartość błędu #ARG!.
  • Jeśli argument x jest ujemny, funkcja ROZKŁAD.CHI zwraca wartość błędu #LICZBA!.
  • Jeżeli argument stopień_swobody nie jest liczbą całkowitą, jest obcinany.
  • Jeśli argument stopnie_swobody < 1 lub argument stopnie_swobody ≥ 10^10, funkcja ROZKŁAD.CHI zwraca wartość błędu #LICZBA!.
  • Równanie funkcji ROZKŁAD.CHI ma postać ROZKŁAD.CHI = P(X>x), gdzie X jest zmienną losową γ2.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
18,307 | Wartość, dla której ma zostać obliczony rozkład
10 | Stopnie swobody
Formuła | Opis (Wynik)
=ROZKŁAD.CHI(A2;A3) | Jednostronne prawdopodobieństwo dla rozkładu chi-kwadrat przy powyższych warunkach (0,050001)


ROZKŁAD.CHI.ODW

Zwraca wartość funkcji odwrotnej jednostronnego prawdopodobieństwa rozkładu chi-kwadrat. Jeśli prawdopodobieństwo wynosi =ROZKŁAD.CHI(x;...), to zachodzi równość ROZKŁAD.CHI.ODW(prawdopodobieństwo;...) = x. Funkcja ta służy do porównywania wyników obserwowanych i oczekiwanych, umożliwiając weryfikację słuszności hipotezy wyjściowej.

Składnia

ROZKŁAD.CHI.ODW(prawdopodobieństwo;stopnie_swobody)

Prawdopodobieństwo to prawdopodobieństwo związane z rozkładem chi-kwadrat.

Stopnie_swobody to liczba stopni swobody.

Spostrzeżenia

  • Jeśli jakikolwiek argument nie jest liczbą, to funkcja ROZKŁAD.CHI.ODW zwraca wartość błędu #ARG!.
  • Jeśli wartość argumentu prawdopodobieństwo < 0 lub wartość argumentu prawdopodobieństwo > 1, to funkcja ROZKŁAD.CHI.ODW zwraca wartość błędu #LICZBA!.
  • Jeżeli argument stopień_swobody nie jest liczbą całkowitą, jest obcinany.
  • Jeśli wartość argumentu stopnie_swobody < 1 lub wartość argumentu stopnie_swobody ≥ 10^10, to funkcja ROZKŁAD.CHI.ODW zwraca wartość błędu #LICZBA!.

Funkcja ROZKŁAD.CHI.ODW wykorzystuje technikę iteracyjną obliczania funkcji. Na podstawie danej wartości prawdopodobieństwa funkcja ROZKŁAD.CHI.ODW dokonuje iteracji do momentu uzyskania wyniku z dokładnością ± 3x10^-7. Jeśli funkcja ROZKŁAD.CHI.ODW nie osiąga zbieżności po 100 iteracjach, zwraca wartość błędu #N/D.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
0,05 | Prawdopodobieństwo związane z rozkładem chi-kwadrat
10 | Stopnie swobody
Formuła | Opis (Wynik)
=ROZKŁAD.CHI.ODW(A2;A3) | Zwraca wartość jednostronnego prawdopodobieństwa rozkładu chi-kwadrat (18,30703).


ROZKŁAD.DWUM

Zwraca wartość pojedynczego składnika dwumianowego rozkładu prawdopodobieństwa. Funkcja ROZKŁAD.DWUM jest przydatna do rozwiązywania problemów, w których występuje stała liczba testów lub prób, wynik każdej próby może być tylko sukcesem lub porażką, próby są niezależne, a prawdopodobieństwo sukcesu jest stałe w trakcie całego eksperymentu. Na przykład funkcja ROZKŁAD.DWUM może wyznaczyć prawdopodobieństwo, że z trojga następnych nowonarodzonych dzieci dwoje będzie płci męskiej.

Składnia

ROZKŁAD.DWUM(liczba_s;próby;prawdopodobieństwo_s;skumulowany)

Liczba_s to liczba sukcesów w próbach.

Próby to liczba niezależnych prób.

Prawdopodobieństwo_s to prawdopodobieństwo sukcesu w każdej próbie.

Skumulowany to wartość logiczna określająca postać funkcji. Jeśli argument skumulowany ma wartość PRAWDA, funkcja ROZKŁAD.DWUM zwraca wartość funkcji rozkładu skumulowanego, czyli prawdopodobieństwo, że zaistniało co najwyżej liczba_s sukcesów; jeśli ma wartość FAŁSZ, funkcja zwraca wartość funkcji gęstości prawdopodobieństwa, czyli prawdopodobieństwo, że zaistniało dokładnie liczba_s sukcesów.

Spostrzeżenia

  • Argumenty liczba_s i próby są obcinane do liczb całkowitych.
  • Jeśli którykolwiek z argumentów: liczba_s, próby lub prawdopodobieństwo_s nie jest liczbą, funkcja ROZKŁAD.DWUM zwraca wartość błędu #ARG!.
  • Jeśli argument liczba_s < 0 lub argument liczba_s > argument próby, funkcja ROZKŁAD.DWUM zwraca wartość błędu #LICZBA!.
  • Jeśli argument prawdopodobieństwo_s < 0 lub argument prawdopodobieństwo_s > 1, funkcja ROZKŁAD.DWUM zwraca wartość błędu #LICZBA!.
  • Funkcja gęstości prawdopodobieństwa dla rozkładu dwumianowego ma postać:

    gdzie:

    jest funkcją KOMBINACJE(n;x).

    Skumulowany rozkład dwumianowy ma postać:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
6 | Liczba sukcesów w próbach
10 | Liczba niezależnych prób
0,5 | Prawdopodobieństwo sukcesu w każdej próbie
Formuła | Opis (Wynik)
=ROZKŁAD.DWUM(A2;A3;A4;FAŁSZ) | Prawdopodobieństwo sukcesu dokładnie w 6 z 10 prób (0,205078)


ROZKŁAD.DWUM.PRZEC

Zwraca ujemny rozkład dwumianowy. Funkcja ROZKŁAD.DWUM.PRZEC zwraca prawdopodobieństwo, że będzie liczba_p niepowodzeń przed liczba_s-tym sukcesem, kiedy stałe prawdopodobieństwo sukcesu jest prawdopodob_s. Funkcja ta jest podobna do rozkładu dwumianowego z tym wyjątkiem, że liczba sukcesów jest stała, a liczba prób jest zmienna. Podobnie, jak w przypadku rozkładu dwumianowego, próby są przyjmowane jako niezależne.

Na przykład trzeba znaleźć 10 ludzi z doskonałym refleksem, a wiadomo, że prawdopodobieństwo, że kandydat ma te kwalifikacje, wynosi 0,3. Funkcja ROZKŁAD.DWUM.PRZEC oblicza prawdopodobieństwo, że przeprowadzone zostaną rozmowy z pewną liczbą kandydatów bez wymaganych kwalifikacji, zanim zostanie znalezionych 10 kandydatów o odpowiednich kwalifikacjach.

Składnia

ROZKŁAD.DWUM.PRZEC(liczba_p;liczba_s;prawdopodob_s)

Liczba_p to liczba niepowodzeń.

Liczba_s to progowa liczba sukcesów.

Prawdopodob_s to prawdopodobieństwo sukcesu.

Spostrzeżenia

  • Argumenty liczba_p i liczba_s powinny być >= 0.
  • Argumenty liczba_p i liczba_s są obcinane do liczb całkowitych.
  • Jeżeli jakikolwiek argument jest argumentem nieliczbowym, ROZKŁAD.DWUM.PRZEC zwraca wartość błędu #ARG!.
  • Jeżeli argument prawdopodob_s < 0 lub jeśli prawdopodobieństwo > 1, funkcja ROZKŁAD.DWUM.PRZEC zwraca wartość błędu #LICZBA!.
  • Równanie ujemnego rozkładu dwumianowego jest następujące:

    gdzie:

    x jest liczba_p, r jest liczba_s, a p jest prawdopodob_s.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
10 | Liczba niepowodzeń
5 | Progowa liczba sukcesów
0,25 | Prawdopodobieństwo sukcesu
Formuła | Opis (Wynik)
=ROZKŁAD.DWUM.PRZEC(A2;A3;A4) | Ujemny rozkład dwumianowy przy powyższych warunkach (0,055049)


ROZKŁAD.EXP

Zwraca wartość funkcji rozkładu wykładniczego. Funkcja ROZKŁAD.EXP jest przydatna do modelowania upływu czasu między zdarzeniami, np. czasu oczekiwania na wypłatę gotówki z bankomatu. Można na przykład użyć funkcji ROZKŁAD.EXP do wyznaczenia prawdopodobieństwa, że zajmie to najwyżej jedną minutę.

Składnia

ROZKŁAD.EXP(x;lambda;skumulowany)

X to wartość funkcji.

Lambda to wartość parametryczna.

Skumulowany to wartość logiczna, wskazująca na formę funkcji wykładniczej, która ma zostać użyta. Jeśli argument skumulowany ma wartość PRAWDA, funkcja ROZKŁAD.EXP zwraca wartość funkcji rozkładu skumulowanego; jeśli ma wartość FAŁSZ, funkcja zwraca wartość funkcji gęstości prawdopodobieństwa.

Spostrzeżenia

  • Jeśli argumenty x lub lambda nie są liczbami, funkcja ROZKŁAD.EXP zwraca wartość błędu #ARG!.
  • Jeśli argument x < 0, funkcja ROZKŁAD.EXP zwraca wartość błędu #LICZBA!.
  • Jeśli argument lambda ≤ 0, funkcja ROZKŁAD.EXP zwraca wartość błędu #LICZBA!.
  • Równanie funkcji gęstości prawdopodobieństwa jest następujące:

  • Równanie funkcji rozkładu skumulowanego jest następujące:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
0,2 | Wartość funkcji
10 | Wartość parametryczna
Formuła | Opis (Wynik)
=ROZKŁAD.EXP(A2;A3;PRAWDA) | Funkcja wykładniczego rozkładu skumulowanego (0,864665)
=ROZKŁAD.EXP(0,2;10;FAŁSZ) | Funkcja wykładniczego rozkładu prawdopodobieństwa (1,353353)


ROZKŁAD.F

Zwraca wartość funkcji rozkładu prawdopodobieństwa F. Funkcja ta jest przydatna w określaniu, czy dwa zbiory danych mają różne stopnie zróżnicowania. Można na przykład sprawdzić wyniki egzaminów uzyskane przez chłopców i dziewczęta zdające do szkoły średniej i określić, czy zmienność wyników uzyskanych przez dziewczęta różni się od zmienności wyników dla chłopców.

Składnia

ROZKŁAD.F(x;stopnie_swobody1;stopnie_swobody)

X to wartość, dla której ta funkcja ma być oszacowana.

Stopnie_swobody1 to licznik stopni swobody.

Stopnie_swobody2 to mianownik stopni swobody.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.F zwraca wartość błędu #ARG!.
  • Jeśli argument x ma wartość ujemną, funkcja ROZKŁAD.F zwraca wartość błędu #LICZBA!.
  • Jeśli argument stopnie_swobody1 lub stopnie_swobody2 nie jest liczbą całkowitą, jego wartość zostanie obcięta do liczby całkowitej.
  • Jeśli argument stopnie_swobody1 < 1 lub argument stopnie_swobody1 ≥ 10^10, funkcja ROZKŁAD.F zwraca wartość błędu #LICZBA!.
  • Jeśli argument stopnie_swobody2 < 1 lub argument stopnie_swobody2 ≥ 10^10, funkcja ROZKŁAD.F zwraca wartość błędu #LICZBA!.
  • Funkcja ROZKŁAD.F jest obliczana według równania ROZKŁAD.F=P(F<x), gdzie F jest zmienną losową o rozkładzie F.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
15,20675 | Wartość, dla której funkcja ma być oszacowana
6 | Licznik stopni swobody
4 | Mianownik stopni swobody
Formuła | Opis (Wynik)
=ROZKŁAD.F(A2;A3;A4) | Rozkład prawdopodobieństwa F przy warunkach określonych powyżej (0,01)


ROZKŁAD.F.ODW

Zwraca wartość funkcji odwrotnej rozkładu prawdopodobieństwa F. Jeżeli p = ROZKŁAD.F(x;...), to ROZKŁAD.F.ODW(p;...) = x.

Rozkład F jest przydatny w teście F, porównującym stopień zmienności dwóch zbiorów danych. Można na przykład przeanalizować rozkład dochodów w Stanach Zjednoczonych i Kanadzie, aby określić, czy oba kraje mają podobne zróżnicowanie dochodów.

Składnia

ROZKŁAD.F.ODW(prawdopodobieństwo;stopnie_swobody1;stopnie_swobody2)

Prawdopodobieństwo to prawdopodobieństwo związane ze skumulowanym rozkładem F.

Stopnie_swobody1 to licznik stopni swobody.

Stopnie_swobody2 to mianownik stopni swobody.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.F.ODW zwraca wartość błędu #ARG!.
  • Jeśli argument prawdopodobieństwo < 0 lub argument prawdopodobieństwo > 1, funkcja ROZKŁAD.F.ODW zwraca wartość błędu #LICZBA!.
  • Jeśli argument stopnie_swobody1 lub stopnie_swobody2 nie jest liczbą całkowitą, jego wartość zostanie obcięta do liczby całkowitej.
  • Jeśli argument stopnie_swobody1 < 1 lub argument stopnie_swobody1 ≥ 10^10, funkcja ROZKŁAD.F.ODW zwraca wartość błędu #LICZBA!.
  • Jeśli argument stopnie_swobody2 < 1 lub argument stopnie_swobody2 ≥ 10^10, funkcja ROZKŁAD.F zwraca wartość błędu #LICZBA!.

Funkcja ROZKŁAD.F.ODW jest przydatna do otrzymywania wartości krytycznych rozkładu F. Na przykład wynikiem obliczeń ANOVA są często dane dla statystyki F, wartości prawdopodobieństwa F i wartości krytycznej F przy poziomie istotności 0,05. Aby otrzymać wartość krytyczną F, należy użyć poziomu istotności jako argumentu prawdopodobieństwa dla funkcji ROZKŁAD.F.ODW.

Funkcja ROZKŁAD.F.ODW stosuje technikę iteracyjną obliczania funkcji. Przy danej wartości prawdopodobieństwa funkcja ROZKŁAD.F.ODW dokonuje iteracji do momentu uzyskania wyniku z dokładnością ± 3x10^-7. Jeśli funkcja ROZKŁAD.F.ODW nie osiąga zbieżności po 100 iteracjach, zwraca wartość błędu #N/D.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
0,01 | Prawdopodobieństwo związane ze skumulowanym rozkładem F
6 | Licznik stopni swobody
4 | Mianownik stopni swobody
Formuła | Opis (Wynik)
=ROZKŁAD.F.ODW(A2;A3;A4) | Odwrotność rozkładu F przy warunkach określonych powyżej (15,20675)


ROZKŁAD.FISHER

Zwraca wartość transformacji Fishera w punkcie x. Wynikiem tej transformacji jest funkcja, która ma przeważnie rozkład normalny, a nie skośny. Funkcja ta jest przydatna w weryfikowaniu hipotez dotyczących współczynnika korelacji.

Składnia

ROZKŁAD.FISHER(x)

X to wartość liczbowa, dla której ma zostać dokonana transformacja.

Spostrzeżenia

  • Jeśli argument x nie jest liczbą, funkcja ROZKŁAD.FISHER zwraca wartość błędu #ARG!.
  • Jeśli argument x ≤ -1 lub argument x ≥ 1, funkcja ROZKŁAD.FISHER zwraca wartość błędu #LICZBA!.

  • Równanie transformacji Fishera ma postać:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ROZKŁAD.FISHER(0,75) | Transformacja Fishera dla argumentu 0,75 (0,972955)


ROZKŁAD.FISHER.ODW

Zwraca wartość funkcji odwrotnej transformacji Fishera. Transformacja ta jest przydatna w analizie korelacji pomiędzy zakresami lub tablicami danych. Jeżeli y = ROZKŁAD.FISHER(x), to ROZKŁAD.FISHER.ODW(y) = x.

Składnia

ROZKŁAD.FISHER.ODW(y)

Y to wartość, dla której ma zostać wyznaczona funkcja odwrotna transformacji.

Spostrzeżenia

  • Jeśli argument y nie jest liczbą, funkcja ROZKŁAD.FISHER.ODW zwraca wartość błędu #ARG!.

  • Równanie funkcji odwrotnej transformacji Fishera ma postać:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ROZKŁAD.FISHER.ODW(0,972955) | Funkcja odwrotna transformacji Fishera dla argumentu 0,972955 (0,75)


ROZKŁAD.GAMMA

Zwraca wartość funkcji rozkładu gamma. Funkcja ta jest przydatna w badaniu zmiennych, które mogą mieć rozkład skośny. Rozkład gamma jest powszechnie stosowany w analizie kolejek.

Składnia

ROZKŁAD.GAMMA(x;alfa;beta;skumulowany)

X to wartość, dla której ma zostać obliczony rozkład.

Alfa to parametr rozkładu.

Beta to parametr rozkładu. Jeśli argument beta = 1, funkcja ROZKŁAD.GAMMA zwraca wartość funkcji standardowego rozkładu gamma.

Skumulowany to wartość logiczna, która określa format funkcji. Jeśli wartością argumentu skumulowany jest PRAWDA, funkcja ROZKŁAD.GAMMA zwraca wartość funkcji rozkładu skumulowanego; jeśli FAŁSZ, funkcja zwraca wartość funkcji gęstości prawdopodobieństwa.

Spostrzeżenia

  • Jeśli argumenty x, alfa lub beta nie są liczbą, funkcja ROZKŁAD.GAMMA zwraca wartość błędu #ARG!.
  • Jeżeli argument x < 0, funkcja ROZKŁAD.GAMMA zwraca wartość błędu #LICZBA!.
  • Jeżeli argument alfa ≤ 0 lub jeżeli argument beta ≤ 0, funkcja ROZKŁAD.GAMMA zwraca wartość błędu #LICZBA!.
  • Równanie dla rozkładu gamma ma postać:

    Standardowy rozkład gamma ma postać:

  • Jeśli argument alfa = 1, funkcja ROZKŁAD.GAMMA zwraca rozkład wykładniczy z:

  • Dla dodatniej liczby całkowitej n, kiedy argument alfa = n/2, argument beta = 2, a argument skumulowany ma wartość PRAWDA, funkcja ROZKŁAD.GAMMA zwraca (1 — ROZKŁAD.CHI(x)) z n stopniami swobody.
  • Jeśli argument alfa jest dodatnią liczbą całkowitą, funkcja ROZKŁAD.GAMMA nazywana jest również rozkładem Erlanga.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
10 | Wartość, dla której ma zostać obliczony rozkład
9 | Parametr alfa rozkładu
2 | Parametr beta rozkładu
Formuła | Opis (Wynik)
ROZKŁAD.GAMMA(A2;A3;A4;FAŁSZ) | Rozkład prawdopodobieństwa gamma przy warunkach określonych powyżej (0,032639)
=ROZKŁAD.GAMMA(A2;A3;A4;PRAWDA) | Skumulowany rozkład gamma przy warunkach określonych powyżej (0,068094)


ROZKŁAD.GAMMA.ODW

Zwraca wartość odwrotną do skumulowanego rozkładu gamma. Jeżeli p = ROZKŁAD.GAMMA.ODW(x;...), to ROZKŁAD.GAMMA.ODW(p;...) = x.

Funkcja ta jest przydatna do badania zmiennej, której rozkład może być skośny.

Składnia

ROZKŁAD.GAMMA.ODW(prawdopodobieństwo;alfa;beta)

Prawdopodobieństwo to prawdopodobieństwo związane z rozkładem gamma.

Alfa to parametr rozkładu.

Beta to parametr rozkładu. Jeśli wartość argumentu beta = 1, funkcja ROZKŁAD.GAMMA.ODW zwraca wartość standardowego rozkładu gamma.

Spostrzeżenia

  • Jeżeli którykolwiek z argumentów nie jest liczbą, funkcja ROZKŁAD.GAMMA.ODW zwraca wartość błędu #ARG!.
  • Jeśli argument prawdopodobieństwo < 0 lub argument prawdopodobieństwo > 1, funkcja ROZKŁAD.GAMMA.ODW zwraca wartość błędu #LICZBA!.
  • Jeśli argument alfa ≤ 0 lub argument beta ≤ 0, funkcja ROZKŁAD.GAMMA.ODW zwraca wartość błędu #LICZBA!.
  • Jeżeli argument beta ≤ 0, funkcja ROZKŁAD.GAMMA.ODW zwraca wartość błędu #LICZBA!.
Funkcja ROZKŁAD.GAMMA.ODW wykorzystuje technikę iteracyjną obliczania funkcji. Przy danej wartości prawdopodobieństwa funkcja ROZKŁAD.GAMMA.ODW dokonuje iteracji do momentu uzyskania wyniku z dokładnością ± 3x10^-7. Jeśli funkcja ROZKŁAD.F.ODW nie osiąga zbieżności po 100 iteracjach, zwraca wartość błędu #N/D.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
0,068094 | Prawdopodobieństwo związane z rozkładem gamma
9 | Parametr alfa rozkładu
2 | Parametr beta rozkładu
Formuła | Opis (Wynik)
=ROZKŁAD.GAMMA.ODW(A2;A3;A4) | Odwrotność skumulowanego rozkładu gamma przy warunkach określonych powyżej (10)


ROZKŁAD.HIPERGEOM

Zwraca rozkład hipergeometryczny. Funkcja ROZKŁAD.HIPERGEOM zwraca prawdopodobieństwo sukcesów danej liczby próbek przy danej liczebności próbki, danych sukcesach populacji i liczebności populacji. Funkcję ROZKŁAD.HIPERGEOM należy stosować do zagadnień ze skończoną populacją, gdzie każda obserwacja jest albo sukcesem, albo brakiem sukcesu i gdzie każdy podzbiór o danej liczebności jest wybierany z jednakowym prawdopodobieństwem.

Składnia

ROZKŁAD.HIPERGEOM(próbka_s;wielk_próbki;populacja_s;wielk_populacji)

Próbka_s to liczba sukcesów w próbce.

Wielk_próbki to liczebność próbki.

Populacja_s to liczba sukcesów w populacji.

Wielk_populacji to liczebność populacji.

Spostrzeżenia

  • Wszystkie argumenty są obcinane do liczb całkowitych.
  • Jeżeli jakiś argument jest nieliczbowy, funkcja ROZKŁAD.HIPERGEOM zwraca wartość błędu #ARG!.
  • Jeżeli argument próbka_s < 0 lub jest większy niż mniejszy z argumentów wielk_próbki lub populacja_s, wówczas funkcja ROZKŁAD.HIPERGEOM zwraca wartość błędu #LICZBA!.
  • Jeżeli argument próbka_s jest mniejszy niż większy spośród 0 lub (wielk_próbki — wielk_populacji + populacja_s), wówczas funkcja ROZKŁAD.HIPERGEOM zwraca wartość błędu #LICZBA!.
  • Jeżeli argument wielk_próbki < 0 lub wielk_próbki > wielk_populacji, wówczas funkcja ROZKŁAD.HIPERGEOM zwraca wartość błędu #LICZBA!.
  • Jeżeli argument populacja_s < 0 lub populacja_s > wielk_populacji, wówczas funkcja ROZKŁAD.HIPERGEOM zwraca wartość błędu #LICZBA!.
  • Jeżeli argument wielk_populacji < 0, wówczas funkcja ROZKŁAD.HIPERGEOM zwraca wartość błędu #LICZBA!.
  • Równanie dla rozkładu hipergeometrycznego jest następujące:

    gdzie:

    x = próbka_s

    n = wielk_próbki

    M = populacja_s

    L = wielk_populacji

    Funkcję ROZKŁAD.HIPERGEOM stosuje się przy próbkowaniu bez zastępowania ze skończonej populacji.

Przykład

Urządzenie do pobierania próbek czekoladek zawiera 20 sztuk. Osiem czekoladek karmelowych i pozostałe dwanaście orzechowych. Jeżeli wybierze się losowo 4 sztuki, następująca funkcja zwraca prawdopodobieństwo, że dokładnie 1 sztuka będzie karmelowa.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
1 | Liczba sukcesów w próbce
4 | Liczebność próbki
8 | Liczba sukcesów w populacji
20 | Liczebność populacji
Formuła | Opis (Wynik)
=ROZKŁAD.HIPERGEOM(A2;A3;A4;A5) | Rozkład hipergeometryczny dla przedstawionej powyżej próbki i populacji (0,363261)


ROZKŁAD.LIN.GAMMA

Zwraca logarytm naturalny funkcji gamma, Γ(x).

Składnia

ROZKŁAD.LIN.GAMMA(x)

X to wartość, dla której ma zostać obliczona funkcja ROZKŁAD.LIN.GAMMA.

Spostrzeżenia

  • Jeżeli argument x nie jest liczbą, funkcja ROZKŁAD.LIN.GAMMA zwraca wartość błędu #ARG!.
  • Jeżeli argument x ≤ 0, funkcja ROZKŁAD.LIN.GAMMA zwraca wartość błędu #LICZBA!.
  • Liczba e podniesiona do potęgi ROZKŁAD.LIN.GAMMA(i), gdzie i jest liczbą całkowitą, daje taki sam wynik jak (i — 1)!.
  • Funkcja ROZKŁAD.LIN.GAMMA jest obliczana w następujący sposób:

    gdzie:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ROZKŁAD.LIN.GAMMA(4) | Logarytm naturalny funkcji gamma dla wartości 4 (1,791759)


ROZKŁAD.LOG

Zwraca skumulowany rozkład logarytmiczno-normalny x, gdzie ln(x) ma rozkład normalny z parametrami średnia i odchylenie_std. Funkcję tę należy stosować do analizowania zlogarytmowanych danych.

Składnia

ROZKŁAD.LOG(x;średnia;odchylenie_std)

X to wartość, dla której ta funkcja ma być oszacowana.

Średnia to wartość średnia ln(x).

Odchylenie_std to standardowe odchylenie ln(x).

Spostrzeżenia

  • Jeżeli jakikolwiek argument jest nieliczbowy, funkcja ROZKŁAD.LOG zwraca wartość błędu #ARG!.
  • Jeżeli argument x ≤ 0 lub odchylenie_std ≤ 0, funkcja ROZKŁAD.LOG zwraca wartość błędu #LICZBA!.
  • Równanie skumulowanego rozkładu logarytmiczno-normalnego jest następujące:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
4 | Wartość, dla której ta funkcja ma być obliczona
3,5 | Średnia ln(x)
1,2 | Odchylenie standardowe ln(x)
Formuła | Opis (Wynik)
=ROZKŁAD.LOG(A2;A3;A4) | Skumulowany rozkład logarytmiczno-normalny dla 4 przy podanych powyżej warunkach (0,039084)


ROZKŁAD.LOG.ODW

Zwraca funkcję odwrotną skumulowanego rozkładu logarytmiczno-normalnego x, gdzie ln(x) ma rozkład normalny z parametrami średnia i odchylenie_std. Jeśli p = ROZKŁAD.LOG(x;...) to ROZKŁAD.LOG.ODW(p;...) = x.

Rozkład logarytmiczno-normalny wykorzystuje się w analizie zlogarytmowanych danych.

Składnia

ROZKŁAD.LOG.ODW(prawdopodobieństwo;średnia;odchylenie_std)

Prawdopodobieństwo to prawdopodobieństwo skojarzone z rozkładem logarytmiczno-normalnym.

Średnia to wartość średnia ln(x).

Odchylenie_std to standardowe odchylenie ln(x).

Spostrzeżenia

  • Jeśli którykolwiek z argumentów jest argumentem nieliczbowym, funkcja ROZKŁAD.LOG.ODW zwraca wartość błędu #ARG!.
  • Jeśli argument prawdopodobieństwo < 0 lub prawdopodobieństwo > 1, funkcja ROZKŁAD.LOG.ODW zwraca wartość błędu #LICZBA!.
  • Jeśli argument odchylenie_std <= 0, funkcja ROZKŁAD.LOG.ODW zwraca wartość błędu #LICZBA!.

  • Funkcja odwrotna do funkcji rozkładu logarytmiczno-normalnego jest równa:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
0,039084 | Prawdopodobieństwo skojarzone z rozkładem logarytmiczno-normalnym
3,5 | Średnia ln(x)
1,2 | Odchylenie standardowe ln(x)
Formuła | Opis (Wynik)
=ROZKŁAD.LOG.ODW(A2; A3; A4) | Funkcja odwrotna skumulowanej funkcji rozkładu logarytmiczno-normalnego przy podanych powyżej warunkach (4,000014)


ROZKŁAD.NORMALNY

Zwraca rozkład normalny dla określonej średniej i odchylenia standardowego. Funkcja ta ma bardzo szeroki zakres zastosowań w statystyce, łącznie z badaniem hipotez.

Składnia

ROZKŁAD.NORMALNY(x;średnia;odchylenie_std;skumulowany)

X to wartość, której rozkład ma być znaleziony.

Średnia to średnia arytmetyczna rozkładu.

Odchylenie_std to odchylenie standardowe rozkładu.

Skumulowany to wartość logiczna określająca postać funkcji. Jeżeli argument skumulowany ma wartość PRAWDA, wówczas funkcja ROZKŁAD.NORMALNY zwraca skumulowaną funkcję rozkładu, a jeśli FAŁSZ, wówczas funkcja ta zwraca funkcję gęstości prawdopodobieństwa.

Spostrzeżenia

  • Jeżeli argumenty średnia lub odchylenie_std są argumentami nieliczbowymi, funkcja ROZKŁAD.NORMALNY zwraca wartość błędu #ARG!.
  • Jeżeli argument odchylenie_std ≤ 0, funkcja ROZKŁAD.NORMALNY zwraca wartość błędu #LICZBA!

  • Jeśli średnia = 0, odchylenie_std = 1 i skumulowany = PRAWDA, to funkcja ROZKŁAD.NORMALNY zwraca standardowy rozkład normalny, funkcję ROZKŁAD.NORMALNY.
  • Równanie normalnej funkcji gęstości (skumulowany = FAŁSZ) przedstawia się tak:

  • Gdy skumulowany = PRAWDA, formuła jest całką od minus nieskończoności do x danej formuły.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
42 | Wartość, dla której ma być znaleziony rozkład
40 | Średnia arytmetyczna rozkładu
1,5 | Odchylenie standardowe rozkładu
Formuła | Opis (Wynik)
=ROZKŁAD.NORMALNY(A2;A3;A4;PRAWDA) | Skumulowana funkcja rozkładu przy podanych powyżej warunkach (0,908789)
=ROZKŁAD.NORMALNY(A2;A3;A4;FAŁSZ) | Funkcja gęstości prawdopodobieństwa przy podanych powyżej warunkach (0,10934005)


ROZKŁAD.NORMALNY.ODW

Zwraca wartość funkcji odwrotnej skumulowanego rozkładu normalnego dla danej średniej i odchylenia standardowego.

Składnia

ROZKŁAD.NORMALNY.ODW(prawdopodobieństwo;średnia;odchylenie_std)

Prawdopodobieństwo to prawdopodobieństwo odpowiadające rozkładowi normalnemu.

Średnia to średnia arytmetyczna rozkładu.

Odchylenie_std to odchylenie standardowe rozkładu.

Spostrzeżenia

  • Jeśli jakiś argument jest nieliczbowy, funkcja ROZKŁAD.NORMALNY.ODW zwraca wartość błędu #ARG!.
  • Jeśli argument prawdopodobieństwo < 0 lub jeśli prawdopodobieństwo > 1, funkcja ROZKŁAD.NORMALNY.ODW zwraca wartość błędu #LICZBA!.
  • Jeśli argument odchylenie_standardowe ≤ 0, to funkcja ROZKŁAD.NORMALNY.ODW zwraca wartość błędu #LICZBA!.

  • Jeżeli argument średnia = 0 i odchylenie_std = 1, w funkcji ROZKŁAD.NORMALNY.ODW stosowany jest standardowy rozkład normalny (patrz ROZKŁAD.NORMALNY.S.ODW).

Do obliczania funkcji ROZKŁAD.NORMALNY.ODW stosowana jest technika iteracji. Przy danej wartości prawdopodobieństwa funkcja ROZKŁAD.NORMALNY.ODW iteruje aż do uzyskania wyniku z dokładnością ± 3x10^-7. Jeśli po 100 iteracjach funkcja nie może uzyskać zbieżności, zwraca wartość błędu #N/D.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
0,908789 | Prawdopodobieństwo odpowiadające rozkładowi normalnemu
40 | Średnia arytmetyczna rozkładu
1,5 | Odchylenie standardowe rozkładu
Formuła | Opis (Wynik)
=ROZKŁAD.NORMALNY.ODW(A2;A3;A4) | Funkcja odwrotna skumulowanego rozkładu normalnego przy podanych powyżej warunkach (42)


ROZKŁAD.NORMALNY.S

Zwraca standardową funkcję skumulowanego rozkładu (dystrybuantę) normalnego. Rozkład ten ma średnią zero i odchylenie standardowe równe jeden. Funkcję tę należy stosować zamiast tabeli obszarów standardowych krzywych normalnych.

Składnia

ROZKŁAD.NORMALNY.S(z)

Z to wartość, której dystrybuanta ma być znaleziona.

Spostrzeżenia

  • Jeżeli argument z jest argumentem nieliczbowym, funkcja ROZKŁAD.NORMALNY.S zwraca wartość błędu #ARG!.
  • Równaniem standardowej normalnej funkcji gęstości jest:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ROZKŁAD.NORMALNY.S(1,333333) | Funkcja skumulowanego rozkładu normalnego dla z = 1,333333 (0,908789)


ROZKŁAD.NORMALNY.S.ODW

Zwraca funkcję odwrotną skumulowanego standardowego rozkładu normalnego. Rozkład ten ma średnią równą zero i odchylenie standardowe równe jeden.

Składnia

ROZKŁAD.NORMALNY.S.ODW(prawdopodobieństwo)

Prawdopodobieństwo to prawdopodobieństwo odpowiadające rozkładowi normalnemu.

Spostrzeżenia

  • Jeśli argument prawdopodobieństwo jest argumentem nieliczbowym, funkcja ROZKŁAD.NORMALNY.S.ODW zwraca wartość błędu #ARG!.
  • Jeśli argument prawdopodobieństwo < 0 lub jeśli prawdopodobieństwo > 1, funkcja ROZKŁAD.NORMALNY.S.ODW zwraca wartość błędu #LICZBA!.

Do obliczania funkcji ROZKŁAD.NORMALNY.S.ODW stosowana jest technika iteracji. Przy danej wartości prawdopodobieństwa funkcja ROZKŁAD.NORMALNY.S.ODW iteruje aż do uzyskania wyniku z dokładnością ± 3x10^-7. Jeśli po 100 iteracjach funkcja ROZKŁAD.NORMALNY.S.ODW nie może uzyskać zbieżności, zwraca wartość błędu #N/D.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ROZKŁAD.NORMALNY.S.ODW(0,908789) | Funkcja odwrotna skumulowanego standardowego rozkładu normalnego z prawdopodobieństwem 0,908789 (1,3333)


ROZKŁAD.POISSON

Zwraca skumulowaną funkcję (dystrybuantę) rozkładu Poissona. Zwykłym zastosowaniem rozkładu Poissona jest prognozowanie liczby zdarzeń w danym czasie, takiej jak liczba samochodów przejeżdżających przez plac w czasie jednej minuty.

Składnia

ROZKŁAD.POISSON (x;średnia;skumulowany)

X to liczba zdarzeń.

Średnia to oczekiwana wartość liczbowa.

Skumulowany to wartość logiczna, która określa formę zwracanego rozkładu prawdopodobieństwa. Jeżeli argument skumulowany ma wartość PRAWDA, funkcja ROZKŁAD.POISSON zwraca skumulowane prawdopodobieństwo Poissona, że liczba przypadkowych zdarzeń będzie pomiędzy zero a x włącznie; jeśli ma wartość FAŁSZ, wówczas funkcja ta zwraca funkcję masy prawdopodobieństwa Poissona, że liczba zdarzeń będzie dokładnie x.

Spostrzeżenia

  • Jeżeli argument x nie jest liczbą całkowitą, jest obcinany do liczby całkowitej.
  • Jeżeli argumenty x lub średnia nie są wartościami liczbowymi, funkcja ROZKŁAD.POISSON zwraca wartość błędu #ARG!.
  • Jeżeli argument x ≤ 0, funkcja ROZKŁAD.POISSON zwraca wartość błędu #LICZBA!.
  • Jeżeli argument średnia ≤ 0, funkcja ROZKŁAD.POISSON zwraca wartość błędu #LICZBA!.
  • Funkcja ROZKŁAD.POISSON obliczana jest w następujący sposób:

    Dla skumulowany = FAŁSZ:

    Dla skumulowany = PRAWDA:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
2 | Liczba zdarzeń
5 | Oczekiwana średnia
Formuła | Opis (Wynik)
=ROZKŁAD.POISSON(A2;A3;PRAWDA) | Skumulowane prawdopodobieństwo Poissona przy podanych powyżej warunkach (0,124652)
=ROZKŁAD.POISSON(A2;A3;FAŁSZ) | Funkcja masy prawdopodobieństwa Poissona przy podanych powyżej warunkach (0,084224)


ROZKŁAD.T

Zwraca Punkty procentowe (prawdopodobieństwo) dla rozkładu t Studenta, gdzie wartość liczbowa (x) jest obliczoną wartością t, dla której mają być obliczone Punkty procentowe. Rozkład t jest stosowany przy testowaniu hipotez w odniesieniu do zbiorów danych małych próbek. Funkcję tę należy stosować zamiast tabeli wartości krytycznych dla rozkładu t.

Składnia

ROZKŁAD.T(x;stopnie_swobody;ślady)

X to wartość liczbowa, przy której ma być oszacowany rozkład.

Stopnie_swobody to liczba całkowita oznaczająca liczbę stopni swobody.

Ślady określa liczbę śladów rozkładu, które mają być zwrócone. Jeżeli ślady = 1, funkcja ROZKŁAD.T daje w wyniku rozkład jednostronny. Jeżeli ślady = 2, funkcja ROZKŁAD.T daje w wyniku rozkład dwustronny.

Spostrzeżenia

  • Jeżeli jakiś argument nie jest wartością liczbową, funkcja ROZKŁAD.T daje w wyniku wartość błędu #ARG!.
  • Jeżeli argument stopnie_swobody < 1, funkcja ROZKŁAD.T daje w wyniku wartość błędu #LICZBA!.
  • Argumenty stopnie_swobody i ślady są redukowane do liczb całkowitych.
  • Jeżeli argument ślady ma wartość inną niż 1 lub 2, funkcja ROZKŁAD.T daje w wyniku wartość błędu #LICZBA!.
  • Funkcja ROZKŁAD.T jest obliczana jako ROZKŁAD.T=p(x<abs(X)), gdzie X jest zmienną losową zgodną z rozkładem t.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
1,96 | Wartość, dla której ta funkcja ma być obliczona
60 | Stopnie swobody
Formuła | Opis (Wynik)
=ROZKŁAD.T(A2;A3;2) | Rozkład dwustronny (0,054644927 lub 5,46 procent)
=ROZKŁAD.T(A2;A3;1) | Rozkład jednostronny (0,027322463 lub 2,73 procent)

Uwaga Aby wyświetlić liczbę w postaci procentowej, należy zaznaczyć komórkę i kliknąć przycisk Polecenia i opcje [image] na pasku narzędzi. Następnie należy kliknąć kartę Format i pozycję Procentowy w polu Format liczby.


ROZKŁAD.T.ODW

Zwraca wartość t rozkładu t Studenta jako funkcję prawdopodobieństwa i liczby stopni swobody.

Składnia

ROZKŁAD.T.ODW(prawdopodobieństwo;stopnie_swobody)

Prawdopodobieństwo to prawdopodobieństwo związane z dwustronnym rozkładem t Studenta.

Stopnie_swobody to liczba stopni swobody dla scharakteryzowania rozkładu.

Spostrzeżenia

  • Jeżeli jakiś argument nie jest wartością liczbową, funkcja ROZKŁAD.T.ODW zwraca wartość błędu #ARG!.
  • Jeżeli prawdopodobieństwo < 0 lub jeśli prawdopodobieństwo > 1, funkcja ROZKŁAD.T.ODW zwraca wartość błędu #LICZBA!.
  • Jeżeli argument stopień_swobody nie jest liczbą całkowitą, jest obcinany.
  • Jeżeli argument stopnie_swobody < 1, funkcja ROZKŁAD.T.ODW daje w wyniku wartość błędu #LICZBA!.
  • Funkcja ROZKŁAD.T.ODW jest obliczana jako ROZKŁAD.T.ODW = p( t<X ), gdzie X jest zmienną losową, która jest zgodna z rozkładem t.
  • Jednostronna wartość t może zostać obliczona przez zamianę prawdopodobieństwa na 2*prawdopodobieństwo. Dla prawdopodobieństwa równego 0,05 i 10 stopni swobody, wartość dwustronna obliczana jest jako ROZKŁAD.T.ODW(0,05;10), równe 2,28139. Wartość jednostronna dla takiego samego prawdopodobieństwa i stopni swobody może zostać obliczona jako ROZKŁAD.T.ODW(2*0,05;10), równe 1,812462.

    Uwaga W niektórych tabelach prawdopodobieństwo wyrażane jest jako (1-p).

Funkcja ROZKŁAD.T.ODW korzysta z techniki iteracji do obliczania wartości funkcji. Przy danej wartości prawdopodobieństwa funkcja ROZKŁAD.T.ODW oblicza kolejne iteracje aż do momentu uzyskania wyniku z dokładnością do ± 3x10^-7. Jeśli nie uda się uzyskać takiej zbieżności po 100 iteracjach, funkcja ROZKŁAD.T.ODW zwraca wartość błędu #N/D.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
0,054645 | Prawdopodobieństwo związane z dwustronnym rozkładem t Studenta
60 | Stopnie swobody
Formuła | Opis (Wynik)
=ROZKŁAD.T.ODW(A2;A3) | Wartość t rozkładu t Studenta dla danych powyżej (1,959997462)


ROZKŁAD.WEIBULL

Zwraca funkcję rozkładu Weibulla. Rozkład ten należy stosować w analizie niezawodności, na przykład przy obliczaniu średniego czasu bezawaryjnej pracy urządzenia.

Składnia

ROZKŁAD.WEIBULL(x;alfa;beta;skumulowany)

X to wartość, dla której ta funkcja ma być oszacowana.

Alfa to parametr rozkładu.

Beta to parametr rozkładu.

Skumulowany to argument określający formę funkcji.

Spostrzeżenia

  • Jeżeli argument x, alfa lub beta nie jest wartością liczbową, funkcja ROZKŁAD.WEIBULL zwraca wartość błędu #ARG!.
  • Jeżeli x < 0, funkcja ROZKŁAD.WEIBULL zwraca wartość błędu #LICZBA!.
  • Jeśli alfa ≤ 0 lub jeśli beta ≤ 0, funkcja WEIBULL zwraca wartość błędu #LICZBA!.
  • Równanie funkcji skumulowanego rozkładu Weibulla jest następujące:

  • Równanie funkcji gęstości prawdopodobieństwa Weibulla jest następujące:

  • Jeśli alfa = 1, funkcja ROZKŁAD.WEIBULL zwraca rozkład wykładniczy z:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
105 | Wartość, dla której funkcja ma być oszacowana
20 | Parametr alfa rozkładu
100 | Parametr beta rozkładu
Formuła | Opis (Wynik)
=ROZKŁAD.WEIBULL(A2;A3;A4;PRAWDA) | Skumulowana funkcja rozkładu Weibulla dla danych powyżej (0,929581)
=ROZKŁAD.WEIBULL(A2;A3;A4;FAŁSZ) | Funkcja gęstości prawdopodobieństwa Weibulla dla danych powyżej (0,035589)


SKOŚNOŚĆ

Zwraca w wyniku skośność rozkładu. Skośność charakteryzuje stopień asymetrii rozkładu wokół jego średniej. Skośność dodatnia oznacza rozkład z asymetrycznym ogonem rozciągającym się w kierunku do wartości bardziej dodatnich. Skośność ujemna oznacza rozkład z asymetrycznym ogonem rozciągającym się w kierunku wartości bardziej ujemnych.

Składnia

SKOŚNOŚĆ(liczba1;liczba2;...)

Liczba1,liczba2; ... to argumenty od 1 do 30, dla których należy obliczyć skośność. Można stosować pojedynczą tablicę lub odwołanie do tablicy zamiast argumentów rozdzielonych średnikami.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami bądź odwołaniami, które zawierają liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeżeli są mniej niż trzy punkty danych lub normalne odchylenie próbki jest zerowe, funkcja SKOŚNOŚĆ daje w wyniku wartość błędu #DZIEL/0!.
  • Równanie skośności jest określone jako:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
3
4
5
2
3
4
5
6
4
7
Formuła | Opis (Wynik)
=SKOŚNOŚĆ(A2:A11) | Skośność rozkładu powyższego zbioru danych (0,359543)


ŚREDNIA

Zwraca wartość średnią (średnią arytmetyczną) argumentów.

Składnia

ŚREDNIA(liczba1;liczba2;...)

Liczba1; liczba2; ... to od 1 do 30 argumentów liczbowych, dla których ma zostać obliczona średnia.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami bądź odwołaniami, które zawierają liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
10
7
9
27
2
Formuła | Opis (Wynik)
=ŚREDNIA(A2:A6) | Średnia z powyższych liczb (11)
=ŚREDNIA(A2:A6;5) | Średnia z powyższych liczb i cyfry 5 (10)


ŚREDNIA.A

Oblicza wartość średnią (średnią arytmetyczną) argumentów z listy. W odróżnieniu od funkcji ŚREDNIA, w obliczeniach uwzględniane są wartości tekstowe i logiczne, takie jak PRAWDA i FAŁSZ.

Składnia

ŚREDNIA.A(wartość1;wartość2;...)

Wartość1; wartość2; ... to od 1 do 30 komórek, zakresów komórek lub wartości, dla których ma zostać obliczona średnia.

Spostrzeżenia

  • Argumenty powinny być liczbami, nazwami, tablicami lub odwołaniami.
  • Jeśli argument tablicowy lub odwołaniowy zawiera tekst, to jego wartość jest równa 0 (zero). Tekst pusty ("") również ma wartość 0 (zero). Jeśli w obliczeniach średniej wartości tekstowe mają być pomijane, należy stosować funkcję ŚREDNIA.
  • Wartość liczbowa argumentów zawierających wartość logiczną PRAWDA wynosi 1; wartość liczbowa argumentów zawierających wartość logiczną FAŁSZ wynosi 0 (zero).

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
10
7
9
2
Niedostępne
Formuła | Opis (Wynik)
=ŚREDNIA(A2:A6) | Średnia z powyższych liczb oraz tekstu „Niedostępne”. Komórka zawierająca wartość „Niedostępne” jest uwzględniana w obliczeniach (7)
=ŚREDNIA.A(A2:A5;A7) | Średnia z powyższych liczb oraz pustej komórki (5,6)


ŚREDNIA.GEOMETRYCZNA

Zwraca średnią geometryczną tablicy lub zakresu danych dodatnich. Funkcji ŚREDNIA.GEOMETRYCZNA można na przykład użyć do obliczenia średniej stopy wzrostu danego procentu składanego przy zmiennej stopie.

Składnia

ŚREDNIA.GEOMETRYCZNA(liczba1;liczba2;...)

Liczba1; liczba2; ... to ciąg od 1 do 30 argumentów, dla których ma zostać obliczona średnia. Zamiast argumentów oddzielonych średnikami można stosować pojedynczą tablicę lub odwołanie do tablicy.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami bądź odwołaniami, które zawierają liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeśli którykolwiek z punktów danych ≤ 0, funkcja ŚREDNIA.GEOMETRYCZNA zwraca wartość błędu #LICZBA!.
  • Równanie dla średniej geometrycznej ma postać:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
4
5
8
7
11
4
3
Formuła | Opis (Wynik)
=ŚREDNIA.GEOMETRYCZNA(A2:A8) | Średnia geometryczna dla zbioru danych pokazanego powyżej (5,476987)


ŚREDNIA.HARMONICZNA

Zwraca średnią harmoniczną zbioru danych. Średnia harmoniczna jest odwrotnością średniej arytmetycznej odwrotności.

Składnia

ŚREDNIA.HARMONICZNA(liczba1;liczba2;...)

Liczba1; liczba2; ... to ciąg od 1 do 30 argumentów, dla których ma zostać obliczona średnia. Zamiast argumentów oddzielonych średnikami można stosować pojedynczą tablicę lub odwołanie do tablicy.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami bądź odwołaniami, które zawierają liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeśli którykolwiek z punktów danych ≤ 0, funkcja ŚREDNIA.HARMONICZNA zwraca wartość błędu #LICZBA!.
  • Średnia harmoniczna jest zawsze mniejsza niż średnia geometryczna, która z kolei jest zawsze mniejsza niż średnia arytmetyczna.
  • Równanie dla średniej harmonicznej ma postać:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
4
5
8
7
11
4
3
Formuła | Opis (Wynik)
=ŚREDNIA.HARMONICZNA(A2:A8) | Średnia harmoniczna dla powyższego zbioru danych (5,028376)


ŚREDNIA.WEWN

Zwraca średnią wewnętrznej części zbioru danych. Funkcja ŚREDNIA.WEWN oblicza wartość średnią wziętą przez wykluczenie pewnego procentu punktów danych z górnego i dolnego śladu zbioru danych. Funkcję tę można stosować, chcąc wykluczyć z analizy dane skrajne.

Składnia

ŚREDNIA.WEWN(tablica;procent)

Tablica to tablica lub zakres wartości do obcięcia i uśrednienia.

Procent to wyrażona w postaci ułamkowej liczba punktów danych, które mają być wyłączone z obliczenia. Przykładowo, jeżeli procent = 0,2, wówczas 4 punkty są obcinane ze zbioru danych zawierającego 20 punktów (20 x 0,2), 2 z góry i 2 z dołu zbioru.

Spostrzeżenia

  • Jeśli procent < 0 lub procent > 1, ŚREDNIA.WEWN zwraca wartość błędu #LICZBA!.
  • Funkcja ŚREDNIA.WEWN zaokrągla liczbę wyłączanych punktów danych w dół, do najbliższej wielokrotności 2. Jeśli procent = 0,1, 10 procent z 30 punktów danych to 3 punkty. Dla symetrii funkcja ŚREDNIA.WEWN wyklucza jedną wartość z góry i jedną z dołu zbioru danych.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
4
5
6
7
2
3
4
5
1
2
3
Formuła | Opis (Wynik)
=ŚREDNIA.WEWN(A2:A12;0,2) | Średnia wewnętrznej części powyższego zbioru danych przy 20 procentach punktów danych wyłączonych z obliczenia (3,777778)


TEST.CHI

Zwraca wartość testu niezależności. Funkcja TEST.CHI zwraca wartość rozkładu chi-kwadrat (γ2) statystyki oraz właściwą liczbę stopni swobody. Test γ2 jest przydatny w sprawdzaniu, czy eksperyment potwierdza wyniki hipotetyczne.

Składnia

TEST.CHI(zakres_rzeczywisty;zakres_oczekiwany)

Zakres_rzeczywisty to zakres danych zawierający wyniki obserwacji, które będą porównywane z wartościami oczekiwanymi.

Zakres_oczekiwany to zakres danych zawierający stosunek iloczynu sum wierszy i sum kolumn do sumy końcowej.

Spostrzeżenia

  • Jeśli argumenty zakres_rzeczywisty i zakres_oczekiwany mają różne liczby punktów danych, funkcja TEST.CHI zwraca wartość błędu #N/D!.
  • Test γ2 najpierw oblicza statystykę γ2, a następnie sumuje różnice między wartościami rzeczywistymi a wartościami oczekiwanymi. Równanie funkcji TEST.CHI ma postać TEST.CHI=p( X>γ2 ), gdzie:

    i gdzie:

    Aij = rzeczywista częstość w i-tym wierszu j-tej kolumny

    Eij = oczekiwana częstość w i-tym wierszu j-tej kolumny

    r = liczba wierszy

    c = liczba kolumn

    Funkcja TEST.CHI zwraca wartość prawdopodobieństwa dla statystyki γ2 i liczby stopni swobody df, gdzie df = (r — 1)(c — 1).

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Mężczyźni (rzeczywisty) | Kobiety (rzeczywisty) | Opis
58 | 35 | Zgodne
11 | 25 | Neutralne
10 | 23 | Niezgodne
Mężczyźni (oczekiwany) | Kobiety (oczekiwany) | Opis
45,35 | 47,65 | Zgodne
17,56 | 18,44 | Neutralne
16,09 | 16,91 | Niezgodne
Formuła | Opis (Wynik)
=TEST.CHI(A2:B4;A6:B8) | Statystyka γ2 dla powyższych danych wynosi 16,16957 przy dwóch stopniach swobody (0,000308)


TEST.F

Zwraca wynik testu F. Test F zwraca jednostronne prawdopodobieństwo, że wariancje w tablicach tablica1 i tablica2 nie różnią się znacząco od siebie. Funkcja ta służy do określenia, czy dwie próbki mają różne wariancje. Na przykład badając wyniki testów ze szkół prywatnych i publicznych można sprawdzić, czy szkoły te mają inne poziomy zróżnicowania.

Składnia

TEST.F(tablica1;tablica2)

Tablica1 to pierwsza tablica lub zakres danych.

Tablica2 to druga tablica lub zakres danych.

Spostrzeżenia

  • Argumenty powinny być liczbami albo nazwami, tablicami bądź odwołaniami, które zawierają liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeśli liczba punktów danych w tablicach tablica1 i tablica2 jest mniejsza niż 2 lub wariancja argumentu tablica1 lub tablica2 jest równa zeru, to funkcja TEST.F zwraca wartość błędu #DZIEL/0!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane1 | Dane2
6 | 20
7 | 28
9 | 31
15 | 38
21 | 40
Formuła | Opis (Wynik)
=TEST.F(A2:A6;B2:B6) | Wartość testu F dla powyższych zbiorów danych (0,648318)


TEST.T

Zwraca prawdopodobieństwo związane z testem t Studenta. Funkcję TEST.T należy stosować do określenia, czy istnieje prawdopodobieństwo, że dwie próbki pochodzą z tych samych podległych populacji, które mają taką samą wartość średnią.

Składnia

TEST.T(tablica1;tablica2;ślady;typ)

Tablica1 to pierwszy zbiór danych.

Tablica2 to drugi zbiór danych.

Ślady to argument określający liczbę śladów rozkładu. Jeżeli ślady = 1, funkcja TEST.T stosuje rozkład jednostronny. Jeżeli ślady = 2, funkcja TEST.T stosuje rozkład dwustronny.

Typ to rodzaj testu t, który ma być przeprowadzony.

Jeżeli typ równa się | Przeprowadzany jest ten test
1 | Sparowany
2 | Wariancja równa dla dwóch prób (homoscedastyczna)
3 | Wariancja nierówna dla dwóch prób (heteroscedastyczna)

Spostrzeżenia

  • Jeżeli argumenty tablica1 i tablica2 mają inną liczbę punktów danych, a typ = 1 (sparowany), wówczas funkcja TEST.T daje w wyniku wartość błędu #N/D.
  • Argumenty ślady i typ są obcinane do liczb całkowitych.
  • Jeżeli argument ślady lub typ nie jest wartością liczbową, funkcja TEST.T daje w wyniku wartość błędu #ARG!.
  • Jeżeli argument ślady ma wartość inną niż 1 lub 2, funkcja TEST.T daje w wyniku wartość błędu #LICZBA!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane 1 | Dane 2
3 | 6
4 | 19
5 | 3
8 | 2
9 | 14
1 | 4
2 | 5
4 | 17
5 | 1
Formuła | Opis (Wynik)
=TEST.T(A2:A10;B2:B10;2;1) | Prawdopodobieństwo związane ze sparowanym testem t Studenta, z dwoma śladami rozkładu (0,196016)


TEST.Z

Zwraca prawdopodobieństwo testu dwustronnego z. Test z generuje standardowy wynik dla x w odniesieniu do zbioru danych, tablicy i daje w wyniku dwustronne prawdopodobieństwo dla rozkładu normalnego. Funkcję tę można stosować do oceniania prawdopodobieństwa, że dana obserwacja jest wzięta z określonej populacji.

Składnia

TEST.Z(tablica;x;sigma)

Tablica to tablica lub zakres danych, w stosunku do którego ma być badana wartość x.

X to wartość, która ma być badana.

Sigma to odchylenie standardowe populacji (znane). Jeżeli argument ten pominie się, stosowane jest odchylenie standardowe próbki.

Spostrzeżenia

  • Jeżeli argument tablica jest pusty, funkcja TEST.Z daje w wyniku wartość błędu #N/D.
  • Funkcja TEST.Z obliczana jest w następujący sposób:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
3
6
7
8
6
5
4
2
1
9
Formuła | Opis (Wynik)
=TEST.Z(A2:A11;4) | Prawdopodobieństwo testu dwustronnego z dla powyższego zestawu danych i wartości badanej 4 (0,090574)


UFNOŚĆ

Zwraca przedział ufności dla średniej z populacji przy rozkładzie normalnym. Przedział ufności jest zakresem po każdej stronie średniej z próby. Na przykład w przypadku zamawiania wyrobu przez pocztę można określić, z określonym poziomem ufności, najwcześniejszą i najpóźniejszą datę dostarczenia przesyłki.

Składnia

UFNOŚĆ(alfa;odchylenie_standardowe;liczność)

Alfa to poziom istotności stosowany do obliczenia poziomu ufności. Poziom ufności jest równy 100*(1 — alfa)% lub innymi słowy, alfa równe 0,05 wskazuje na 95-procentowy poziom ufności.

Odchylenie_standardowe to odchylenie standardowe populacji danych i zakłada się, że jest ono znane.

Liczność jest to wielkość próby.

Spostrzeżenia

  • Jeśli którykolwiek z argumentów nie jest liczbą, funkcja UFNOŚĆ zwraca wartość błędu #ARG!.
  • Jeśli argument alfa ≤ 0 lub argument alfa ≥ 1, funkcja UFNOŚĆ zwraca wartość błędu #LICZBA!.
  • Jeśli argument odchylenie_standardowe ≤ 0, funkcja UFNOŚĆ zwraca wartość błędu #LICZBA!.
  • Jeśli argument liczność nie jest liczbą całkowitą, zostaje obcięty do liczby całkowitej.
  • Jeśli argument liczność < 1, funkcja UFNOŚĆ zwraca wartość błędu #LICZBA!.
  • Jeśli wartość parametru alfa zostanie przyjęta jako 0,05, należy obliczyć pole powierzchni pod standardową krzywą normalną, która równa jest (1 — alfa) czyli 95%. Wartość ta wynosi ± 1,96. Przedział ufności wynosi zatem:

Przykład

Przypuśćmy, że w przypadku próby 50 osób dojeżdżających do pracy średni czas dotarcia do pracy wynosi 30 minut przy odchyleniu standardowym dla populacji wynoszącym 2,5. Można mieć 95-procentową pewność, że średnia dla populacji zawiera się w przedziale:

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane | Opis
0,05 | Poziom istotności
2,5 | Odchylenie standardowe dla populacji
50 | Liczebność próbki
Formuła | Opis (Wynik)
=UFNOŚĆ(A2;A3;A4) | Przedział ufności dla średniej z populacji (0,692951). Innymi słowy średni czas dojazdu do pracy wynosi 30 ± 0,692951 minut, lub od 29,3 do 30,7 minut.


WARIANCJA

Ocenia wariancję na podstawie próbki.

Składnia

WARIANCJA(liczba1;liczba2;...)

Liczba1; liczba2; ... to od 1 do 30 argumentów liczbowych odpowiadających próbce z populacji.

Spostrzeżenia

  • Funkcja WARIANCJA przyjmuje, ze jej argumenty są próbka z populacji. Jeżeli nasze dane reprezentują cala populacje, należy obliczyć wariancje stosując funkcje WARIANCJA.POPUL.
  • Wartości logiczne, takie jak PRAWDA i FALSZ, oraz wartości tekstowe są ignorowane. Jeśli wartości logiczne i tekst nie maja być ignorowane, użyj funkcji arkusza WARIANCJA.A.
  • Funkcja WARIANCJA używa następującej formuły:

Przykład

Przyjmijmy, ze 10 narzędzi wykonanych na tej samej maszynie w jednym cyklu produkcji zostało zebranych jako przypadkowa próbka, na której przeprowadzono pomiar wytrzymałości na złamanie.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Siła
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
Formuła | Opis (Wynik)
=WARIANCJA(A2:A11) | Wariancja dla wytrzymałości na złamanie charakteryzującej powyższe narzędzia (754,2666667)


WARIANCJA.A

Ocenia wariancję na podstawie próbki. Oprócz liczb, w obliczeniach mogą być brane pod uwagę teksty oraz wartości logiczne PRAWDA i FAŁSZ.

Składnia

WARIANCJA.A(wartość1;wartość2;...)

Wartość1; wartość2; ... to od 1 do 30 wartości odpowiadających próbce populacji.

Spostrzeżenia

  • Funkcja WARIANCJA.A przyjmuje, że jej argumenty są próbką z populacji. Jeżeli nasze dane reprezentują całą populację, należy obliczyć wariancję, stosując funkcję WARIANCJA.POPUL.A.
  • Wartość liczbowa argumentów zawierających wartość logiczną PRAWDA wynosi 1; wartość liczbowa argumentów zawierających wartość tekstową lub wartość logiczną FAŁSZ wynosi 0 (zero). Jeśli w obliczeniach wartości tekstowe i logiczne powinny być pomijane, należy stosować funkcję arkusza kalkulacyjnego WARIANCJA.
  • Funkcja WARIANCJA.A wykorzystuje następującą formułę:

Przykład

Przyjmijmy, ze 10 narzędzi wykonanych na tej samej maszynie w jednym cyklu produkcji zostało zebranych jako przypadkowa próbka, na której przeprowadzono pomiar wytrzymałości na złamanie.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Siła
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
Formuła | Opis (Wynik)
=WARIANCJA.A(A2:A11) | Wariancja wytrzymałości na złamanie (754,2666667)


WARIANCJA.POPUL

Oblicza wariancję na podstawie całej populacji.

Składnia

WARIANCJA.POPUL(liczba1;liczba2;...)

Liczba1; liczba2; ... to od 1 do 30 argumentów liczbowych odpowiadających populacji.

  • Wartości logiczne, takie jak PRAWDA i FAŁSZ, oraz wartości tekstowe są ignorowane. Jeśli wartości logiczne i tekst nie mają być ignorowane, użyj funkcji arkusza WARIANCJA.POPUL.A.

Spostrzeżenia

  • Funkcja WARIANCJA.POPUL zakłada, że jej argumenty są całą populacją. Jeżeli dane reprezentują próbkę z populacji, wówczas należy obliczyć wariancję, stosując funkcję WARIANCJA.
  • Funkcja WARIANCJA.POPUL wykorzystuje następujące równanie:

Przykład

Przyjmijmy, że 10 narzędzi wykonanych na tej samej maszynie w jednym cyklu produkcji zostało zebranych i zmierzonych pod kątem wytrzymałości na złamanie.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Siła
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
Formuła | Opis (Wynik)
=WARIANCJA.POPUL(A2:A11) | Wariancja wytrzymałości na złamanie dla wszystkich narzędzi przy założeniu, że wyprodukowano ich tylko 10 (678,84)


WARIANCJA.POPUL.A

Oblicza wariancję na podstawie całej populacji. Oprócz liczb w obliczeniach brane są pod uwagę wartości tekstowe oraz wartości logiczne takie jak PRAWDA i FAŁSZ.

Składnia

WARIANCJA.POPUL.A(wartość1;wartość2;...)

Wartość1; wartość2; ... to od 1 do 30 wartości odpowiadających populacji.

Spostrzeżenia

  • Funkcja WARIANCJA.POPUL.A zakłada, że jej argumenty są całą populacją. Jeżeli nasze dane reprezentują próbkę z populacji, wówczas należy obliczyć wariancję, stosując funkcję WARIANCJA.A.
  • Wartość liczbowa argumentów zawierających wartość logiczną PRAWDA wynosi 1; wartość liczbowa argumentów zawierających wartość tekstową lub wartość logiczną FAŁSZ wynosi 0 (zero). Jeśli wartości logiczne i tekstowe nie mają być włączane do obliczenia, należy zastosować funkcję VARP.
  • Funkcja WARIANCJA.POPUL.A wykorzystuje następujące równanie:

Przykład

Przyjmijmy, że 10 narzędzi wykonanych na tej samej maszynie w jednym cyklu produkcji zostało zebranych i zmierzonych pod kątem wytrzymałości na złamanie.

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Siła
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
Formuła | Opis (Wynik)
=WARIANCJA.POPUL.A(A2:A11) | Wariancja wytrzymałości na złamanie dla wszystkich narzędzi przy założeniu, że wyprodukowano ich tylko 10 (678,84)


WSP.KORELACJI

Zwraca wartość współczynnika korelacji zakresów komórek tablica1 i tablica2. Współczynnik korelacji jest przydatny do wyznaczania zależności między dwoma własnościami. Na przykład można sprawdzić zależność między średnią temperaturą panującą w danej miejscowości a używaniem klimatyzatorów.

Składnia

WSP.KORELACJI(tablica1;tablica2)

Tablica1 to zakres komórek zawierających wartości.

Tablica2 to drugi zakres komórek zawierających wartości.

Spostrzeżenia

  • Argumenty powinny być liczbami, nazwami, tablicami lub odwołaniami zawierającymi liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeśli argumenty tablica1 i tablica2 mają różne liczby punktów danych, funkcja WSP.KORELACJI zwraca wartość błędu #N/D!.
  • Jeśli którykolwiek z zakresów tablica1 lub tablica2 jest pusty lub jeśli s (odchylenie standardowe) ich wartości jest równe zero, funkcja WSP.KORELACJI zwraca wartość błędu #DZIEL/0!.
  • Równanie współczynnika korelacji ma postać:

    gdzie:

    i:

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane1 | Dane2
3 | 9
2 | 7
4 | 12
5 | 15
6 | 17
Formuła | Opis (Wynik)
=WSP.KORELACJI(A2:A6;B2:B6) | Współczynnik korelacji dla dwóch zestawów danych pokazanych powyżej (0,997054)


WYST.NAJCZĘŚCIEJ

Zwraca wartość najczęściej występującą lub powtarzającą się w tablicy albo w zakresie danych. Podobnie jak funkcja MEDIANA, funkcja WYST.NAJCZĘŚCIEJ jest miarą lokalizacji.

Składnia

WYST.NAJCZĘŚCIEJ(liczba1;liczba2;...)

Liczba1; liczba2; ... to liczba od 1 do 30 argumentów, dla których ma być obliczona wartość modalna. Zamiast listy argumentów oddzielonych średnikami można użyć pojedynczej tablicy lub odwołania do tablicy.

Spostrzeżenia

  • Argumenty powinny być liczbami, nazwami, tablicami lub odwołaniami zawierającymi liczby.
  • Jeśli argument tablicowy lub odwołanie zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak włączane do obliczeń.
  • Jeśli zbiór danych nie zawiera powtarzających się punktów danych, to funkcja WYST.NAJCZĘŚCIEJ zwraca wartość błędu #N/D.

W zbiorze wartości najczęściej występującą wartością jest wartość modalna, mediana jest wartością środkową, a średnia oznacza wartość uśrednioną. Żadna pojedyncza miara głównych tendencji nie dostarcza kompletnego obrazu danych. Na przykład można przyjąć założenie, że dane są zgromadzone w trzech obszarach, połowa wokół jednej najniższej wartości, a druga połowa wokół dwóch najwyższych wartości. Zarówno funkcja ŚREDNIA, jak i funkcja MEDIANA mogą zwrócić wartość zlokalizowaną we względnie pustym środku, a funkcja WYST.NAJCZĘŚCIEJ może zwrócić dominującą wartość najniższą.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
5,6
4
4
3
2
4
Formuła | Opis (Wynik)
=WYST.NAJCZĘŚCIEJ(A2:A7) | Wartość modalna, czyli liczba występująca najczęściej w powyższym zbiorze (4)


ASC

W językach korzystających z zestawu znaków dwubajtowych (DBCS) zmienia jednobajtowe znaki angielskie na znaki dwubajtowe.

Składnia

ASC(tekst)

Tekst to tekst lub odwołanie do komórki, zawierającej tekst, który chcesz zmienić. Jeśli tekst nie zawiera żadnych angielskich liter o pełnej szerokości, tekst nie zostaje zmieniony.

Przykłady

ASC("EXCEL") równa się "EXCEL"

=ASC(" Excel Excel Excel Excel ") równa się " Excel Excel Excel Excel "


DŁ

Funkcja DŁ zwraca liczbę znaków ciągu tekstowego.

Składnia

DŁ(tekst)

Tekst to tekst, którego długość należy znaleźć. Spacje liczy się jako znaki.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Phoenix, AZ
Jeden
Formuła | Opis (Wynik)
=DŁ(A2) | Długość pierwszego ciągu (11)
=DŁ(A3) | Długość drugiego ciągu (0)
=DŁ(A4) | Długość trzeciego ciągu, który zawiera 5 spacji (10)


FRAGMENT.TEKSTU

Funkcja FRAGMENT.TEKSTU zwraca określoną liczbę znaków z ciągu tekstowego, począwszy od podanej pozycji.

Składnia

FRAGMENT.TEKSTU(tekst;liczba_początkowa;liczba_znaków)

Tekst to ciąg tekstowy zawierający znaki, które mają być wyodrębnione.

Liczba_początkowa to położenie pierwszego znaku, który należy wydzielić z tekstu. Pierwszy znak w tekście ma liczbę_początkową 1 i tak dalej.

Liczba_znaków określa liczbę znaków, które należy pobrać z tekstu.

Spostrzeżenia

  • Jeśli liczba_początkowa jest większa niż długość tekstu, funkcja FRAGMENT.TEKSTU zwraca wartość "" (tekst pusty).
  • Jeśli liczba_początkowa jest mniejsza niż długość tekstu, ale liczba_początkowa plus liczba_znaków przewyższają długość tekstu, funkcja FRAGMENT.TEKSTU zwraca znaki do końca tekstu.
  • Jeśli liczba_początkowa jest mniejsza niż 1, funkcja FRAGMENT.TEKSTU zwraca wartość błędu #ARG!.

  • Jeśli liczba_znaków jest ujemna, funkcja FRAGMENT.TEKSTU zwraca wartość błędu #ARG!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Przepływ płynu
Formuła | Opis (Wynik)
=FRAGMENT.TEKSTU(A2;1;5) | Pięć znaków z powyższego ciągu, poczynając od pierwszego znaku (Przep)
=FRAGMENT.TEKSTU(A2;7;20) | Dwadzieścia znaków z powyższego ciągu, poczynając od siódmego znaku (yw płynu)
=FRAGMENT.TEKSTU(A2;20;5) | Ponieważ punkt początkowy jest większy niż długość ciągu, zwracany jest tekst pusty ()


KOD

Zwraca kod liczbowy pierwszego znaku w ciągu. Zwrócony kod odpowiada zestawowi znaków używanemu w komputerze.

Składnia

KOD(tekst)

Tekst to tekst, którego pierwszy znak ma być zwrócony jako kod.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=KOD("A") | Wyświetla kod liczbowy litery A (65)
=KOD("!") | Wyświetla kod liczbowy znaku ! (33)


KWOTA

Zamienia liczbę na tekst stosując format walutowy, z częściami dziesiętnymi zaokrąglonymi do odpowiedniego miejsca. Zastosowany format to (# ##0,00 zł).

Składnia

KWOTA(liczba;miejsca_dziesiętne)

Liczba to liczba lub odwołanie do komórki zawierającej liczbę lub formułę, dającą w wyniku liczbę.

Miejsca_dziesiętne to liczba cyfr po prawej stronie przecinka dziesiętnego. Jeśli argument miejsca_dziesiętne jest ujemny, liczbę zaokrągla się do lewej strony przecinka dziesiętnego. Jeśli argument miejsca_dziesiętne zostanie pominięty, domyślnie przyjmuje się go jako 2.

Spostrzeżenia

Główna różnica między formatowaniem komórki zawierającej liczbę w formacie Waluta (karta Format, okno dialogowe Polecenia i opcje), a formatowaniem liczby bezpośrednio za pomocą funkcji KWOTA polega na tym, że ta funkcja przekształca wynik na tekst. Liczba sformatowana w formacie Waluta jest nadal liczbą. Liczby sformatowane za pomocą funkcji KWOTA mogą być używane w formułach, ponieważ liczby wpisywane jako wartości tekstowe są przed wykonaniem obliczeń konwertowane na liczby.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
1234,567
-1234,567
-0,123
99,888
Formuła | Opis (Wynik)
=KWOTA(A2; 2) | Wyświetla pierwszą liczbę w formacie waluty, 2 cyfry po prawej stronie przecinka dziesiętnego (1 234,57 zł)
=KWOTA(A2; -2) | Wyświetla pierwszą liczbę w formacie waluty, 2 cyfry po lewej stronie przecinka dziesiętnego (1 200 zł)
=KWOTA(A3; -2) | Wyświetla drugą liczbę w formacie waluty, 2 cyfry po lewej stronie przecinka dziesiętnego ((1 200 zł))
=KWOTA(A4; 4) | Wyświetla trzecią liczbę w formacie waluty, 4 cyfry po prawej stronie przecinka dziesiętnego((0,1230 zł))
=KWOTA(A5) | Wyświetla czwartą liczbę w formacie waluty, 2 cyfry po lewej stronie przecinka dziesiętnego (99,89 zł)


LEWY

Funkcja LEWY zwraca pierwszy znak lub znaki w ciągu tekstowym, w zależności od określonej przez użytkownika liczby znaków.

Składnia

LEWY(tekst;liczba_znaków)

Tekst to ciąg tekstowy zawierający znaki, które należy wydzielić.

Liczba_znaków określa, ile znaków ma być wynikiem działania funkcji LEWY.

  • Liczba_znaków musi być większa niż lub równa zeru.

  • Jeśli liczba_znaków jest większa niż długość tekstu, funkcja LEWY zwraca cały tekst.

  • Pominięcie argumentu liczba_znaków oznacza, że jego wartość zostanie przyjęta jako równa 1.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Cena sprzedaży
Szwecja
Formuła | Opis (Wynik)
=LEWY(A2;4) | Pierwsze cztery znaki pierwszego ciągu (Cena)
=LEWY(A3) | Pierwszy znak drugiego ciągu (S)


LITERY.MAŁE

Zamienia wszystkie wielkie litery w ciągu tekstowym na małe.

Składnia

LITERY.MAŁE(tekst)

Tekst to tekst, który należy przetworzyć na małe litery. Funkcja LITERY.MAŁE nie zmienia w tekście znaków, które nie są literami.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
S. W. Borowik
m. 2B
Formuła | Opis (Wynik)
=LITERY.MAŁE(A2) | Zmienia litery na małe w pierwszym ciągu (s. w. kowalski)
=LITERY.MAŁE(A3) | Zmienia litery na małe w ostatnim ciągu (m. 2b)


LITERY.WIELKIE

Funkcja przekształca małe litery tekstu w wielkie.

Składnia

LITERY.WIELKIE(tekst)

Tekst oznacza tekst, którego znaki przekształcane są w wielkie litery. Tekst może być odwołaniem lub ciągiem tekstowym.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
razem
Zysk
Formuła | Opis (Wynik)
=LITERY.WIELKIE(A2) | Pierwszy ciąg przedstawiony wielkimi literami (RAZEM)
=LITERY.WIELKIE(A3) | Drugi ciąg przedstawiony wielkimi literami (ZYSK)


OCZYŚĆ

Usuwa z tekstu wszystkie znaki, które nie mogą być wydrukowane. Funkcji OCZYŚĆ należy używać do tekstów importowanych z innych aplikacji, zawierających znaki niemożliwe do wydrukowania w użytkowanym systemie operacyjnym. Na przykład funkcji OCZYŚĆ można użyć do usunięcia pewnych fragmentów kodów komputerowych niskiego poziomu, często kończących i rozpoczynających zbiory z danymi i nie nadających się do wydrukowania.

Składnia

OCZYŚĆ(tekst)

Tekst to dowolna informacja z arkusza roboczego, z której należy usunąć znaki niemożliwe do drukowania.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
=ZNAK(7)&"tekst"&ZNAK(7)
Formuła | Opis (Wynik)
=OCZYŚĆ(A2) | Usuwa z powyższego tekstu (tekst) niemożliwy do wydrukowania znak, ZNAK(7).


PODSTAW

Funkcja zastępuje argument stary_tekst w ciągu tekstowym argumentem nowy_tekst. Funkcję PODSTAW stosuje się, aby zastąpić wybrany tekst w ciągu tekstowym, funkcję ZASTĄP zaś, kiedy trzeba zastąpić dowolny tekst występujący w określonym miejscu ciągu tekstowego.

Składnia

PODSTAW(tekst;stary_tekst;nowy_tekst;wystąpienie_liczba)

Tekst jest to tekst lub adres komórki zawierającej tekst, w którym mają być zastąpione znaki.

Stary_tekst jest to tekst do zastąpienia.

Nowy_tekst jest to tekst, którym zostanie zastąpiony stary_tekst.

Wystąpienie_liczba określa, które wystąpienie argumentu stary_tekst zostanie zastąpione przez nowy_tekst. Jeśli wybierze się wystąpienie_liczba, to tylko to wystąpienie stary_tekst zostanie zastąpione. W innym przypadku każde pojawienie się stary_tekst jest zamieniane przez nowy_tekst.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Dane sprzedaży
1 kwartał 2008
1 kwartał 2011
Formuła | Opis (Wynik)
=PODSTAW(A2; "sprzedaży"; "kosztów") | Podstawia słowo kosztów zamiast sprzedaży (Dane kosztów)
=PODSTAW(A3; "1"; "2"; 1) | Zastępuje pierwsze wystąpienie ciągu "1" ciągiem "2" (2 kwartał 2008)
=PODSTAW(A4; "1"; "2"; 3) | Zastępuje trzecie wystąpienie ciągu "1" ciągiem "2" (1 kwartał 2012)


PORÓWNAJ

Porównuje dwa ciągi tekstowe i zwraca wartość PRAWDA, jeśli są dokładnie takie same, a w przeciwnym przypadku FAŁSZ. Funkcja PORÓWNAJ rozróżnia wielkie i małe litery, ale ignoruje różnice w formatowaniu. Funkcję PORÓWNAJ należy stosować do sprawdzania tekstu wprowadzanego do dokumentu.

Składnia

PORÓWNAJ(tekst1;tekst2)

Tekst1 jest pierwszym ciągiem tekstowym.

Tekst2 jest drugim ciągiem tekstowym.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Pierwszy ciąg | Drugi ciąg
wyraz | wyraz
wyraz | wyraz
wyraz | wyraz
Formuła | Opis (Wynik)
=PORÓWNAJ(A2;B2) | Sprawdza, czy ciągi w pierwszym wierszu są jednakowe (PRAWDA)
=PORÓWNAJ(A3;B3) | Sprawdza, czy ciągi w drugim wierszu są jednakowe (FAŁSZ)
=PORÓWNAJ(A4;B4) | Sprawdza, czy ciągi w trzecim wierszu są jednakowe (FAŁSZ)


POWT

Funkcja wykonuje określoną liczbę powtórzeń tekstu. Stosuje się ją, aby wypełnić komórkę konkretną liczbą ciągów tekstowych.

Składnia

POWT(tekst;ile_razy)

Tekst jest tekstem, który ma być powtarzany.

Ile_razy jest liczbą dodatnią określającą liczbę powtórzeń tekstu.

Spostrzeżenia

  • Jeśli argument ma wartość 0, funkcja zwraca "" (pusty tekst).

  • Jeśli liczba powtórzeń nie jest liczbą całkowitą, jest do takiej wartości obcinana.

  • Wynik funkcji POWT nie może być dłuższy niż 32 767 znaków. W przeciwnym wypadku funkcja POWT zwraca wartość błędu #WARTOŚĆ!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=POWT("*-";10) | Wyświetla ciąg 3 razy (*-*-*-)
=POWT("-";10) | Wyświetla myślnik 10 razy (----------)


PRAWY

Funkcja PRAWY zwraca ostatni znak lub znaki w łańcuchu tekstowym, korzystając z określonej liczby znaków.

Składnia

PRAWY(tekst;liczba_znaków)

Tekst to ciąg tekstowy zawierający znaki, które mają być wyodrębnione.

Liczba_znaków określa liczbę znaków jakie ma pobrać funkcja PRAWY.

Spostrzeżenia

  • Liczba_znaków musi być większa niż lub równa zeru.
  • Jeśli wartość argumentu liczba_znaków jest większa od długości tekstu, to funkcja PRAWY zwraca cały tekst.
  • Pominięcie argumentu liczba_znaków oznacza, że jego wartość zostanie przyjęta jako równa 1.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Cena sprzedaży
Numer magazynowy
Formuła | Opis (Wynik)
=PRAWY(A2;5) | Pięć ostatnich znaków pierwszego ciągu (edaży)
=PRAWY(A3) | Ostatni znak drugiego ciągu (y)


SZUKAJ.TEKST

Funkcja SZUKAJ.TEKST zwraca numer znaku, przy którym konkretny znak lub ciąg tekstowy wystąpił po raz pierwszy, poczynając od liczba_początkowa. Funkcję SZUKAJ.TEKST należy stosować do znajdowania położenia znaku lub ciągu tekstowego wewnątrz innego ciągu tekstowego, aby umożliwić wykorzystanie funkcji FRAGMENT.TEKSTU lub ZASTĄP do zmiany tekstu.

Składnia

SZUKAJ.TEKST(szukany_tekst;obejmujący_tekst;liczba_początkowa)

Szukany_tekst jest tekstem, który należy znaleźć. W argumencie szukany_tekst można używać znaków zastępczych — znaku zapytania (?) i gwiazdki (*). Znak zapytania zastępuje dowolny pojedynczy znak, a gwiazdka — sekwencję znaków. Chcąc znaleźć faktycznie istniejący znak zastępczy, należy przed tym znakiem wpisać tyldę (~).

Obejmujący_tekst jest to tekst, w którym należy szukać argumentu szukany_tekst.

Liczba_początkowa jest to numer znaku w argumencie obejmujący_tekst, od którego należy zacząć poszukiwanie.

Porada

Aby przeskoczyć wybraną liczbę znaków idąc od lewej strony tekstu, należy zastosować argument liczba_początkowa. Na przykład załóżmy, że pracujemy z następującym ciągiem tekstowym: "AUM0093.UbraniaMęskie". Aby znaleźć numer pierwszego "U" w opisowej części łańcucha tekstowego, należy nadać argumentowi liczba_początkowa wartość 8 tak, że część numeru seryjnego tekstu nie będzie przeszukiwana. Funkcja SZUKAJ.TEKST rozpocznie przeszukiwanie od znaku numer 8, znajdzie tekst określony argumentem szukany_tekst na następnym znaku i zwróci liczbę 9. Jeśli argument liczba_początkowa jest większy niż 1, funkcja SZUKAJ.TEKST zawsze zwraca liczbę znaków poczynając od początku tekstu określonego argumentem obejmujący_tekst, zliczając także znaki pominięte.

Spostrzeżenia

  • Funkcja SZUKAJ.TEKST nie rozróżnia wielkości liter w trakcie przeszukiwania tekstu.
  • Funkcja SZUKAJ.TEKST jest podobna do funkcji ZNAJD? z taką różnicą, że funkcja ZNAJD? rozróżnia wielkość liter.
  • Jeśli argument szukany_tekst nie zostanie znaleziony, zostanie zwrócona wartość błędu #WARTOŚĆ!.
  • Jeśli argument liczba_początkowa zostanie pominięty, to zakłada się, że jest równy 1.
  • Jeśli argument liczba_początkowa nie jest większy niż 0 lub jest większy niż długość określona argumentem obejmujący_tekst, zwrócona zostanie wartość błędu #WARTOŚĆ!.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Instrukcje
Margines zysku
margines
Formuła | Opis (Wynik)
=SZUKAJ.TEKST("e";A2;6) | Pozycja pierwszego wystąpienia litery "e" w pierwszym z powyższych ciągów, poczynając od szóstej pozycji (10)
=SZUKAJ.TEKST(A4;A3) | Pozycja tekstu "margines" w ciągu "Margines zysku" (1)
=ZASTĄP(A3;SZUKAJ.TEKST(A4;A3);6;"Kwota") | Zastępuje ciąg "Margines" ciągiem "Kwota" (Kwota zysku)


T

Funkcja zwraca tekst, do którego odnosi się wartość.

Składnia

T(wartość)

Wartość jest wartością, która ma być testowana.

Spostrzeżenia

  • Jeśli argument wartość jest tekstem lub odnosi się do tekstu, to funkcja T zwraca wartość argumentu. Jeśli zaś nie odnosi się do tekstu, to funkcja T zwraca "" (pusty tekst).

  • Zazwyczaj nie ma potrzeby używania funkcji T w formułach, ponieważ na ogół wartości są w razie potrzeby poddawane konwersji. Funkcja ta zapewnia zgodność z innymi programami arkuszy kalkulacyjnych.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Deszcz
19
PRAWDA
Formuła | Opis (Wynik)
=T(A2) | Ponieważ pierwsza wartość jest tekstem, zwracany jest tekst (Deszcz)
=T(A3) | Ponieważ druga wartość jest liczbą, zwracany jest tekst pusty ()
=T(A4) | Ponieważ trzecia wartość jest wartością logiczną, zwracany jest tekst pusty ()


TEKST

Funkcja przekształca wartość w tekst w określonym formacie liczbowym.

Składnia

TEKST(wartość;format_tekst)

Wartość jest wartością liczbową, formułą, której wynikiem jest liczba lub odwołaniem do komórki zawierającej wartość liczbową.

Format_text jest formatem liczbowym w formacie tekstowym z pola Format liczby na karcie Format w oknie dialogowym Polecenia i opcje.

Spostrzeżenia

  • Formatowanie komórki za pomocą opcji na karcie Format (okno dialogowe Polecenia i opcje) zmienia tylko format, a nie wartość. Zastosowanie funkcji TEKST spowoduje przekształcenie wartości w sformatowany tekst, a wynik nie będzie już dłużej obliczany jako liczba.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Sprzedawca | Sprzedaż
Borowik | 2800
Zieliński | 0,4
Formuła | Opis (Wynik)
=A2&" sprzedał za sumę "&TEKST(B2; "Waluta")&"." | Łączy podaną powyżej treść tworząc zdanie (Borowik sprzedał za sumę 2800,00 zł.)
=A3&" osiągnął "&TEKST(B3;"Procent")&" łącznej sprzedaży." | Łączy podaną powyżej treść tworząc zdanie (Zieliński osiągnął 40,00% łącznej sprzedaży.)


USUŃ.ZBĘDNE.ODSTĘPY

Funkcja usuwa wszystkie spacje z tekstu oprócz pojedynczych spacji pomiędzy słowami. Stosuje się ją w przypadku tekstu pochodzącego z innych aplikacji, w którym mogą występować nieregularne spacje.

Składnia

USUŃ.ZBĘDNE.ODSTĘPY(tekst)

Tekst jest tekstem, z którego mają być usunięte spacje.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=USUŃ.ZBĘDNE.ODSTĘPY(" Zarobki w pierwszym kwartale ") | Usuwa początkową i ostatnią spację z tekstu w formule (Zarobki w pierwszym kwartale)


WARTOŚĆ

Przekształca tekst reprezentujący liczbę w liczbę.

Składnia

WARTOŚĆ(tekst)

Tekst jest tekstem objętym znakami cudzysłowu lub odwołaniem do komórki zawierającym tekst do przekształcenia.

Spostrzeżenia

  • Tekst może być w dowolnym formacie stałej liczbowej, daty lub czasu rozpoznawanym przez arkusz kalkulacyjny. Jeśli tekst nie jest przedstawiony w jednym z tych formatów, to funkcja WARTOŚĆ zwraca wartość błędu #WARTOŚĆ!.

  • Zazwyczaj w formule nie trzeba korzystać z funkcji WARTOŚĆ, gdyż w razie potrzeby tekst jest automatycznie przekształcany w liczby. Funkcja ta zapewnia zgodność z innymi programami arkuszy kalkulacyjnych.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=WARTOŚĆ("1 000zł") | Liczbowy ekwiwalent ciągu (1 000)
=WARTOŚĆ("16:48:00")-WARTOŚĆ("12:00:00") | Numer kolejny będący ekwiwalentem 4 godzin i 48 minut, co odpowiada "16:48:00"-"12:00:00" (0,2 lub 4:48)


Z.WIELKIEJ.LITERY

Funkcja zamienia na wielką literę pierwszą małą literę tekstu i wszystkie inne litery w tekście następujące po znaku innym niż litera. Wszystkie inne litery zastępowane są literami małymi.

Składnia

Z.WIELKIEJ.LITERY(tekst)

Tekst to tekst ujęty w cudzysłów, formuła, której wynikiem jest tekst, lub odwołanie do komórki zawierającej tekst, który ma zostać częściowo przekształcony na tekst pisany wielkimi literami.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
to jest TYTUŁ
2-groszowa wartość
76BudŻet
Formuła | Opis (Wynik)
=Z.WIELKIEJ.LITERY(A2) | Poprawna wielkość liter w pierwszym ciągu (To Jest Tytuł)
=Z.WIELKIEJ.LITERY(A3) | Poprawna wielkość liter w drugim ciągu (2-Groszowa Wartość)
=Z.WIELKIEJ.LITERY(A4) | Poprawna wielkość liter w trzecim ciągu (76Budżet)


ZAOKR.DO.TEKST

Zaokrągla liczbę do podanej liczby miejsc dziesiętnych, formatuje liczbę w postaci dziesiętnej z użyciem przecinków i odstępów i zwraca wynik w postaci tekstowej.

Składnia

ZAOKR.DO.TEKST(liczba;miejsca_dziesiętne;bez_przecinka)

Liczba to liczba, którą należy zaokrąglić i zamienić na tekst.

Miejsca_dziesiętne to liczba cyfr po prawej stronie przecinka dziesiętnego.

Bez_przecinka to wartość logiczna, która jeśli ma wartość PRAWDA, zapobiega umieszczaniu odstępów przez funkcję ZAOKR.DO.TEKST w tekście wyjściowym.

Spostrzeżenia

  • Liczby w programie Microsoft Excel nie mogą nigdy mieć więcej niż 15 cyfr znaczących, ale cyfr dziesiętnych może być aż 127.
  • Jeśli argument miejsca_dziesiętne jest ujemny, liczbę zaokrągla się do lewej strony przecinka dziesiętnego.
  • Jeśli pominie się argument miejsca_dziesiętne, domyślnie przyjmuje się wartość 2.
  • Jeśli argument bez_przecinka ma wartość FAŁSZ lub jest pominięty, to wyjściowy tekst zawiera zwyczajowe odstępy.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
1234,567
-1234,567
44,332
Formuła | Opis (Wynik)
=ZAOKR.DO.TEKST(A2; 1) | Zaokrągla pierwszą liczbę do jednej cyfry po prawej stronie przecinka dziesiętnego (1234,6)
=ZAOKR.DO.TEKST(A2; -1) | Zaokrągla pierwszą liczbę do jednej cyfry po lewej stronie przecinka dziesiętnego (1 230)
=ZAOKR.DO.TEKST(-1234,567; -1; PRAWDA) | Zaokrągla drugą liczbę do jednej cyfry po lewej stronie przecinka dziesiętnego, bez odstępów (-1230)
=ZAOKR.DO.TEKST(44,332) | Zaokrągla drugą liczbę do dwóch cyfr po lewej stronie przecinka dziesiętnego (44,33)


ZASTĄP

Funkcja ZASTĄP zastępuje część ciągu tekstowego innym ciągiem tekstowym, korzystając z określonej liczby znaków.

Składnia

ZASTĄP(stary_tekst;liczba_początkowa;liczba_znaków;nowy_tekst)

Stary_tekst to tekst, w którym mają być zastąpione niektóre znaki.

Liczba_początkowa to pozycją znaku w tekście określonym przez argument stary_tekst, od której ma być zastąpiony tekst za pomocą nowy_tekst.

Liczba_znaków to liczba znaków w stary_tekst do zastąpienia za pomocą nowy_tekst przy użyciu funkcji ZASTĄP.

Nowy_tekst to tekst, który zastąpi znaki w stary_tekst.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
abcdefghijk
2009
123456
Formuła | Opis (Wynik)
=ZASTĄP(A2;6;5;"*") | Zastępuje pięć znaków, poczynając od szóstego znaku (abcde*k)
=ZASTĄP(A3;3;2;"10") | Zastępuje dwie ostatnie cyfry liczby 2009 cyframi 10 (2010)
=ZASTĄP(A4;1;3;"@") | Zastępuje trzy pierwsze znaki symbolem @ (@456)


ZŁĄCZ.TEKSTY

Łączy kilka wartości tekstowych w jedną.

Składnia

ZŁĄCZ.TEKSTY (tekst1;tekst2;...)

Tekst1; tekst2; ... to od 1 do 30 elementów tekstowych przeznaczonych do połączenia w pojedynczy tekst. Elementami tekstowymi mogą być ciągi tekstowe, liczby lub odwołania do pojedynczych komórek.

Spostrzeżenia

Przy łączeniu tekstów zamiast funkcji ZŁĄCZ.TEKSTY można także używać operatora "&".

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
gatunku pstrągów
rzecznych
32
Formuła | Opis
=ZŁĄCZ.TEKSTY("Zagęszczenie ryb z ";A2;" ";A3;" wynosi ";A4;"/milę") | Z podanych powyżej danych tworzy zdanie (Zagęszczenie ryb z gatunku pstrągów rzecznych wynosi 32/milę)


ZNAJDŹ

Znajduje jeden ciąg tekstowy (szukany_tekst) w innym ciągu tekstowym (obejmujący_tekst) i zwraca pozycję początkową szukanego_tekstu liczoną od pierwszego znaku obejmującego_tekstu. Można również użyć funkcji SZUKAJ.TEKST, aby znaleźć jeden ciąg tekstowy w innym, ale w odróżnieniu od funkcji SZUKAJ.tekst funkcja ZNAJDŹ uwzględnia wielkość liter, a nie umożliwia użycia symboli wieloznacznych.

Składnia

ZNAJDŹ(szukany_tekst;obejmujący_tekst;liczba_początkowa)

Szukany_tekst jest tekstem, który należy znaleźć.

Obejmujący_tekst to tekst zawierający tekst, który należy znaleźć.

Liczba_początkowa oznacza znak, od którego należy rozpocząć przeszukiwanie. Pierwszy znak w argumencie obejmujący_tekst jest znakiem numer 1. Jeśli argument liczba_początkowa zostanie pominięty, przyjmowana jest wartość 1.

Porada

Należy skorzystać z argumentu liczba_początkowa, aby przeskoczyć wybraną liczbę znaków poczynając od lewej strony tekstu. Na przykład załóżmy, że pracujemy z następującym ciągiem tekstowym: "AUM0093.UbraniaMęskie". Aby znaleźć numer pierwszego "U" w opisowej części ciągu tekstowego, należy ustawić argument liczba_początkowa równy 8, tak że nie będzie przeszukiwana część tekstu zawierająca numer seryjny. Funkcja ZNAJDŹ rozpocznie przeszukiwanie od znaku 8, znajdzie szukany_tekst w następnym znaku i zwróci liczbę 9. Jeśli argument liczba_początkowa jest większy niż 1, funkcja ZNAJDŹ zawsze zwraca liczbę znaków poczynając od lewej strony obejmujący_tekst, zliczając pominięte znaki.

Spostrzeżenia

  • Jeśli argument szukany_tekst jest "" (pustym tekstem), to funkcja ZNAJDŹ dopasowuje pierwszy znak w przeszukiwanym ciągu (tj. znak oznaczony liczba_początkowa lub 1).
  • Argument szukany_tekst nie może zawierać żadnych znaków zastępczych.
  • Jeśli argument szukany_tekst nie występuje w obejmujący_tekst, funkcja ZNAJDŹ zwraca wartość błędu #ARG!.
  • Jeśli argument liczba_początkowa nie jest większy od zera, to funkcja ZNAJDŹ zwraca wartość błędu #ARG!.
  • Jeśli argument liczba_początkowa jest większy od długości argumentu obejmujący_tekst, to funkcja ZNAJDŹ zwraca wartość błędu #ARG!.

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Marian Morawski
Formuła | Opis (Wynik)
=ZNAJDŹ("M";A2) | Pozycja pierwszej litery "M" w powyższym ciągu (1)
=ZNAJDŹ("M";A2) | Pozycja pierwszej litery "n" w powyższym ciągu (6)
=ZNAJDŹ("M";A2;3) | Pozycja pierwszej litery "M" w powyższym ciągu, poczynając od trzeciego znaku (8)

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Dane
Izolatory ceramiczne #124-TD45-87
Cewki miedziane #12-671-6772
Różne oporniki #116010
Formuła | Opis (Wynik)
=FRAGMENT.TEKSTU(A2,1,ZNAJDŹ(" #";A2;1)-1) | Wybiera tekst od pozycji 1 do pozycji "#" w pierwszym ciągu powyżej (Izolatory ceramiczne)
=FRAGMENT.TEKSTU(A3,1,ZNAJDŹ(" #";A3;1)-1) | Wybiera tekst od pozycji 1 do pozycji "#" w drugim ciągu powyżej (Cewki miedziane)
=FRAGMENT.TEKSTU(A4,1,ZNAJDŹ(" #";A4;1)-1) | Wybiera tekst od pozycji 1 do pozycji "#" w trzecim ciągu powyżej (Różne oporniki)


ZNAK

Zwraca znak o podanym numerze kodu. Funkcji ZNAK należy używać do tłumaczenia na znaki numerów kodów, które mogą występować w plikach komputerów innego typu.

Składnia

ZNAK(liczba)

Liczba to liczba od 1 do 255 określająca żądany znak. Znak należy do zestawu znaków stosowanego w użytkowanym komputerze.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza kalkulacyjnego.

Jak?

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).

Formuła | Opis (Wynik)
=ZNAK(65) | Wyświetla 65 znak w zestawie (A)
=ZNAK(33) | Wyświetla 33 znak w zestawie (!)


Wyświetlanie lub ukrywanie paska narzędzi arkusza kalkulacyjnego

  1. W oknie projektowania upewnij się, że arkusz kalkulacyjny jest uaktywniony. Aby uzyskać instrukcje, zapoznaj się z Pomocą programu do projektowania.
  2. Kliknij prawym przyciskiem myszy komórkę w arkuszu kalkulacyjnym, kliknij polecenie Polecenia i opcje w menu skrótów, a następnie kliknij kartę Skoroszyt.
  3. W obszarze Pokazywanie/Ukrywanie zaznacz albo wyczyść pole wyboru Pasek narzędzi.


Użycie przykładu w pustym arkuszu kalkulacyjnym

  1. Utwórz pusty arkusz kalkulacyjny.
  2. Wybierz przykład w temacie Pomocy.

    Wybieranie przykładu z Pomocy

    Wybieranie przykładu z Pomocy

  3. Naciśnij klawisze CTRL+C.
  4. W arkuszu kalkulacyjnym zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  5. Aby się przełączyć między wyświetlaniem formuły, która zwraca wynik, a wyświetlaniem wyniku w komórce, zaznacz komórkę i naciśnij klawisz F2, a następnie ENTER, albo kliknij przycisk Polecenia i opcje na pasku narzędzi arkusza kalkulacyjnego, kliknij kartę Formuła, a następnie zobacz pole Formuła w komórce aktywnej (komórka aktywna).